• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Help! My LG Optimus GT540 is stuck at the Android screen. [RESOLVED]

12 posts in this topic

Posted (edited)

So my Optimus is rooted. I removed all of the preinstalled applications from LG from the phone using adb shell (I deeply regretted doing this). It was working fine. But then I realised theres isn't any other FM Radio app on the market. So I searched on google and found that paticular apk. Downloaded it. and then pushed it into my phone using adb push D:/LgeFMRadio.apk /system/app. I restarted the phone and it wont go past the android screen. All I see now is the Android logo appearing to load before disappearing and then reappearing again. I cant press any buttons, they dont seem to work, even the power button. So I have had to remove the battery to turn it off. So err..help!!

Edit 1 :

Ok so I can access the phone using adb for only a few seconds before it goes offline and then back online. Tried adb reboot bootloader, it just reboots and nothing else.

Edit 2 :

Tried adb logcat. Gave me a bunch of errors about not being able to find some of the stuff. logcat file attached

Edit 3 :

Printed out the bugreport in case it could be of help. Really really hope someone can help me here.

logcat.txt

bugreport.txt

Edited by Ixirim
0

Share this post


Link to post
Share on other sites

Posted (edited)

So my Optimus is rooted. I accidentally removed LgeFMRadio.apk from the phone using adb shell. I searched on google and found that paticular apk. Downloaded it. and then pushed it into my phone using adb push D:/LgeFMRadio.apk /system/app. I restarted the phone and it wont go past the android screen. All I see now is the Android logo appearing to load before disappearing and then reappearing again. I cant press any buttons, they dont seem to work, even the power button. So I have had to remove the battery to turn it off. So err..help!!

Edit 1 :

Ok so I can access the phone using adb for only a few seconds before it goes offline and then back online. Tried adb reboot bootloader, it just reboots and nothing else.

Edit 2 :

Tried adb logcat. Gave me a bunch of errors about not being able to find some of the stuff. logcat file attached

Edit 3 :

Printed out the bugreport in case it could be of help. Really really hope someone can help me here.

Ok, here is what you can try

with your device OFF< plug the USB cable, make sure you have LG PC Suite installed, you will need LG USB Modem driver

Make a note of the com port number that your device will appear in Device Manager under MODEMS tab, double click on "LG Android USB Modem" and select Modem tab, below you will see COM port number (remember it)

Run Hyper Terminal, setup a connection with your device and bitrate should be set to 115200, select the COM port you checked your device is connected to as MODEM

In Hyper Terminal type

AT --> if youre not getting any text typed go to FILE>>PROPERTIES>>SETTINGS>>ASCII SETUP and put tick on "Echo typed characters only"

then click OK

In Hyper Terminal window, type

AT

OK --> if youre getting OK, then connection with your device is OK, if there is no OK, check again your PORTS

if you get OK, the type

AT%FRST

FACTORY RESET OK --> this will perform factory reset to your device, it might fix your problem but it might not

Let me know the result

P.S. Checked your logcat

E/AndroidRuntime( 1230): *** EXCEPTION IN SYSTEM PROCESS. System will crash.

E/AndroidRuntime( 1230): dalvik.system.StaleDexCacheError: /system/app/LgeFmRadi

o.apk

seems that the FMRadio is not pushed to the place it should be or the version/size of the APK is different. Anyway, try above and let me know

Edited by Batkoto
0

Share this post


Link to post
Share on other sites

Posted

Ok, here is what you can try

with your device OFF< plug the USB cable, make sure you have LG PC Suite installed, you will need LG USB Modem driver

Make a note of the com port number that your device will appear in Device Manager under MODEMS tab, double click on "LG Android USB Modem" and select Modem tab, below you will see COM port number (remember it)

Run Hyper Terminal, setup a connection with your device and bitrate should be set to 115200, select the COM port you checked your device is connected to as MODEM

In Hyper Terminal type

AT --> if youre not getting any text typed go to FILE>>PROPERTIES>>SETTINGS>>ASCII SETUP and put tick on "Echo typed characters only"

then click OK

In Hyper Terminal window, type

AT

OK --> if youre getting OK, then connection with your device is OK, if there is no OK, check again your PORTS

if you get OK, the type

AT%FRST

FACTORY RESET OK --> this will perform factory reset to your device, it might fix your problem but it might not

Let me know the result

P.S. Checked your logcat

E/AndroidRuntime( 1230): *** EXCEPTION IN SYSTEM PROCESS. System will crash.

E/AndroidRuntime( 1230): dalvik.system.StaleDexCacheError: /system/app/LgeFmRadi

o.apk

seems that the FMRadio is not pushed to the place it should be or the version/size of the APK is different. Anyway, try above and let me know

I dont think there's Hyper Terminal in win7. Are there alternatives?

0

Share this post


Link to post
Share on other sites

Posted (edited)

I dont think there's Hyper Terminal in win7. Are there alternatives?

Yes, you can download Hyper Terminal or TeraTerm, just GOOGLE it

BTW... I just followed your steps, removed the FMradio apk from my device and power cycle, then its loading properly without issues

Edited by Batkoto
0

Share this post


Link to post
Share on other sites

Posted

Yes, you can download Hyper Terminal or TeraTerm, just GOOGLE it

BTW... I just followed your steps, removed the FMradio apk from my device and power cycle, then its loading properly without issues

Ok so on TeraTerm, I set the port to 10 (because that's what it says) and bitrate to 115200. However when I typed AT. The cursor goes back to the beginning.

0

Share this post


Link to post
Share on other sites

Posted

Ok so on TeraTerm, I set the port to 10 (because that's what it says) and bitrate to 115200. However when I typed AT. The cursor goes back to the beginning.

Not sure about tera term, in Hyper terminal the ECHO is fixing that problem

Try pushing my apk file to your device (extract from ZIP)

BTW, do you know if the "LgeFmRadio.odex" is still under system/app or it is removed as well

You can probably use the DDMS>> File Explorer

LgeFmRadio.zip

0

Share this post


Link to post
Share on other sites

Posted (edited)

Not sure about tera term, in Hyper terminal the ECHO is fixing that problem

Try pushing my apk file to your device (extract from ZIP)

BTW, do you know if the "LgeFmRadio.odex" is still under system/app or it is removed as well

You can probably use the DDMS>> File Explorer

LgeFmRadio.odex is still there although I think its not the stock. God damnit I feel like Im in a race with the phone.

Edit : Woot I won the race! Many thanks to you Batkoto ;)

Edited by Ixirim
0

Share this post


Link to post
Share on other sites

Posted

LgeFmRadio.odex is still there although I think its not the stock. God damnit I feel like Im in a race with the phone.

Edit : Woot I won the race! Many thanks to you Batkoto :(

Good to hear ;)

Where was the problem

0

Share this post


Link to post
Share on other sites

Posted

Good to hear ;)

Where was the problem

Like you said. The radio app was causing it to crash. Removing both the apk and odex solved it. Had to do it before it reboots though which was like every 15 seconds or so.

0

Share this post


Link to post
Share on other sites

Posted

Ok, here is what you can try

with your device OFF< plug the USB cable, make sure you have LG PC Suite installed, you will need LG USB Modem driver

Make a note of the com port number that your device will appear in Device Manager under MODEMS tab, double click on "LG Android USB Modem" and select Modem tab, below you will see COM port number (remember it)

Run Hyper Terminal, setup a connection with your device and bitrate should be set to 115200, select the COM port you checked your device is connected to as MODEM

In Hyper Terminal type

AT --> if youre not getting any text typed go to FILE>>PROPERTIES>>SETTINGS>>ASCII SETUP and put tick on "Echo typed characters only"

then click OK

In Hyper Terminal window, type

AT

OK --> if youre getting OK, then connection with your device is OK, if there is no OK, check again your PORTS

if you get OK, the type

AT%FRST

FACTORY RESET OK --> this will perform factory reset to your device, it might fix your problem but it might not

Let me know the result

P.S. Checked your logcat

E/AndroidRuntime( 1230): *** EXCEPTION IN SYSTEM PROCESS. System will crash.

E/AndroidRuntime( 1230): dalvik.system.StaleDexCacheError: /system/app/LgeFmRadi

o.apk

seems that the FMRadio is not pushed to the place it should be or the version/size of the APK is different. Anyway, try above and let me know

ok i have this similar problem and i want to factor reset but when i pick the port and try to connect i lose connection with my phone... even when i try to check port after 5 sec connection is lost... this may be some protection or so?? so any idea what can be?

0

Share this post


Link to post
Share on other sites

Posted

hello hope this is not here off topic !

I Got a LG GT540 from an Auction from a Pawnshop , this LG is Password locked the Phone Boots , but screen is locked.

How can i Reset the Phone , the phone was Rooted , says the Guy.

thx in advance

0

Share this post


Link to post
Share on other sites

Posted

Had the same problem and after some attemts it worked. (puuh)

Damn, on windows mobile it was so easy to hardreset.

Thank you

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.