• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Turning off the vibrate when key pressed

30 posts in this topic

Posted · Report post

Anyone know how to turn off the vibrate when pressing the back button key? I can't locate it.

It's a little annoying, as even when locked and in your pocket (yes it fits in my pocket ;) ) it can occasionally vibrate... then of course I take my phone out to think I have a message etc

I don't think you can... but would be great if you could

0

Share this post


Link to post
Share on other sites

Posted · Report post

I havent found a setting for it yet...

0

Share this post


Link to post
Share on other sites

Posted · Report post

I havent found a setting for it yet...

Me, either

0

Share this post


Link to post
Share on other sites

Posted · Report post

Anyone know how to turn off the vibrate when pressing the back button key? I can't locate it.

It's a little annoying, as even when locked and in your pocket (yes it fits in my pocket ;) ) it can occasionally vibrate... then of course I take my phone out to think I have a message etc

I don't think you can... but would be great if you could

Err... my back button doesn't vibrate when locked. Are you SURE it's vibrating when you touch it? The phone shouldn't respond to anything but the power button when locked.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Err... my back button doesn't vibrate when locked. Are you SURE it's vibrating when you touch it? The phone shouldn't respond to anything but the power button when locked.

Yes kupo

I am sure... when the lock is on and when I press the back button it (can) vibrate... ;)

HOWEVER.. when testing this, after your query, I found out that it will not always vibrate... but if you press the side power button, this activates the unlock screen display... THEN when either the back/home/menu buttons are pressed, it will vibrate.

So.. if it is in your pocket, and those buttons are pressed acidentally, it'll vibrate. Which happens quite a lot.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes kupo

I am sure... when the lock is on and when I press the back button it (can) vibrate... ;)

HOWEVER.. when testing this, after your query, I found out that it will not always vibrate... but if you press the side power button, this activates the unlock screen display... THEN when either the back/home/menu buttons are pressed, it will vibrate.

So.. if it is in your pocket, and those buttons are pressed acidentally, it'll vibrate. Which happens quite a lot.

Oh sorry! I get it now. I don't get that. I've disabled my lockscreen so the power button unlocks. I guess you wear tighter trousers than I do.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Oh sorry! I get it now. I don't get that. I've disabled my lockscreen so the power button unlocks. I guess you wear tighter trousers than I do.

too right... so tight you can see what religion I am ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Anyone know how to turn off the vibrate when pressing the back button key? I can't locate it.

It's a little annoying, as even when locked and in your pocket (yes it fits in my pocket :D ) it can occasionally vibrate... then of course I take my phone out to think I have a message etc

I don't think you can... but would be great if you could

You can swap with me if you like GrizLore as my vibrate has decided to stop working :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

I got rid of the key vibration. :huh:

There is an attribute in the sysfs tree named "/sys/class/timed_output/vibrator/enable".

It's actually fun to make the Streak hum by saying on the adb shell:

echo "100" > /sys/class/timed_output/vibrator/enable
If you are root, you can change the permissions of the attribute to read-only:
chmod 0444 /sys/class/timed_output/vibrator/enable

Et voilá - no more shivering when opening a menu !

Of course, this disables vibration globally. But I personally could not care less.

I used the "chmod" line in the Autostart app (see Market) to make the setting boot-proof.

It should be easy to write a little app to switch key vibation off and on. We'll see ...

0

Share this post


Link to post
Share on other sites

Posted · Report post

I got rid of the key vibration. :huh:

There is an attribute in the sysfs tree named "/sys/class/timed_output/vibrator/enable".

It's actually fun to make the Streak hum by saying on the adb shell:

echo "100" > /sys/class/timed_output/vibrator/enable
If you are root, you can change the permissions of the attribute to read-only:
chmod 0444 /sys/class/timed_output/vibrator/enable

Et voilá - no more shivering when opening a menu !

Of course, this disables vibration globally. But I personally could not care less.

I used the "chmod" line in the Autostart app (see Market) to make the setting boot-proof.

It should be easy to write a little app to switch key vibation off and on. We'll see ...

Bravo!

0

Share this post


Link to post
Share on other sites

Posted · Report post

When you say "globally" do you mean all key vibrations.... or the device will never vibrate, say for phone ringing and SMS notifications

Either way...Thanks for fixing this

0

Share this post


Link to post
Share on other sites

Posted · Report post

After reading this I realize that my screen dims on lock and all three of the side buttons wake the device. I never had that happen on 1.6 and I hate it. I always used to use the power button to sleep/wake. I tried to use no lock, but then that wakes the phone even more.

0

Share this post


Link to post
Share on other sites

Posted · Report post

When you say "globally" do you mean all key vibrations.... or the device will never vibrate, say for phone ringing and SMS notifications

I suppose so. Did not check but logic tells me if no application can use the vibration facility, there will be no vibrations anymore, good or bad :huh:

The disabling method is obviously pretty rude, but it's the only place where we can influence anything right now.

The next step could be to circle in on the application which is involved.

The log excerpt says this for a press on one of the "buttons":

E/PrintK  (	6): <3>[Jackie]report KEY_MENU KEYPRESS

I/KeyInputQueue( 1204): Input event: dev=0x10003 type=0x1 scancode=139 keycode=82 value=1

V/PhoneWindowManager( 1204): interceptKeyTq event=android.view.RawInputEvent@319015b8 keycode=82 screenIsOn=true keyguardShowing=true

D/PhoneWindowManager( 1204): KEYCODE_MENU, down=true

D/PhoneWindowManager( 1204): -Vibrate- Detect the Menu key short press

E/PrintK  ( 1204): <3>[VIB]qsd_timed_vibrator_enable=0

E/PrintK  ( 1204): <3>[VIB]vibrator_onOff=0

E/PrintK  ( 1204): <3>[VIB]qsd_timed_vibrator_enable=35

E/PrintK  ( 1204): <3>[VIB]vibrator_onOff=1

D/LockPatternKeyguardView( 1204): goToUnlockScreen()... unlockMode=Pattern mUnlockScreenMode=Pattern

D/LockPatternKeyguardView( 1204):  - isSecure = false, unlock the screen

D/KeyguardViewMediator( 1204): mAuthenticated set to true

D/KeyguardViewMediator( 1204): keyguardDone(true)

D/KeyguardViewMediator( 1204): handleKeyguardDone

D/KeyguardViewMediator( 1204): handleHide

E/PrintK  ( 1266): <3>[VIB]vibrator_onOff=0

E/PrintK  (	6): <3>[Jackie]temp_rd.data=0x0

E/PrintK  (	6): <3>[Jackie]report KEY[0] Release

I/KeyInputQueue( 1204): Input event: dev=0x10003 type=0x1 scancode=139 keycode=82 value=0

V/PhoneWindowManager( 1204): interceptKeyTq event=android.view.RawInputEvent@319015b8 keycode=82 screenIsOn=true keyguardShowing=false

D/PhoneWindowManager( 1204): KEYCODE_MENU, down=false

I/StatusBarPolicy( 1204): Status Bar RSSI asu = 13,iconLevel = 4

I/ActivityManager( 1204): Starting activity: Intent { flg=0x4400000 cmp=com.rechild.advancedtaskkiller/.AdvancedTaskKiller }

W/ActivityManager( 1204): startActivity called from non-Activity context; forcing

I'm not very familiar with Android and its logs yet, but I assume "PrintK" is coming from the kernel; the vibration is obviously initiated by "PhoneWindowManager".

Note: I'm still on 1.6 !

Happy hunting!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Wil this also work the other way? i.e. if your vibration is not working

0

Share this post


Link to post
Share on other sites

Posted · Report post

Wil this also work the other way? i.e. if your vibration is not working
Of course you can change the file permissions back to 777 which is the default (set in "init.rc"). It's reset anyway after rebooting because this is not a physical file but rather a kernel or rather driver interface.

If your vibration is broken or not working, this may be caused by anything.

I recommend to try out the "echo" line in my first post.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Of course you can change the file permissions back to 777 which is the default (set in "init.rc"). It's reset anyway after rebooting because this is not a physical file but rather a kernel or rather driver interface.

If your vibration is broken or not working, this may be caused by anything.

I recommend to try out the "echo" line in my first post.

So the code would be:

chmod 777 /sys/class/timed_output/vibrator/enable

0

Share this post


Link to post
Share on other sites

Posted · Report post

So the code would be:

chmod 777 /sys/class/timed_output/vibrator/enable

That's right.

And to test if it's working:

echo "<milliseconds>" > /sys/class/timed_output/vibrator/enable

0

Share this post


Link to post
Share on other sites

Posted · Report post

That's right.

And to test if it's working:

echo "<milliseconds>" > /sys/class/timed_output/vibrator/enable

Worked !

Thanks.

0

Share this post


Link to post
Share on other sites

Posted · Report post

very good, thanks for the tip!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Here is a little app to deactivate and reactivate all vibrations.

It requests root rights which are needed to set the permissions of the system file.

If you can't or won't give these rights, it will only be able to test the vibration feature.

Note: as mentioned before, vibration will always be enabled after a reboot.

The Test button uses the normal API function for vibrating.

The Enable/Disable button runs the "chmod" shell function (and nothing else).

Get Streak Vibrations and stop trembling. :huh:

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Here is a little app to deactivate and reactivate all vibrations.

It requests root rights which are needed to set the permissions of the system file.

If you can't or won't give these rights, it will only be able to test the vibration feature.

Note: as mentioned before, vibration will always be enabled after a reboot.

The Test button uses the normal API function for vibrating.

The Enable/Disable button runs the "chmod" shell function (and nothing else).

Get Streak Vibrations and stop trembling. ;)

WOW Thank you !

give me your bank account ... $ 1 million waiting for you :huh:

Edited by steflucrene
0

Share this post


Link to post
Share on other sites

Posted · Report post

give me your bank account ... $ 1 million waiting for you ;)

That's what I call Good Vibrations ... :huh:

0

Share this post


Link to post
Share on other sites

Posted · Report post

That's what I call Good Vibrations ... :huh:

Works great! Thanks a lot!

0

Share this post


Link to post
Share on other sites

Posted · Report post

If anyone would like it, I've got a custom boot.img that disables the vibration on boot. No more need to turn it off. I'll post it upon request.

0

Share this post


Link to post
Share on other sites

Posted · Report post

As stated above, I use the "Autostart" app from the Market (needs root) on my system, which calls the script

/data/opt/autostart.sh at boot time which can contain any desired command. I have only one line in it so far:

chmod 0444 /sys/class/timed_output/vibrator/enable

So my vibrations are disabled from the start as well.

If I'd be using your ROM, could I re-enable vibrations with my app?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.