• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

WiFi won't stay connected

35 posts in this topic

Posted

I love my Nexus One. Everything is near perfect for my needs EXCEPT the wifi! When its connected it works great, but it won't stay connected after the device goes into standby/sleep....

I have changed/tried the Advanced WiFi settings Sleep Policy to "Never" - doesn't help one bit.

The device will connect when I turn WiFi off and then back on OR if I forget the network and then reconnect. But once the device falls asleep for a few minutes and is then subsequently awakened it won't re-associate. If I go into the WiFi networks the network is there (because its remembered), but it says "Disabled".

I would appreciate any and all help to resolve this issue. Not sure why BlackBerry and Apple get this right perfectly out of the box, but Google can't figure out how to create a working WiFi stack. WTF Google? Seriously ridiculous that the final release of Froyo is now out and this issue still isn't resolved....

0

Share this post


Link to post
Share on other sites

Posted

I love my Nexus One. Everything is near perfect for my needs EXCEPT the wifi! When its connected it works great, but it won't stay connected after the device goes into standby/sleep....

I have changed/tried the Advanced WiFi settings Sleep Policy to "Never" - doesn't help one bit.

The device will connect when I turn WiFi off and then back on OR if I forget the network and then reconnect. But once the device falls asleep for a few minutes and is then subsequently awakened it won't re-associate. If I go into the WiFi networks the network is there (because its remembered), but it says "Disabled".

I would appreciate any and all help to resolve this issue. Not sure why BlackBerry and Apple get this right perfectly out of the box, but Google can't figure out how to create a working WiFi stack. WTF Google? Seriously ridiculous that the final release of Froyo is now out and this issue still isn't resolved....

I think you may be alone on this . . . . . I'm not seeing other poster post this issue you are having. Have you done a complete full wipe of everything, (even the SD card), and the pulling of the battery? In the past, when I have had issues that can't be resolved, or when they don't seem to have anything to do with the battery or wiping, I have done so only to find that the solution (many different issues), has been resolved.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I think you may be alone on this . . . . . I'm not seeing other poster post this issue you are having. Have you done a complete full wipe of everything, (even the SD card), and the pulling of the battery? In the past, when I have had issues that can't be resolved, or when they don't seem to have anything to do with the battery or wiping, I have done so only to find that the solution (many different issues), has been resolved.

I wipe every time I change OS'. From ERE27 to FRF50 to FRF72 to FRF83 - same issue with all. Wipe, wipe cache, wipe dalvik.

I haven't wiped the microSD card - will do that now and report back.

Edited by kyle16
0

Share this post


Link to post
Share on other sites

Posted

I'm not sure how the SD card would have anything to do with the WiFi - but whatever. I tried it, and as I suspected, it did nothing to improve the situation. Btw - I'm not the only person to have this issue. Was hoping someone might have some insight on here.

Previously used/remembered networks should never have to initiated. This has been standard protocol on smartphones for years. The fact that 5 different BB's and 4 different iPhone's all work flawlessly on this network is proof enough for me that it's the device (or the device's OS).

0

Share this post


Link to post
Share on other sites

Posted

I'm not sure how the SD card would have anything to do with the WiFi - but whatever. I tried it, and as I suspected, it did nothing to improve the situation. Btw - I'm not the only person to have this issue. Was hoping someone might have some insight on here.

Previously used/remembered networks should never have to initiated. This has been standard protocol on smartphones for years. The fact that 5 different BB's and 4 different iPhone's all work flawlessly on this network is proof enough for me that it's the device (or the device's OS).

My Wifi drops whenever I put the phone into sleep or the screen goes of.

However it keeps the 3G running so I haven't really thought about it.

0

Share this post


Link to post
Share on other sites

Posted

I think you may be alone on this . . . . .

I'm getting this disabled problem too, it seems to depend on the router, as it doesn't happen at home, just at work.

Didn't happen with the 2.1 original.

0

Share this post


Link to post
Share on other sites

Posted

I'm getting this disabled problem too, it seems to depend on the router, as it doesn't happen at home, just at work.

Didn't happen with the 2.1 original.

Same problem here, but not every time...

0

Share this post


Link to post
Share on other sites

Posted

For me it depends on the router. The routers at school, my fiance's house, etc worked fine, but my home router would drop me most of the time, like you described. Solution? Bought a $30 802.11n router from ASUS. Now I don't get dropped anywhere. Old router was a Belkin.

So yes there is something funky with N1 wifi, but the issues are pretty rare.

0

Share this post


Link to post
Share on other sites

Posted (edited)

For me it depends on the router. The routers at school, my fiance's house, etc worked fine, but my home router would drop me most of the time, like you described. Solution? Bought a $30 802.11n router from ASUS. Now I don't get dropped anywhere. Old router was a Belkin.

So yes there is something funky with N1 wifi, but the issues are pretty rare.

My router is a Belkin too! That might be the issue. I am thinking about going out and purchasing a cheap Linksys router tonight. Thanks for the help ushim6!

Edited by kyle16
0

Share this post


Link to post
Share on other sites

Posted (edited)

Although I am having the same issue at work too. No Belkin router here. Same "Disabled,..." message after the device goes to sleep for a few minutes. WiFi connectivity should just work.

<banging head against desk out of sheer frustration!> ;)

Many users are having this issue. Shocked that Google hasn't resolved this. Maybe they can't if its a hardware issue.

Edited by kyle16
0

Share this post


Link to post
Share on other sites

Posted (edited)

Although I am having the same issue at work too. No Belkin router here. Same "Disabled,..." message after the device goes to sleep for a few minutes. WiFi connectivity should just work.

<banging head against desk out of sheer frustration!> :lol:

Many users are having this issue. Shocked that Google hasn't resolved this. Maybe they can't if its a hardware issue.

i'm STILL banging my head :D

Edited by Land O' Beats
0

Share this post


Link to post
Share on other sites

Posted

If you go into wifi settings (so you can see your list of networks), press menu key, press advanced, look at "WiFi Sleep Policy". You may want to change it to "never" so it stops disconnecting while your phone sleeps.

Are you letting the phone sleep while you're on that wifi settings screen, so that's the first thing displayed as soon as the phone wakes up?

0

Share this post


Link to post
Share on other sites

Posted

If you go into wifi settings (so you can see your list of networks), press menu key, press advanced, look at "WiFi Sleep Policy". You may want to change it to "never" so it stops disconnecting while your phone sleeps.

Are you letting the phone sleep while you're on that wifi settings screen, so that's the first thing displayed as soon as the phone wakes up?

Been there, done that, but Wi-Fi signal still loses during sleep.

Any other solution?

Regards.

0

Share this post


Link to post
Share on other sites

Posted

I have the same problem. Works at uni, doesn;t work at home. It's failed at home on 2 routers. A d-link and a linksys.

I have a suspicion that it might be related to having a hidden SSID. Anyone else experiencing problems only on networks with a hidden SSID? I haven't been bothered to try unhiding the SSID...maybe i should! :lol:

0

Share this post


Link to post
Share on other sites

Posted

A solution that semi worked (or seemed to at least make things better) was to long press on the wifi network in question and when the menu comes up say "Modify Network" and then just click save. It has seemed to resolve issues for me.

0

Share this post


Link to post
Share on other sites

Posted

This is a common and disappointing issue. I have no data plan, so Wifi is king for me. Have not yet found a solution.

Some routers auto-reconnect after I wake up the phone, some routers fail to auto-reconnect, but the N1 never listens to me about not sleeping when screen is off. :/

0

Share this post


Link to post
Share on other sites

Posted

I am having the same issues. Here is what I have tried:

Original:

Verizon FiOS Router

Broadcast SSID

Issue Present

New:

D-Link N Router

Broadcast SSID

Issue Present

New 2:

D-Link N Router

Hidden SSID

Issue Present

New 3:

Verizon FiOS Router

Hidden New SSID

Issue Present

I have done wipes whenever I have installed a new ROM (Cyan 5.x, ERD79, FRF50, FRF72, ERD79 w/Update 1). I have cleaned out the network, added it back in, done a modify then save. Nothing has helped to keep a consistent connection.

I have an old MyTouch 3G and it connects right away to ANY connection I am close to while the Nexus One doesn't.

0

Share this post


Link to post
Share on other sites

Posted

I think you may be alone on this . . .

Pretty sure I'm not LOL. Might want to do a little research next time....

This has to be a hardware issue, especially since other Android devices don't seem to be having this issue. Which would also explain why Google hasn't attempted to address it (they will never replace hardware). Extremely frustrating.

0

Share this post


Link to post
Share on other sites

Posted

Pretty sure I'm not LOL. Might want to do a little research next time....

This has to be a hardware issue, especially since other Android devices don't seem to be having this issue. Which would also explain why Google hasn't attempted to address it (they will never replace hardware). Extremely frustrating.

I just began using WiFi Static (free on the Android Market) and that seems to help.

After some more testing, I wonder if HTC is using a weaker antenna.

0

Share this post


Link to post
Share on other sites

Posted

Have you made a ping to your phones?

Everything is fine, when screen is on. When it turns off, the ping time grows and grows.

Then it drops. When you turn on the screen, ping is okay.

It's a shame! I wanna hear some Music over WiFi and must have the screen on for it.

0

Share this post


Link to post
Share on other sites

Posted

Pretty sure I'm not LOL. Might want to do a little research next time....

This has to be a hardware issue, especially since other Android devices don't seem to be having this issue. Which would also explain why Google hasn't attempted to address it (they will never replace hardware). Extremely frustrating.

I'm not certain it is a hardware issue. It could very well be a wifi driver issue. But most people never notice a problem because they have 3G connections and set the wifi to sleep when the screen is off. Not very useful for us without data plans though!

It is definitely related to the router though. Some people manage to fix it by changing the channel of their wifi router (usually it is on 11 I think). Others fix by buying a new router. I'm considering setting Locale to enable and disable my wifi every hour (via a calendar event) so that it stays connected (in case other people don't observe this, my wifi does stay connected for a while after the screen turns off, sometimes even as long as 6 hours, but eventually it disconnects and then sits their "scanning")

I'm still hoping the final Froyo release will fix it!

0

Share this post


Link to post
Share on other sites

Posted

I think I've discovered a workaround for the interim. Yes, I'm still holding out hope that Google will fix this someday.

After reserving my N1's MAC & IP via the router config software everything seems to be working smoothly (in conjunction w/ Wifi Static). We shall see if this continues. I should not have to go to such lengths to get wifi to operate smoothly, but whatever.

0

Share this post


Link to post
Share on other sites

Posted

I have the same problem as most here with some different issues. At work on a Linksys router I never lose connection to it but at home on my D-Link router it won't connect but tries to and it won't actually make a connection unless i manual try to connect it then it works and seems to work fine.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I have a Belkin N+ router and a Comcast connection. Drops the connections after the device is turned off w/in 3 minutes usually (YES the sleep policy is set to "Never" noobs before you ask).

Edited by kyle16
0

Share this post


Link to post
Share on other sites

Posted

I have a Belkin N+ router and a Comcast connection. Drops the connections after the device is turned off w/in 3 minutes usually (YES the sleep policy is set to "Never" noobs before you ask).

Hey,

How will this MAC address hack affect me if I have multiple other devices connected to the same router? I use the same Belkin N+ router.

Please advice.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.