• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

27/Jul r3b MG Custom Rom for pulse mini

173 posts in this topic

Posted

I installed r3b this morning, thanks to the excellent guide posted elsewhere.

GPS and WiFi seem to be working fine. The only things I'm missing from the t-mobile setup are the 9 desktops that scroll via the button and the ability to drag icons between them. Also the favourite contacts button (for thumb browsing). I'm sure that has a proper name. Maybe these can be got back, I don't know.

0

Share this post


Link to post
Share on other sites

Posted

I installed r3b this morning, thanks to the excellent guide posted elsewhere.

GPS and WiFi seem to be working fine. The only things I'm missing from the t-mobile setup are the 9 desktops that scroll via the button and the ability to drag icons between them. Also the favourite contacts button (for thumb browsing). I'm sure that has a proper name. Maybe these can be got back, I don't know.

thats t-mobile launcher with 4 options. in r3b i think its set to vanilla android or some other launcher not sure i modifyed it alot :)

Atm im messing with new ROMs on huawei, that RedBull frameworks seems interesting :D

0

Share this post


Link to post
Share on other sites

Posted

I've learned a bit having messed around with it today. 5 desktops is plenty and I've discovered the home icon twice to bring up the switcher.

Barnacle seems worse than ever. Constant "NAT Restart: Message too long" when trying to open google on a client.

0

Share this post


Link to post
Share on other sites

Posted

The ability to search contacts seems to be missing when composing a text. Major pain! Is there any way to bring it back?

0

Share this post


Link to post
Share on other sites

Posted

The ability to search contacts seems to be missing when composing a text. Major pain! Is there any way to bring it back?

gforums is on vacation until 17th, and all my cooked roms failed so far. but imo maybe if u replace the contacts.app with the one u had before (i hope u made nandroid backup and can extract stuff from it) then u should be fine

have no idea for barnacle i dont use it at all,there are plenty of free/opened wifi's arround me :)

0

Share this post


Link to post
Share on other sites

Posted

ok guys, I am back from vacations!

Any questions left now? Please post them (again), as I don't know how actual this thread still is.

I have used the pulse mini over the last the weeks now with my r3b rom and it was working all well. Zero FCs, just sometimes a hang (one click on "wait" and done...) of the fancy weather widget.

Of course, this rom can cause trouble on other huawei devices. It is just for the UK PULSE MINI and all other devices won't work probably. For other devices, we would need a working original rom of each of those and modify them. Not that difficult, but not my job as I don't own other devices than the pulse mini. ;-)

Best,

gforums

0

Share this post


Link to post
Share on other sites

Posted

ok guys, I am back from vacations!

Any questions left now? Please post them (again), as I don't know how actual this thread still is.

I have used the pulse mini over the last the weeks now with my r3b rom and it was working all well. Zero FCs, just sometimes a hang (one click on "wait" and done...) of the fancy weather widget.

Of course, this rom can cause trouble on other huawei devices. It is just for the UK PULSE MINI and all other devices won't work probably. For other devices, we would need a working original rom of each of those and modify them. Not that difficult, but not my job as I don't own other devices than the pulse mini. ;-)

Best,

gforums

great rom - stable and quick, thanks. any idea if we will get a 2.2 rom or is that just wishful thinking? ;-)

0

Share this post


Link to post
Share on other sites

Posted

great rom - stable and quick, thanks. any idea if we will get a 2.2 rom or is that just wishful thinking? ;-)

asap (as soon as possible). ROM for new huawei froyo phone Huawei Ideos / U8150 should be quite interesting :D

0

Share this post


Link to post
Share on other sites

Posted

Hi i have not used your rom yet but it looks good now your back will you update apps in the rom mainly superuser as thats had lots of updates. also as i dont seem to get any replays i have a pulse mini uk with stock rom atm i tryed to install both recovery images without rooting the clockwork image works fine but any other wont work all i get is the t-mobile splash and with any newer clockwork images i get blackscreen hope you can help. sorry 1 more thing if i use the superboot to root my phone after a few restarts the usb stops mounting in windows i have tryed turning debug on off still the same.

0

Share this post


Link to post
Share on other sites

Posted

Hi i have not used your rom yet but it looks good now your back will you update apps in the rom mainly superuser as thats had lots of updates. also as i dont seem to get any replays i have a pulse mini uk with stock rom atm i tryed to install both recovery images without rooting the clockwork image works fine but any other wont work all i get is the t-mobile splash and with any newer clockwork images i get blackscreen hope you can help. sorry 1 more thing if i use the superboot to root my phone after a few restarts the usb stops mounting in windows i have tryed turning debug on off still the same.

Not sure how often I'll update the rom...I'm not using the pulse mini as my main phone and my time is very limited at the moment where I am writing my diploma thesis soon. I'll have a look at the rom from time to time but for now, r3b looks quite stable....

I have a prepared r4 on my PC which has some little improvements, but nothing what really matters. If I get some time, I'll test it soon and make it public...

0

Share this post


Link to post
Share on other sites

Posted

ok guys, I am back from vacations!

Any questions left now? Please post them (again), as I don't know how actual this thread still is.

I have used the pulse mini over the last the weeks now with my r3b rom and it was working all well. Zero FCs, just sometimes a hang (one click on "wait" and done...) of the fancy weather widget.

Of course, this rom can cause trouble on other huawei devices. It is just for the UK PULSE MINI and all other devices won't work probably. For other devices, we would need a working original rom of each of those and modify them. Not that difficult, but not my job as I don't own other devices than the pulse mini. ;-)

Best,

gforums

Hi gforums,

I hope you had a good vacation. I used your rom and liked it very much, but I had to go back to the stock rom, because GPS was not working. (Austrian T-mobile phone)

Will there be a fix for that, so I can switch back to your release?

Cheers

Zisius

0

Share this post


Link to post
Share on other sites

Posted

Not sure how often I'll update the rom...I'm not using the pulse mini as my main phone and my time is very limited at the moment where I am writing my diploma thesis soon. I'll have a look at the rom from time to time but for now, r3b looks quite stable....

I have a prepared r4 on my PC which has some little improvements, but nothing what really matters. If I get some time, I'll test it soon and make it public...

ok thanks cant wait.

0

Share this post


Link to post
Share on other sites

Posted

Hi gforums,

I hope you had a good vacation. I used your rom and liked it very much, but I had to go back to the stock rom, because GPS was not working. (Austrian T-mobile phone)

Will there be a fix for that, so I can switch back to your release?

Cheers

Zisius

Probably it's not working because it's an Austrian phone. We'd need to do the modifications on an Austrian Base rom. Is it availbale somewhere?

Don't know if I find time to release roms for different pulse mini phones...and without devices to test it on....difficult.

0

Share this post


Link to post
Share on other sites

Posted

Probably it's not working because it's an Austrian phone. We'd need to do the modifications on an Austrian Base rom. Is it availbale somewhere?

Don't know if I find time to release roms for different pulse mini phones...and without devices to test it on....difficult.

If you want to build a rom for Huawei U8100 I can volunteer as a tester =)

0

Share this post


Link to post
Share on other sites

Posted (edited)

@gforum

Can i just ask what recovery image and version your using and how flashed it?

Edited by jasonXXx
0

Share this post


Link to post
Share on other sites

Posted (edited)

SD Card wont mount

Hi All,

Just tried flashing your rom this morning. That is r3b, not that i got to that part.

I have a UK T-Mobile pulse mini, and up to this point have done nothing with it except unlock it via http://www.dc-unlocker.com/

I have installed the drivers/pc-suit tool on my windows 7 pc

Following your tutorial:

0. my battery is fully charged.

1. I installed AmonRA that was easy enough i then did a nand backup via it onto my sd card, then dumped my whole sd card onto my computer.

2. entered recovery mode again after the backup

3. partitioned my sd card with a 0mb swap and 256mb ext2

4. wiped my data, and then cleared the dalvik cache

5. downloaded the rom then booted up my phone to copy it onto the SD card.

This is where i am now, unable to mount the SD card.

I am still able to boot up to the android system recovery mode.

I can't restore my backup image as android system menu cannot read my SD card.

Help would be very much appreciated.

Kind regards,

James

UPDATE #1:

I have tried re-partitioning the SD card via the recovery menu, powering off, then trying to mount - still can't mount

I have tried formatting the SD card using the file manager built into android - still can't mount

I can creat folders on the SD card, so it does seem to be functioning but - still can't mount

UPDATE #2:

I have tried access the SD card from OSX - still can't mount

SD card mounts fine using a USB card reader. I'm going to try and restore my NAND backup i took

UPDATE #3

Restoring the NAND backup that i took also restored my ability to mount the SD card, i'm now going to flash the custom ROM

UPDATE #4

Flashed the rom, then did a wipe data, works fine!

Just want to say thanks to those guys who developed this rom. Great job!

Conclusion:

Firstly the bad:

SD Mount doesn't work

The Good:

The new rom is better in ALL respects

I especially like the fact Google contacts are now filtered and only those in 'My Contacts' are displayed, not 'All contacts'

It's fast- really fast, it turns this underpowered handset into something really useful

Theming is great, or rather lack of it, gone is the pink of t-mobile.

I could go on!

Edited by webjames
0

Share this post


Link to post
Share on other sites

Posted

SD Card wont mount

Hi All,

Just tried flashing your rom this morning. That is r3b, not that i got to that part.

I have a UK T-Mobile pulse mini, and up to this point have done nothing with it except unlock it via http://www.dc-unlocker.com/

I have installed the drivers/pc-suit tool on my windows 7 pc

Following your tutorial:

0. my battery is fully charged.

1. I installed AmonRA that was easy enough i then did a nand backup via it onto my sd card, then dumped my whole sd card onto my computer.

2. entered recovery mode again after the backup

3. partitioned my sd card with a 0mb swap and 256mb ext2

4. wiped my data, and then cleared the dalvik cache

5. downloaded the rom then booted up my phone to copy it onto the SD card.

This is where i am now, unable to mount the SD card.

I am still able to boot up to the android system recovery mode.

I can't restore my backup image as android system menu cannot read my SD card.

Help would be very much appreciated.

Kind regards,

James

UPDATE #1:

I have tried re-partitioning the SD card via the recovery menu, powering off, then trying to mount - still can't mount

I have tried formatting the SD card using the file manager built into android - still can't mount

I can creat folders on the SD card, so it does seem to be functioning but - still can't mount

UPDATE #2:

I have tried access the SD card from OSX - still can't mount

SD card mounts fine using a USB card reader. I'm going to try and restore my NAND backup i took

UPDATE #3

Restoring the NAND backup that i took also restored my ability to mount the SD card, i'm now going to flash the custom ROM

UPDATE #4

Flashed the rom, then did a wipe data, works fine!

Just want to say thanks to those guys who developed this rom. Great job!

Funny did you root your phone before installing the recovery image? if i try to install recovery image without root it says complete but i still just get t-mobile image no recovery also if i install recovery after i root i get tmobile image then screen goes black and hangs. I have noticed when you root the phone usb mount no longer works.

0

Share this post


Link to post
Share on other sites

Posted

Funny did you root your phone before installing the recovery image? if i try to install recovery image without root it says complete but i still just get t-mobile image no recovery also if i install recovery after i root i get tmobile image then screen goes black and hangs. I have noticed when you root the phone usb mount no longer works.

Well my phone wasn't rooted before, although i got the recovery working fine seemingly. You are right, I can't mount my SD card anymore, but given how much better the rom is i'm sticking with it.

See my post above to see the steps i took.

If i find anything i'll post it.

James

0

Share this post


Link to post
Share on other sites

Posted

Well my phone wasn't rooted before, although i got the recovery working fine seemingly. You are right, I can't mount my SD card anymore, but given how much better the rom is i'm sticking with it.

See my post above to see the steps i took.

If i find anything i'll post it.

James

Hmm just flashed back to stock and then put the recovery on and it worked the same as you sead with the usb so i followed your steps and the same happend with me. Ok now i would love to have root but not if the usb is not mounting is there any way to extract the orig recovery image from the t-mobile uk stock rom?

0

Share this post


Link to post
Share on other sites

Posted

Hmm just flashed back to stock and then put the recovery on and it worked the same as you sead with the usb so i followed your steps and the same happend with me. Ok now i would love to have root but not if the usb is not mounting is there any way to extract the orig recovery image from the t-mobile uk stock rom?

I just restored a rom i had on backup that i took just after installing the loader. If you don't have one then i'm not knowledgeable enough to help you further i'm afraid. If you've got a backup on your computer, you can use a usb card reader to put it on your SD card then boot into the recovery loader then do a nand restore.

All the best,

James

0

Share this post


Link to post
Share on other sites

Posted

I just restored a rom i had on backup that i took just after installing the loader. If you don't have one then i'm not knowledgeable enough to help you further i'm afraid. If you've got a backup on your computer, you can use a usb card reader to put it on your SD card then boot into the recovery loader then do a nand restore.

All the best,

James

Ok thanks for help but thats not what i mean im back to stock now. Ok what i would like to do is install a recovery image this will then let me install updates.zip files so i could use the lates su and superuser update.zip from xde developers this is the latest version of su and superuser app when i update using the zip this stays even when i do a wipe so thats all good i would then like to get rid of the recovery image and restore the stock t-mobile recovery. And i will then have a fully stock system but it will be fully rooted with the latest su and superuser app.

0

Share this post


Link to post
Share on other sites

Posted

For those with SD Mounting problems

If it helps i've found that restarting the phone with the USB cable plugged in seems to fix it until you unplug it

--OR--

Take the SD Card out while connected via USB, wait for the PCOPTIONS menu to come up on the pc, (Start it if it doesn't automatically), the reinsert the SD Card, and chose Mass Storage (or whatever it's called) from the PC.

This works for me and may work for you, eh no harm done in trying :D

Dan :D

0

Share this post


Link to post
Share on other sites

Posted

hmm i noticed that you have changed the finger print can i ask what device fingerprint is used? and is there any chance you could suppliy the file or tell me how to change thanks in advance.

0

Share this post


Link to post
Share on other sites

Posted

hmm i noticed that you have changed the finger print can i ask what device fingerprint is used? and is there any chance you could suppliy the file or tell me how to change thanks in advance.

I took the fingerprint from flibblesan's pulse mod. I'm notsure what fingerprint it is exactly.

You can change it within the "build.prop" file from the rom. there are two entries responsable for the fingerprint.

0

Share this post


Link to post
Share on other sites

Posted

We gonna see r4 soon? i was working on ur r3 mod and combined some stuff with RedBull stuff avaible on huawei device site so wana check how r4 will be :D

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.