MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

19/Aug - Streak 2.1 downloads / how-tos (ROM / Superboot / Recovery)

146 posts in this topic

Posted · Report post

So this is what happened to me last night:

I wanted to do a nandroid backup and followed the insuctions in the first post including the amendments regarding ADB

I'd go back to the recovery rom by using the power and two volume keys to only be presented with the same 4 default options.

What I didnt know was that the flash had been succesful every time and that I actually had choose the option to update the device using the update.pkg to see the extra options (including nandroid)

Paul can you please update the instructions and make it clear that this is the case. It took me over and hour to figure that out since I was worried about accidentally restoring using the update.pkg file

Wow - thanks for this, been driving me nuts!!!

+1

0

Share this post


Link to post
Share on other sites

Posted · Report post

Set the drivers manually while you're in recovery mode. That worked for me

Recovery mode? Do you mean ClockworkMod Recovery 2.5.01 mode? What driver did you use? Android ADB Interface, Android Bootloader Interface or Android Composite ADB Interface?

I am also getting the error: 'error: device not found'.

I have tried it from:

1. Fully booted up with the usb cable plugged in(it asks me to mount usb but i dont) with all three drivers:

-Android ADB Interface

-Android Bootloader Interface

-Android Composite ADB Interface

2. Fully booted up with the usb cable plugged in(it asks me to mount usb and i press yes) with all three drivers:

-Android ADB Interface

-Android Bootloader Interface

-Android Composite ADB Interface

3. From ClockworkMod Recovery 2.5.01 modewith all three drivers:

-Android ADB Interface

-Android Bootloader Interface

-Android Composite ADB Interface

4. From Fastboot mode with all three drivers:

-Android ADB Interface

-Android Bootloader Interface

-Android Composite ADB Interface

I need to do this mod as my stock 2.1 keeps rewriting the stock recovery image over ClockworkMod

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Recovery mode? Do you mean ClockworkMod Recovery 2.5.01 mode? What driver did you use? Android ADB Interface, Android Bootloader Interface or Android Composite ADB Interface?

I am also getting the error: 'error: device not found'.

I have tried it from:

1. Fully booted up with the usb cable plugged in(it asks me to mount usb but i dont) with all three drivers:

-Android ADB Interface

-Android Bootloader Interface

-Android Composite ADB Interface

2. Fully booted up with the usb cable plugged in(it asks me to mount usb and i press yes) with all three drivers:

-Android ADB Interface

-Android Bootloader Interface

-Android Composite ADB Interface

3. From ClockworkMod Recovery 2.5.01 modewith all three drivers:

-Android ADB Interface

-Android Bootloader Interface

-Android Composite ADB Interface

4. From Fastboot mode with all three drivers:

-Android ADB Interface

-Android Bootloader Interface

-Android Composite ADB Interface

I need to do this mod as my stock 2.1 keeps rewriting the stock recovery image over ClockworkMod

stop it from writing over the clockwork...

get root ..

using rootexplorer go to /system/etc then mount r/w and delete install-recovery.sh

follow my other instructions for flashing the clockwork recovery from shell direct on the streak

no need for drivers then..

with a rooted device..

copy the recovery image to the sdcard

install and open terminal emulator (unless that one can't do root) in which case better terminal emulator (paid app) which is frankly *better*

su

flash_image recovery /sdcard/whateveryoucalledtherecovery.img

reboot

while its rebooting hold down both volume keys

Edited by fards
0

Share this post


Link to post
Share on other sites

Posted · Report post

stop it from writing over the clockwork...

.....

while its rebooting hold down both volume keys

Cheers fards!!

Anyone know what the deal is with the three side lights? they dont light up except to flash every so often?!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Cheers fards!!

Anyone know what the deal is with the three side lights? they dont light up except to flash every so often?!

kernel/baseband mismatch I think..

you need the same baseband as the boot.img

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Found the solution from xda!

http://forum.xda-developers.com/showthread.php?t=752769

it fact, the error is caused by win7, i follow lufc's instruction and it works! and I got 2.1! :P

Hello CSSL1212,

:P :) :(

I have exactly this problem and the thread 752769 is no longer available...

Could you please give a description of how to solve this Streak driver detection/install problem on Win7/64 as each time I connect it, I get the "do do do" from death...

It seems that it search and cannot fnd the android 1.0 driver..

Hepl :D :( :(

Edited by BooToo
0

Share this post


Link to post
Share on other sites

Posted · Report post

Well...

I managed to get my 2.1 update 1 installed on my O2 Streak via the official DELL Wifi download page.

I am VERY surprised by some people comments relative to how slow the 2.1 is coming from 1.6.

Personnaly, I find it MUCH faster...

One thing though... My SD card no longer appear under windows. I explored the settings menue unsucessfully.

Anybody got the same problem and found how to solve it by any chance?

Cheer,

BooToo

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well...

I managed to get my 2.1 update 1 installed on my O2 Streak via the official DELL Wifi download page.

I am VERY surprised by some people comments relative to how slow the 2.1 is coming from 1.6.

Personnaly, I find it MUCH faster...

One thing though... My SD card no longer appear under windows. I explored the settings menue unsucessfully.

Anybody got the same problem and found how to solve it by any chance?

Cheer,

BooToo

I just read your post, congratulations! I trust you found the way to sort out the problem, how can you do that?

One of the solution below in case someone get this problem

-device is not recognized by PC (win7) during Fastboot mode

-go to device manager > right click unknown device > properties > update driver > browse driver in computer > let me choose from computer's drive > choose Android Phone then it should be sorted!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well...

I managed to get my 2.1 update 1 installed on my O2 Streak via the official DELL Wifi download page.

I am VERY surprised by some people comments relative to how slow the 2.1 is coming from 1.6.

Personnaly, I find it MUCH faster...

One thing though... My SD card no longer appear under windows. I explored the settings menue unsucessfully.

Anybody got the same problem and found how to solve it by any chance?

Cheer,

BooToo

Press the notification area at the top and pressed mount?

Maybe you have a duff USB cable..

0

Share this post


Link to post
Share on other sites

Posted · Report post

hi paul im using your guide to update my baseband 00 to 21 to use this 2.1 update. may i ask if im just a normal user. can i do without the SUPERBOOT and recovery images step after i updated to 2.1 using the first 2 step? please help

0

Share this post


Link to post
Share on other sites

Posted · Report post

kernel/baseband mismatch I think..

you need the same baseband as the boot.img

Mine is an O2 version and i presume the MCR is an O2 version. So the baseband+boot.img must match id say??

0

Share this post


Link to post
Share on other sites

Posted · Report post

One of the solution below in case someone get this problem

-device is not recognized by PC (win7) during Fastboot mode

-go to device manager > right click unknown device > properties > update driver > browse driver in computer > let me choose from computer's drive > choose Android Phone then it should be sorted!

This did the trick for me on Windows XP! Thank you VERY much!!!

:P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Finally the lock screen is back the 1.6 fastness!

There was a big of lag with the previous 2.1 versions, very annoying, especially when your screen timout is something like 30 secs!

But its definately back to the 1.6 speed now :-)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Does anyone have 8105 in zip form so it can be flashed from an aftermarket recovery? Stock recovery isn't working for me, and the modaco rom just hangs at boot screen.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I just read your post, congratulations! I trust you found the way to sort out the problem, how can you do that?

One of the solution below in case someone get this problem

-device is not recognized by PC (win7) during Fastboot mode

-go to device manager > right click unknown device > properties > update driver > browse driver in computer > let me choose from computer's drive > choose Android Phone then it should be sorted!

I went through wifi for the update so did not need to get the streak identified in recovery mode ;-)

Anyway, I followed your instructions by selecting the android driver manually and the Streak is now fully recognized so BIG THANKS ;-) (By the way, for the one who have this probel, be aware this needs to be done in both normal and recovery mode)

For the USB mount problem, I also found the solution.

It needs to be done manually by clicking the top menu bar on the right of the SIM one (the one where it shows the USB symbol) + click the USB connection and you will be proposed with an option to mount your card.

I guess, this is a difference with Froyo who automatically mount it on my Nexus.

Next stop for me is the 2.2 upgrade (I really miss flash on the sites) as soon as it is available + SIM FREE when the codes start to be distributed and I will have my Adroid dream terminal ;-))))

Edited by BooToo
0

Share this post


Link to post
Share on other sites

Posted · Report post

Flashed, rebooted, now just getting the Dell Logo and the MCR logo flashing.

0

Share this post


Link to post
Share on other sites

Posted · Report post

New to this and I just followed this procedure and am stuck in the Dell Logo....and all three buttons are lit up

I had a direct purchased Dell Streak - and got applied 6267 yesterday and since then was having issues - so I thought I would follow this and see where it got to

My device was not rooted and I followed the instruction in first screen

fast boot and applied update.pkg

now stuck in dell logo for 30 minutes r so - should I continue to wait ????

please help

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

New to this and I just followed this procedure and am stuck in the Dell Logo....and all three buttons are lit up

I had a direct purchased Dell Streak - and got applied 6267 yesterday and since then was having issues - so I thought I would follow this and see where it got to

My device was not rooted and I followed the instruction in first screen

fast boot and applied update.pkg

now stuck in dell logo for 30 minutes r so - should I continue to wait ????

please help

I had such problem yesterday when i flashed the 8105, finally i went thru it after took out the battery. However, the 3 leds are blinking 3 times every few minutes... very annoying... i will try reflashing tonight.

Edited by CSSL1212
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I had such problem yesterday when i flashed the 8105, finally i went thru it after took out the battery. However, the 3 leds are blinking 3 times every few minutes... very annoying... i will try reflashing tonight.

The phone seems working very good so far followed with Paul's procedure: copy the 8105 update.pkg to SD card then reflashing > done! The LEDs do not blink anymore, I am so happy. :)

Thanks Paul. :P

Edited by CSSL1212
0

Share this post


Link to post
Share on other sites

Posted · Report post

The phone seems working very good so far followed with Paul's procedure: copy the 8105 update.pkg to SD card then reflashing > done! The LEDs do not blink anymore, I am so happy. :)

Thanks Paul. :P

Re flashed 2.1 mcr but still got flashing leds!grrrr

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

adb-windows shell (or adb-linux shell or adb-mac shell)

su

mount -o remount,rw /dev/block/mtdblock6 /system && rm /system/etc/install-recovery.sh && mount -o remount,ro /dev/block/mtdblock6 /system

exit

exit

I tried the above but I just get "device not found" error following the first bit which means it doesn't understand the mount command. I guess I'm missing something somthing fundamental (a clue!) but I'm in over my head already. Have I missed something simple?

I'm currently on a rooted 7546 build.

Hehehe...

I am now sucessfully on 2.1 official on my O2. So far so good :)

Now, I am trying to install the custom recovery image and am also running through the same issue as above.

My drivers did not get installed automatically under windows and I had to select Android 1.0 manually and it seems that everything got install correctly ( I can connect to the phone using ADB shell when booted or in recovery mode connected to my W7 pc).

However, when I follow the instructions above and try to connect to the phone via the "adb-windows" from the recovery image folder directly (instead of sdk/tools), I get a "Device not found".

How weird is that??????

I have tried the procedure from my sdk/tools folder and all command seemed to work, then I double clicked the "install-recovery-windows.bat" who also seemed sucessfull.

Unfortunately, when I boot pressing the volume buttons, I get the Dell/O2 logos and get back to my 2.1 home screen :P

Not sure what i am doing wrong here so any input is welcome :(

Thanks in advance.

BooToo

Edited by BooToo
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I managed to solve the problem of Device not found by making a copy of ADB for SDK/Tools in the recovery folder (Low tech but it works...)

But now.. Well, have a look to the erro message I get and hopefully, you won't have to tell me I am not a morron who doesn't know how copy a command line :P

mount -o remount,rw /dev/block/mtdblock6 /system && rm /system/etc/install-recovery.sh && mount -o remount,ro /dev/block/mtdblock6 /system rm failed for /system/etc/install-recovery.sh, No such file or directory

Input more than welcome!!!

BooToo

Edited by BooToo
0

Share this post


Link to post
Share on other sites

Posted · Report post

If you are using koush's recovery, you need to go into partitions to mount system. This may be easier

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

If you are using koush's recovery, you need to go into partitions to mount system. This may be easier

Hi,

Not sure I understand, could you please ellaborate?

The only Streak partition I see in windows is the SD card. I do not see the system partition...

Thanks,

BooToo

Edited by BooToo
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

Newbie here.

I have a Dell direct Streak, 00-EU baseband. I updated with the Dell update on Friday and now have the flashing Menu and Home buttons. My screen is hyper sensitive (making texting impossible).

I have tried to follow the instructions at the top of this topic but my PC (Win7 and XP) cannot find drivers to run the Streak in the Fastboot mode so therefore wont allow me to access the device.

Someone please help me. This unit cost me over £450 and I am totally pee'd off now.

Looking forward to some idiot proof responses, I am not that technically minded and have never had to do this sort of stuff before.

Cheers folks

Andy

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.