jsplace

WinXP/7 ZTE Blade drivers and ADB

69 posts in this topic

For those who have had problems installing drivers and getting adb to work for their Blade I have pulled the necessary files from my SDK installation that should get you going.

The .rar contains the r3 android driver, latest adb from the SDK and a modified .inf file to allow the Blade to be recognised by Windows in both ADB and bootloader modes.

I have had sucess with this both in WinXP and Win7 using exactly the same files.

Enjoy and please let me know if it works for you :lol:

http://www.easy-share.com/1912504577/usb_driver.zip

~6.5Mb

EDIT: Sorry for the REALLY crapps hosting, if someone could please upload to somewhere sensible it would be appreciated!

EDIT2: Quick HowTo. (How I did it)

1. Download the file above and extract to a folder of your choice.

2. With your phone ON and fully booted, connect to PC with USB cable.

New Hardware wizard should start. (See below if it doesn't)

3. When asked to search select no and browse to the folder where you extracted the files.

Click next and the wizard should install 2 devices. (SingleAdbInterface and CompositeAdbInterface)

4. Unplug the phone from the pc and restart phone in bootloader mode (Power on with Volume up key pressed)

Phone should stay on Green Android screen.

5. Plug in phone again and wizard should detect new hardware. Again point wizard to folder where you extracted files and SingleBootloader device should be installed.

6. Job done B) Reboot phone and all should be working.

IF NEW HARDWARE WIZARD DOES NOT START.

1. Open device manager and right click on The exclamation (Think it says HSUSB?)

2. Select Update driver

3. When asked to search select no and browse to the folder where you extracted the files. Select next and driver will be installed.

4. Repeat step 3 for the other HSUSB device with exclamation.

5. Reboot into bootloader, rinse and repeat.

Hope this helps B)

Big thanks to Matty P for hosting this on his site too :lol:

Here is his link (Fixed)

http://www.matthewpickering.co.cc/usb_driver.zip

Rapidshare etc just wont work for me for some reason....

Edited by jsplace
0

Share this post


Link to post
Share on other sites
For those who have had problems installing drivers and getting adb to work for their Blade I have pulled the necessary files from my SDK installation that should get you going.

The .rar contains the r3 android driver, latest adb from the SDK and a modified .inf file to allow the Blade to be recognised by Windows in both ADB and bootloader modes.

I have had sucess with this both in WinXP and Win7 using exactly the same files.

Enjoy and please let me know if it works for you :lol:

http://www.easy-share.com/1912504577/usb_driver.zip

~6.5Mb

EDIT: Sorry for the REALLY crapps hosting, if someone could please upload to somewhere sensible it would be appreciated!

Rapidshare etc just wont work for me for some reason....

sticking a readme in there for beginers may not be a bad idea

also heres a reupload on my site so you dont have to click and wait click and wait like on the current file hoster just click safe file when the window comes up http://www.matthewpickering.co.cc/usb_driver.zip

1

Share this post


Link to post
Share on other sites

Nice one mate, got it working nicely for me.

Cheers

0

Share this post


Link to post
Share on other sites
Nice one mate, got it working nicely for me.

Cheers

Great stuff :lol:

Will try and put a quick readme together later.

Cheers all.

0

Share this post


Link to post
Share on other sites

Cheers got it working :lol:

0

Share this post


Link to post
Share on other sites

Post #1 edited to give instructions too.

Enjoy :lol:

0

Share this post


Link to post
Share on other sites

Just done this and am only getting the one entry in device manager on the first bit - Android Composite ADB Interface???

Edited by synet
0

Share this post


Link to post
Share on other sites

Thanks for this. Now rooted and on r2 :)

0

Share this post


Link to post
Share on other sites
3. When asked to search select no and browse to the folder where you extracted the files.

Click next and the wizard should install 2 devices. (SingleAdbInterface and CompositeAdbInterface)

Having browsed to your provided drivers my Win7 (64 bit) Device Manager has two entries under 'Android Phone': Android ADB Interface and Android Composite ADB Interface. Is this the same as SingleAdbInterface and CompositeAdbInterface or have I done something wrong?

Thanks.

Edited by Scatterbug
0

Share this post


Link to post
Share on other sites

Worked perfectly through Device Manager.

Thanks!

0

Share this post


Link to post
Share on other sites
Having browsed to your provided drivers my Win7 (64 bit) Device Manager has two entries under 'Android Phone': Android ADB Interface and Android Composite ADB Interface. Is this the same as SingleAdbInterface and CompositeAdbInterface or have I done something wrong?

Thanks.

Nope you havent done anything wrong, that should work fine :)

0

Share this post


Link to post
Share on other sites

This seems to have worked for me - many thanks to jsplace for posting :)

0

Share this post


Link to post
Share on other sites

Can't download it, keeps going to a blank page after clicking "download"

0

Share this post


Link to post
Share on other sites

Thanks for the mirror rotten & the op for supplying, all went well, but phone is stuck in bootloader mode, won't turn off, any fix?

Fixed, removed battery then replace, started up fine.

Edited by goods
0

Share this post


Link to post
Share on other sites
I uploaded them to another mirror, if you want to try depositfiles: http://depositfiles.com/files/x41hu5ias

Thanks to the OP. :)

Thanks for rehosting ;)

For some reason HTTP uploads always stop after 1Mb the host I found was the only free one that I could use FTP.

0

Share this post


Link to post
Share on other sites

I've updated my modified drivers to fully support 32bit and 64bit Windows Vista & Windows 7 as well as 32bit XP and Windows 2000. http://flibblesan.co.uk/android/zte_driver.zip

You will probably need to install the drivers manually from the device manager. Ignore any warnings about them being unsigned.

0

Share this post


Link to post
Share on other sites

Thanks for sorting out these divers. A lot of people are struggling on windows, I have linked this thread in my guide on sorting out the MoDoCo ROM.

Great work

0

Share this post


Link to post
Share on other sites

can you please upload them on a different site, am having trouble opening this page.....

0

Share this post


Link to post
Share on other sites
I've updated my modified drivers to fully support 32bit and 64bit Windows Vista & Windows 7 as well as 32bit XP and Windows 2000. http://flibblesan.co.uk/android/zte_driver.zip

You will probably need to install the drivers manually from the device manager. Ignore any warnings about them being unsigned.

First post - having picked up a SF yesterday, I'm having a play :)

Anyhow: Flibblesan's driver pack didn't work under 32-bit Vista, sadly - the modem driver is installed, but Vista then can't find the driver for "ZTE HSUSB". JSPlace's driver pack did the job, but I had to download it from Matty P's link, as the free hosting thing completely failed to work...

Edited by j00ce
0

Share this post


Link to post
Share on other sites

Hi, I followed this, after step 5 the phone has stuck on the Green Android screen and won't reboot. Any ideas? I don't want to pull the battery in case I brick the handset?

For those who have had problems installing drivers and getting adb to work for their Blade I have pulled the necessary files from my SDK installation that should get you going.

The .rar contains the r3 android driver, latest adb from the SDK and a modified .inf file to allow the Blade to be recognised by Windows in both ADB and bootloader modes.

I have had sucess with this both in WinXP and Win7 using exactly the same files.

Enjoy and please let me know if it works for you :)

http://www.easy-share.com/1912504577/usb_driver.zip

~6.5Mb

EDIT: Sorry for the REALLY crapps hosting, if someone could please upload to somewhere sensible it would be appreciated!

EDIT2: Quick HowTo. (How I did it)

1. Download the file above and extract to a folder of your choice.

2. With your phone ON and fully booted, connect to PC with USB cable.

New Hardware wizard should start. (See below if it doesn't)

3. When asked to search select no and browse to the folder where you extracted the files.

Click next and the wizard should install 2 devices. (SingleAdbInterface and CompositeAdbInterface)

4. Unplug the phone from the pc and restart phone in bootloader mode (Power on with Volume up key pressed)

Phone should stay on Green Android screen.

5. Plug in phone again and wizard should detect new hardware. Again point wizard to folder where you extracted files and SingleBootloader device should be installed.

6. Job done :) Reboot phone and all should be working.

IF NEW HARDWARE WIZARD DOES NOT START.

1. Open device manager and right click on The exclamation (Think it says HSUSB?)

2. Select Update driver

3. When asked to search select no and browse to the folder where you extracted the files. Select next and driver will be installed.

4. Repeat step 3 for the other HSUSB device with exclamation.

5. Reboot into bootloader, rinse and repeat.

Hope this helps :)

Big thanks to Matty P for hosting this on his site too :D

Here is his link (Fixed)

http://www.matthewpickering.co.cc/usb_driver.zip

Rapidshare etc just wont work for me for some reason....

0

Share this post


Link to post
Share on other sites
Hi, I followed this, after step 5 the phone has stuck on the Green Android screen and won't reboot. Any ideas? I don't want to pull the battery in case I brick the handset?

Open a command prompt in the folder where you have fastboot/adb (and the drivers) just type "fastboot reboot"

Phone should restart, pulling battery at this point tho is safe, you are not flashing anything :)

Edited by jsplace
0

Share this post


Link to post
Share on other sites

Excellent, much appreciated.

Open a command prompt in the folder where you have fastboot/adb (and the drivers) just type "fastboot reboot"

Phone should restart, pulling battery at this point tho is safe, you are not flashing anything :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.