• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

1click app2sd now includes 1 click root

140 posts in this topic

Posted

Thanks m8. What is the check screen?

0

Share this post


Link to post
Share on other sites

Posted

need help.....

i do a partition like pdf...

i run file in XP....

i choose english...

then??? i try 1 and 4 but when i install app. they go on memory phone???

why not in SD????

help pls

thank

Did you restart the phone after applied app2sd (menu 6) ?

When you selected the menu 1 or 4 did it showed Data Copying or unable to mount ext2 ?

0

Share this post


Link to post
Share on other sites

Posted

Thanks m8. What is the check screen?

menu 8

0

Share this post


Link to post
Share on other sites

Posted (edited)

Working now, thx m8

Edited by sarbe
0

Share this post


Link to post
Share on other sites

Posted

Thanks. On menu 8 i get nothing lol

If usb debugging is on and select menu 8 you should see something similar :

/dev: 86488K total, 12K used, 86476K available (block size 4096)

/data: 142848K total, 27596K used, 115252K available (block size 4096)

/cache: 65536K total, 1156K used, 64380K available (block size 4096)

/sqlite_stmt_journals: 4096K total, 0K used, 4096K available (block size 4096)

/system: 250880K total, 234828K used, 16052K available (block size 4096)

/lgdrm: 2816K total, 1180K used, 1636K available (block size 4096)

/system/sdcard: 932865K total, 46652K used, 886213K available (block size 1024)

/data/app: 932865K total, 46652K used, 886213K available (block size 1024)

/data/dalvik-cache: 932865K total, 46652K used, 886213K available (block size 10

24)

/data/data: 932865K total, 46652K used, 886213K available (block size 1024)

/sdcard: 14683712K total, 1593536K used, 13090176K available (block size 32768)

As you see in this example /data/app , /data/dalvik-cache, /data/data is mounted on sd.

0

Share this post


Link to post
Share on other sites

Posted

Did you restart the phone after applied app2sd (menu 6) ?

When you selected the menu 1 or 4 did it showed Data Copying or unable to mount ext2 ?

i restat phone but all app. are installed on memory phone

0

Share this post


Link to post
Share on other sites

Posted

i restat phone but all app. are installed on memory phone

What is your check screen ?

0

Share this post


Link to post
Share on other sites

Posted

Did you restart the phone after applied app2sd (menu 6) ?

When you selected the menu 1 or 4 did it showed Data Copying or unable to mount ext2 ?

when i select 1 or 4 it dont show nothing

0

Share this post


Link to post
Share on other sites

Posted

when i select 1 or 4 it dont show nothing

What does it say if you select menu 8 ?

0

Share this post


Link to post
Share on other sites

Posted

How the script works :

It copies the contents of the selected folders to the sd ext2 partition . It does not removes the copied files from the phone , because in the case of sd failure or sd removal the phone will be able to bootup. The removal process removes the files and directories needed to app2sd operate normally , but leaves the ext2 untouched.

To use it you need to turn on the USB Debugging mode on the phone .Create the ext2 if not exists .The first partitition should be FAT if your card is smaller than 4GB and should be FAT32 if bigger than 4 GB. The second partition should be ext2. Both partition must be primary.

Dont forget to restart the phone and turn off mass storage mode after creation of the ext2.Download the zip file , extract it and run autorootapp2sd.bat on your pc.

You can use app2sd even if your phone is not rooted.

The attached pdf contains the guide how to create the ext2.

MOD:

The script has the possibilities to turn on root. The root and unroot function is the same as 1 click root .

Thankyou so much :-)

you really helped me and it works too :D

and i really appreciate your help that you provided in your step-by-step guide :P

I am a noob in android ,can you please also provide me help regarding custom roms and cynogens ...i dont know what they are and are they safe?

Once again thanks man for your help :D

0

Share this post


Link to post
Share on other sites

Posted

I install app2sd and when i install a program from the market it go to memory phone why....??? not on sd ????

thks

0

Share this post


Link to post
Share on other sites

Posted

The first partitition should be FAT if your card is smaller than 4GB and should be FAT32 if bigger than 4 GB. The second partition should be ext2. Both partition must be primary.

thx for the one-click. got one question though.

i want to use the recovery rom, it says u need to put the fat partition in the last. and is that compatible with your method?

i want to try all possibilities in my gt540 :P

thx again.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Everytime I install app2sd, everything works fine till, for no reason, errors start to appear out of nowhere, so many errors I can't even use the phone no more. Every method I've tried leads to the same result. What could be wrong? :S

Edited by fjsferreira
0

Share this post


Link to post
Share on other sites

Posted

If usb debugging is on and select menu 8 you should see something similar :

/dev: 86488K total, 12K used, 86476K available (block size 4096)

/data: 142848K total, 27596K used, 115252K available (block size 4096)

/cache: 65536K total, 1156K used, 64380K available (block size 4096)

/sqlite_stmt_journals: 4096K total, 0K used, 4096K available (block size 4096)

/system: 250880K total, 234828K used, 16052K available (block size 4096)

/lgdrm: 2816K total, 1180K used, 1636K available (block size 4096)

/system/sdcard: 932865K total, 46652K used, 886213K available (block size 1024)

/data/app: 932865K total, 46652K used, 886213K available (block size 1024)

/data/dalvik-cache: 932865K total, 46652K used, 886213K available (block size 10

24)

/data/data: 932865K total, 46652K used, 886213K available (block size 1024)

/sdcard: 14683712K total, 1593536K used, 13090176K available (block size 32768)

As you see in this example /data/app , /data/dalvik-cache, /data/data is mounted on sd.

Joestone,

I seem to be having similar problems, I have installed the Australia Optus 2.1 update and using your app2sd I can't use #4 option keep getting errors. My #8 is attached but I only have 113mg internal available space? Would that be right as when I used the Baltic version I had 125mg.

Clive

post-762375-1288083791_thumb.png

0

Share this post


Link to post
Share on other sites

Posted

Everytime I install app2sd, everything works fine till, for no reason, errors start to appear out of nowhere, so many errors I can't even use the phone no more. Every method I've tried leads to the same result. What could be wrong? :S

too big a partition size, try making a smaller one, maybe around 400 meg., or the card is dying(Ext will use up the finite writes on a card, so can kill a card quicker, with all the journaling it does), faulty phone..you name it, roll a dice, for a problem, it could be a couple of things.

0

Share this post


Link to post
Share on other sites

Posted

too big a partition size, try making a smaller one, maybe around 400 meg., or the card is dying(Ext will use up the finite writes on a card, so can kill a card quicker, with all the journaling it does), faulty phone..you name it, roll a dice, for a problem, it could be a couple of things.

I've tried with another card, a new one, and after a day or two, force closings all around! :P I guess it's the phone then. Very sad i can't use app2sd because internal memory is just too little.

0

Share this post


Link to post
Share on other sites

Posted

I've tried with another card, a new one, and after a day or two, force closings all around! :P I guess it's the phone then. Very sad i can't use app2sd because internal memory is just too little.

I have noticed some sd mount errors if the partiton was ext3 not ext2. With ext2 i did not notice any problems.

0

Share this post


Link to post
Share on other sites

Posted

I've tried ext2 and ext3, errors in both. I gave up :P

0

Share this post


Link to post
Share on other sites

Posted

I've tried ext2 and ext3, errors in both. I gave up :D

same ! :P

0

Share this post


Link to post
Share on other sites

Posted

People who aren't getting force closings with app2sd, please post:

App used to partition SD card (I used both gparted and minitool partition wizard)

Sd card capacity and brand (I've used a 2GB kingston and a Sandisk 4GB)

Partition scheme (I've used fat32 - ext2; fat - ext2; fat32 - ext3; fat-ext2, and all combinations with a swap area, and I've tried with different partition sizes)

Rom (I've used 2.1 baltic and 2.1 greek, with fresh installs (hard resets and all that))

Tutorial used (I've used all of them :S)

Any other info you consider relevant.

I'de be very much grateful, maybe I can finally see if I'm doing something wrong.

0

Share this post


Link to post
Share on other sites

Posted (edited)

ok. since i've got much errors too from this 1 click app2sd.

this is my setup:

partition sdcard: paragon partition manager.

sdcard capacity: team 8 gb (supposedly class 6, but i dont think it is :D )

partition scheme: 6.69 gb fat32, 501 mb ext2

rom: 2.1 black edition by Quarx, with firmwire that has fastboot and recovery (clockwork), updated kernel too

tutorial used: 1 click root app2sd. when very first time i use the other app2sd (the one with copying the .sh) it worked, but it bricked my sdcard, thankfully the warranty've covered it

so either the partition to large, or my sdcard is not good for app2sd (i'm afraid it'll brick to if i try the app2sd, but if u never try u will never know right :P )

thankfully the remove app2sd from the 1 click app2sd can solve all the force close

Edited by m1st3r1
0

Share this post


Link to post
Share on other sites

Posted

ok. since i've got much errors too from this 1 click app2sd.

this is my setup:

partition sdcard: paragon partition manager.

sdcard capacity: team 8 gb (supposedly class 6, but i dont think it is :D )

partition scheme: 6.69 gb fat32, 501 mb ext2

rom: 2.1 black edition by Quarx, with firmwire that has fastboot and recovery (clockwork), updated kernel too

tutorial used: 1 click root app2sd. when very first time i use the other app2sd (the one with copying the .sh) it worked, but it bricked my sdcard, thankfully the warranty've covered it

so either the partition to large, or my sdcard is not good for app2sd (i'm afraid it'll brick to if i try the app2sd, but if u never try u will never know right :P )

thankfully the remove app2sd from the 1 click app2sd can solve all the force close

Yes, removing fixes it, but living without app2sd is just shitty with our low memory capacity phone :D I have 14 apps and already only 12mb available.

0

Share this post


Link to post
Share on other sites

Posted

thanks joe,

your update worked a treat!!

now got a rooted GT540 :)

already got your apps 2 sd working.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Guys...

finally, I got app2sd now and working no problem but just little working slowly.

anyway I have a problem I turn off my phone and turn on. however, my phone is not booting but after removed Memory card it's working.

What happen? after app2sd I can't turn off? Please give me solution.

Rom : Vodafone 2.1

Memory: Transcend 8gb class6

partition scheme: 6.69 gb fat32, 501 mb ext2(around like that)

tutorial used: 1 click root app2sd.

Edited by ohoosong
0

Share this post


Link to post
Share on other sites

Posted

Removed apps to sd . It worked 2 days , reinstalled , it worked more couple of days , reinstalled , yesterday same thing with force closes and unisnalled it . Now Im without apps to sd ...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.