• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

1click app2sd now includes 1 click root

140 posts in this topic

Posted (edited)

Okay guys, thank you all very much for useful informations. Any many thanks to author who make it really easy way. Here is my first experience:

Device GT540

LG Europe 2.1 Official ROM (20B)

SD 32GB Class 4 Kingston (Faster isn't currently available with this capacity)

SD is divited aprox.this way: XXGB FAT32, 850MB Ext2, 150MB SWAP

UPDATED:

Here's my observations as I was playing with the thing for a day:

My recommendations:

1) Apply App2SD on clean ROM (preferably do factory reset before or reflash it entirely)

2) If you messed up with it for a while it's good idea to reformat ext2 partition as there are MBs of different data

My observations:

1) Class 4 card is probably still too slow for applying full app2sd, mainly appdata needs to be accessed really promptly

2) Options 1, 2, where appdata is not moved make your installations lowerring system memory still significantly that is why I believe appdata can make a big part of whole single app

3) If I apply any of 3, 4, I will get some force closing in near future, phone is laggy, sometimes on power on I'm not even asked for pin to sim. When someone calls me I'm getting ringing with blackscreen and it takes a considerable time to render call display with controls but fortunately I can answer call anytime by pressing hw button. I think that this is manly because I have quite slow SD card for this use. Do I?

4) But anyway it seems that all options work quite well when considering app installations. It seems that on my configuration is practically applicable only first option which is sufficient for my use.

SERIOUS QUESTIONS: (Appreciated if anyone can answer)

1) THE MOST SERIOUS PROBLEM: Consider option 1 Standart App2SD. As most of the applications work great I'm having problems mainly with players. There's app arcMedia. It's media player. It works great when installed without app2sd. But I tried every possible option of app2sd and this app doesn't work! And don't really understand why and it considerably argues stability of app2sd as it should just trick android to move standart app directory to other place. But now it seems it's not that simple! I guess there might be two possible issues. Either the app is strangely hardcoded and cannot find some parts when run on SD (it would correspond to no icon and system label) or app2sd missing some aspect of Android system which cannot be provided by simple directory mount (I guess it's called simlink in unix speech). I don't quite understand it. Any one can answer this? Anyone who think has working app2sd can try this app and post result?

Maybe there is problem in my configuration, use of official lg rom with a lot of integrated apps and such, not sure. Any ideas would be appreciated. I'd love to have stable phone with enough room for apps.

UPDATE 2: Phone hangs over night with full app2SD. I think it run but cannot be awake, there's no response to buttons, only way to restart is to reconnect the battery then it works. Strange behaviour!

Let Android live!

Edited by Siamoen
0

Share this post


Link to post
Share on other sites

Posted

Right, I finally managed to get app2sd working, but I can only have Option 1. Options 3 and 4 make the phone unstable!!!

But, this isn't an issue. I am more than happy to run with Option 1. I can now install loads of apps/games and my Internal Storage doesn't run low any where near as quickly as it used to.

My question is though, why do some phones not like Options 3 and 4??? Why do they make the phone unstable????

0

Share this post


Link to post
Share on other sites

Posted

i'm using transcend 8gb class 2 sd card...will app2sd work fine with this??

0

Share this post


Link to post
Share on other sites

Posted (edited)

Just thought I'd mention,

DO NOT TAKE OUT THE MICROSD AND THEN TURN ON THE PHONE, THIS CAUSES 90% OF APPS TO CEASE FUNCTIONING, AND CONSTANTLY "FORCE CLOSE".

I learnt this the hard way and had to reinstall EVERY single app!!! :D

Edited by Corrupt Systems
0

Share this post


Link to post
Share on other sites

Posted

i'm using transcend 8gb class 2 sd card...will app2sd work fine with this??

Yes mate, this should work perfectly. Just make sure you follow the instructions carefully.

0

Share this post


Link to post
Share on other sites

Posted

I'm also up for option 1. But can anyone please try to install application arcMedia and run it with some video? I'm really curious if it works. Please post some results and sys config. Thanks

0

Share this post


Link to post
Share on other sites

Posted

how do i know if the process is finished..i chose option 1 and pressed enter then the command promt showed something like starting app2sd then became blank...is it done already or do i have to wait??

0

Share this post


Link to post
Share on other sites

Posted

how do i know if the process is finished..i chose option 1 and pressed enter then the command promt showed something like starting app2sd then became blank...is it done already or do i have to wait??

turns out my phone is not detected...how can i make the phone detected?

0

Share this post


Link to post
Share on other sites

Posted

Why don't you guys just update to android 2.2.1.It's faster than 2.1 and it fully supports app2sd.And there's no lag.Check out this thread at xda developers:

http://forum.xda-developers.com/showthread.php?t=857213

I'm running Cyanogenmod 6.1.1 right now and it's really smooth.

But this is just me,if you don't want to upgrade,continue using 2.1.

0

Share this post


Link to post
Share on other sites

Posted

Why don't you guys just update to android 2.2.1.It's faster than 2.1 and it fully supports app2sd.And there's no lag.Check out this thread at xda developers:

http://forum.xda-developers.com/showthread.php?t=857213

I'm running Cyanogenmod 6.1.1 right now and it's really smooth.

But this is just me,if you don't want to upgrade,continue using 2.1.

Because it still has some bugs and some features missing. Stuff that perhaps some don not use, but others do. For example, FM Radio is not working, bluetooth is not working for everyone, and there are updates coming out too often. Not everyone wants to flash their phone once per week, risk of bricking is never zero no matter what you do.

0

Share this post


Link to post
Share on other sites

Posted

Because it still has some bugs and some features missing. Stuff that perhaps some don not use, but others do. For example, FM Radio is not working, bluetooth is not working for everyone, and there are updates coming out too often. Not everyone wants to flash their phone once per week, risk of bricking is never zero no matter what you do.

Totally agree, when froyo is completed, I'm swithing to it right away. Till it happend I need stable full featured version with atleast weak app2sd.

0

Share this post


Link to post
Share on other sites

Posted

works great. i have installed app2sd and rooted my phone. ;)

0

Share this post


Link to post
Share on other sites

Posted

Hello. I've installed the app2sd and checked and it IS working. just to check do I have to UN install all of the apps and RE install them?

Thanks ;)

0

Share this post


Link to post
Share on other sites

Posted (edited)

I did every step corectly ..... but when I lounch autorootapp2sd i chouse english ..... and every comand I do (r ... 1....2.....3.....4......) do nothing .....

I am usig official v20b firmfare ....

What I am doing wrong ...... could u please hellp me .......

Edited by markisioful
0

Share this post


Link to post
Share on other sites

Posted

I love app2sd Option 1. I now have LOADS of apps on my phone and I've still got 70mb left on the internal storage.

Big thanks to the coders that made this possible.

0

Share this post


Link to post
Share on other sites

Posted

Doesn't work for me either.

says adp isn't an internal windows command or something and proceeds to do nothing. I'm still running 1.6 (cannot upgrade, it's a nightmare) from Belgium 10b.

I'm actually trying to do all of this from virtualbox inside linux (does it matter?)

Clues, anybody?

0

Share this post


Link to post
Share on other sites

Posted

Just thought I'd mention,

DO NOT TAKE OUT THE MICROSD AND THEN TURN ON THE PHONE, THIS CAUSES 90% OF APPS TO CEASE FUNCTIONING, AND CONSTANTLY "FORCE CLOSE".

I learnt this the hard way and had to reinstall EVERY single app!!! :lol:

Successfully used app2sd with cache. Worked great for a day or two. Installed bunch of apps without any problems. Only one app force close and can't be used with app2sd - arcMedia (try it yourself). Was happy, but yesterday night my phone got self-restarted. In the morning I noticed, that apps doesn't have their icons but default android one. Widgets from installed apps keep sayin' loading... Restarted phone, icons ok but everything still forced to close. I needed to reinstall every single app. And guess what? Today it happend again, every single app it's gone and need to be reinstalled. Any solution to this?

GT540 ROM: Europe 2_0B = Eclair 2.1 + rooted + SD 32GB class 4

I'm going to try link2sd, app2sd is too unreliable. My suggestion is, that probably moving dalvik cache to sd may cause the problem when there's temporary card error. I can't imagine how apps can be broken.

0

Share this post


Link to post
Share on other sites

Posted

I love app2sd Option 1. I now have LOADS of apps on my phone and I've still got 70mb left on the internal storage.

Big thanks to the coders that made this possible.

can u tell me your steps?

do we need to root first? the title said that it works for non root phone

0

Share this post


Link to post
Share on other sites

Posted

Manually tried simpliest version of app2sd, only app dir moved to sd, nothing else. After half day phone restarted itself and apps are gone again! :-(

Anyone who has it succesfully longterm working can post his config please? ROM, SDCard cap+class+manufacturer

I'm desperate here...

0

Share this post


Link to post
Share on other sites

Posted

did option 1 but after a day my phone began to run slowly and became unstable..sometimes it reboots by itself and seem to be stuck on the android screen and sometimes apps just force closes and needs to be reinstalled...I'll jst have to wait for cyanogen to be complete and free from bugs then i'm upgrading.....

0

Share this post


Link to post
Share on other sites

Posted

why is it that after i installed this apps2sd i always have notifications "sd card unexpectedly removed" every once in a while and then evrything gets messed up...whats the problem??

0

Share this post


Link to post
Share on other sites

Posted (edited)

the batchfile says

what did i wrong?

edit:

it says

mount: Invalid argument

Unable to mount ext2

*********************app2sd finished**************************

"You need to restart your phone"

I have this problem too. Anyone?

EDIT: When you turn on USB Mass Storage, it disables USB Debugging, so you have to re-enable it................

Edited by skinnypupp
0

Share this post


Link to post
Share on other sites

Posted

i have tried to open the autorootapp2sd.bat but the message says that the application is not available. anyone knows how to solve this problem?

0

Share this post


Link to post
Share on other sites

Posted

what about backup and the apps that are already existing on the sd card

0

Share this post


Link to post
Share on other sites

Posted

Hi,

I have installed app2sd on my phone, however my phone started to hang very frequently and has acore not responding messages every few seconds. I removed app2sd and it went back to normal. Am I the only 1 facing this issue?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.