• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[FAQ]GT540 Reference Thread !

185 posts in this topic

Posted (edited)

Dear All,

Tq for this thread.

I am from Indonesia n I want to upgrade my GT540 become android 2.1

I have followed ur guide step by step, but when my "KDZ Updater" already finish and then appear "! emergency" with blue background color in my phone.

I must take off my battery to turn on my phone again, luckly there is no error after that.

for ur information

- I already use Baltic ROM

- but I use my HP Probook 4410s to do this upgrade, so I am not sure about USB cable issue.

any help please? :unsure: B)

tq ALL

Best regards

EDITED--

[R&D Test Tools Log File]

16:35:50 : Launching SW update

16:35:50 : Unpacking KDZ

16:35:54 : KDZ file extraced

16:35:56 : Files were extracted.

16:35:56 : LGMobileDL Load.

16:35:56 : Port = -1

16:35:56 : Connecting to phone

16:36:06 : Check Phone mode = 1

16:36:24 : Phone type check.......

16:36:24 : LGMobileDL.DLL Loading....

16:36:24 : _SetAuthMark Ok : wAuthMark(1335)

16:36:24 : _DetachDLL Call

16:36:24 : _DetachDLL Call End

16:36:24 : Param : Path = C:\ProgramData\LGMOBILEAX\Phone\DZ_GT540AT-00-V20d-BAL-XXX-DEC-02-2010.dz

16:36:24 : Param : moduleDir =

16:36:24 : Param : waitTime = 0

16:36:24 : Param : UsbHighSpeed = 1

16:36:24 : Param : PhoneMode = 1

16:36:24 : Param : BinVersion = V20D_00

16:36:24 : Param : AuthMark = 1335

16:36:24 : Call fn_StartUpgrade

16:36:34 : 3GQCT : wParam = 4, lParam = 0

16:36:34 : Step Complete : DLOAD Change

i use baltic ROM = "V20D_00.kdz"

I've no idea why it can be change become "......-2010.dz"

any idea brother m sister???

tq

EDITED AGAIN...

nice guide for going to toilet after push "start to update" button at kdz updater...

my only problem is I think my phone is going to error when my phone become in blue color... lol

many thank with this thread...

AWESOME

TQ

Edited by yufenn
0

Share this post


Link to post
Share on other sites

Posted

great job, far clearer than the mess in the updates thread

very much agree...thanks ilovelg...hehe...you too hecatae..just upgraded..very helpful...

0

Share this post


Link to post
Share on other sites

Posted

The rooting instuctions for 2.1 aren't very clear. Are there any preconditions that the Windows machine I'm trying to root from has to meet in order for it to succeed? I don't have any LG USB drivers installed, and all I get when running the batch file is this:

C:\rootgt540>adb push rageagainstthecage-arm5.bin /data/local/tmp/rageagainstthecage

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

error: device not found


C:\rootgt540>adb shell chmod 4755 /data/local/tmp/rageagainstthecage

error: device not found


C:\rootgt540>adb shell /data/local/tmp/rageagainstthecage

error: device not found


C:\rootgt540>adb wait-for-device

and then it stalls. I guess it's waiting for the device to register itself at the USB, but it's plugged in right now, with Mass Storage disabled and Debugging Mode enabled. So please enlighten me, folks: What's wrong?

Thanks a bunch in advance :unsure:

0

Share this post


Link to post
Share on other sites

Posted

The rooting instuctions for 2.1 aren't very clear. Are there any preconditions that the Windows machine I'm trying to root from has to meet in order for it to succeed? I don't have any LG USB drivers installed, and all I get when running the batch file is this:

C:\rootgt540>adb push rageagainstthecage-arm5.bin /data/local/tmp/rageagainstthecage

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

error: device not found


C:\rootgt540>adb shell chmod 4755 /data/local/tmp/rageagainstthecage

error: device not found


C:\rootgt540>adb shell /data/local/tmp/rageagainstthecage

error: device not found


C:\rootgt540>adb wait-for-device

and then it stalls. I guess it's waiting for the device to register itself at the USB, but it's plugged in right now, with Mass Storage disabled and Debugging Mode enabled. So please enlighten me, folks: What's wrong?

Thanks a bunch in advance :unsure:

Am... Hello ?

0

Share this post


Link to post
Share on other sites

Posted

Hi, i am noob, i have this phone at GT540f version, in mexico with telcel that is the company. i upgrade android like this manual but i have some problems with the start, no LG logo and no android logo, i must wait a little more than the android sound to start, when it starts i get a lot of error messages about starting com.android.phone and stucks in there... i realy need the phone... so is it posible to restore the default android (1.6)??? i ve tried with LG software but i cant conect to the cellphone, the only way is with KDZ updater... and where can i find the KDZ for my phone??? thanks... :D

0

Share this post


Link to post
Share on other sites

Posted

Hi, i am noob, i have this phone at GT540f version, in mexico with telcel that is the company. i upgrade android like this manual but i have some problems with the start, no LG logo and no android logo, i must wait a little more than the android sound to start, when it starts i get a lot of error messages about starting com.android.phone and stucks in there... i realy need the phone... so is it posible to restore the default android (1.6)??? i ve tried with LG software but i cant conect to the cellphone, the only way is with KDZ updater... and where can i find the KDZ for my phone??? thanks... :D

Goto Settings and look for option to do a factory Reset. I cant recall where exact the options is and i cant check it bymyself right now couse my phone is tottaly Bricked dosnt even work anymore, will have to provide it to LG Service Guys.

0

Share this post


Link to post
Share on other sites

Posted

how do i get into fastboot?

0

Share this post


Link to post
Share on other sites

Posted

Thanks I got 2.1 now :D. Do i need to root my phone for appstosd?

0

Share this post


Link to post
Share on other sites

Posted

thanks worked like a charm!

0

Share this post


Link to post
Share on other sites

Posted

Once again my friend, thank you.

The rooting, and apps2sd worked very well. The speed is very acceptable given the free app space on the phone.

0

Share this post


Link to post
Share on other sites

Posted

I've succesfully upgraded my phone from 1.6 to 2.1. However, I don't have any idea about android and it's hard for me to understand things since this is my first android phone.

Can someone please tell me how to install apps in my phone. Is the App2sd the way? Do I just copy the apps after the partition is done? How do I install the live wallpapers and games. I am totally clueless and I don't wan to do anything yet because am afraid that I might screw up my phone ;)

Thank you so much!

0

Share this post


Link to post
Share on other sites

Posted

I've succesfully upgraded my phone from 1.6 to 2.1. However, I don't have any idea about android and it's hard for me to understand things since this is my first android phone.

Can someone please tell me how to install apps in my phone. Is the App2sd the way? Do I just copy the apps after the partition is done? How do I install the live wallpapers and games. I am totally clueless and I don't wan to do anything yet because am afraid that I might screw up my phone ;)

Thank you so much!

Theres a market application in your phone, there are all the games and apps. You need internet connection on your phone for it.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Cusetion: The pdf manual for app2sd is complete?. the last page (8) have last point (22) that said: "run autorootapp2sd.bat on your pc" my question is: that's it? no more steps.

Greetings from Mexico

Edited by jael65
0

Share this post


Link to post
Share on other sites

Posted

Cusetion: The pdf manual for app2sd is complete?. the last page (8) have last point (22) that said: "run autorootapp2sd.bat on your pc" my question is: that's it? no more steps.

Greetings from Mexico

I havent created that .pdf file, i think i put credits of dude who posted it, try contacting him or other people who installed Apps2SD. I dont use it and never have used Apps2SD.

0

Share this post


Link to post
Share on other sites

Posted

Cusetion: The pdf manual for app2sd is complete?. the last page (8) have last point (22) that said: "run autorootapp2sd.bat on your pc" my question is: that's it? no more steps.

Greetings from Mexico

that is not it. you need to root your phone, than select store method, the best one is under number 1 - standard app2sd.

0

Share this post


Link to post
Share on other sites

Posted

Hi there.

I'm having a little trouble with my Optimus, I have upgraded to 2.1 (Romanian) and rooted (with 1 click) and installed apps2sd (with the last option apps and cache).

I have a 4GB microsd installed in the phone gaved 700 MB for apps2sd.

The issue that I have is that the phone freezes every time I use it for anything even if it is to check the weather (stays frozen for abou 30s every time). If I restart the phone it gives me an error that android.phone has stopped.

Any advice?

Thanks in advance, and a happy new year!!!

choose 1st option, standard app2sd and no problem.

0

Share this post


Link to post
Share on other sites

Posted (edited)

hi when i flash the phone into 2.1 i lost the android market. what to do? please help.

i got the market back but when i download things, it wont download. any help.

Edited by drino
0

Share this post


Link to post
Share on other sites

Posted

Thanks a lot my mobile is now working! LG GT540. Ur the master!!!

0

Share this post


Link to post
Share on other sites

Posted

hi when i flash the phone into 2.1 i lost the android market. what to do? please help.

i got the market back but when i download things, it wont download. any help.

What ROM did you flash?

Does it have something called SlideME instead of the market?

0

Share this post


Link to post
Share on other sites

Posted

Two questions on the original instructions of this thread:

2. How to root my 2.1 device ?

- Download 1click root for GT540

- Excract zip file

- [...]

Launch root.bat from extracted folder.

Do I extract the files to and run root.bat from my PC or the SDcard of my phone?

3. How to Install Apps2SD to my 2.1 device ?

- Download autorootapp2sd.zip

- Download App2sd_guide_GT540.pdf

- Read App2sd_guide_GT540.pdf for further instructions. Guide have pictures in it.

Must my phone be rooted in order to install Apps2SD or can I skip the step on "How to root my 2.1 device"?

Thanks for any insight you can provide!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Two questions on the original instructions of this thread:

Do I extract the files to and run root.bat from my PC or the SDcard of my phone?

Must my phone be rooted in order to install Apps2SD or can I skip the step on "How to root my 2.1 device"?

I tried running root.bat from my PC but that didn't work. I think it's because the LG modem drivers are not installed correctly. They are a pain!

I ran the "LGMobile update" program and selected "install USB Driver", but that doesn't seem to work. My device manager (Windows 7) lists four "Other Devices" (2x LGSIMODEM01 and 2x LGSIMODEM02) whose status says "The drivers for this device are not installed. (Code 28)". "Update Driver" doesn't help and when I delete the devices, they just come back after i "scan for hardware changes". BTW: I recently installed a new main-board, CPU and RAM. Everything else on my PC works fine. Please help me get these f***ng USB drivers installed.

Edited by Peter Lairo
0

Share this post


Link to post
Share on other sites

Posted

i get this error message saying " Upgrade Error WParam:100 LParam: 6" please help

0

Share this post


Link to post
Share on other sites

Posted

Ilovelg

Thanks worked a treat :P

0

Share this post


Link to post
Share on other sites

Posted

Hi before i begin i have gt540 but pc says gt540go on LG software does this actually make a difference on what one to download or should i get the 02 one just to be safe

0

Share this post


Link to post
Share on other sites

Posted

Hi before i begin i have gt540 but pc says gt540go on LG software does this actually make a difference on what one to download or should i get the 02 one just to be safe

GT540/GT540 Swift/Swift/GT540GO/GT540 Optimus/Optimus All of these phones are same, they are just called differently in different countries.

Download and install any of the ROM's you like, it dosnt matter... if LG Update software shows theres an update, do it, dont ever worrie about it.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.