• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ROM] 10/Nov r6: de-bouyguesed ROM for ZTE Blade/Orange San Francisco [eclair] [OLED]

75 posts in this topic

Posted

Didn't think I was complaining! I didn't explore all of the possibilities I admit, and based much on Titanium Backup not working. Much apologies for any offence caused. I'm sure I'll give it another try sometime soon before eating my words...

Part of the problem with the Orange ROM is that as stock it did not come with a xbin's directory, which can cause problems for some root aplications, as it puts the SU into there... thats why there is a sudo addon for the rom..

with r6 onwards I've included a AOSP version of xbin directory which should help things, but as far as Im aware ALL of the de-oranged ROMS have been root-able.

0

Share this post


Link to post
Share on other sites

Posted

I assume then that when i installed the Superuser binary it had no effect, didn't create an xbin dir, or just installed incorrectly. I'm curious to give your de-Bo ROM a try, I guess the same issue doesn't exist there?

0

Share this post


Link to post
Share on other sites

Posted

Hmm... I have the same problem. AndRoot won't root it either (fails, fu guu~~). I'm going to try a wipe.

--edit

Nope.

$ adb remount

remount failed: Operation not permitted

Which bootloader do you have flashed?

i got the same message but ithen tried to root again and the second time it said it was rooted

0

Share this post


Link to post
Share on other sites

Posted

OK, the FAT version of the ROM is now up.

I've checked the Lite and Fat version, they are boot rooted 'out of the box', anyone having problems... see a doctor

0

Share this post


Link to post
Share on other sites

Posted

Is this rom based on 2.1 or 2.2 ?

ty

0

Share this post


Link to post
Share on other sites

Posted

OK, the FAT version of the ROM is now up.

I've checked the Lite and Fat version, they are boot rooted 'out of the box', anyone having problems... see a doctor

I have tried it on my rooted SF (UK), and after R6 lite it was not rooted according to Titanium. Installed Androot, Busybox, rooted it, Superuser, and then Titanium. First time it ran fine, then the next start it complained again about not getting root access.

As to me the WiFi issue would be the only reason to swap, I have gone back to my backup of Modaco R4.

But thanks for the efforts, much appreciated! :rolleyes:

0

Share this post


Link to post
Share on other sites

Posted

Sebastian,

Do you know how to change the menu item colors to match the standard AOSP colors?

This would really smarten the build up.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I have tried it on my rooted SF (UK), and after R6 lite it was not rooted according to Titanium. Installed Androot, Busybox, rooted it, Superuser, and then Titanium. First time it ran fine, then the next start it complained again about not getting root access.

As to me the WiFi issue would be the only reason to swap, I have gone back to my backup of Modaco R4.

But thanks for the efforts, much appreciated! smile.gif

Same here, tried the de_Bo ROM, no root prompt after asking for su in adb shell, Superuser binary wouldn't install (CWM's fault I think, "bad" zip), so I'm restoring MCRr4. Will be following progress on this though.

Edited by weba
0

Share this post


Link to post
Share on other sites

Posted

I have tried it on my rooted SF (UK), and after R6 lite it was not rooted according to Titanium. Installed Androot, Busybox, rooted it, Superuser, and then Titanium. First time it ran fine, then the next start it complained again about not getting root access.

As to me the WiFi issue would be the only reason to swap, I have gone back to my backup of Modaco R4.

But thanks for the efforts, much appreciated! :rolleyes:

You've installed 2 different root applications? At the same time?

I've never used titanium, it maybe an issue with that, I will look into it I guess

0

Share this post


Link to post
Share on other sites

Posted

Sebastian,

Do you know how to change the menu item colors to match the standard AOSP colors?

This would really smarten the build up.

Which menu colours? In settings?

0

Share this post


Link to post
Share on other sites

Posted

the zte taskmanager doesnt work with this it fails on a full restore or manual install

0

Share this post


Link to post
Share on other sites

Posted

Hi again Sebastian,

I've been messing with my own blade ROM also based on the French rom and you need to put su in /system/xbin or it will be invalidated on the next boot. Also remove the /system/etc/customize folder to unlock all languages.

All work fine for me except some apps that uses the google maps framework. I haven't tried your ROM but I've tried pauls R4 and it have the same problem. The thing is that exactly the same apps force close on my Huawei U8100 if I enable JIT. I'm starting to suspect that the ZTE eclair ROMs are JIT enabled but adding dalvik.vm.execution-mode=int:fast to build.prop doesn't help.

0

Share this post


Link to post
Share on other sites

Posted (edited)

OK, the FAT version of the ROM is now up.

I've checked the Lite and Fat version, they are boot rooted 'out of the box', anyone having problems... see a doctor

Wrong, i just flashed both fat and lite and trying to use titanium backup or vm heap tool they both complain about not having root. Ive tried adb shell and su and nothing happens.

Edited by ArcticFox
0

Share this post


Link to post
Share on other sites

Posted

Hi again Sebastian,

I've been messing with my own blade ROM also based on the French rom and you need to put su in /system/xbin or it will be invalidated on the next boot. Also remove the /system/etc/customize folder to unlock all languages.

All work fine for me except some apps that uses the google maps framework. I haven't tried your ROM but I've tried pauls R4 and it have the same problem. The thing is that exactly the same apps force close on my Huawei U8100 if I enable JIT. I'm starting to suspect that the ZTE eclair ROMs are JIT enabled but adding dalvik.vm.execution-mode=int:fast to build.prop doesn't help.

Dude where's your ROM? :rolleyes:

0

Share this post


Link to post
Share on other sites

Posted

Which menu colours? In settings?

Sorry, I wasn't very clear :rolleyes:

I mean, if you're in an app and hit the Menu button, then menu is dark with light text. Standard Android has a light grey menu with dark text (like the notification bar)

Do you know how to change this, or how I can change it myself before flashing?

Rich

0

Share this post


Link to post
Share on other sites

Posted

Sorry, I wasn't very clear :rolleyes:

I mean, if you're in an app and hit the Menu button, then menu is dark with light text. Standard Android has a light grey menu with dark text (like the notification bar)

Do you know how to change this, or how I can change it myself before flashing?

Rich

It's most likely in framework-res.apk, I'm currently trying to restore it to standard but I haven't done any theme:ing before so I may be looking in the wrong place. I'll report back and post my framework-res.apk here when/if I succeed.

0

Share this post


Link to post
Share on other sites

Posted

It's most likely in framework-res.apk, I'm currently trying to restore it to standard but I haven't done any theme:ing before so I may be looking in the wrong place. I'll report back and post my framework-res.apk here when/if I succeed.

I thought the same as you - but all the XML in the APK is compiled. I am also looking at ways to just replace the APK with a standard eclair one... but this tends to bugger the phone :rolleyes:

My aim is to also get a vanilla ROM as much as possible, lets hope we can get there together...

0

Share this post


Link to post
Share on other sites

Posted

a few questions to Sebastian404 and anyone that can answer, maybe even paul :rolleyes:

the baseband is slightly different in the bouyguessed.

correct me if i am wrong, this is the radio?

where can i get hold of the radio image as it is not available in any of the roms as i would like to flash this? i would do it via fastboot, no problems there. but how to i get hold of the radio image?

this is mainly to sebastian, could you not use the apns..list from cyanogens rom because its huge. i mean people all over the world will be getting this phone shortly so wouldn't that make more sense? i know you are going for the "stock" approach but its just a suggest. a huge apn list wont make it less stock would it :huh:

just trying to be newb friendly as possible because people panic they have no internet, usually if its their first android phone.

0

Share this post


Link to post
Share on other sites

Posted (edited)

the baseband is slightly different in the bouyguessed.

correct me if i am wrong, this is the radio?

where can i get hold of the radio image as it is not available in any of the roms as i would like to flash this? i would do it via fastboot, no problems there. but how to i get hold of the radio image?

"Baseband" refers to the radio sub-system carrying phone and data to (and from) the mobile network.

The "FM radio" (for listening to broadcasts, nothing to do with 'baseband') has not been in Seb's recent roms. It doesn't function for Seb in the USA and some people believe (curiously) that the mere presence of the program causes a non-measured performance drop.

However it IS supposed to be in all the "fat" versions ...

Edited by oh!dougal
0

Share this post


Link to post
Share on other sites

Posted (edited)

Wrong, i just flashed both fat and lite and trying to use titanium backup or vm heap tool they both complain about not having root. Ive tried adb shell and su and nothing happens.

they are all rooted from the off, titanium backup's error message is VERY misleading.. I've tested it out and the problem is not that the phone is not rooted, but that its not got the EXACT version of us titanium is expecting..

There also seems to a be bug with titanium backup that means once your ran titaniums backup get the error, then let SuperUser download the latest su binary it still wont recognize the phone as rooted untill you reboot/wipe the user data.

Titanium Backup has some pre-requests, a particular version of SU in /system/xbin and noshufou's version of SuperUser has to be installed before you run it....

Edited by Sebastian404
0

Share this post


Link to post
Share on other sites

Posted

Sorry, I wasn't very clear :rolleyes:

I mean, if you're in an app and hit the Menu button, then menu is dark with light text. Standard Android has a light grey menu with dark text (like the notification bar)

Do you know how to change this, or how I can change it myself before flashing?

Rich

Ahhh, your right, I've played with so many Android devices I'd not spotted that, thanks for pointing it out...

I've produced an update zip for both of my ROMS that will 'fix' that issue, it also includes the new Android Market Update...

http://www.podtwo.com/android/beta/

Let me know if your happy :huh:

0

Share this post


Link to post
Share on other sites

Posted

"Baseband" refers to the radio sub-system carrying phone and data to (and from) the mobile network.

The "FM radio" (for listening to broadcasts, nothing to do with 'baseband') has not been in Seb's recent roms.

This is exactly right, also there is (as far as I know) no way read the radio baseband out of a phone, so we'd need a carrier to release an update... Orange are apparently working on an update for the phone, but Im not sure it will come with a baseband update..

It doesn't function for Seb in the USA

And even if it did, Id not really want to listen to the sort of stuff they play on FM out here.

0

Share this post


Link to post
Share on other sites

Posted

this is mainly to sebastian, could you not use the apns..list from cyanogens rom because its huge. i mean people all over the world will be getting this phone shortly so wouldn't that make more sense? i know you are going for the "stock" approach but its just a suggest. a huge apn list wont make it less stock would it :rolleyes:

just trying to be newb friendly as possible because people panic they have no internet, usually if its their first android phone.

There are a number of places who have collated an APN list, Ive never bothered, but then I caught myself merging the UK and France one for the Bouyguesed ROM...

End Users can manually insert the APN into the phone via the settings menu..

0

Share this post


Link to post
Share on other sites

Posted

Ahhh, your right, I've played with so many Android devices I'd not spotted that, thanks for pointing it out...

I've produced an update zip for both of my ROMS that will 'fix' that issue, it also includes the new Android Market Update...

http://www.podtwo.com/android/beta/

Let me know if your happy :rolleyes:

Sebastian,

I have just wiped and reflashed the r6 de-orange lite, then straight away flashed the update1. Wanted to feedback my thoughts for you:

1) Menu background color is spot on, but the text/icon/lines are too light grey, they are darker grey on AOSP.

2) Market works fine, downloaded Angry Birds over Wifi (started on GPRS) and no issues for me. Also showed my previous purchases fine etc.

Overall, this a great ROM, congrats!

Rich :huh:

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.