Simon O

[ROM][OLED+TFT] FLB-Froyo G2 for ZTE Blade

4207 posts in this topic

Hi, Firstly thanks for this ROM, fantastic, switched from Paul's after 3 days as I didn't like the first lockscreen and never looked back. Pretty new to Android also.

Quick question, has anyone else had problems finding location over wifi or GPS in maps, It was working fine in r5, I went straight to r7 (wiped) then applied r7a and haven't been able to get location since going r7.

Am I being stupid and missing something, just searches and then after a while 'your current location is temporarily unavailable'

(by the way the best thing about the update is that now my menu and home button light up!)

0

Share this post


Link to post
Share on other sites
Hi, Firstly thanks for this ROM, fantastic, switched from Paul's after 3 days as I didn't like the first lockscreen and never looked back. Pretty new to Android also.

Quick question, has anyone else had problems finding location over wifi or GPS in maps, It was working fine in r5, I went straight to r7 (wiped) then applied r7a and haven't been able to get location since going r7.

Am I being stupid and missing something, just searches and then after a while 'your current location is temporarily unavailable'

(by the way the best thing about the update is that now my menu and home button light up!)

Upgrading without wipeing do not work for me (i still have R6. Contacts seems to be broken (i can start the dialer but after selecting contacts FC, dialer one has no contacts, and contacts crashed).

After wipeing i can use contacts again. but wiping ist bad :-(

I also would like to get that radio app included in latest version with RDS support: http://android.modaco.com/content-page/327...de-sf/page/220/

But if i apply the kernel change it cant boot.

Is it possible to get the ZTE bootlogo back only for the one who like that?

0

Share this post


Link to post
Share on other sites

You will also add the code for "sim contacts" functionality in Contacts.apk for your r8 release? Or does 2.2.2 source contain this code?

0

Share this post


Link to post
Share on other sites

I have been a lurker here since I got my SF last October.

However, I have gone from stock Orange 2.1 to Flibblesan's Froyo, R2, then R6 and now R7a.

I would like to thank you Flb a great deal for your hard work on this.

The posts have been helpful in me understanding a bit more about using the phone and installing/updating ROMs...

...keep up the good work...

Minor issues mentioned as with others... the "reboot" option not working properly; the "wake-on-menu-button". would be nice to sort these out in a future release. Haven't yet tried other stuff - GPS, MMS, etc.

I have noticed though that when I get a phone call (from someone in my contacts list) I just get the number shown on the screen rather than their name... any ideas as to why that might happen (used to be fine on early R6 release) but it's probably not a ROM related issue.

Thx.

0

Share this post


Link to post
Share on other sites
Again this is an excellent ROM, good speed, good battery life and good looks.

About the only odd thing I've noticed is that GPS locks seem to take a little longer than I would expect with A-GPS enabled. With the stock ROM and JJ7 I was getting locks within about 10 seconds whereas now it can take a minute or much longer if moving. Is there any way I can check that this is working properly?

Yep, I've noticed this as well. I know you are busy Flibble, but could you add this to the fix list please?

Cheers... ;)

0

Share this post


Link to post
Share on other sites

Hi Flibble, GREAT rom.

I have an issue though. Yesterday after a factory reset and removing some apps from the original rom I installed r7a on a 128mb system partition.

Everything seemed to work correctly. However the rom caused a high CPU usage (constantly above 95%) and the system was slow because of this I think.

Although I rolled back to r6, I think that this high CPU usage would also impact the battery life.

Any ideas why this happened?

And one more question Flibble. Why is this rom, r7a, bigger that the r6?? Even if additional apps are removed it is still bigger.

Thanks for the great job!!!!!

0

Share this post


Link to post
Share on other sites
You will also add the code for "sim contacts" functionality in Contacts.apk for your r8 release? Or does 2.2.2 source contain this code?

Non of the stock contact apps have this. It can read SIM contacts and copy to the phone or Google contacts, but you can't save to the SIM.

0

Share this post


Link to post
Share on other sites
Hi Flibble, GREAT rom.

I have an issue though. Yesterday after a factory reset and removing some apps from the original rom I installed r7a on a 128mb system partition.

Everything seemed to work correctly. However the rom caused a high CPU usage (constantly above 95%) and the system was slow because of this I think.

Although I rolled back to r6, I think that this high CPU usage would also impact the battery life.

Any ideas why this happened?

And one more question Flibble. Why is this rom, r7a, bigger that the r6?? Even if additional apps are removed it is still bigger.

Thanks for the great job!!!!!

Exactly where are you seeing high CPU usage? If you've gone to Settings > About Phone > Battery use and seen Android System at around 95% then this is not CPU usage. Showing "Android system" as 95% means that the Android System is currently using 95% of the current power usage. It doesn't mean that it's using 95% of the battery (it could be using 20% really) but if nothing else is utilising battery then this figure will be higher.

Somebody said on a forum "That means that 91% of the things that have used your battery are part of Android and not third party apps. Not that Android System is running 91% of the time. The higher the number for Android System, the better"

Open SpareParts > Battery history then change "other usage" to "CPU usage". Set this to "Total since boot" then it'll list potential culprits. On my phone Android System has used next to no CPU.

You will also want to check partial wake usage as this can be responsible for high battery usage.

If the phone was using 100% battery with my rom then it would be flat within 2-3 hours.

Hope this sort of makes some sense. It's a difficult thing to explain and I personally feel that Google haven't made this very clear in the app.

0

Share this post


Link to post
Share on other sites
And one more question Flibble. Why is this rom, r7a, bigger that the r6?? Even if additional apps are removed it is still bigger.

Extra ringtones and alert tones probably.

0

Share this post


Link to post
Share on other sites
Hi Flibble, GREAT rom.

I have an issue though. Yesterday after a factory reset and removing some apps from the original rom I installed r7a on a 128mb system partition.

Everything seemed to work correctly. However the rom caused a high CPU usage (constantly above 95%) and the system was slow because of this I think.

Although I rolled back to r6, I think that this high CPU usage would also impact the battery life.

Any ideas why this happened?

And one more question Flibble. Why is this rom, r7a, bigger that the r6?? Even if additional apps are removed it is still bigger.

Thanks for the great job!!!!!

You have misunderstood what the Battery usage is telling you entirely.

0

Share this post


Link to post
Share on other sites
You have misunderstood what the Battery usage is telling you entirely.

I had a similar problem too. The high CPU usage was indicated in Task Manager's Resource tab. Rebooting got rid of the problem for now, but I did install Watchdog to see what's causing it in case it happens again.

0

Share this post


Link to post
Share on other sites

Just wanted to say thank you for this ROM - I'm still running FLB 1.7 on my Pulse and recently bought my gf a Blade for her birthday. The stock Orange ROM lasted about 2 hours before I rooted it and installed R7 of this ROM ;)

Great work as always flibblesan!

0

Share this post


Link to post
Share on other sites
Hi Flibble, GREAT rom.

I have an issue though. Yesterday after a factory reset and removing some apps from the original rom I installed r7a on a 128mb system partition.

Everything seemed to work correctly. However the rom caused a high CPU usage (constantly above 95%) and the system was slow because of this I think.

Although I rolled back to r6, I think that this high CPU usage would also impact the battery life.

Any ideas why this happened?

And one more question Flibble. Why is this rom, r7a, bigger that the r6?? Even if additional apps are removed it is still bigger.

Thanks for the great job!!!!!

Did you reboot after it's first boot up? It says to do so in big red letters on post 1 but I missed it the first time I tried the rom! If you don't, the cpu sits being used flat out and the phone is really sluggish. You also have to reboot after applying the gingerbread pack for some reason.

I installed it as soon as r7 was out and I couldn't work out why everyone was raving about this rom... it seemed so slow to me! Luckily I came back and gave it another go with r7a and read the post more carefully. ;)

0

Share this post


Link to post
Share on other sites

I'm generally very happy with this ROM (7a/GB theme/Circle battery), most things are working without any problem.

There is one bug I have noticed and one query I have:

Using voice search (with voice input language set to US English to give full functionality), I can bring up a dialog with a command like "send e-mail to Fred". This dialog has a microphone icon to allow voice input of the message, but clicking this causes a FC.

The query is, looking in Settings/Applications/Manage Applications and picking the All tab. There are two entries for Car Home and two entries for SoundRecorder. Does this indicate that the apps are somehow included twice in the ROM?

0

Share this post


Link to post
Share on other sites
Open SpareParts > Battery history then change "other usage" to "CPU usage". Set this to "Total since boot" then it'll list potential culprits. On my phone Android System has used next to no CPU.

You will also want to check partial wake usage as this can be responsible for high battery usage.

Just for your info Flibblesan, I'm still on your R6. Just tried this and get the following results:

CPU usage

Total since boot

Android

akmd2

Handcent SMS

Browser

Launcher

TouchPal

SwtchPro Widget

com.google.process.gapps

and

Partial wake usage

Total since boot

Maps

Handcent SMS

UID 10021

Dialer

Watchdog

Messaging

Media

It doesn't make a great deal of sense to me but thought I'd let you know.

0

Share this post


Link to post
Share on other sites
I'm generally very happy with this ROM (7a/GB theme/Circle battery), most things are working without any problem.

There is one bug I have noticed and one query I have:

Using voice search (with voice input language set to US English to give full functionality), I can bring up a dialog with a command like "send e-mail to Fred". This dialog has a microphone icon to allow voice input of the message, but clicking this causes a FC.

The query is, looking in Settings/Applications/Manage Applications and picking the All tab. There are two entries for Car Home and two entries for SoundRecorder. Does this indicate that the apps are somehow included twice in the ROM?

That voice search issue has been resolved now, thank you ;)

One of the CarHome is a launcher to allow this to work on devices without a dock. The second Soundrecorder is a wrapper as normally the application doesn't show.

0

Share this post


Link to post
Share on other sites
Exactly where are you seeing high CPU usage? If you've gone to Settings > About Phone > Battery use and seen Android System at around 95% then this is not CPU usage. Showing "Android system" as 95% means that the Android System is currently using 95% of the current power usage. It doesn't mean that it's using 95% of the battery (it could be using 20% really) but if nothing else is utilising battery then this figure will be higher.

I completely understand what you're saying. But on most Android phones, you typically get roughly 30% cell standby, 30% phone idle, and 5% Android System. Whereas FLB R7a (and R6a) typically show 98% Android System.

This can mean one of 3 things:

1) Android System is using far more resources than expected in FLB ROMs

2) Other processes are exceptionally efficient on FLB ROMs

3) The FLB kernel is reporting certain processes as being part of Android System, whereas other Android systems show them as separate processes.

As a comparison, I flashed Seb's de-crossed ROM, and the battery use statistics are back to what I'd normally expect. So there's definitely something strange going on....

0

Share this post


Link to post
Share on other sites
Just for your info Flibblesan, I'm still on your R6. Just tried this and get the following results:

CPU usage

Total since boot

Android

akmd2

Handcent SMS

Browser

Launcher

TouchPal

SwtchPro Widget

com.google.process.gapps

and

Partial wake usage

Total since boot

Maps

Handcent SMS

UID 10021

Dialer

Watchdog

Messaging

Media

It doesn't make a great deal of sense to me but thought I'd let you know.

The only thing I'd be worried about is partial wake usage. This prevents the phone from sleeping. So based on that list Maps (well known as a battery killer) and Handcent are causing the phone to keep awake. Clicking each entry will give you the amount of time they have been keeping the phone awake. if it's too high then you'll have a problem.

0

Share this post


Link to post
Share on other sites
The only thing I'd be worried about is partial wake usage. This prevents the phone from sleeping. So based on that list Maps (well known as a battery killer) and Handcent are causing the phone to keep awake. Clicking each entry will give you the amount of time they have been keeping the phone awake. if it's too high then you'll have a problem.
Thanks for that mate. how would I stop 'Maps' and 'Handcent' from keeping the phone awake?

EDIT: clicking on Maps in Partial wake usage shows:

Partial Wakelock:Maps

Total time: 14m 0s

And clicking on Handcent gives:

Partialwakelock:Handcent SMS

Total time 7m 47s

Edited by Blasphemous
0

Share this post


Link to post
Share on other sites
Exactly where are you seeing high CPU usage? If you've gone to Settings > About Phone > Battery use and seen Android System at around 95% then this is not CPU usage. Showing "Android system" as 95% means that the Android System is currently using 95% of the current power usage. It doesn't mean that it's using 95% of the battery (it could be using 20% really) but if nothing else is utilising battery then this figure will be higher.

Somebody said on a forum "That means that 91% of the things that have used your battery are part of Android and not third party apps. Not that Android System is running 91% of the time. The higher the number for Android System, the better"

Open SpareParts > Battery history then change "other usage" to "CPU usage". Set this to "Total since boot" then it'll list potential culprits. On my phone Android System has used next to no CPU.

You will also want to check partial wake usage as this can be responsible for high battery usage.

If the phone was using 100% battery with my rom then it would be flat within 2-3 hours.

Hope this sort of makes some sense. It's a difficult thing to explain and I personally feel that Google haven't made this very clear in the app.

Guys I checked CPU usage through the task manager. I m not confusing it with battery usage. I just supposed that the cpu usage would impact battery I didn't check that somehow.

and yes I did all the necessary, restart, etc.

Now, any ideas?

0

Share this post


Link to post
Share on other sites

Great ROM (7a), but I have one major problem. I am often loose GSM connection when I am connecting WiFi. This status is not correct, because I am still able to receive calls. Initiating calls is not possible, I get an error that I am not connected to the GSM network. Some times after a minute it "reconnects" to GSM network.

Thx,

alpinestars

0

Share this post


Link to post
Share on other sites
Tar mate, i have been using handcent but ill give the default app a go with the user agent changed.

it still didn't work, unlike in 2.1, 2.2 doesn't seem to turn data on to send the message, you have to have data on to start with and it then sends.

0

Share this post


Link to post
Share on other sites

Sorry if this has been answered already but I cannot look through all 132 pages! Does anyone know if this ROM will fit on a phone which has had the partitions resized via TPT with the JJRLS9 ROM? Has anyone changed from JJ to FLB and if so, is the battery life any better?

Thanks

0

Share this post


Link to post
Share on other sites
Great ROM (7a), but I have one major problem. I am often loose GSM connection when I am connecting WiFi. This status is not correct, because I am still able to receive calls. Initiating calls is not possible, I get an error that I am not connected to the GSM network. Some times after a minute it "reconnects" to GSM network.

Thx,

alpinestars

I have this problem, too. Also, wireless connection does indeed take a whole lot longer to reconnect after sleep than other roms. JJ and Modaco both reconnected faster, if the network didn't disable itself.

flibblesan, could you look into this? apart from GSM-wifi-issue this works very good!

0

Share this post


Link to post
Share on other sites

Hi Flib, great ROM, thanks for it. I'm using v r7a. Anyway, I have a problem with Email app: my Exchange account says it needs "Update Security Settings". When I tap on it, it gives a "DM Test" screen. What am I supposed to do there?

I already tried swappping Email app provided on p127, force stopping app, removing data, rebooting.

Any ideas on that?

Thanks,

Previ

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.