• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

16/Nov r4 - MoDaCo Custom Froyo ROM for the HTC Legend with Online Kitchen

74 posts in this topic

Posted

I've baked a couple of ROMs now, both with the new radio and without - but I'm not able to go online. The settings for the mobile network is correct, and I'm connected to my Service Provider (Telenor - Norway). When I restore my phone to the old version, everything is OK. Is there anyway I can troubleshoot what's really happening? Any suggestions?

Through wi-fi everything works fine, of course.

Krissi

0

Share this post


Link to post
Share on other sites

Posted

adb pull /proc/config.gz stock-froyo-legend-config.gz

This will get the config.gz en place it in the directory where you ran adb.

This file is needed to build at least tun.ko.

Yblih

I've uploaded the config.gz:

http://filebin.ca/hppuea

pulled from r4 - MoDaCo Custom Froyo ROM

cheers

0

Share this post


Link to post
Share on other sites

Posted

adb pull /proc/config.gz stock-froyo-legend-config.gz

This will get the config.gz en place it in the directory where you ran adb.

This file is needed to build at least tun.ko.

Yblih

Thaks Yblih for your prompt reply, after I did what you said, I got the file and found the Kernel version: "Linux kernel version: 2.6.32.17"

0

Share this post


Link to post
Share on other sites

Posted

Hi. thanks a lot for this (quick) kitchen.

I install ROM Manager but I have the message "Failure to launch a command with root permissions!" (in french, my translatation is maybe not the english message)

I cannot backup my ROM B)

0

Share this post


Link to post
Share on other sites

Posted

I've baked a couple of ROMs now, both with the new radio and without - but I'm not able to go online. The settings for the mobile network is correct, and I'm connected to my Service Provider (Telenor - Norway). When I restore my phone to the old version, everything is OK. Is there anyway I can troubleshoot what's really happening? Any suggestions?

Through wi-fi everything works fine, of course.

Krissi

i tried MoDaCo Custom Froyo ROM prebaked and custom from kitchen with radio enabled but 47.51.35.17U_7.13.35.05 baseband did not get installed, mobile data didn't work.

Right now I'm on prebaked 3.14.161.1 r1 - Stock Froyo ROM, 47.51.35.17U_7.13.35.05 baseband is installed and mobile data works again.

hope this helps.

0

Share this post


Link to post
Share on other sites

Posted

i tried MoDaCo Custom Froyo ROM prebaked and custom from kitchen with radio enabled but 47.51.35.17U_7.13.35.05 baseband did not get installed, mobile data didn't work.

Right now I'm on prebaked 3.14.161.1 r1 - Stock Froyo ROM, 47.51.35.17U_7.13.35.05 baseband is installed and mobile data works again.

hope this helps.

I got an error when I tried to install the pre-baked Stock ROM - I've posted the error message in the appropriate forum.

Thanks, anyways. B)

Krissi

0

Share this post


Link to post
Share on other sites

Posted (edited)

sorry for bad English

I want arabic support for froyo

froyo has Arabic font but this font not compact

i4612_20100820224603.png

Sent massage compact and inbox massage Separately

Have to Change Libskia.so to compact Arabic Letters

This is a Atabic fix for desire , change libskia.so and framework.jar

http://rapidshare.com/files/426732840/Fars...Persianblue.zip

I change libskia.so , but not boot my legend

plese Add a fix libskia.so and framework.jar to compact letters & right to left

Edited by Kasra_Qeshm
0

Share this post


Link to post
Share on other sites

Posted

What is new in r4? (I've installed r1)

0

Share this post


Link to post
Share on other sites

Posted

Hi

First of all I've installed the pre-baked and its working fine till now (4-5 days) thank you.

second I'm very happy to be able to see the Arabic letter.

IMPORTANT POINTs:

-If you add Farsi/Persian fonts it will cover both arabic and farsi (as for in arabic fonts there are still probs with farsi)

-but still as mentioned above the letters are not joined, here is a link to developer of persian soft keyboard (http://stargrads.net/blogs/davinci/2009/11/persian-soft-keyboard-and-applications-for-android/) he has the fonts I type joined ... so maybe if you do what he did with the thing, you could solve the prob once and for all

"To display Persian on Android, it is not sufficient just to install a font. You also need to get the system to join the glyphs and to display them in right-to-left order."

the pic above is actual the persian soft keyboard (the green bubble is how it should be (and it is when we type, and the grayish brown is how it is how we see when we recive ... )

if you just google "farsi or arabic for android" you'll see the high demand (and it is visible here as well)

you work is much appreciated already (and I'm greatfull for you've freed my legend)

THANK YOU

0

Share this post


Link to post
Share on other sites

Posted

Sorry noob here.

how do I download? everything i click on the download link it send me to "http://www.modaco.com/"

0

Share this post


Link to post
Share on other sites

Posted (edited)

I had to wipe before installing. Had many errors otherwise. Mobile data does not work.

Haven't tried kitchen baked yet.

I couldn't get mobile data to work on 1.31 version either for me.

Everything else works fine.

Thank you

UPDATE: Like Krissi I didn't have my APN settings configured.

I used my provider's APN settings and all is well now.

Edited by japlha
0

Share this post


Link to post
Share on other sites

Posted

I've been struggling making this ROM work on my phone, the mobile network has not kicked it. Tonight I tried a new installation of a baked ROM, and I finally checked the APN settings, and they were not set. B)

Putting in the correct information from my service provider made all the difference. This is a bit embarrasing...

Now the ROM works just fine. :)

Krissi

0

Share this post


Link to post
Share on other sites

Posted

Any news of a new prebaked version of this great ROM ? B)

0

Share this post


Link to post
Share on other sites

Posted

I've been struggling making this ROM work on my phone, the mobile network has not kicked it. Tonight I tried a new installation of a baked ROM, and I finally checked the APN settings, and they were not set. B)

Putting in the correct information from my service provider made all the difference. This is a bit embarrasing...

Now the ROM works just fine. :)

Krissi

That worked for me too. I didn't realize I had to manually configure the APN.

0

Share this post


Link to post
Share on other sites

Posted

Thaks Yblih for your prompt reply, after I did what you said, I got the file and found the Kernel version: "Linux kernel version: 2.6.32.17"

Yes, ok, the link above filebin.ca does not work. But I need more than just the kernel version ;-) this file has all the settings to build te kernel ;-)

Let's see if htc has published this kerel

0

Share this post


Link to post
Share on other sites

Posted

dear paul

can u guide how to solve the facebook sync n calendar sync problems in legend froyo

cause i cant sync these 2 thing.

i've read somewhere that need to modify the build.prop but so far its not working

thanks

0

Share this post


Link to post
Share on other sites

Posted

Yes, ok, the link above filebin.ca does not work. But I need more than just the kernel version ;-) this file has all the settings to build te kernel ;-)

Let's see if htc has published this kerel

sry about that, next try:

config.gz

0

Share this post


Link to post
Share on other sites

Posted

the data connection on my phone doesn't work, why?

0

Share this post


Link to post
Share on other sites

Posted

the data connection on my phone doesn't work, why?

It can't pull the apn settings from your service provider, set them up manually! BTW The answer is here already ;-)

0

Share this post


Link to post
Share on other sites

Posted

I just flashed your ROM r4 (not from the kitchen) and my Radio ROM is not updated.

Everything works like a charm.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Paul, please update Adobe Reader when you relese version r5. Now i have version 9.x, but the last version on the Market is 10.x.

It will be nice if you create a Lite ROM image without the software available in the Android Market. Like Adobe Reader, Google Maps, YouTube, Facebook, Twiter, etc.

Edited by firewolf
0

Share this post


Link to post
Share on other sites

Posted (edited)

It will be nice if you create a Lite ROM image without the software available in the Android Market...

It's just a matter of unpacking the zip file, deleting the unwanted apk's ond odex's (if they are there), re-packing and signing it again...but watch for the widgets, there are another references somewhere in the system to them, though I don't know where...

Edited by Dr.Romca
0

Share this post


Link to post
Share on other sites

Posted (edited)

Everything is fine with one mistake on my phone.

When i set a alarm on my phone it dont stops ringing and no message is shown. I have to put the batterie out of the phone.

I dont use the htc-lockscreen i disabled it in my baked rom, could this the reason?

.....

edit:

i flashed again with htc lockscreen included and now everything is fine. THX for this great ROM

Edited by daihogo
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.