• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

power adapter

9 posts in this topic

Posted

hi everyone

got my vega delivered this evening and all was going great until i decided to plug it in and try to update etc

plugged in usb then the power adaptor.

next thing the whole house electrics went off !

reset trips and tried again

the adaptor is now not charging and smells of electrical burning

please everyone be careful

mine has a manufacture date of 2010.10.11 incase there is a dodgy batch

goodness knows what will happen now as i liked it and the chances of them sending me a new power adaptor at the present time seems very slim

hope the whole lots doesnt have to go back as i like it !

0

Share this post


Link to post
Share on other sites

Posted

Have you reported this to Advent??

0

Share this post


Link to post
Share on other sites

Posted

Mine doesn't always seem to register on the device (the light) and seems a little flimsy.

0

Share this post


Link to post
Share on other sites

Posted

yeah i have tried to report it

rang techguys at midnight last night

they said i had to ring back at 9 this morning

was on the phone for nearly an hour to find out they have no replacement parts and it all has to go back

I told they i didnt really want to send it back as they were as rare as rocky horses sh*t

he said he would see if anywhere had a power supply that they could ship in the mean time that would be suitable

no one has yet called me back and i am not optomistic .

anyone know where i can get a cheap car charger for the vega

i could use this in the mean time till they got further stock or stock of spares

thanks in advance

0

Share this post


Link to post
Share on other sites

Posted

yeah i have tried to report it

rang techguys at midnight last night

they said i had to ring back at 9 this morning

was on the phone for nearly an hour to find out they have no replacement parts and it all has to go back

I told they i didnt really want to send it back as they were as rare as rocky horses sh*t

he said he would see if anywhere had a power supply that they could ship in the mean time that would be suitable

no one has yet called me back and i am not optomistic .

anyone know where i can get a cheap car charger for the vega

i could use this in the mean time till they got further stock or stock of spares

thanks in advance

If you can make a note of the voltage & current on the original then I'm sure you can buy a replacement.

The most critical info is the voltage - make sure he replacement is the same otherwise it'll be your vega smelling bad!

The new charger should have to supply at least the same current (amps or milliamps - mA) but it wouldn't cause a problem if it had a higher rating.

Does the Vega charge via USB? Or is it via a round connector?

0

Share this post


Link to post
Share on other sites

Posted

Wonder if they ever bring out a dock if it will charge it?

0

Share this post


Link to post
Share on other sites

Posted (edited)

hi everyone

got my vega delivered this evening and all was going great until i decided to plug it in and try to update etc

plugged in usb then the power adaptor.

next thing the whole house electrics went off !

reset trips and tried again

the adaptor is now not charging and smells of electrical burning

please everyone be careful

mine has a manufacture date of 2010.10.11 incase there is a dodgy batch

goodness knows what will happen now as i liked it and the chances of them sending me a new power adaptor at the present time seems very slim

hope the whole lots doesnt have to go back as i like it !

Mine has the same date so it is not likely a batch issue. Maybe a spike on initial draw - was it plugged into a power strip by any chance? you may have overloaded the 13 amp fuse limit....

Did everything in the house go or just the ring your plug is on - did the lights upstairs for example stay on or was is the master switch on the RCD?

Either way the adapter is a standard APD adapter (WA-12I12R) and outputs 12v at 1A and looks like a standard 2mm plug.

If you are anywhere near a maplins then they should have a suitable replacement

http://www.maplin.co.uk/Module.aspx?ModuleNo=46107

This one should do it I think - check the polarity on the tips when you get it shoud be - ---C---- +

Take your vega with you - they might let you try it if you let them have a go :P

*Edited as the first recomendation was ac/ac adapter

Edited by morchuboo
0

Share this post


Link to post
Share on other sites

Posted

Wonder if they ever bring out a dock if it will charge it?

Dock is coming, check the vega accessories thread for more details.

0

Share this post


Link to post
Share on other sites

Posted

it took the lot out

there was definately something wrong inside the adapter took mains rcd out direct into sock

it flashed when i plugged it in and smells of electronics burning inside the adapter

i asked pcworld if i could open it up and have a go at fixing it (im an electronics engineer ) but they said no way

i have a similar supply to the one that was mentioned and have used that last night to charge it

i will just keep using this until they can swap out when they have some stock

hopefully the dock wont be ridiculously priced like the screen protector

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.