MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.
Sign in to follow this  
Followers 0

Wireless not connecting?

12 posts in this topic

Posted (edited) · Report post

My G2/Hero has suddenly stopped connecting to my home wireless network.

All other wireless devices I have work fine (Wii, G1 phone, Vega tablet, netbook) so it's not the wireless router (Thomson/O2 wireless box III). When I take my phone to the office it connects to the guest network there fine so my phone's wifi is working OK there.

I've tried changing the channel on the router to various settings manually and restarting everything but the phone refuses to connect. When I try to select the SSID to connect the wifi changes to disconnected status and I have to turn wifi off and on again.

I had VillainROM 12 installed when this started to happen then, last night I wiped and installed the MoDaCo ROM r5 baked from the kitchen. My radio version is higher than the version supplied in the kitchen so I didn't select it when baking the ROM. My baseband version is 63.18.55.06PU_6.35.15.14

Anything else I can try? I'm totally confused why the different parts work apart but not together.

P.S. The wireless is secured with WPA/WPA2 PSK and the pass code is definitely right. I know it off by heart now!

P.P.S I installed the Wireless Analyzer app on the phone and it shows all the networks around me and mine is the strongest signal. Changing the channel manually I see it moving around the channels on the display so there is no issue with seeing the wireless network I just can't connect to it!

Edited by English Haze
0

Share this post


Link to post
Share on other sites

Posted · Report post

34 views and no suggestions?

The ridiculous thing is I can attempt to connect my phone to neighbouring protected wireless networks and the phone can be seen to attempt to obtain an IP address and then show unsuccessful (as expected because the key is invalid). Every other wireless device I have in the house (eight!) connects perfectly to my wireless access point but my phone? no! not, even an attempt to obtain an IP address! And it used to work fine up until 3 days ago. My access point allows any wireless connection automatically (with a valid key of course) and the DHCP address range has plenty of spare addresses.

The ROM versions I have tried have no regulatory domain menu option under advanced network options so I can't change the channel on the phone that way so I followed some instructions I found on XDA to edit the build properties file manually to add channels=14 and still no joy.

I am completely out of ideas.

I've put VillainROM12 back on and it's still the same as with MoDaCo r5.

0

Share this post


Link to post
Share on other sites

Posted · Report post

34 views and no suggestions?

The ridiculous thing is I can attempt to connect my phone to neighbouring protected wireless networks and the phone can be seen to attempt to obtain an IP address and then show unsuccessful (as expected because the key is invalid). Every other wireless device I have in the house (eight!) connects perfectly to my wireless access point but my phone? no! not, even an attempt to obtain an IP address! And it used to work fine up until 3 days ago. My access point allows any wireless connection automatically (with a valid key of course) and the DHCP address range has plenty of spare addresses.

The ROM versions I have tried have no regulatory domain menu option under advanced network options so I can't change the channel on the phone that way so I followed some instructions I found on XDA to edit the build properties file manually to add channels=14 and still no joy.

I am completely out of ideas.

I've put VillainROM12 back on and it's still the same as with MoDaCo r5.

Lo,

This might sound really stupid, but have you rebooted? No. I'm not being facetious, I'll explain why, as it happened to me :)

I have a WPA2 (Enterprise) WiFi network, and when I setup my WiFi profile, I enabled credential storage, with a password. Now, when I reboot, I cannot sign into WiFi until I go to the profile, try to view it and enter the credential storage password. Once that's done, I can dis/enable WiFi and it connects.

The other thing you may have is that sometimes, the wpa_supplicant goes loopy. If you have root, delete /data/misc/wifi/wpa_supplicant.conf and restart wifi, it'll rebuild the file. I have had problems when I've tweaked it and permissions changed (broke the client), and also sometimes editing the eapol_version can fix issues on a couple of networks.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for your reply. I have re booted many many times. Thanks for the file tip but that didn't work either. Still the same problem.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Thanks for your reply. I have re booted many many times. Thanks for the file tip but that didn't work either. Still the same problem.

Have you re enabled credential storage AFTER the reboot? As mentioned, mine won't connect until I enter the credential password AFTER rebooting.

Also, as mentioned, check (or add and change) the eapol_version - this got another android device connecting to WiFi (X10 Mini Pro), even though it could see the network.

No reason why it should randomly stop working mind you, but it's worth a go.

Edited by ptruman
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Nope, not a thing still. I've even baked a new ROM from the Hero kitchen and included the radio from there and flashed that. I'm getting desperate now.

My phone is frantically telling me there are wireless networks to connect to and is quite happy to try and get an IP addresses from all of them except mine! Every other device in the flat connects to the wireless faultlessly. I've tried taking the security off, using WEP only. Nothing wants to work.

If the phone didn't connect to any wireless network I'd be satisfied that there was a fault on the phone but it connects to every other network I can see (and fails the security check). The status goes to "unsuccessful" for all other networks but for mine it doesn't even try for an IP address it goes straight to "disconnected". Nothing appears in the router log to show any connection errors.

The WiFi Analyser app sees all the networks around and shows mine as clearly the strongest signal and in a fairly clear channel range. But no connection!

I'm ready to tear my hair out now.

*edit* Trying the Cyanogen 6.1 ROM now.

*edit* And it still doesn't work!

Edited by English Haze
0

Share this post


Link to post
Share on other sites

Posted · Report post

Nope, not a thing still. I've even baked a new ROM from the Hero kitchen and included the radio from there and flashed that. I'm getting desperate now.

My phone is frantically telling me there are wireless networks to connect to and is quite happy to try and get an IP addresses from all of them except mine! Every other device in the flat connects to the wireless faultlessly. I've tried taking the security off, using WEP only. Nothing wants to work.

If the phone didn't connect to any wireless network I'd be satisfied that there was a fault on the phone but it connects to every other network I can see (and fails the security check). The status goes to "unsuccessful" for all other networks but for mine it doesn't even try for an IP address it goes straight to "disconnected". Nothing appears in the router log to show any connection errors.

The WiFi Analyser app sees all the networks around and shows mine as clearly the strongest signal and in a fairly clear channel range. But no connection!

I'm ready to tear my hair out now.

*edit* Trying the Cyanogen 6.1 ROM now.

*edit* And it still doesn't work!

Manually set an IP address. If the only thing it's failing is getting an IP from *your* network, it would imply your router is not happy with the DHCP request - have you rebooted the routers? Also, check your router admin pages to see if your DHCP pool is large enough, and/or that it's not trying to allocate an already allocated IP.

If a fixed IP (that you know is free) works, then the problem is more than likely with DHCP on the router.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Already done all of those things. The phone doesn't even get to ask for an IP address. Nothing shows in the router logs at all

Like I say, I'm running out of ideas entirely.

Edited by English Haze
0

Share this post


Link to post
Share on other sites

Posted · Report post

OK, I am now suspecting that O2 have remotely updated my router firmware and this is what has broken my connection. I just connected up my old netgear wireless router and the phone jumped onto it in an instant! I can't get onto the internet (anyone know if I can piggyback one router onto another?) But wireless is perfect.

I think I will be calling O2 tomorrow. There is no online firmware download that I can find.

0

Share this post


Link to post
Share on other sites

Posted · Report post

SOLVED!

A complete hard reset of my router and reconfiguration.

0

Share this post


Link to post
Share on other sites

Posted · Report post

SOLVED!

A complete hard reset of my router and reconfiguration.

There you go - if the phone was connecting to other networks, it would imply the network was the problem.

My routers periodically 'decide to be odd', but it's rare, and every so often they restart their own processes - but DHCP sometimes fails, or (more annoying) the authentication fails, or the wireless mesh (I have two routers)....

Still, glad you have it going.

0

Share this post


Link to post
Share on other sites

Posted · Report post

But it was the fact that everything else connected fine that threw me. 8 other wireless devices had no problems whatsoever. It was a desperate last ditch solution to wipe the router back to factory default settings (not just a restart or re-boot) and reconfigure.

I'll put that one down to experience and remember to try that next time.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.