• Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

16GB SD cards that definitely work

364 posts in this topic

Posted · Report post

My 8gb class 2 sandisk card works fine

0

Share this post


Link to post
Share on other sites

Posted · Report post

Just to reply to my own thread - thanks to reports here I got a ScanDisk 16GB Class 2 from Play.com and it's working fine. It seems like this card works for everyone so may be a safe choice if unsure.

0

Share this post


Link to post
Share on other sites

Posted · Report post

That's what I thought but it's simply not true. To be sure of having a working one, I bought the Kingston 16GB Class 4 card but it doesn't work in either the OLED or TFT SFs that we have. I paid £22 for it rather than £16 for one from Play so I'm not too pleased about it. It keeps unmounting. The problem I now have is sending a card back that will no doubt test ok in a PC and that's what the vendor will base his test / refund against.

I've got just the same issue with Kingston 16GB Class 4 card. Did you resolve your problem in the end? If so, how?

0

Share this post


Link to post
Share on other sites

Posted · Report post

16GB class 4 kingston from mymemory.co.uk works fine for me.

But doesn't for me. Bought from a reputable supplier.

0

Share this post


Link to post
Share on other sites

Posted · Report post

For my own part, my 16GB card threw a bit of a hissy fit the first time it was used, but has been rock solid both for file transfers between laptop and phone and for general purpose use (photos, backups, caching, test file transfers) ever since, and that's been around 10 days of faultless operation. I'm using the stock Orange ROM. If those with problems have modified their Blades then I guess they don't have much cause to complain. Go back to stock and then see what happens.

I'm on the Stock Orange B08 ROM, and am getting issues with a Kingston 16Gb Class 4 SD.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Sandisk Micro SDHC 16GB, from Play.com working 100%

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I've recently moved on from the stock B05 ROM to Japanese Jellyfish 3b and now 4. My Play.com Class 4 16GB card is still working perfectly with the new ROMs, and of course I had no problem copying the ROMs over to the phone via USB in the first place. No problem with Nandroid backups either.

The way the reports are coming in for a wide variety of cards I would draw the conclusion that there is some sort of problem with contact reliability between the phone and the card. I find it difficult to believe that so many cards are duff from so many different manufacturers. Also, given that there are few/no complaints about the phone when used with the original card I struggle to see what other cause there might be for these problems. My guess is a badly seated card.

Edited by tdodd
0

Share this post


Link to post
Share on other sites

Posted · Report post

I've just got This one from Play.com and the phone will not see it at all.

When inserted it just says "SD card removed. Please insert new one". It cannot be seen in recovery mode either. I've tried formatting the card on the PC and then inserting in the phone but still no good.

However, my wifes HTC Wildfire can see the card fine. I formatted the card again in her phone and then inserted into the SF but still it won't see it.

I will see what it is like when we have the new 2.2 releases after next week and see if that makes any difference. I can't help feeling that this is a software issue rather than a hardware one as other devices that I have had, camera's, phones etc, have been able to see larger SD cards after a software update. As I understand it, as long as the hardware supports the SDHC standard (rather than just SD) then the size limit is governed by the software.

I also think that we should list what firmware we are running to see if there are any combinations that definately work.

I am running "Sebastian404's de-orangeated-rom - r7" ROM

I have the same problem with my OLED Orange UK one Play.com 16gb class 4. And after 16GB Class 4 started not working 2GB Verbatim one has a similar problem now. I replaced the phone twice, replaced Verbatims several times in Orange store. But now I can't use SD Cards. At the longest time I use, I could download something 5 MB and SD Card Unexpectedly Removed, Preparing SD Card after Damaged SD Card warnings appear. Is this a general problem?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've recently moved on from the stock B05 ROM to Japanese Jellyfish 3b and now 4. My Play.com Class 4 16GB card is still working perfectly with the new ROMs, and of course I had no problem copying the ROMs over to the phone via USB in the first place. No problem with Nandroid backups either.

The way the reports are coming in for a wide variety of cards I would draw the conclusion that there is some sort of problem with contact reliability between the phone and the card. I find it difficult to believe that so many cards are duff from so many different manufacturers. Also, given that there are few/no complaints about the phone when used with the original card I struggle to see what other cause there might be for these problems. My guess is a badly seated card.

There's no way it's just a badly seated card issue. I wasn't going to throw away £18 lightly so I spent ages fitting and re-fitting the first card I got. It never worked, not once over several days trying. To me that proved it isn't just a seating issue.

The reason I started this thread is that I wanted to find a card which worked for other people. Everyone who posted said the ScanDisk 16GB class 2 from play.com worked, so I got one and.... it works. Coincidence? I don't think so.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Interesting. I just took the 16Gb card that didn't work, and put it in an HTC phone. I managed to format it OK in there. I then put it back in my Blade, and formatted it there. It seemed to be working. Then I put it in a PC, and copied files to it. It then stopped working again. I went round the whole cycle, and it's back in my Blade working OK. There's definitely something strange going on here.

Next up is to try to copy the files from my old card using USB cable with the new card in the phone, rather than putting the new card in a PC to do the copy...

Anyone got a good explanation for this behaviour?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Interesting. I just took the 16Gb card that didn't work, and put it in an HTC phone. I managed to format it OK in there. I then put it back in my Blade, and formatted it there. It seemed to be working. Then I put it in a PC, and copied files to it. It then stopped working again. I went round the whole cycle, and it's back in my Blade working OK. There's definitely something strange going on here.

Next up is to try to copy the files from my old card using USB cable with the new card in the phone, rather than putting the new card in a PC to do the copy...

Anyone got a good explanation for this behaviour?

I note that my 2G card isn't recognized as having valid partitions when plugged directly into my PC, but is when connected via the phone.

I had put this down to strange block-device wrapping of Android in that it doesn't really expose the full raw device, but the symptoms match what you describe.

I would say this is similar to the old LBA/CHS problem of the victorian age but it doesn't make sense for linearly addressed storage.

But... if keeping the device in the phone works - then do that!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Interesting. I just took the 16Gb card that didn't work, and put it in an HTC phone. I managed to format it OK in there. I then put it back in my Blade, and formatted it there. It seemed to be working. Then I put it in a PC, and copied files to it. It then stopped working again. I went round the whole cycle, and it's back in my Blade working OK. There's definitely something strange going on here.

Next up is to try to copy the files from my old card using USB cable with the new card in the phone, rather than putting the new card in a PC to do the copy...

Anyone got a good explanation for this behaviour?

There's a post over on the Vega sub-forum where someone complains of problems with a Sandisk 16GB Class 2 card. He also asserts that the error/failure rate with micro SDHC cards is quite high. I have no idea how true that is but it might explain the random nature of problems and successes being reported here.

There is another card thread on the Blade sub-forum where there is the suggestion that the mechanism of resting the card into place on the Blade, rather than sliding it into position as with most devices, is a possible reason for poor contact and thus unreliable connection. This is because debris and oxides are not scraped off as the card is positioned. I have no idea how probable that is as a cause of problems, but it does not seem unreasonable to me.

I think the reality is that we still do not have statistically meaningful results achieved under controlled conditions - different phones, different ROMS, different cards, different USB ports, different people, different climatic conditions - just too many variables and nowhere near enough samples.

0

Share this post


Link to post
Share on other sites

Posted · Report post

He also asserts that the error/failure rate with micro SDHC cards is quite high.

That does not explain why the same card always works in the PC, always stops working in the Blade if formatted on the PC, and so far, works fine on the Blade if formatted in the Blade.

This includes multiple insertions and removals and re-seatings (the card has now been in and out of my phone perhaps 20 times), so I'd be pretty sure it is not a contacts issue, as the effects are consistent with the state of the card. If it were contacts, it would not show this "history" effect. This seems more consistent with some kind of software issue (depending on the state of the card), not a hardware issue.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Bang goes another theory. Card worked fine, until I started copy some files to it from my Mac over the USB cable. I then got an "SD Card unexpectedly removed" message.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Bang goes another theory. Card worked fine, until I started copy some files to it from my Mac over the USB cable. I then got an "SD Card unexpectedly removed" message.

That's the exact problem many people had - including me.

0

Share this post


Link to post
Share on other sites

Posted · Report post

another happy user of Kingston 16GB class 4 bought from MyMemory. I got my San Fran during launch week and got the 16GB about a week after that.

For what it's worth, I even went to the Kingston "verify" site where you could check you had a genuine Kingston card. Mine checked out fine. But it does not work fine.

0

Share this post


Link to post
Share on other sites

Posted · Report post

That's the exact problem many people had - including me.

So what did you do in the end?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've got just the same issue with Kingston 16GB Class 4 card. Did you resolve your problem in the end? If so, how?

No but I've been dealing with Kingston directly who have sent me an RMA.

0

Share this post


Link to post
Share on other sites

Posted · Report post

So what did you do in the end?

I bought a different card - see above.

0

Share this post


Link to post
Share on other sites

Posted · Report post

That does not explain why the same card always works in the PC, always stops working in the Blade if formatted on the PC, and so far, works fine on the Blade if formatted in the Blade.

Ah yes, same for me as well but do try this please. I expect miserable failure :unsure: On the phone, simply copy a file on the card and then paste it elsewhere on the card. I used the built-in Filer on the stock B05 ROM. I'd expect that any similar app will give the same result though. My test does at least show that the issue has got nothing to do with the PC OS or drivers. It's a local phone / SD card issue.

0

Share this post


Link to post
Share on other sites

Posted · Report post

For what it's worth, I even went to the Kingston "verify" site where you could check you had a genuine Kingston card. Mine checked out fine. But it does not work fine.

Kingston wanted to verify mine, which is fair enough. Authentic of course :unsure:

0

Share this post


Link to post
Share on other sites

Posted · Report post

Bang goes another theory. Card worked fine, until I started copy some files to it from my Mac over the USB cable. I then got an "SD Card unexpectedly removed" message.

Yes, that's because the phone was probably not writing anything to the card until you used the Mac.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes, that's because the phone was probably not writing anything to the card until you used the Mac.

No, I moved quite a few files around on the card first. It was only when I tried a sustained long write operation it fell over.

0

Share this post


Link to post
Share on other sites

Posted · Report post

No, I moved quite a few files around on the card first. It was only when I tried a sustained long write operation it fell over.

That's more or less like me as well. My copies from the PC gave me more than a zero percent progress bar before the card eventually unmounted. Data volumes seem relevant.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.