• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

01/Feb r3: USB Mode (host / slave switcher)

126 posts in this topic

Posted

usbmode1.png

usbmode2.png

The USB mode switcher is now part of my MoDaCo Custom ROM - I recommend that you use it as part of this ROM. :(

As promised, here's my 'USB Mode' switcher application (for switching between host / slave modes), which will be included in the r6 addon pack. Nothing too fancy, but it does the job. ;)

Use at your own risk, backup before use etc. etc. blah blah disclaimer disclaimer. ;)

Note: Due to how this works, it will overwrite your kernel with my custom kernel.

  • r3 DOWNLOAD (ROMraid Load Balancing) - MD5: b13c86264ffa2fb50bdd81912a7aeb74


    P.S. I'll be posting the source for this on my GitHub when I've tidied it up a little. ;)

    Changelog

    r3
    • Now using MCK r2!
    • Slave / Host mode is indicated in Settings -> About
    • The /misc is no longer mounted in the ramdisk (BSOD fix)

    r1

      [*]Initial Release

0

Share this post


Link to post
Share on other sites

Posted

nice one! Great work - It's been very quiet on here today - this should wake em up a bit!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Will try immediately! :(

Will it need a reboot after switching?

EDIT: Duh!! Screenshot tells it needs a reboot...

EDIT2: Forgot to thank you, so: THANK YOU, PAUL!

Edited by rvdgeer
1

Share this post


Link to post
Share on other sites

Posted

Doesnt work for me, says

there is a problem parsing the package

0

Share this post


Link to post
Share on other sites

Posted

Hey paul can you add this mode to the Htc desire too??? It's anawsome feature

0

Share this post


Link to post
Share on other sites

Posted (edited)

Is this instead of the other mod or in conjunction.

Not sure what to with it :(

Steve

Edited by s.morris
0

Share this post


Link to post
Share on other sites

Posted

Just installed it works well automatically reboots much easier than the GScript way :(

0

Share this post


Link to post
Share on other sites

Posted

Ive tried downloading it again, used package installer and astro to try and open it and no luck, how did you install it?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Ive tried downloading it again, used package installer and astro to try and open it and no luck, how did you install it?

Copied the apk over via usb to the microsd card.

Edit is there now a way to safely remove USB keys I removed it just by unplugging and it came up with Remove1 much better than the weird grey screen problem with GScript work round, GREAT!

Well done Paul, appreciated.

Edited by remlap
0

Share this post


Link to post
Share on other sites

Posted

Thanks Paul worked a treat as usual

0

Share this post


Link to post
Share on other sites

Posted (edited)

Ok I had to download the file from my PC for some reason. Copied it over and works a treat, thanks Paul much appreciated.

(edited got it woking now)

Edited by marind
0

Share this post


Link to post
Share on other sites

Posted

Thanks for another great bit of dev!

Your really eaning that tenner :(

Ross

0

Share this post


Link to post
Share on other sites

Posted

That is totally awesome Paul - and easy too!

Simon

0

Share this post


Link to post
Share on other sites

Posted

Is this instead of the other mod or in conjunction.

Not sure what to with it :(

Steve

Good question which I hope Paul or one of our fellow members could answer please ??? i.e. can we un-install Gscript once we have installed Pauls mod?

0

Share this post


Link to post
Share on other sites

Posted

That rocks!

Got a parse error, but it was ok when i downloaded from the mirror.

Thanks Paul.

0

Share this post


Link to post
Share on other sites

Posted

Good question which I hope Paul or one of our fellow members could answer please ??? i.e. can we un-install Gscript once we have installed Pauls mod?

This is how I went

Used GScript to set the Vega back to USB Slave first.

Deleted the two scripts, and unistalled GScript.

Rebooted, made sure I was in USB Slave mode by connecting to PC, transferred apk over with USB, installed APK, selected USB Host and it rebooted itself fine. Checked USB key with file on it.

0

Share this post


Link to post
Share on other sites

Posted

This is now including in MCR Add-on r6. :(

P

0

Share this post


Link to post
Share on other sites

Posted (edited)

I can confirm just install apk and that's it, work ok on mine

Thanks paul top man

don't forget to update list here

Steve

Edited by s.morris
0

Share this post


Link to post
Share on other sites

Posted

works on stock mobii tegra after getting root

awesome!!

greetz

0

Share this post


Link to post
Share on other sites

Posted

Downloaded on to sd card from computor.

Put card back in Vega yet the file doesn't even appear on it! ;)

Then tried to put downloaded file on PC desktop, attached USB to Vega enabled USB file transfer>transfered file across and.........again no sign of the file on the Vega SD card nor any little USB icon in apps...

Great news that Paul has done it and it works....as usual any help for me (the most brain cell challenged on here) much appreciated :(

0

Share this post


Link to post
Share on other sites

Posted (edited)

After the update mouse is working showing USB Host operating OK but when I load USB Memory Stick it doesn't show any files in /usbdisk or am I looking in wrong place (it's been a while since I tried) ?

Edited by trevor432990
0

Share this post


Link to post
Share on other sites

Posted

Downloaded on to sd card from computor.

Put card back in Vega yet the file doesn't even appear on it! ;)

Then tried to put downloaded file on PC desktop, attached USB to Vega enabled USB file transfer>transfered file across and.........again no sign of the file on the Vega SD card nor any little USB icon in apps...

Great news that Paul has done it and it works....as usual any help for me (the most brain cell challenged on here) much appreciated :(

The filename seems to get truncated a bit (this threw me too) .... look for one called com.modaco... in the folder you copied it to then click on it and it should show you the vegasusb.... file as mentioned in Paul's notes then click on install

0

Share this post


Link to post
Share on other sites

Posted

After the update mouse is working showing USB Host operating OK but when I load USB Memory Stick it doesn't show any files in /usbdevice or am I looking in wrong place (it's been a while since I tried) ?

In file manager there is a new icon and its contents appears under /mnt/usb/system_usb.

I have noticed that the device is jerky in host mode, nothing scrolls smoothly! WEIRD......

Swapping back to slave appears to fix the scroll.

0

Share this post


Link to post
Share on other sites

Posted (edited)

In file manager there is a new icon and its contents appears under /mnt/usb/system_usb.

I have noticed that the device is jerky in host mode, nothing scrolls smoothly! WEIRD......

Swapping back to slave appears to fix the scroll.

Thanks for navigating me to the right path Ptbw it's not very logical really but will try and remember that in future. Not noticed it being jerky yet but system seems a little fragile right now (apps disappear then reappear after reboot very strange). Titanium Backup is now asking me to switch USB Debugging on which I don't recall it doing before and as USB cable is not connected I don't know why it is.

Edited by trevor432990
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.