• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

SD card unexpectedly removed - Error

37 posts in this topic

Posted

Dear all,

I am having the error "SD card unexpectedly removed" sometimes when I press the hangup button, some other times when I pickup the phone from a desk or my pocket.

I tried using a new SD card and still the error occurs. Is it a mechanical issue or a software issue?

I have my phone on 2.1 v20a Europe ROM.

0

Share this post


Link to post
Share on other sites

Posted

Dear all,

I am having the error "SD card unexpectedly removed" sometimes when I press the hangup button, some other times when I pickup the phone from a desk or my pocket.

I tried using a new SD card and still the error occurs. Is it a mechanical issue or a software issue?

I have my phone on 2.1 v20a Europe ROM.

LG hardware error: http://code.google.com/p/android/issues/detail?id=9736

0

Share this post


Link to post
Share on other sites

Posted

Dear all,

I am having the error "SD card unexpectedly removed" sometimes when I press the hangup button, some other times when I pickup the phone from a desk or my pocket.

I tried using a new SD card and still the error occurs. Is it a mechanical issue or a software issue?

I have my phone on 2.1 v20a Europe ROM.

It sounds like a hardware error. I've used V20a European Open rom and never experienced something like this.

0

Share this post


Link to post
Share on other sites

Posted

It sounds like a hardware error. I've used V20a European Open rom and never experienced something like this.

What is the exact type of your SD card?

I used a 4 GB SanDisk that came with the phone when I bought it, and tried another one called GoodRam 8GB

0

Share this post


Link to post
Share on other sites

Posted

What is the exact type of your SD card?

I used a 4 GB SanDisk that came with the phone when I bought it, and tried another one called GoodRam 8GB

I use Kingston 2GB, which came with the phone.

0

Share this post


Link to post
Share on other sites

Posted

Going through all the replies there, it does not seem an LG issue, HTC and other phones users also have the same problem.

All LG models and some others :D.

Maybe it denpends on rom, I've had same issue with 1.6 and 2.2 (CyanogenMod) but not with 2.1 (20B Vietnam).

0

Share this post


Link to post
Share on other sites

Posted

All LG models and some others :D.

Maybe it denpends on rom, I've had same issue with 1.6 and 2.2 (CyanogenMod) but not with 2.1 (20B Vietnam).

I've had this problem and fixed it by flashing it in cs_emergency mode with the card and battery out...

0

Share this post


Link to post
Share on other sites

Posted (edited)

I have formatted the card on the computer (again) and copied my files back on it and used "CHKDSK" with a /r option.

My thought is that there is an application using the SD in a wrong way and causing a file allocation table problem.

The small cards with 1 or 2 GB does not have such a problem because the use FAT and not FAT32 so this problem does not arise.

Thats my first thought.

BTW:Its working now after the format I will check it for a day or two and tell you how it goes.

Edited by Dr.Alani
0

Share this post


Link to post
Share on other sites

Posted

I have formatted the card on the computer (again) and copied my files back on it and used "CHKDSK" with a /r option.

My thought is that there is an application using the SD in a wrong way and causing a file allocation table problem.

The small cards with 1 or 2 GB does not have such a problem because the use FAT and not FAT32 so this problem does not arise.

Thats my first thought.

BTW:Its working now after the format I will check it for a day or two and tell you how it goes.

My SDcard is 2G.

Formatting (using Computer or phone) doesn't help, after 2h, this error happens again (although I don't copy anything to sdcard).

0

Share this post


Link to post
Share on other sites

Posted

My SDcard is 2G.

Formatting (using Computer or phone) doesn't help, after 2h, this error happens again (although I don't copy anything to sdcard).

It did not work anyway. I have changed the card now with a Kingston 4GB SDHC4 and has been working well since yesterday. I formatted it in the phone and removed it and connected it to the laptop and copied my old files into it.

I suggest you try to format it as FAT not FAT32 and see what happens.

0

Share this post


Link to post
Share on other sites

Posted

It did not work anyway. I have changed the card now with a Kingston 4GB SDHC4 and has been working well since yesterday. I formatted it in the phone and removed it and connected it to the laptop and copied my old files into it.

I suggest you try to format it as FAT not FAT32 and see what happens.

I believe I have found the solution for this issue.

The reason behind the error message is that the SDHC card is of class 2. The solution is to use SDHC of class 4 and higher for Android 2.1 and higher.

Reason:

Class 2 SDHC cards have a speed of 2Mbps while Class 4 is 4Mbps. Android 2.1 was optimized to get the best out of the camera and be able to record HD video. This HD video requires a speed higher than 2Mbps. Even if your camera does not support HD video, the OS does. Thus, many applications that use the SD card that were written for 2.1 rely on using the read/write speed of 4Mbps or higher. This leads to many applications tend to cause this error on the phone.

The solution is simple, get a class 4 or higher SDHC card if you have 2.1 or higher android. Many phones do not face this problem because they already supply the phones with such a card. I was not that lucky, though. I received my phone with a 4GB SanDisk class 2 SDHC card. I do not blame the distributor for that as the phone was 1.6 Android when I bought it.

I hope this helps.

0

Share this post


Link to post
Share on other sites

Posted

I believe I have found the solution for this issue.

The reason behind the error message is that the SDHC card is of class 2. The solution is to use SDHC of class 4 and higher for Android 2.1 and higher.

Reason:

Class 2 SDHC cards have a speed of 2Mbps while Class 4 is 4Mbps. Android 2.1 was optimized to get the best out of the camera and be able to record HD video. This HD video requires a speed higher than 2Mbps. Even if your camera does not support HD video, the OS does. Thus, many applications that use the SD card that were written for 2.1 rely on using the read/write speed of 4Mbps or higher. This leads to many applications tend to cause this error on the phone.

The solution is simple, get a class 4 or higher SDHC card if you have 2.1 or higher android. Many phones do not face this problem because they already supply the phones with such a card. I was not that lucky, though. I received my phone with a 4GB SanDisk class 2 SDHC card. I do not blame the distributor for that as the phone was 1.6 Android when I bought it.

I hope this helps.

class 2 means speed > 2 MByte/s

http://developer.qualcomm.com/dev/chips/qs...-chipset-family

Desire, N1, Liquid E, X10 use QSD 8250, can play or record HD720 video: H.264 High Profile v3.0 Up to 30fps @720p (1280x720), 10Mbps, max bitrate is 10Mbit/s ~ 1.25 MByte/s

Applications can't decide read/write speed, it's managed by OS (android), and it depend on sdcard.

0

Share this post


Link to post
Share on other sites

Posted

class 2 means speed > 2 MByte/s

http://developer.qualcomm.com/dev/chips/qs...-chipset-family

Desire, N1, Liquid E, X10 use QSD 8250, can play or record HD720 video: H.264 High Profile v3.0 Up to 30fps @720p (1280x720), 10Mbps, max bitrate is 10Mbit/s ~ 1.25 MByte/s

Applications can't decide read/write speed, it's managed by OS (android), and it depend on sdcard.

Thanks for the insight my friend. First of all, I meant MBps not Mbps, my bad.

Second, I did not say that the application decides the speed of interaction with the SD, applications use OS bridge to access the memory.

Regarding the HD 720p format you mentioned earlier, it is not the standard. HD720 has variable bit-rate. The one announced about the X10 is not the actual standard. The codecs can go as up to 24Mbps (almost 3MByte/s) for H.264 and about 19Mbps (almost 2.375 MByte/s) for the 30fps.

http://www.dvinfo.net/forum/general-hd-720...ng-formats.html

Anyway, this is not the issue here. The issue is that if someone is using a Class 4 SDHC memory with android 2.1 and having this error, please write about it.

This has solved the issue for me, I mean moving from Class 2 to Class 4.

0

Share this post


Link to post
Share on other sites

Posted

Thanks for the insight my friend. First of all, I meant MBps not Mbps, my bad.

Second, I did not say that the application decides the speed of interaction with the SD, applications use OS bridge to access the memory.

Regarding the HD 720p format you mentioned earlier, it is not the standard. HD720 has variable bit-rate. The one announced about the X10 is not the actual standard. The codecs can go as up to 24Mbps (almost 3MByte/s) for H.264 and about 19Mbps (almost 2.375 MByte/s) for the 30fps.

http://www.dvinfo.net/forum/general-hd-720...ng-formats.html

Anyway, this is not the issue here. The issue is that if someone is using a Class 4 SDHC memory with android 2.1 and having this error, please write about it.

This has solved the issue for me, I mean moving from Class 2 to Class 4.

I think Dr.Alani told so right more than merrymenvn because when i was using Rom 2.1 which from LG Services set up. I used "move to sd card" in 2.1 Rom that sometime SD Card Unexpectedly remove "auto" more than one time. I thought have problem from SD CARD i used... Until i installed application in Rom 2.2.1 CyonagenMod i had any problem. When i read informations from Dr.Alani who told to need and use Micro SDHC class 4 or higher, i believe that is true.

IF SOMEONE ONE USING MICRO SDHC FROM CLASS 4 TO CLASS 10 HAVE PROBLEM ABOUT THIS WE NEED TO LISTEN! AND IF NOT WE NEED SOMEONE TALK ABOUT SUCCESSFULLY, WE NEED PROOF.. THANKS

0

Share this post


Link to post
Share on other sites

Posted

Hi guys!

I just want to say:

I have Transcend 4GB microSD class 6 from the 1st day of my life with GT540 (that means 1.6 and now 2.1 OS) and NEVER had one single problem with the card. Card is formated in FAT32 sistem by phone himself. :D

I hope this info help some of you...

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi,

I have SanDisk Class4 4GB SDHC and get the "SD card unexpectedly removed" error on 2.1 at least 3 times a day, so your theory may not hold.

Thorn

Edited by ThornInMySide
0

Share this post


Link to post
Share on other sites

Posted

Hi,

I have SanDisk Class4 4GB SDHC and get the "SD card unexpectedly removed" error on 2.1 at least 3 times a day, so your theory may not hold.

Thorn

I don't know my friend. Maybe its not quite right, but it worked for me. So, there has to be a reasonable explanation.

0

Share this post


Link to post
Share on other sites

Posted

Hi guys!

I just want to say:

I have Transcend 4GB microSD class 6 from the 1st day of my life with GT540 (that means 1.6 and now 2.1 OS) and NEVER had one single problem with the card. Card is formated in FAT32 sistem by phone himself. :D

I hope this info help some of you...

your informations sound good. HAVE YOU GOT APP2SD APPLICATIONS ON 2.1 ROM? , AND ANY PROBLEM???

I'M WAITING FOR YOUR ANSWER. IMPORTANT PROOF...PLEASE.

0

Share this post


Link to post
Share on other sites

Posted

I don't know my friend. Maybe its not quite right, but it worked for me. So, there has to be a reasonable explanation.

You're right, there has to be a reasonable explanation. Maybe I've fiddled too much and this could explain why I get the error?

I will do a backup this weekend and format my card and see if this resolves the error for me. Will post the result a few days after that.

0

Share this post


Link to post
Share on other sites

Posted

your informations sound good. HAVE YOU GOT APP2SD APPLICATIONS ON 2.1 ROM? , AND ANY PROBLEM???

I'M WAITING FOR YOUR ANSWER. IMPORTANT PROOF...PLEASE.

If it helps, my phone is not rooted and I don't use Apps2sd and got the error using two different SD cards of class 2, and the error was gone when I used a class 4 card.

0

Share this post


Link to post
Share on other sites

Posted

Using a 4GB Class 4 Kingston card, app2sd applied, rooted, never seen the problem once since I got the phone (past September 2010).

0

Share this post


Link to post
Share on other sites

Posted

If it helps, my phone is not rooted and I don't use Apps2sd and got the error using two different SD cards of class 2, and the error was gone when I used a class 4 card.

THANK YOU SO MUCH

0

Share this post


Link to post
Share on other sites

Posted

Using a 4GB Class 4 Kingston card, app2sd applied, rooted, never seen the problem once since I got the phone (past September 2010).

THANK YOU SO MUCH

0

Share this post


Link to post
Share on other sites

Posted (edited)

Edit: dont't work ;)

Edited by merrymenvn
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.