• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Mobile Broadband dongles

216 posts in this topic

Posted (edited)

Unfortunately not, I've done a google search and tried various combinations with no luck.

Now I have the red triangle and cant get rid of it, even after a re flash with the Modaco rom.

EDIT: I ran the recovery program and it got rid of the red triangle!

One problem down, one to go!

Edited by nowimboard
0

Share this post


Link to post
Share on other sites

Posted

Brilliant thread....I have wasted so much time trawling the web to see whether android/broadband dongles would co-exist. Seems like I should have come here in the first place. Is this something a relative newbie is capable of achieving? Excellent work Bakedbeans superb follow-up bobbler and thanks to all who have contributed their twopenn'orth. B01

0

Share this post


Link to post
Share on other sites

Posted

Just a quick one for anyone with an E160 and 02 pay as you go...

Got this working by the normal method described above, new google account > wireless settings. This was fine but then the apn settings were the tricky bit but I got from here http://forum.o2.co.uk/viewtopic.php?t=13757

Have a suspicion you will have to have used the dongle before to set up the normal dial numbers etc. but in APN settings you put:

Username o2web (thats an o for oscar not a zero)

Password password

APN m-bb.o2.co.uk (thats an o for oscar not a zero)

When connected you MUST visit the web page to pay for access: http://mobilebroadbandaccess.o2.co.uk

Anyway, works for me...

0

Share this post


Link to post
Share on other sites

Posted (edited)

Posting from my Vega using a Vodafone K3565 dongle.

Followed BakedBeans instructions from post #12 and found two Voda networks but neither gave me a 3g icon. Tried auto selecting but still no good then a google search revealed apn for Voda to be pp.internet not just internet...changed and 3g came straight up.

Thanks mucho, can't wait to make my wife's wifi ipad jealous!

(EDIT) Also didn't do the cd unmount as the dongle was recognised. Unplugged and re-plugged in and at first it looked like I was going to have to do the whole setup again but eventually it picked up the signal again. Found it's quicker to make sure you turn off the 3g service before unplugging then re-initialising. Is there a quicker way to turn the 3g settings on and off?

Just going to test if the Vega's various phone options work (although I assume my dongle is data only...?)

...yep doesn't appear to work as a phone unsurprisingly

Edited by ace_dynamo
0

Share this post


Link to post
Share on other sites

Posted

so once you have a 3g dongle working on your vega, can you then share that connection with other devices by creating an ad hoc wifi?

0

Share this post


Link to post
Share on other sites

Posted

Anyone got it working with t-mobile (uk)? if so can you give me the correct APN settings.

0

Share this post


Link to post
Share on other sites

Posted

Hi all!

Needed to 'borrow' my brothers e220 dongle (might give it back sometime), and I can confirm that following BakedBeans instructions in post #12, that it does work, good work mate :D

I'm running r8, just need to try it with some of the other roms, as soon as I've tried it, I'll post back.

Keep up the good work everyone

0

Share this post


Link to post
Share on other sites

Posted

Anyone got it working with t-mobile (uk)? if so can you give me the correct APN settings.

Will try and sort this out for you later on tonight have mine working on a e160 on virgin which uses t-mobile

0

Share this post


Link to post
Share on other sites

Posted

Will try and sort this out for you later on tonight have mine working on a e160 on virgin which uses t-mobile

Thanks. I think I have it all sorted, except the APN which is the only thing preventing me from getting the 3G icon, I tried using the settings from t-mobiles web site, but still nothing, so if you have the correct APN settings that I could try, let us know.

0

Share this post


Link to post
Share on other sites

Posted

Just a quick one for anyone with an E160 and 02 pay as you go...

Got this working by the normal method described above, new google account > wireless settings. This was fine but then the apn settings were the tricky bit but I got from here http://forum.o2.co.uk/viewtopic.php?t=13757

Have a suspicion you will have to have used the dongle before to set up the normal dial numbers etc. but in APN settings you put:

Username o2web (thats an o for oscar not a zero)

Password password

APN m-bb.o2.co.uk (thats an o for oscar not a zero)

When connected you MUST visit the web page to pay for access: http://mobilebroadbandaccess.o2.co.uk

Anyway, works for me...

Hey mate, I came across your post while searching on the forum to try and get my o2 payg dongle working and I to have the E160.

I have done the above and get to selecting a network, but it just keeps searching and doesn't go any further.

Any help will be much appreciated :)

Carl

0

Share this post


Link to post
Share on other sites

Posted

Hi !

I have actually got it working ! ( For half an hour till I disconnect the dongle and now can't connect it) I have Huawei E156g dongle and have been playing with settings in APN.

What you need is APN 3internet and mmsc *99# mcc 234 mnc 20 save and connect. It was working as i said and as have used quick Setting to turn it on and off.

After turning off even this annoying red ! icon is gone !

Good luck everybody !

0

Share this post


Link to post
Share on other sites

Posted

I currently have the T-mobile USB dongle 120 mobile broadband thing. Can someone atest to or give me advice or help if these devices would in essence work on a modified Vega?

* i am travelling next week and i would love to bring my tablet to check my emails, read news,etc.

Please help. Thank you.

0

Share this post


Link to post
Share on other sites

Posted

I was going to originally buy one of the supported dongles people know that work on the Advent Vega as I currently have a Huawei Model 1752Eu and I could not get it to register on the network but can confirm that it is now working OK.

1. Installed an application called Status Bar 2G-3G which exposes settings rather than having to create a new Google Account etc.

2. Previously I had set-up a manual APN using O2 settings for Monthly Broadband which I believe are still there as follows:

Name: mobile.o2.co.uk

APN: mobile.o2.co.uk

Proxy:

Port:

Username: o2web

Password: password

Server:

MMSC:

MMS proxy:

MMS port:

MCC: 234

MNC: 10

Authentication type:

APN type: default,supl

3. Connected dongle to computer, found which COM port it was using and used PuTTY to send the following command: AT^U2DIAG=0 - should see OK back.

4. Connected dongle into Vega, checked it was on 3G via Status Bar 2G-3G and it was working within 20 seconds.

0

Share this post


Link to post
Share on other sites

Posted

So slightly off topic. But assuming one has got a compatible and unlocked dongle.....

What is the best PAYG data sim deals out there great for use with Vega?

0

Share this post


Link to post
Share on other sites

Posted

So slightly off topic. But assuming one has got a compatible and unlocked dongle.....

What is the best PAYG data sim deals out there great for use with Vega?

Cuurently using Three.

Can get a 3gig 90 day sim of of the Bay or Amazon for £8.50.

Hope that helps :)

Keith

0

Share this post


Link to post
Share on other sites

Posted

I got one of them too it arrived yesterday but wont work in my o2 dongle for some reason. orange and tmobile both work in it very strange

0

Share this post


Link to post
Share on other sites

Posted

OK so i got it to work but it just constantly gets signal and then drops after two seconds and then picks up again about 10 seconds later. It works fine with all other networks it's just 3 i seem to be having issues with.

I'm using Newbe/Corvus5 rom with a E160g.

Any suggestions appreciated.

Also does anyone know where I can get a flash code for the E160g?

0

Share this post


Link to post
Share on other sites

Posted

Hi, have just followed the thread and have got my vega, running r8, connected to an unlocked but on contract huawei e160e on orange.

Works like a charm! Used the add account method to start then the quick setting to reconnect after.

Genius work, thank you.

0

Share this post


Link to post
Share on other sites

Posted

All,

I know this has been mentionned on here a couple of times but I have a working T-Mobile dongle on my Vega.

This is the Huawei 1750 and is the fifty pound deal Carphone Warehouse do for three months with a couple of gig per month. On a windows box install the software and download putty. Use putty to connect to the serial port of the modem and send AT^U2DIAG=0 Ensure tablet is in the right USB mode and insert dongle.

Goto. Settings and accounts. Add account and select Google. Press the menu button and scan for networks. I have found it does not work if you boot with it and I am working on the phone function! Battery life isn't awesome -about fifty percent worse than wifi.

John

0

Share this post


Link to post
Share on other sites

Posted

I have a working, surfing conection via an Huawei E220 3G dongle on my Vega.

Details:

1. Installed theMoDaCo Custom ROM for the Advent Vega r7

2. Enabled USB Host Mode (USB Mode --> USB Host (required reboot)

3. Inserted the Huawei E220 USB Dongle (mine was a t-mobile PAYG dongle)

4. If USB Host Mode is enabled, the dongle will flash green, then blue

*Interesting bit*:

5a. Go to Settings --> Accounts & Sync --> Add Account

5b. Select 'Google'

5b. Hold down the back button (the physical button) for 2-5 seconds until a 'Wireless Settings' icon appears at the bottom of the screen

5c. Select 'Wireless Settings'

5d. Select '3G Service enabled'

5e. Select 'Data enabled'

5f. Select 'Network Operators' ... You may need to wait 10-30 seconds as the Vega configures itself to read the USB dongle, makes a connection and identifies what providers are available... the light on my USB Dongle went solid blue at this point (if I recall correctly)

5g. Choose your network operator

5h. The Vega notification bar will change to show a "3G" icon, which is animated to show upload/download action; and a signal strenth icon.

6. Ensure WiFi is off and surf to a website... In my case, I got the t-mobile top-up page, which showed me my dongle's phone number and the fact that I had no further credit on my account.

When you unplug the dongle, the notification bar will change to a red triable for 'No Service: Selected network unavailable).

At this point I don't know whether this is chewing my battery or not when not connected.. as the "No Service" notification does not go away, even though I've disabled '3G Service'.

This is my first post here, so if I've posted in the wrong please, let me know and I'll happily move it.

Cheers,

BB.

hiya folks would someone please please tell me how to Enabled USB Host Mode ????? so i can try my huwaei e220 dongle :unsure: :) thanks in advance :P

0

Share this post


Link to post
Share on other sites

Posted

hiya folks would someone please please tell me how to Enabled USB Host Mode ????? so i can try my huwaei e220 dongle :unsure: :) thanks in advance :P

What ROM are you using?

On Stock ROM, Host mode is not possible, you need to change the kernel to CorvusKernel 0.2

On MoDaCo ROM r8 you need the USBswitcher application, which should be in your application drawer

On Corvus0.5, CM7 and my ROM (Ganbarou V0.3) you reboot the tablet and keep back button pressed until Android has complete bootet, then you are in Host mode.

0

Share this post


Link to post
Share on other sites

Posted

What ROM are you using?

On Stock ROM, Host mode is not possible, you need to change the kernel to CorvusKernel 0.2

On MoDaCo ROM r8 you need the USBswitcher application, which should be in your application drawer

On Corvus0.5, CM7 and my ROM (Ganbarou V0.3) you reboot the tablet and keep back button pressed until Android has complete bootet, then you are in Host mode.

hi beegee thanks so much for your quick reply .im using MoDaCo ROM r8 i bought the vega already with it. i look in applications i dont see the usb in apps..could you please direct me to it thanks :unsure: :)

0

Share this post


Link to post
Share on other sites

Posted

hi beegee thanks so much for your quick reply .im using MoDaCo ROM r8 i bought the vega already with it. i look in applications i dont see the usb in apps..could you please direct me to it thanks :) :P

ermmm ok i found the usb switcher on the market..it installs but wont open..so thats probably why the app isnt on my vega? please does anyone anyone else know which app i need to usb switch on the r8? grrrrr so frustrating!! ive read hundreds of pages but everything is so spread about and confusing to a newby :P ;) :o :unsure:

0

Share this post


Link to post
Share on other sites

Posted (edited)

I just got 3G working on my POV Mobii with a HUAWEI e 153u1 Adapter...

Could even make a phone call from my Tablet to my mobile ..!!!

you have to disable the CD-rom autostart function before it all works smootly .....

How do you remove the automount? I have seen it several times on previous posts, could you point me out to any tutorial?

Thanks...

Sent the AT Commands and now I get the bars, but not the 3G simbol, can dial but not talk (is that even posible, tried my bluetooth headset and nothing), but still no data conection, what should I try next?

Edited by León
0

Share this post


Link to post
Share on other sites

Posted

How do you remove the automount? I have seen it several times on previous posts, could you point me out to any tutorial?

Thanks...

Sent the AT Commands and now I get the bars, but not the 3G simbol, can dial but not talk (is that even posible, tried my bluetooth headset and nothing), but still no data conection, what should I try next?

hiya leon i had to figure my own problem out too with little help :) ..lets hope i can help you out? i didnt know how to do the automount so i could do the 3g either..must be something that was mentioned in earlier days..difficult for us newbies....heres wot i did..i didnt do that step..and it works fine without it..just do the usb thingy..mines working fine :unsure: streaming movies ect ..hope that helps u?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.