• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

ZTE Latest USB Driver for Blade from Chinese blade dump rom package

17 posts in this topic

Posted (edited) · Report post

When I check the dump rom of chinese blade, I found this driver in path /romdump/system/etc/pcsuite.iso

The driver version is 5.2066.1.6B01, support Chinese and English.

Download: http://www.fxdove.com/MyAndroid/ZTE_HS_Driver_Setup.exe

Readme.txt

===============================================

This packet contains the drivers of ADB, Diag, Modem, NMEA, Rndis and ADB tools.

ADB is Android Debug Bridge. If you want to usb ADB, MAKE SURE

Settings->Applications->Development->USB debugging is ENABLE on ZPhone.

Following is the driver Path, choose the apropriate drivers according to Windows version.

ZTE_HS_Driver_Setup_V5.2066.1.6-signed

----32bit

----VISTA for Windows Vista 32bit

----WIN7 for Windows 7 32bit

----WNET for Windows XP and Windows 2K 32bit

----64bit

----VISTA for Windows Vista 64bit

----WIN7 for Windows 7 64bit

----WNET for Windows XP and Windows 2K 32bit

----tools

----ADBinstall.bat double click it to run ADB install program

----ADBunistall.bat double click it to run ADB uninstall program

post-810731-1295200655_thumb.jpg

post-810731-1295200678_thumb.jpg

post-810731-1295200688_thumb.jpg

Edited by Weird Sun
0

Share this post


Link to post
Share on other sites

Posted · Report post

When I check the dump rom of chinese blade, I found this driver in path /romdump/system/etc/pcsuite.iso

The driver version is 5.2066.1.6B01, support Chinese and English.

Readme.txt

===============================================

This packet contains the drivers of ADB, Diag, Modem, NMEA, Rndis and ADB tools.

ADB is Android Debug Bridge. If you want to usb ADB, MAKE SURE

Settings->Applications->Development->USB debugging is ENABLE on ZPhone.

Following is the driver Path, choose the apropriate drivers according to Windows version.

ZTE_HS_Driver_Setup_V5.2066.1.6-signed

----32bit

----VISTA for Windows Vista 32bit

----WIN7 for Windows 7 32bit

----WNET for Windows XP and Windows 2K 32bit

----64bit

----VISTA for Windows Vista 64bit

----WIN7 for Windows 7 64bit

----WNET for Windows XP and Windows 2K 32bit

----tools

----ADBinstall.bat double click it to run ADB install program

----ADBunistall.bat double click it to run ADB uninstall program

thanks for all the above info but can you tell me how to use twitter on my phone you seem to be the person in the know ..many thanks chris

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Maybe I've lost the plot... but what does a new driver have to do with Twitter??

The download link doesn't seem to work?

Edited by targetbsp
0

Share this post


Link to post
Share on other sites

Posted · Report post

When I check the dump rom of chinese blade, I found this driver in path /romdump/system/etc/pcsuite.iso

The driver version is 5.2066.1.6B01, support Chinese and English.

Download: http://www.fxdove.com/MyAndroid/pcsuite.iso

The download link is not working.

0

Share this post


Link to post
Share on other sites

Posted · Report post

the first time you plug the device in, it mounts that ISO and it looks like your have an external storage device.. it lets you install drivers...

if you look in /etc/ there is a vold.conf that seems to be doing the trick, tho I've not spent too long tracking down HOW it does it...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

The download link is not working.

You are right. I have updated download url. Please try it again.

Edited by Weird Sun
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

You are right. I have updated download url. Please try it again.

Thanks for uploading again.

Edited by nedian05
0

Share this post


Link to post
Share on other sites

Posted · Report post

the first time you plug the device in, it mounts that ISO and it looks like your have an external storage device.. it lets you install drivers...

if you look in /etc/ there is a vold.conf that seems to be doing the trick, tho I've not spent too long tracking down HOW it does it...

I entirely agree with your view. Maybe we can find much more surprises. ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for uploading again. I downloaded and ran the file and it started a wizard. But when I checked in device manager it still shows the unknown device on windows 7 64bit.

I think you should try to manually install this driver in your device manager.

You can find win7 64bit driver in path: C:\Program Files\ZTE 3GPhone USB Driver\Drivers\64bit\WIN7

0

Share this post


Link to post
Share on other sites

Posted · Report post

thanks for all the above info but can you tell me how to use twitter on my phone you seem to be the person in the know ..many thanks chris

This is not the right place to ask this question.

0

Share this post


Link to post
Share on other sites

Posted · Report post

thanks for all the above info but can you tell me how to use twitter on my phone you seem to be the person in the know ..many thanks chris

lolwut

Is this just automatically running the .exe we have elsewhere or are the drivers different?

0

Share this post


Link to post
Share on other sites

Posted · Report post

There are so many different drivers now ;) Very confusing.

0

Share this post


Link to post
Share on other sites

Posted · Report post

the first time you plug the device in, it mounts that ISO and it looks like your have an external storage device.. it lets you install drivers...

if you look in /etc/ there is a vold.conf that seems to be doing the trick, tho I've not spent too long tracking down HOW it does it...

It may be useful for custom ROMs, like including installable options (with ADB of course) :)

Like, you add an image to DATA: and mount it, user mounts it, and it installs the SELECTED apps ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

the first time you plug the device in, it mounts that ISO and it looks like your have an external storage device.. it lets you install drivers...

if you look in /etc/ there is a vold.conf that seems to be doing the trick, tho I've not spent too long tracking down HOW it does it...

"USB mode-switching" is what it is called, and a standard way to provide drivers for many USB devices.

Once the drivers are installed they will load when the device is inserted and it will switch the mode of the device so that it no longer pretends to be a CD and the drivers are no longer visible.

However, presenting an ISO device is cool, and if it can slave-through to an iso file on the phone, it will make it easy to install linux using the phone as the usb device. Cool hack points, but lower usefullness as I'm not likely to have a cable to hand when I'm at someones house/

0

Share this post


Link to post
Share on other sites

Posted · Report post

the first time you plug the device in, it mounts that ISO and it looks like your have an external storage device.. it lets you install drivers...

if you look in /etc/ there is a vold.conf that seems to be doing the trick, tho I've not spent too long tracking down HOW it does it...

I'm sorry but I just wanna install usb tethering drivers. Could you pls make an idiot proof guide for installing that precisely? :P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Same issue as the other drivers for the modem. It say its workong but it isnt..

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.