Sebastian404

[APP] Recovery Manager v0.36 [BETA]

313 posts in this topic

one question i have recovery 2.5.1.8 experimental installed (with ext3 support)

is this works ?

0

Share this post


Link to post
Share on other sites
I found the problem with the modaco rom, and I've got a fix for it, but Im not having much time to do that much, probably be an update at the weekend

Good to know! Looking forward to the fix.

Thanks

0

Share this post


Link to post
Share on other sites
one question i have recovery 2.5.1.8 experimental installed (with ext3 support)

is this works ?

Okay.

That seems to do the work, recovery is now recognized.

Somehow i had "old" 2.5.1.8 or something?

if either of you still have those old files, and you upload them somewhere and PM me the link? I'll look at adding them

0

Share this post


Link to post
Share on other sites

I just installed this app... At first the app didn't recognise the recovery I had installed (2.5.1.8), but I can confirm that a reinstall of the recovery via recovery manager sorts this problem.

Everything else worked good so far... I did a backup, installed a new rom... Fine!

But I have to agree with gamesticker:

Hey Seb, just installed 0.26b, tried installing a couple of updates and all working fine. A few suggestions:
  1. Under Firmware tab, Install Firmware and Install Firmware Update seems redundant. They can be replaced by any one of follows
    • Two seperate entries "Install Firmware" and "Install Firmware Addons/Updates" just like now, but "Install Firmware" displays zips >50mb and "Install Firmware Addons/Update" displays zips <50mb
    • A single entry "Install Firmware", on click displays list of ZIPs just like now, on select asks you to "wipe data/settings". User can select to wipe for firmware installs or can leave it unchecked for addon installation

[*]Maybe the unimplemented entries can be disabled/greyed-out for now

0

Share this post


Link to post
Share on other sites

I agree...option to wipe or not wipe would be of great use...I reflashed JJ7 yesterday to remove 0x90 mod..didnt want to wipe, so option would be great..

0

Share this post


Link to post
Share on other sites

I would like to backup my stock firmware, in case I will need to return the phone on warranty :lol: But when I try using the 'Backup Current Firmware' option, I get an error saying:

You need to install a custom firmware before you can back up your Firmware!

As I understand it, when I install custom firmware - there will be no option of restoring the phone to a before-flashing state! (Unless I will find a Play's stock firmware somewhere in the web...) Is there an option / method of backuping the current stock ROM in a different way? I think I might try romdump...

My device is:

Play (Poland): ZTE Blade

PLAY_P729VV1.0.0B03

ro.build.version.release=2.1-update1

ro.build.date=Thu Dec  2 11:09:17 CST 2010

ro.build.sw_internal_version=PLAY_P729VV1.0.0B04

ro.build.display.id=PLAY_P729VV1.0.0B03

ro.com.google.gmsversion=2.1_r12

0

Share this post


Link to post
Share on other sites

Im not sure why but both .23 and .26 are force closing on me :S

Edited by vareBlade
0

Share this post


Link to post
Share on other sites
I would like to backup my stock firmware, in case I will need to return the phone on warranty :lol: But when I try using the 'Backup Current Firmware' option, I get an error saying:

Same here. Backup Current Firmware not working for me on .26b (trying to backup JJ RSL8).

0

Share this post


Link to post
Share on other sites
Same here. Backup Current Firmware not working for me on .26b (trying to backup JJ RSL8).

I don't believe that 0.26b recognises JJ8, does it? To enable a backup, does the Recovery Manager need to recognise the ROM, sorry firmware? :lol:

0

Share this post


Link to post
Share on other sites

To do a backup, it has to recognise your recovery, and afaik only clockwork is currently supported for backup and restore firmware.

0

Share this post


Link to post
Share on other sites
To do a backup, it has to recognise your recovery, and afaik only clockwork is currently supported for backup and restore firmware.

Ah - I see. Thanks guys!

0

Share this post


Link to post
Share on other sites
if either of you still have those old files, and you upload them somewhere and PM me the link? I'll look at adding them

here :lol:

link

0

Share this post


Link to post
Share on other sites

Firstly, hi all.

Anyone getting Force-closes - Re-install the Recovery Manager APP (from APK) - Kill all processes and re-launch.

After following your guide I'm getting the forced closures, I have tried re-installing the RM app (killed processes etc) but this is having no effect.

What would be my best route now? Should I manually install the custom rom via Clockwork?

0

Share this post


Link to post
Share on other sites
Firstly, hi all.

After following your guide I'm getting the forced closures, I have tried re-installing the RM app (killed processes etc) but this is having no effect.

What would be my best route now? Should I manually install the custom rom via Clockwork?

This happens when superboot doesn't kick in right

Use a Task killer to kill everything.

Then RE-install the Recovery Manager(from the APK) - then restart it

0

Share this post


Link to post
Share on other sites

Hi guys

I'm also having the problems with force close. I've tried killing all processes and reinstalling as suggested but it still crashes. Only way to get it working once is to uninstall, unroot, reroot and reinstall. Then it works until you reboot. Any suggestions?

Thanks in advance!

Paul

Edited by paul_harris77
0

Share this post


Link to post
Share on other sites
This happens when superboot doesn't kick in right

Use a Task killer to kill everything.

Then RE-install the Recovery Manager(from the APK) - then restart it

Thanks for the reply, Steven.

Unfortunately, I have already tried those suggestions several times and still no go. It was all going fine via your guide, got to the part where I did the full phone back-up then went to use RM again to install the CFW and ever since it's resulted in forced closures.

0

Share this post


Link to post
Share on other sites
Great work Sebastian. I will work on updating my guide monday night.

3 methods of updating now.

Truly the blade is the most hacker friendly device ever.

Edit: I have just ran my first backup.

System rebooted and handed over to clockwork 2.5.1.8 perfectly, then rebooted.

However on the first launch of the app I had a blank screen instead of the superuser prompt. Obviously a fault with su. So I task killed them both and relaunched the recovery app. Each time after this it force closed. It must have been a partial first run thing. I re installed and it worked perfectly.

One question does your app work with all 3 current versions of clockwork and RA_recovery?

0

Share this post


Link to post
Share on other sites
I noticed your not using a UK Blade... so I have couple of questions that might help us out..

Where did you get your device?

Have you used any of the TPT updates to resize your partitions?

do you know what size you recovery partition is?

To answer the last question you might need to look at your /proc/mtd file...

Hello Mister Sebastian,

I used your Recovery Manager via StevenHarper's new beginners-guide. (I followed all steps by the letter).

In the tab recovery>install recovery (after the installation of clockwork 2.5.1.8 it wont get recognized)

In the tab firmware it recognizes the YESSS_P729V Stock Firmware. Nothing works, it just tells me to install a custom firmware before I can install a new one (thats exactly what I am trying to do lol)

I have a Blade from Austria, I did not resize any partitions.

What should I do to make your great app work? Or am I doing something wrong here? (I doubt that because I am just following stevenharper's guide)

0

Share this post


Link to post
Share on other sites
Hello Mister Sebastian,

I used your Recovery Manager via StevenHarper's new beginners-guide. (I followed all steps by the letter).

In the tab recovery>install recovery (after the installation of clockwork 2.5.1.8 it wont get recognized)

In the tab firmware it recognizes the YESSS_P729V Stock Firmware. Nothing works, it just tells me to install a custom firmware before I can install a new one (thats exactly what I am trying to do lol)

I have a Blade from Austria, I did not resize any partitions.

What should I do to make your great app work? Or am I doing something wrong here? (I doubt that because I am just following stevenharper's guide)

Your ok : If you have installed Clockwork VIA The Recovery Manager, then you can just reboot and enter recovery ans install manually.

Follow the 3. How to Install a ROM using Clockwork Manually in my guide.

http://android.modaco.com/content/zte-blad...-the-zte-blade/

0

Share this post


Link to post
Share on other sites
Hello Mister Sebastian,

I used your Recovery Manager via StevenHarper's new beginners-guide. (I followed all steps by the letter).

In the tab recovery>install recovery (after the installation of clockwork 2.5.1.8 it wont get recognized)

In the tab firmware it recognizes the YESSS_P729V Stock Firmware. Nothing works, it just tells me to install a custom firmware before I can install a new one (thats exactly what I am trying to do lol)

I have a Blade from Austria, I did not resize any partitions.

What should I do to make your great app work? Or am I doing something wrong here? (I doubt that because I am just following stevenharper's guide)

did you download the latest recovery image from the first page?

0

Share this post


Link to post
Share on other sites
This happens when superboot doesn't kick in right

Use a Task killer to kill everything.

Then RE-install the Recovery Manager(from the APK) - then restart it

As I couldn't get RM to work via this method I re-rooted the phone then all went well. Now running RLS8 (soon to be RLS9 once it's finished downloading).

Thanks to Sebastian404 and StevenHarperUK for their efforts. :lol:

0

Share this post


Link to post
Share on other sites
did you download the latest recovery image from the first page?

Yes sir, I used all the files step by step from Stevenharper's beginner-guide.

0

Share this post


Link to post
Share on other sites
Your ok : If you have installed Clockwork VIA The Recovery Manager, then you can just reboot and enter recovery ans install manually.

Follow the 3. How to Install a ROM using Clockwork Manually in my guide.

http://android.modaco.com/content/zte-blad...-the-zte-blade/

Thanks for the advice mister, I'm going to do step 3.

To bad I could not use Sebastian404's APP, because it looks the easiest way for noobs like myself.

0

Share this post


Link to post
Share on other sites

Hi Seb If I want to install new version of ROM eg JJ RLS9 (from having RLS8 installed) without wipe suppose I just use 'Install Firmware Update'?

I know silly Q but just asking to be thorough>>

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.