Sebastian404

[RECOVERY] : ClockworkMod Recovery for ZTE Racer

66 posts in this topic

+1 for a solution for us aussies.

Great little phone but so much Telstra bloatware

0

Share this post


Link to post
Share on other sites

Hi, Sebastian404, I'm a new member and am new to Android. Though I'm a bit of an old hand at modding/hacking - xbox, cp and used to be a symbian freak (O my heart strings twang at even the thought of that old system!). Anyway, my question is, and, if this has been asked before, please forgive me, which version of 'recovery' do I use? I have the 3 UK model of ZTE Racer. Thanks in advance!

0

Share this post


Link to post
Share on other sites
Hi, Sebastian404, I'm a new member and am new to Android. Though I'm a bit of an old hand at modding/hacking - xbox, cp and used to be a symbian freak (O my heart strings twang at even the thought of that old system!). Anyway, my question is, and, if this has been asked before, please forgive me, which version of 'recovery' do I use? I have the 3 UK model of ZTE Racer. Thanks in advance!

Sorry, I meant 'clockwork' - you have four files, two signed - do I apply all? I doubt it. Thanks again!

0

Share this post


Link to post
Share on other sites

<doublepost, i don't know how, sorry please delete> :D

Edited by TigTex
0

Share this post


Link to post
Share on other sites
Sorry, I meant 'clockwork' - you have four files, two signed - do I apply all? I doubt it. Thanks again!

Hey blatny,

i have also just got one on 3 [£50 = nice ;)] for the nephew. which cwm did you use and what rom / theme have you used.? it definately needds to be quicker and more user friendly!

cheers

0

Share this post


Link to post
Share on other sites

Deleted.

Edited by dms05
0

Share this post


Link to post
Share on other sites

Sebastian404

After official update to 2.2.2 ClockWork not work. I think partition sizes is different. Connect with me to build new version of Clockwork.

0

Share this post


Link to post
Share on other sites

please help recovery manager does not work force close.

i have already installed cm7 to my racer.

defianatly rooted.

says recovery manager has been granted superuser permissions then the force close sign comes up

PLEASE HELPsad.gif

0

Share this post


Link to post
Share on other sites

please help recovery manager does not work force close.

i have already installed cm7 to my racer.

defianatly rooted.

says recovery manager has been granted superuser permissions then the force close sign comes up

PLEASE HELPsad.gif

what exactly are you trying to do, restore a backup or to install new rom? do you have clockwork recoverymod install or just recovery manager?

0

Share this post


Link to post
Share on other sites

hey,

my device is the

telstra smart touch t3020 bought in australia

clockwork mod works fine BUT just to let everybody else know:

the key mapping is slightly different than stated in the mod

volume up and down works as expected but select doesnt work via the home key

to select use volume up and down until it suddenly says "back menu button enabled", that happens usually when you're at the first item in the menu and go one higher so it jumps to the last or vice versa (go to the last, one lower so it jumps to the first)

after you've done that, you can now select with the POWER BUTTON on the top of your phone!

havent found that information here so far, so if it helps somebody, you are welcome. if that bit of information is here already somewhere, i'm sorry but you are still welcome.

1

Share this post


Link to post
Share on other sites

hey,

my device is the

telstra smart touch t3020 bought in australia

clockwork mod works fine BUT just to let everybody else know:

the key mapping is slightly different than stated in the mod

volume up and down works as expected but select doesnt work via the home key

to select use volume up and down until it suddenly says "back menu button enabled", that happens usually when you're at the first item in the menu and go one higher so it jumps to the last or vice versa (go to the last, one lower so it jumps to the first)

after you've done that, you can now select with the POWER BUTTON on the top of your phone!

havent found that information here so far, so if it helps somebody, you are welcome. if that bit of information is here already somewhere, i'm sorry but you are still welcome.

thx for the info, some other members have had same experience with the newest 5.0.1.5 CWM, it seems that its from updating from a way lower version example 3.0.2.4 of the mod and jumping straight to the latest rather than updating as and when new updates were available........seems the way to solve keymapping was to downgrade to 5.0.1.4 and then updating to 5.0.1.5

0

Share this post


Link to post
Share on other sites

Hmm, that is interesting, it sounds like they have made some changes to the hardware for the AU market,,,

If you go into the advances menu theres a key test function, can you use that and let me know the values its reporting for all the physical keys on the device?

Have you dumped its rom?

0

Share this post


Link to post
Share on other sites

ok heres the results of key test, my version 4.0.1.5 gen1 works great no probs and have never had keymapping problems at all, but i do update CWM whenever theirs an update....

green button 231

end call 107

vol+115

vol- 114

power button 142

Edited by Racerboy
0

Share this post


Link to post
Share on other sites

Hmm, that is interesting, it sounds like they have made some changes to the hardware for the AU market,,,

If you go into the advances menu theres a key test function, can you use that and let me know the values its reporting for all the physical keys on the device?

Have you dumped its rom?

It's not the physical keys that are the problem, it's the virtual keys. They just don't work in ClockworkMod Recovery.

EDIT: I'm using ClockworkMod v4.0.1.5

EDIT: Holding in the power key shows 116

Edited by YoYo Kenny
0

Share this post


Link to post
Share on other sites

hi Sebastian404 did you want a rom dump for the rom i`ve got installed (4pda 2.3.5 #179) on 3uk Racer?

if so can you pm me a guide to use romdump on adb plz, i`ve tried the commands list you posted but no success

ADB is fully setup and working fine, adb devices : Racer

EDIT: I sorted it

Edited by Racerboy
0

Share this post


Link to post
Share on other sites

hey,

my device is the

telstra smart touch t3020 bought in australia

clockwork mod works fine BUT just to let everybody else know:

the key mapping is slightly different than stated in the mod

volume up and down works as expected but select doesnt work via the home key

to select use volume up and down until it suddenly says "back menu button enabled", that happens usually when you're at the first item in the menu and go one higher so it jumps to the last or vice versa (go to the last, one lower so it jumps to the first)

after you've done that, you can now select with the POWER BUTTON on the top of your phone!

havent found that information here so far, so if it helps somebody, you are welcome. if that bit of information is here already somewhere, i'm sorry but you are still welcome.

0

Share this post


Link to post
Share on other sites

TO ALL Telstra T3020 USERS info needed so that Sebastian can maybe change the keymapping on CWM......

If you go into the advances menu theres a key test function, can you use that and post the values its reporting for all the physical keys on the device? thx

example:

green/call button 231

end call 107

vol+115

vol- 114

power button 142

0

Share this post


Link to post
Share on other sites

TO ALL Telstra T3020 USERS info needed so that Sebastian can maybe change the keymapping on CWM......

If you go into the advances menu theres a key test function, can you use that and post the values its reporting for all the physical keys on the device? thx

example:

green/call button 231

end call 107

vol+115

vol- 114

power button 142

i also have problem with 4.0.1.5 recovery,doesnt work keys for me why?

0

Share this post


Link to post
Share on other sites

ok, post your original phone operator and do the test as mensioned above, post the results...then maybe sebastian can see and maybe change somethings......

a work around that has worked is to downgrade CWM to 4.0.1.4 then upgrade to 4.0.1.5.............i dont know if its a problem with 4.0.1.5 or not

HERE is gen1 4.0.1.4 update.zip file, to installed through CWM, reboot into recovery, check you have version 4.0.1.4 installed now, now install 4.0.1.5 HERE update .zip through CWM again, reboot into CWM again and check you have 4.0.1.5 installed and then check hardkey functions, hopefully thats fixed it for you..

Edited by Racerboy
0

Share this post


Link to post
Share on other sites

hey when i press back key enabled,it worked

0

Share this post


Link to post
Share on other sites

hey when i press back key enabled,it worked

did what i said above work for you?

when you press the end call button, it changes the button config lol aswell....... but rebooting CWM should reset the config back to normal.......

Edited by Racerboy
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.