• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[LIQUID METAL] My build AOSP experience

68 posts in this topic

Posted · Report post

I'll try to fix this for next build, and the wifi too.

I still can't get RIL working, so no call/data.

I have not so much time to work on it but i try to do my best.

To me are doing most that you can imagin :(

I like learning and the result is not so important..

Thank a lot for that you're doing :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yep it's normal, it have to be fix.

For the boot, try to backsmali both services.jar from AOSP and Acer, and replace those files :

all MountService*.smali

all NativeDaemonConnector*.smali

from Acer to AOSP.

Smali the modified services.jar and push it on phone, reboot.

Ok I do that, but when i make smali i optained a service.jar of 1.3 Mb instead of original 638 Kb..

It seems too size different and it don't work..

Now boot stops at boot logo :/

to baksmali I've type this

java -jar baksmali.jar services.jar

to smaly this

java -jar smali.jar out/com/android/server -o services.jar

I've downloaded the last version of smali-backsmali (1.2.6)

Is that right?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok I do that, but when i make smali i optained a service.jar of 1.3 Mb instead of original 638 Kb..

It seems too size different and it don't work..

Now boot stops at boot logo :/

to baksmali I've type this

java -jar baksmali.jar services.jar

to smaly this

java -jar smali.jar out/com/android/server -o services.jar

I've downloaded the last version of smali-backsmali (1.2.6)

Is that right?

To smali just type :

java -jar smali.jar out -o services.jar

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

To smali just type :

java -jar smali.jar out -o services.jar

Nop :( Same error and services.jar has always 1.3 Mb size

E/AudioHardwareMSM72XX( 1436): failed to open AUDIO_NORMAL_FILTER /system/etc/AudioFilter.csv: No such file or directory (2).
E/AudioHardwareMSM72XX( 1436): Could not open MSM SND driver.
W/AudioHardwareInterface( 1436): Using stubbed audio hardware. No sound will be produced.
W/AudioHardwareMSM72XX( 1436): Attempt to close invalid output stream
E/JNIHelp ( 1442): Native registration unable to find class 'com/android/server/Watchdog'
E/AndroidRuntime( 1442): Unable to register all android natives
E/AudioHardwareMSM72XX( 1443): failed to open AUDIO_NORMAL_FILTER /system/etc/AudioFilter.csv: No such file or directory (2).
E/AudioHardwareMSM72XX( 1443): Could not open MSM SND driver.
W/AudioHardwareInterface( 1443): Using stubbed audio hardware. No sound will be produced.
W/AudioHardwareMSM72XX( 1443): Attempt to close invalid output stream
E/JNIHelp ( 1449): Native registration unable to find class 'com/android/server/Watchdog'
E/AndroidRuntime( 1449): Unable to register all android natives
E/AudioHardwareMSM72XX( 1450): failed to open AUDIO_NORMAL_FILTER /system/etc/AudioFilter.csv: No such file or directory (2).
E/AudioHardwareMSM72XX( 1450): Could not open MSM SND driver.
W/AudioHardwareInterface( 1450): Using stubbed audio hardware. No sound will be produced.
W/AudioHardwareMSM72XX( 1450): Attempt to close invalid output stream
[/codebox]

I've to compile smali and baksmali or just download that?

http://code.google.com/p/smali/downloads/d...mp;can=2&q=

http://code.google.com/p/smali/downloads/d...mp;can=2&q=

Edited by davidevinavil
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Strange, didn't have this error.

Can you try this services.jar ? http://shoobee.eu/upp/download.php?file=276services.jar

You are a g-d :(

It's working :( :) ;)

Even if most things are not working I can see that UI is very very smooth ;)

Edited by davidevinavil
0

Share this post


Link to post
Share on other sites

Posted · Report post

Strange, didn't have this error.

Can you try this services.jar ? http://shoobee.eu/upp/download.php?file=276services.jar

I've already try to baksmali and smali but same error about size of services.jar

You are running Linux or windows?

What JRE version? 1.5 or 1.6

And I've to compile baksmali and smali or just download .jar?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've already try to baksmali and smali but same error about size of services.jar

You are running Linux or windows?

What JRE version? 1.5 or 1.6

And I've to compile baksmali and smali or just download .jar?

I'm using it on both Linux and Windows. (Java 1.5)

You don't need to compil anything, just download jar files.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've already try to baksmali and smali but same error about size of services.jar

You are running Linux or windows?

What JRE version? 1.5 or 1.6

And I've to compile baksmali and smali or just download .jar?

don't know about Linux, but in Windows u need to take classes.dex file from services.jar (open it with WinRAR) and type

java -jar baksmali.jar -o classout/ classes.dex

and u'll have folders with smali files..

java -Xmx512M -jar smali.jar classout/ -o classes.dex

for packing back the classes.dex file and putting it back into services.jar

:(

0

Share this post


Link to post
Share on other sites

Posted · Report post

don't know about Linux, but in Windows u need to take classes.dex file from services.jar (open it with WinRAR) and type

java -jar baksmali.jar -o classout/ classes.dex

and u'll have folders with smali files..

java -Xmx512M -jar smali.jar classout/ -o classes.dex

for packing back the classes.dex file and putting it back into services.jar

:(

Thank this evening I'll try..

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Strange, didn't have this error.

Can you try this services.jar ? http://shoobee.eu/upp/download.php?file=276services.jar

As said lgcmn I've to open services.jar into an unzip program, make baksmali, change files, make smali and then put classes.dex into unzip program..

Now it works :(

Edited by davidevinavil
0

Share this post


Link to post
Share on other sites

Posted · Report post

@Vache

I've read that to get ril working could be necessary to edit framework.jar..

Could be the way?!

0

Share this post


Link to post
Share on other sites

Posted · Report post

@Vache

I've read that to get ril working could be necessary to edit framework.jar..

Could be the way?!

Maybe, we need to know what's wrong before.

I'll try to look at this tonight.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Maybe, we need to know what's wrong before.

I'll try to look at this tonight.

Have you understood what's wrong in ril?

I've played with framework.jar and put Acer phone.apk with no good results..

Edited by davidevinavil
0

Share this post


Link to post
Share on other sites

Posted · Report post

Didn't had time to look at it.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

This is my logcat -b radio

E/RILD    ( 1349): **RIL Daemon Started**
E/RILD ( 1349): **dl open failed **
E/RILD ( 1429): **RIL Daemon Started**
E/RILD ( 1429): **dl open failed **
E/RILD ( 1480): **RIL Daemon Started**
E/RILD ( 1480): **dl open failed **
E/RILD ( 1510): **RIL Daemon Started**
E/RILD ( 1510): **dl open failed **
E/RILD ( 1560): **RIL Daemon Started**
E/RILD ( 1560): **dl open failed **
I/PHONE ( 1591): In makeDefaultPhone function
I/PHONE ( 1591): Network Mode set to 3
I/PHONE ( 1591): Cdma Subscription set to 1
E/RIL_UiccManager( 1591): Constructing
D/RILJ ( 1591): [0000]> RIL_REQUEST_REPORT_STK_SERVICE_IS_RUNNING
D/STK ( 1591): StkService: StkService: is running
D/STK ( 1591): StkService: NEW sInstance
I/PHONE ( 1591): get Phone Type:1
D/RILJ ( 1591): [0000]< RIL_REQUEST_REPORT_STK_SERVICE_IS_RUNNING error: com.android.internal.telephony.CommandException: RADIO_NOT_AVAILABLE
D/PHONE ( 1591): mDoesRilSendMultipleCallRing=false
D/PHONE ( 1591): mCallRingDelay=3000
D/RIL_IMS ( 1591): Ims Ims SMS Dispatcher phone ref:Handler{30bb2ca0}
D/CDMA ( 1591): Register for EVENT_NEW_SMS
D/GSM ( 1591): Register for EVENT_NEW_SMS
D/RIL_IccCardProxy( 1591): Setting radio tech RADIO_TECH_3GPP
D/RIL_IccCardProxy( 1591): Updating quite mode
D/RIL_IccCardProxy( 1591): 3GPP subscription -> QuiteMode: false
I/PHONE ( 1591): Creating GSMPhone
D/RILJ ( 1591): [0001]> GET_CURRENT_CALLS
D/GSM ( 1591): Phone subscription:0
E/GSM ( 1591): Wrong network type: 0
E/GSM ( 1591): Wrong network type: 0
D/GSM ( 1591): Poll ServiceState done: oldSS=[1 home null null null Unknown CSS not supported 0 0RoamInd: 0DefRoamInd: 0EmergOnly: false] newSS=[1 home null null null Unknown CSS not supported -1 -1RoamInd: -1DefRoamInd: -1EmergOnly: false] oldType=unknown newType=unknown
I/GSM ( 1591): EONS: ServiceState changed,calling checkEonsAndUpdateSpnDisplay()
D/RILJ ( 1591): [0001]< GET_CURRENT_CALLS error: com.android.internal.telephony.CommandException: RADIO_NOT_AVAILABLE
V/PHONE ( 1591): [PhoneProxy] ---EVENT_RADIO_STATE_CHANGED : newState = RADIO_UNAVAILABLE
V/PHONE ( 1591): [PhoneProxy] setPowerStateToDesired : mDesiredPowerState = true, getRadioState() = RADIO_UNAVAILABLE
E/RIL_IccCardProxy( 1591): Broadcasting intent ACTION_SIM_STATE_CHANGED ABSENT reason null
D/RILJ ( 1591): [0002]> RIL_REQUEST_SET_TTY_MODE : 0
D/RILJ ( 1591): [0002]< RIL_REQUEST_SET_TTY_MODE error: com.android.internal.telephony.CommandException: RADIO_NOT_AVAILABLE
D/RILJ ( 1591): [0003]> RIL_REQUEST_QUERY_TTY_MODE
D/RILJ ( 1591): [0003]< RIL_REQUEST_QUERY_TTY_MODE error: com.android.internal.telephony.CommandException: RADIO_NOT_AVAILABLE
E/RILD ( 1756): **RIL Daemon Started**
E/RILD ( 1756): **dl open failed **
D/STK ( 1591): StkService: Return current sInstance
D/STK ( 1591): StkAppService$ServiceHandler: OP_BOOT_COMPLETED
I/RILJ ( 1591): Couldn't find 'rild' socket; retrying after timeout
E/RILD ( 1885): **RIL Daemon Started**
E/RILD ( 1885): **dl open failed **
I/RILJ ( 1591): Couldn't find 'rild' socket; retrying after timeout
I/RILJ ( 1591): Couldn't find 'rild' socket; retrying after timeout
E/RILD ( 1888): **RIL Daemon Started**
E/RILD ( 1888): **dl open failed **
I/RILJ ( 1591): Couldn't find 'rild' socket; retrying after timeout
E/RILD ( 1889): **RIL Daemon Started**
E/RILD ( 1889): **dl open failed **
I/RILJ ( 1591): Couldn't find 'rild' socket; retrying after timeout
E/RILD ( 1892): **RIL Daemon Started**
E/RILD ( 1892): **dl open failed **
I/RILJ ( 1591): Couldn't find 'rild' socket; retrying after timeout
E/RILD ( 1893): **RIL Daemon Started**
E/RILD ( 1893): **dl open failed **
[/codebox]

Seems we have issue about ril daemon :/

Look at this i think could be useful..

http://androidapps.org.ua/i_sect18_d1e18369.html

Edited by davidevinavil
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I'm trying to change some stuff about telephony in framework.jar, but results are less good that original aosp framework.jar :/

Edited by davidevinavil
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I've push libril*.so and libreference-ril.so from acer to phone..

Reinstalled aosp Phone.apk

Take SimCard.smali and BaseCommands.smali from acer to aosp framework.jar

Now I've no service instead of no simcard

This is my framework.jar

https://docs.google.com/leaf?id=0BwYKbOD16O...yMjk5&hl=en

This is result of adb shell ls -l /dev/socket/*

srw-rw---- bluetooth bluetooth          2011-03-12 15:27 dbus
srw------- system system 2011-03-12 15:27 installd
srw-rw-rw- root root 2011-03-12 15:27 keystore
srw-rw---- root system 2011-03-12 15:27 netd
srw-rw-rw- root root 2011-03-12 15:27 property_service
srw-rw---- root mount 2011-03-12 15:27 vold
srw-rw-rw- root root 2011-03-12 15:27 zygote
[/codebox]

Here result of metalounay

[codebox]srw-rw---- 1 1002 1002 0 Mar 12 19:33 /dev/socket/dbus
srw------- 1 1000 1000 0 Mar 12 19:33 /dev/socket/installd
srw-rw-rw- 1 0 0 0 Mar 12 19:33 /dev/socket/keystore
srw-rw---- 1 0 1000 0 Mar 12 19:33 /dev/socket/netd
srw-rw-rw- 1 0 0 0 Mar 12 19:33 /dev/socket/property_service
srw-rw---- 1 0 1001 0 Mar 12 19:33 /dev/socket/rild
srw-rw---- 1 1001 1000 0 Mar 12 19:33 /dev/socket/rild-debug
srw-rw---- 1 0 1009 0 Mar 12 19:33 /dev/socket/vold
srw-rw-rw- 1 0 0 0 Mar 12 19:33 /dev/socket/zygote

How can we add rild and rild-debug to /dev/socket?

I've tryed with adb shell with no succes :D

Edited by davidevinavil
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.