• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0


3 posts in this topic

Posted (edited)

I tried to flash metal ROM 1.001.02 to my liquid S100. After AMSS or so the phone showed not connected in the acer download tool. I removed the USB, tried to switch phone on.


1. The phone does not switch on(Black Screen as when switched off)

2. Does not boot into recovery by the button combo...Power, volume, camera

3.No use trying malez recovery or superboot from computer end...It does not recognize device..Though, I have all the acer drivers installed.

4.Acer download tool does not recognize the phone anymore and says not connected everytime I try to reflash the earlier working Bin.

5.I have tried all the basic steps of removing battery, usb etc.

6. When I connect the phone to charger, still the screen remains black(as when switched off)...No sign of any activity..


[email protected]

Edited by amolb

Share this post

Link to post
Share on other sites


Hello, have a look on that :



This one in French (FR Liquid Reference forum :()... http://www.acer-android.fr/flasher-desimlo...-mode-t544.html

Google translator if needed...

hope it will work fine for you...



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.