Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

new new new

43 posts in this topic

Posted · Report post

hi guys im new to the defy coming from a g1, t mobile pulse,zte blade(now maybe for sale )...just wondered whats the story on the phone is android 2.2 available official or not?..any bugs? ...can you use flash player 10? .....how mutch can you custom it? .......can you take motoblur away and use adw ex ...and is it possible to theme the rom eg install honybread or any othe themes to framework

thanks in advance just want to get started ....

0

Share this post


Link to post
Share on other sites

Posted · Report post

Should come out this spring with flash 10 on it from what I have read.

I have tried a de-motoblurred rom & TBH, there's usually menus still there for you to try setting up motoblur but ofcourse it won't work... I think in the same one I tried getting into "Accounts" (for my gmail setup) & it just dumped me back to where I was. So I think I prefer the leaked UK Froyo motoblur, I don't like seeing menus that are there but don't function properly. I think motoblur is quite useful 'cos if it's lost or stolen you can log in to it & remote wipe (only the phone, not SD card).

There are tiny bugs in Froyo (leaked) like colour markers in calendar are gone (the numbers are still bold) making it look empty when it's not.

Sometimes the homescreen profile changer will loose all the icons, but switch profiles they come back. Had YouTube unresponsive 'til I reboot.

On 2.1 I had screen freezing issues but they're gone in Froyo. Overall it's much more improved over 2.1 with only one or two VERY minor things which are nothing really. I really love this phone since upgrading to Froyo :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

+1 to the Op,

Also coming from the Blade!

Any info till my defy comes from my Ebay seller will keep me happy!!!

Thanks :D :D :( ;) B)

0

Share this post


Link to post
Share on other sites

Posted · Report post

If you want to root / hack it you want RSD Lite & the moto drivers for PC, these will help when you (I) brick it lol :D

Word of caution, don't think you can download from Froyo to Eclair, well it may be possible but that is more technical / involve more risk etc...

But most people want [at least] Froyo anyway, sooo, check all the forums you can there are custom roms & what not.

I'm no dev but it's like a nagging itch eventually you will root / custom rom / overclock it, whatever.

On Eclair it was possible to use z4root & clockwork mod recovery to root & install custom roms (nandroid backup / recoveries) on your SD card, but doesn't seem to work on my Froyo build, so RSD Lite it is for flashing, & SuperOneClick for rooting (all on PC).

I think there is a new app on market that lets you backup & restore roms on your card but I forgot what it's called.

Just read here & other android forums before you go at it aye!

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm no dev but it's like a nagging itch eventually you will root / custom rom / overclock it, whatever.

LOL, so true, I have had a Defy for 3 days now and already am thinking about rooting etc etc. lol. I wasn't intending to but coming from a rooted Desire that I can do absolutely anything with, to a Defy that I can't do much with at all, it's a real "shock to the system".

I'm not rushing into it though, want to get it right first time, had major issues when rooting my Desire and got my knickers in a right old twist. LMAO

Alison

0

Share this post


Link to post
Share on other sites

Posted · Report post

LOL, so true, I have had a Defy for 3 days now and already am thinking about rooting etc etc. lol. I wasn't intending to but coming from a rooted Desire that I can do absolutely anything with, to a Defy that I can't do much with at all, it's a real "shock to the system".

I'm not rushing into it though, want to get it right first time, had major issues when rooting my Desire and got my knickers in a right old twist. LMAO

Alison

same, came from a rooted desire and ended up rooting the defy on the first day. I only did it to get 2.2 though as I need it for my works email app.

Whatever you do though, dont flash a rom like you would the desire if you want to try and keep your warranty. Motorola have it locked down good and unlike the desire you cant downgrade unless you do it in a certain way. I spent the full day reading through stuff trying to work it out but ive managed and ive tested downgrading and its all good :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

So full adobe flash is possible on froyo(full vertion not lite) ? So far the phone is great apart from the power button feeling a bit loose..anyone can confirm this.

0

Share this post


Link to post
Share on other sites

Posted · Report post

So full adobe flash is possible on froyo(full vertion not lite) ? So far the phone is great apart from the power button feeling a bit loose..anyone can confirm this.

not sure on the froyo and flash, as much as I use mine for browsing I never really watch flash videos.

Yes my power button is loose too and my brothers. Seems its part of the design?

0

Share this post


Link to post
Share on other sites

Posted · Report post

not sure on the froyo and flash, as much as I use mine for browsing I never really watch flash videos.

Yes my power button is loose too and my brothers. Seems its part of the design?

Ok thanks I love the fact that out of the box it beats my zte blade...that is hacked up.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok thanks I love the fact that out of the box it beats my zte blade...that is hacked up.

Well I'm amazed how much more refined the Defy is after my blade running ginger bread!

Have rooted and installed custom recovery on my 2.51.1 defy takes alot of hunting around to find the correct drivers, even needing to install a new .Net framework on my pc!.

Am I correct in thinking that any of the current froyo roms have bugs still? Seems alot of folk are saying so.......?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well I'm amazed how much more refined the Defy is after my blade running ginger bread!

Have rooted and installed custom recovery on my 2.51.1 defy takes alot of hunting around to find the correct drivers, even needing to install a new .Net framework on my pc!.

Am I correct in thinking that any of the current froyo roms have bugs still? Seems alot of folk are saying so.......?

im yet to experience one with 3.4.3-11

0

Share this post


Link to post
Share on other sites

Posted · Report post

im yet to experience one with 3.4.3-11

Very tempted to go froyo, which version of eclair did you upgrade from?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Very tempted to go froyo, which version of eclair did you upgrade from?

2.51. Just make sure you dont directly flash if you want to be able to downgrade in the future

0

Share this post


Link to post
Share on other sites

Posted · Report post

2.51. Just make sure you dont directly flash if you want to be able to downgrade in the future

so can you add a link to the best froyo rom available ....and what bugs are on it ....

0

Share this post


Link to post
Share on other sites

Posted · Report post

so can you add a link to the best froyo rom available ....and what bugs are on it ....

ive come the pulse and blade as well!!

you'll find the development isnt as interesting because it has a locked bootloader meaning we can edit the kernel.

however their is a froyo update thats official us update but we had leaks b4 then

you can edit the framework and make it look how u want

can use flash and works lovley

and yeah you can just adw to hide blur or you can custom rom it to remove blur in total which is much better

their isnt as much to do as with the blade and pulse however it is a much much better phone and theirs nothing ive found it cant handel

0

Share this post


Link to post
Share on other sites

Posted · Report post

So any ROM for 2.51 will work for 2.51.1?

As this is where I'm getting a bit confused! Or do you think it's worth waiting for the official froyo update?

0

Share this post


Link to post
Share on other sites

Posted · Report post

So any ROM for 2.51 will work for 2.51.1?

As this is where I'm getting a bit confused! Or do you think it's worth waiting for the official froyo update?

im as confuse as you there seem to be so much to it eg all i am used to is 1.5,2.0,2.1,2.2,2.3. so what is this 2.51,2.51.1 business.

0

Share this post


Link to post
Share on other sites

Posted · Report post

im as confuse as you there seem to be so much to it eg all i am used to is 1.5,2.0,2.1,2.2,2.3. so what is this 2.51,2.51.1 business.

now that i can answer!

2.51 and 2.51.1 are build numbers not versions of android. tho i cant clarify further as to what this does!

0

Share this post


Link to post
Share on other sites

Posted · Report post

oo so what build number goes with what froyo...

0

Share this post


Link to post
Share on other sites

Posted · Report post

oo so what build number goes with what froyo...

Exactly where i'm getting confused!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Exactly where i'm getting confused!

lol o boy this is so painfull ....lol and noone is here to sorta guide us i been reading on xda and boy im even more lost and i think i got the 2.51.1 so cant downgrade but if you follow this other steps you can but then you cant then so on im just lost and wanting 2.2 lol

0

Share this post


Link to post
Share on other sites

Posted · Report post

lol o boy this is so painfull ....lol and noone is here to sorta guide us i been reading on xda and boy im even more lost and i think i got the 2.51.1 so cant downgrade but if you follow this other steps you can but then you cant then so on im just lost and wanting 2.2 lol

Great isnt it two reasonably hardcore phone geeks completely and hoplessly lost and confused!!!!

LMAO!!!!!!! :D :D :D B) ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Correct, 2.51 is the build number which is android version 2.1 (eclair)

if you want to upgrade and dont care about downgrading then go ahead and flash any UK froyo rom but make sure its not one with the LED bug which I think is limited to the chinese ones as they are actually for a different model number.

To keep downgradeability you need to flash "fixed" sbf`s. Dont ask me why or what that means, I just accept this is the case and do it. Then you can restore a nandroid of the version of froyo that goes with that sbf. If you have come from another android phone then this might seem odd to you but its because motorola have the bootloader locked and this is the only way to work around it.

Try my guide here, Ive got a t-mobile UK defy and this worked for me. I can still downgrade my phone as ive tested it.

http://android.modaco.com/index.php?s=&amp...t&p=1648898

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Correct, 2.51 is the build number which is android version 2.1 (eclair)

if you want to upgrade and dont care about downgrading then go ahead and flash any UK froyo rom but make sure its not one with the LED bug which I think is limited to the chinese ones as they are actually for a different model number.

To keep downgradeability you need to flash "fixed" sbf`s. Dont ask me why or what that means, I just accept this is the case and do it. Then you can restore a nandroid of the version of froyo that goes with that sbf. If you have come from another android phone then this might seem odd to you but its because motorola have the bootloader locked and this is the only way to work around it.

Try my guide here, Ive got a t-mobile UK defy and this worked for me. I can still downgrade my phone as ive tested it.

http://android.modaco.com/index.php?s=&amp...t&p=1648898

what is your phone vertion im on 2.51.1 will it work ......

when i try flashing the system of the file given it says md5 mis match .....so it aboarts iti downloaded the file alot of time with same outcome any help on how to flash the syste, like you mention.

Edited by fredewis
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

what is your phone vertion im on 2.51.1 will it work ......

when i try flashing the system of the file given it says md5 mis match .....so it aboarts iti downloaded the file alot of time with same outcome any help on how to flash the syste, like you mention.

Im not sure about 2.51.1 but my understanding is it shouldnt matter, mine was 2.51. Try redownloading, its possible your download is corrupt?

have a read through this and see if it can help you

http://forum.xda-developers.com/showthread.php?t=714114

Edited by Diggedy
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.