• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

29 Jun: 4.0.0.5 - ClockworkMod Recovery for the LG Optimus 2X

311 posts in this topic

Posted

ROM Manager doesn't seem to work for me either. It just sits there for a while and then says that "An error occurred while flashing your recovery" (and that's all the info I get). The weird thing is that it doesn't even prompt for su rights :mellow:.

0

Share this post


Link to post
Share on other sites

Posted

ROM Manager doesn't seem to work for me either. It just sits there for a while and then says that "An error occurred while flashing your recovery" (and that's all the info I get). The weird thing is that it doesn't even prompt for su rights :mellow:.

IM assuming this is because it cm site is down and it cannot download it, wait till their servers are back up and retry

0

Share this post


Link to post
Share on other sites

Posted

ROM Manager doesn't seem to work for me either. It just sits there for a while and then says that "An error occurred while flashing your recovery" (and that's all the info I get). The weird thing is that it doesn't even prompt for su rights :mellow:.

Seems to be working now, just did a successful flash with rom manager.

0

Share this post


Link to post
Share on other sites

Posted

You're right, working for me too now :mellow:. I figured out after some Googling that an unreachable server would probably be the cause. Would be nice if it simply gave me the timeout exception though, at least I'd know what's up..

0

Share this post


Link to post
Share on other sites

Posted

i cant update my cwr yo 3.0.2.8 by using rom manager, i currently have pauls version.

so how do i install this standalone, do i just flash it using the old cwr or how is this done?

I know it's sorted now, but for future reference you can use it with Paul's batch file. Just rename the recovery (or edit the batch).

0

Share this post


Link to post
Share on other sites

Posted (edited)

I've just been looking through my backup files for CWM but it seems all of the dates and times are incorrect on each of the backup folders: eg - I did two backups today one with 3.0.1.4 r1 and the other with the Rom Manager at about 9:45am GMT this morning yet these are the date stamps I got:

Rom Manager - 2011-05-16.14.50.32

3.0.1.4 r1 - 2011-05-16.14.37.38

Yet my phones date and time are set correctly so could anyone advise whats going on here?

Ignore this post I've figured it out. - Found the correct entries.

Edited by castab
0

Share this post


Link to post
Share on other sites

Posted

Ok a new question - has anyone managed to get the 'Manage and Restore Backups' option in ROM Manager to actually display any backups made with either 3.0.1.4 r1 or ROM Manager (v4.2.0.2)?

I just get a blank screen.

Is there something I need to do first to get this to work? I can backup from ROM Manager successfully I've checked.

I know I can manually boot into recovery to access my backups but I want to be able to do it from within ROM Manager.

0

Share this post


Link to post
Share on other sites

Posted

It's because ROM Manager looks on the internal SD and ClockworkMod looks on the external SD.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi Paul/Everyone,

I just updated my phone to version LGP990-V110d today and 2x Recovery Boot no longer works. (I have also tried the Rom Manager and it also does not work.) When I click the app, it goes directly into the Android Recovery System and not ClockworkMod. The Android Recovery System also does not work / allow me to enter and reboot my system.

I have notice that my quadrant score is also lower than when I first added your Performance Pack so I assume the fixes you made in it were not taken advantage of in this update? So was planning to install your Performance Pack on top of this update.

Let me know?

Thanks.

Edit: Correction LGP990-V10d with baseband 1035.21_20110405 and kernal 2.6.32.9

So the idea was when I was on V10a older baseband and dirty version of kernal, I was able to use 2x Recovery Boot. But now not.

Any help would be appreciated.

Edit 2: Yes, re-rooted with superoneclick but still did not work even after reboot. But uninstalled and reinstalled 2x Recovery Boot again and it works now. Thanks all!

Edited by orangekid1
0

Share this post


Link to post
Share on other sites

Posted

very much a newby, so please excuse me

Followed instructions, downloaded the 2x recovery app

That just says no root access

and this is the extract from the adb screen;

D:\LG\3.0.1.4-r1-2x-clockworkmod-modaco>install-clockworkmod-windows

D:\LG\3.0.1.4-r1-2x-clockworkmod-modaco>adb-windows push psneuter /data/local/ps

neuter

1859 KB/s (557962 bytes in 0.293s)

D:\LG\3.0.1.4-r1-2x-clockworkmod-modaco>adb-windows shell chmod 4755 /data/local

/psneuter

D:\LG\3.0.1.4-r1-2x-clockworkmod-modaco>adb-windows shell /data/local/psneuter

mmap() failed. Operation not permitted

D:\LG\3.0.1.4-r1-2x-clockworkmod-modaco>adb-windows wait-for-device

D:\LG\3.0.1.4-r1-2x-clockworkmod-modaco>adb-windows push clockworkmod.img /data/

local/

1968 KB/s (4651008 bytes in 2.307s)

D:\LG\3.0.1.4-r1-2x-clockworkmod-modaco>adb-windows shell dd if=/data/local/cloc

kworkmod.img of=/dev/block/mmcblk0p7

9084+0 records in

9084+0 records out

4651008 bytes transferred in 3.172 secs (1466269 bytes/sec)

any ideas?

or rather, what do I do next... a bit scared to boot into recovery

0

Share this post


Link to post
Share on other sites

Posted

Hi Paul/Everyone,

I just updated my phone to version LGP990-V110d today and 2x Recovery Boot no longer works. (I have also tried the Rom Manager and it also does not work.) When I click the app, it goes directly into the Android Recovery System and not ClockworkMod. The Android Recovery System also does not work / allow me to enter and reboot my system.

I have notice that my quadrant score is also lower than when I first added your Performance Pack so I assume the fixes you made in it were not taken advantage of in this update? So was planning to install your Performance Pack on top of this update.

Let me know?

Thanks.

Edit: Correction LGP990-V10d with baseband 1035.21_20110405 and kernal 2.6.32.9

So the idea was when I was on V10a older baseband and dirty version of kernal, I was able to use 2x Recovery Boot. But now not.

Any help would be appreciated.

Performing the update will have overwritten your custom recovery I suspect, and quite possibly binned off your root access too. You can just run the batch from the OP again to sort that, or use SuperOneClick to re-root and use ROM Manager to install the latest CMW recovery.

0

Share this post


Link to post
Share on other sites

Posted

Updated to 3.0.2.8!

P

0

Share this post


Link to post
Share on other sites

Posted

Updated to 3.0.2.8!

P

So Paul, can you confirm, we can now safely reboot to recovery with your Market app and the correct/updates/compatible version of CWM will be installed?

I've avoided using your app since I upgraded CWM from ROM Manager just in case.

0

Share this post


Link to post
Share on other sites

Posted

Correct, my app uses the latest release now.

P

0

Share this post


Link to post
Share on other sites

Posted

works really nice :unsure:

Thank you Paul !

0

Share this post


Link to post
Share on other sites

Posted

I dont know if someone have same problem.

I can install Recovery, all work fine, can flash, can backup ...

The problem is if i try to restore any backup, donde with the recovery, it restore fine, but dosent power , kepp in LG Logo screen, with loading bar stoped.

I have make some test, and can confirm that the kernel dosent restore correctly.

If after make a full restore, i flash a custom kernel, all work fine again.

IN my forum have some users with same problem.

Have you tried it paul?

0

Share this post


Link to post
Share on other sites

Posted

is there any one like me??

the vibrator is always on while in recovery.

it's kinda annoying.

0

Share this post


Link to post
Share on other sites

Posted

is there any one like me??

the vibrator is always on while in recovery.

it's kinda annoying.

i have it too

0

Share this post


Link to post
Share on other sites

Posted

I have the vibration issue as well. I did post a thread asking if anyone had a fix for it on xda but there was no response.

0

Share this post


Link to post
Share on other sites

Posted

Hold down the buttons and don't release them until recovery appears...

So I hold down the Power + Vol Down and it would boot straight into recovery? Or will it go pass the SW Upgrade screen first? I also always get to SW Upgrade screen :unsure:

0

Share this post


Link to post
Share on other sites

Posted

So I hold down the Power + Vol Down and it would boot straight into recovery? Or will it go pass the SW Upgrade screen first? I also always get to SW Upgrade screen :unsure:

It should go straight to recovery, if you have clockworkmod recovery installed.

0

Share this post


Link to post
Share on other sites

Posted

So I hold down the Power + Vol Down and it would boot straight into recovery? Or will it go pass the SW Upgrade screen first? I also always get to SW Upgrade screen :P

You must hold it until ANDROID message appear, i have same problem :-)

0

Share this post


Link to post
Share on other sites

Posted

Hi guys, updating to 3.0.2.8 i get "can't mound /sdcard".

How can i fix it ?

Thank's

0

Share this post


Link to post
Share on other sites

Posted

Hi guys,

Do u have working adb shell with 3.0.2.8 ?

I cannot connect to device this way anymore. I push back 3.0.1.4 and adb shell works again.

Is there other way for new ClockWorkMod?

Thanks

0

Share this post


Link to post
Share on other sites

Posted

Hi guys, updating to 3.0.2.8 i get "can't mound /sdcard".

How can i fix it ?

Thank's

I had the same problem. Solved by reflashing the ClockworkMod Recovery.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.