removed-36

[HOWTO]Change the digitizer screen (ZTE Blade)

Recommended Posts

WildeRNS    0

i ordered display in 17.12.2011 and 10.01.2012 displayes arrived in dealextreme, now they preparing to ship me. so i think they are in stock.

Share this post


Link to post
Share on other sites
WAWA72    4

Here a small How to for you:

All screws out

Open the Blade

Open the Fascia Connector

Open the Display Connector

Solve the display:

From the right side of the display Connector you do push a toothpick inside (half length) and let it inside

Next toothpick push it an the left side from the connector and let it in.

The third 1cm from the second toothpick....and the 4th ....

If you are at the end of the display you can with you Fingers the display pry

I do it, more then 10 times with 10 Blades, it works without any problem.

Only what you never will forget, befor you work with my tootpick trick, ist open the Connector and slide it out.

I repaired more then 30 Blades here in germany, believe in me.

The new Display build in is very easy:

First you connect the Connector

After that, you fold down the display. It will fit 99% in right position.

Edited by WAWA72

Share this post


Link to post
Share on other sites
mamboboy    0

p

screws out

Buddy open

the flap open

digitizer open

new digitizer build in

flap close

its very easy, i do it so many times

next time, i make a video from this, includet my dust protections

Oh well, replacement digitizer didn't fix it so I've definitely screwed something on the mainboard. Gutted :(

Share this post


Link to post
Share on other sites
WAWA72    4

I think you get a faulty replacement. Thats normal, from 10 are 3 faulty. Ask you seller for a new one. I buy only from mpas (ebay).

Share this post


Link to post
Share on other sites
mamboboy    0

I honestly think I've done something to the actual mainboard. When I messaged the seller about the first he said he's never had a report of the "A Grade" digitizers not working and both of the ones he's send me have been in pristine condition

I stupidly didn't look at this thread before trying and used a screwdriver to reopen the phone to clean it again thinking it would be quicker. I'd put money on me scratching a contact :(

Share this post


Link to post
Share on other sites
mamboboy    0

That's very kind of you but shipping rates, etc to Germany will make it a little pointless really.

If I took a photo of the phones board and posted it here do you think you'd be able to spot if anything has broken off?

Share this post


Link to post
Share on other sites
Sluysen    0

@WAWA thx

so far I managed to get it open( tough job hope I didn't break anything :P)

But i'm not sure on how I can disconnect the digitizer, and then the screen itself. This connector:

sanfran6o.jpg

Share this post


Link to post
Share on other sites
mamboboy    0

@WAWA thx

so far I managed to get it open( tough job hope I didn't break anything :P)

But i'm not sure on how I can disconnect the digitizer, and then the screen itself. This connector:

sanfran6o.jpg

It's like a flap holding it down, just lift it with your fingernail...

Edited by mamboboy

Share this post


Link to post
Share on other sites
WAWA72    4

Di you buy only the digitizer or digitizer includet the Fascia?

The second Variant is the better Idea.

For all Flaps use your Fingernails, no screwdrivers !!

For connect the Connector u can use the Fingernail and a toothpick.

Share this post


Link to post
Share on other sites
Sluysen    0

It's not my picture :P it's from the first post of this topic.

I don't think i need a digitizer hence my touch still works, only 95% black lcd display.

I disconnected the digitizer one

but the big one from the screen doesn't work.

I removed a metal brace from around the screen, but the screen itself doesn't move. Is that glue'd or something??

Edited by Sluysen

Share this post


Link to post
Share on other sites
Sluysen    0

Yeah I fell with my bike, and display is 95% busted, only little parts that i can see..

But I can still slide it, turn it, type, ... so it's only the screen that's busted not the top layer digitizer (not a scratch on it :()

But now I can't get the big connector of the screen loose. And the screen itself seems to be stuck with glue or something cause it doesn't move a bit

Share this post


Link to post
Share on other sites
Sluysen    0

I can't get the big connector of the screen loose. And the screen itself seems to be stuck with glue or something cause it doesn't move a bit.

Any help with this? The new screen itself is Ordered, but i need to remove the broken one first ;)

Share this post


Link to post
Share on other sites
WAWA72    4

The digitizer (screen, Touchscreen) is no glue, only flaped. Open the flap and put it off.

The display is faulty, open the flap (Oled or LCD) Lcd flaped from edge and Oled flaped from right. Use your Fingernails like a backhoe bucket

the display is glued to circuid board. You can use toothpicks betweens display and board to solve

Edited by WAWA72

Share this post


Link to post
Share on other sites
Sluysen    0

Ok, once i get that big ribbon connecter of the screen loose, i'll try to use toothpicks. Might need them for that connector strip too :P

Share this post


Link to post
Share on other sites
WAWA72    4

Please:

screen is (Touchscreen)

display is display

otherwise when u call all screen iam get confused

Share this post


Link to post
Share on other sites
Sluysen    0

Ok display my bad :D It's finally loose, after using and breaking 20 toothpicks. It's really sticky tape they used :D

Now the waiting game for the new display begins

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.