Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

802.11 n WIFI connecting issue

29 posts in this topic

Posted · Report post

The Liquid Metal supports the 802.11 b/g/n. But I found it cannot connect to the WIFI stably, if the router set to "n" (only, not b/g/n mixed mode). It cannnot keep the connection more than 1 minute.

Does anyone found the same problem? Or any good solution? Thanks in advance.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Could you provide a logcat when it try to connect ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I confirm, my liquid wirk good in wifi and I'm using wifi n

0

Share this post


Link to post
Share on other sites

Posted · Report post

I confirm, my liquid wirk good in wifi and I'm using wifi n

Thanks Vache and dieghito.

There are more informaiton: maybe it's not about wifi n, just because the wifi used secured with 802.1x EAP2/EAP-MSCHAP-v2.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Does anyone found the same problem? Or any good solution? Thanks in advance.

yes, same problem for me.

this is g/n mode issue (probably bug in old ar6000 wifi driver). to fix this issue, follow the steps below (for rooted device):

- adb remount rw;

- adb shell;

- vi /system/bin/wlan_tool;

in vi, press 'i' key for editor mode;

- uncomment WMODE="bg" line (line 11 in file);

- press 'Esc';

- then press ':';

- then press 'wq';

- then press 'Enter';

or adb pull /system/bin/wlan_tool, edit, then adb push back to device.

- reboot phone.

enjoy.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Does anyone found the same problem? Or any good solution? Thanks in advance.

can you show dmesg from device ?

command: adb shell dmesg

0

Share this post


Link to post
Share on other sites

Posted · Report post

and decrease wmitimeout.

add

echo 1 > /sys/module/ar6000/parameters/wmitimeout

after

insmod /system/wifi/ar6000.ko

in

/system/bin/wlan_tool

link to my wlan_tool: http://www.2shared.com/file/XyW4RVR6/wlan_tool.html

p.s. probably, wmitimeout is enough.

What is the interest to change this setting?

0

Share this post


Link to post
Share on other sites

Posted · Report post

What is the interest to change this setting?

in fact, no changes are helping to solve the problem completely.

past 2 days I'm trying to solve this problem by adjusting the parameters of the module or using wmitool without any stable results. sometime it works, sometime not.

it seems that the problem can not be solved with current ar6003 driver for acer 2.6.29 kernel.

0

Share this post


Link to post
Share on other sites

Posted · Report post

in fact, no changes are helping to solve the problem completely.

past 2 days I'm trying to solve this problem by adjusting the parameters of the module or using wmitool without any stable results. sometime it works, sometime not.

it seems that the problem can not be solved with current ar6003 driver for acer 2.6.29 kernel.

Maybe it can help : http://localhostr.com/file/PyUq79T/updated_wifi_drivers.zip

Updated drivers from 1.100.99 bin, i check wlan_tool and wmiconfig too, they are identical, so i just included wifi driver.

0

Share this post


Link to post
Share on other sites

Posted · Report post

can you show dmesg from device ?

command: adb shell dmesg

Hi Alex, thanks so much.

Sorry, I cannot show the dmesg this moment, because I found other problem in my phone, alredy sent to Acer servcie to repair. Will update you if it's done.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Maybe it can help : http://localhostr.com/file/PyUq79T/updated_wifi_drivers.zip

Updated drivers from 1.100.99 bin, i check wlan_tool and wmiconfig too, they are identical, so i just included wifi driver.

same problem with this driver. wifi on, connected, and wifi indicator always show that wifi connection is ok, but in fact network is dead.

see dmesg parts below:

wifi on - http://pastebin.com/v6Tu9PXz

turn off wifi - http://pastebin.com/FGicZWAN

0

Share this post


Link to post
Share on other sites

Posted · Report post

same problem with this driver. wifi on, connected, and wifi indicator always show that wifi connection is ok, but in fact network is dead.

see dmesg parts below:

wifi on - http://pastebin.com/v6Tu9PXz

turn off wifi - http://pastebin.com/FGicZWAN

so, this is a bug in wpa_supplicant.

using wpa_supplitsant, phone connects to the AP and lose connection after a few seconds.

using wmiconfig works fine (except wifi indicator).

i wrote simple script for wmiconfig. see example below:

#!/system/bin/sh -x

SSID=""

PASSPHRASE=""

CIPHER=""

rmmod ar6000

insmod /system/wifi/ar6000.ko

if [ "$?" != 0 ] ; then exit 1 ; fi

sleep 3

false

while [ "$?" != 0 ]

do

wmiconfig -i wlan0 --connect $SSID --wpa 2 $CIPHER $CIPHER $PASSPHRASE

sleep 5

ip link set wlan0 up

sleep 2

ip link show wlan0 | grep -qo 'state UP'

done

dhcpcd wlan0

for i in $(seq 1 4)

do

setprop net.dns${i} $(getprop dhcp.wlan0.dns{i})

done

setprop net.dnschange 1

setprop init.svc.wpa_supplicant running

setprop wlan.driver.status ok

0

Share this post


Link to post
Share on other sites

Posted · Report post

vache, can you make archive with wpa_supplicant from gingerbread rom ?

You can get it from Gingerounay.

0

Share this post


Link to post
Share on other sites

Posted · Report post

1.100.99 bin is it from liquid Vache?

0

Share this post


Link to post
Share on other sites

Posted · Report post

can someone imrove the ad hoc connection??? I find a script flashable for n1 and desire. I try with amon ra, but them wifi does not work

0

Share this post


Link to post
Share on other sites

Posted · Report post

You can get it from Gingerounay.

Hi Alex, did you get the driver and fix this connection issue? Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Alex, did you get the driver and fix this connection issue? Thanks

no.

0

Share this post


Link to post
Share on other sites

Posted · Report post

no.

I have flashed the latest rom (1.100.36.AAP.GEN2), but this issue still is outstanding.

0

Share this post


Link to post
Share on other sites

Posted · Report post

i also have problem connecting to eduroam, i think it must be due to this issue.

did anyone try with 2.3 bin?

0

Share this post


Link to post
Share on other sites

Posted · Report post

i also have problem connecting to eduroam, i think it must be due to this issue.

did anyone try with 2.3 bin?

Same question. Anyone had a try?

0

Share this post


Link to post
Share on other sites

Posted · Report post

The funny thing is I had to disable wifi-n mode of my router because of the iPad being unable to keep a stable connection (where my Liquid MT does not have any problem : mixed mode b/g/n...)

0

Share this post


Link to post
Share on other sites

Posted · Report post

i still have this problem in gingernouray 1.1, which is strange since this is supposed to be fixed on android 2.3

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.