Sign in to follow this  
Followers 0
hyped-x

desperate need of help !

3 posts in this topic

Hi people hope someone can help me out here im pretty much sure i have knackered up my phone but heres the problem hope someone can help me out as this is the only phone in quite a distance for me to use !

i saw an update for my phone on the tmobile website so i dloaded it and placed it on the root of my sd card and proceeded to install after getting up to half way it then showed a yellow sign and also said update failed but as just noticing this my frickin battery fell out and off it went. anyway i placed the battery back in and the cover back on for a second round ! come to my suprise the phone woudnt switch on ! no screen or power sign whatsoever i also tried a few of the ideas on here to boot up see if that worked but yet again nothing ! also plugged the little bugger in the pc and yes nothing ! damn what have i done wrong ? and can i resolve this somehow ? i would bedeeply indebted to whome ever helps and also thanks in advance :)

0

Share this post


Link to post
Share on other sites

well i guess after this many views and no comments i guess i need to take it to get repaired or get a new one !

0

Share this post


Link to post
Share on other sites
well i guess after this many views and no comments i guess i need to take it to get repaired or get a new one !

Did they repair it?

Not a lot can be done if it lost power due to you not putting the back cover on during the install and allowing the battery to fall out.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.