• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

ZTE V9/Light 2.2 Update now available..

292 posts in this topic

Posted

Ok, guys, I've managed to screw up my V9 using the files as a TPT, but people seem to have had more success with the .EXE that is also linked...

I recommend you proceed with care..

If any of you have an Optus mytab and are feel like installing it, can you PM me before you run it.. I might be able to fix my tab with your help...

Man this was a breeze!

Confirming ZTE Light V9 2.1 update to 2.2 using FTM mode. Operator is Finnish TeliaSonera with Saunalahti SIM. IMEI intact (SLES Backup NV OK)

blade-specific z4root permanent root works as well.

clockworkmod installed and working. Installing Sebastian404's "custom" rom next.

recoverymanager working.

I'm loving this :) Now my kids can watch Voddler films in car B)

0

Share this post


Link to post
Share on other sites

Posted

hi.. i just got my v9 and i'm planning to updatee it to 2.2.. i already downloaded files that need to be uploaded but my question is, what if it failed to update while it's in the 'update mode', would it still go back to 2.1 normally? i'm hesitating to update coz of that... :|

0

Share this post


Link to post
Share on other sites

Posted (edited)

Just after a successfully updated my own ZTE Light, I went to update my wife's tablet but ran into this issue:

- successfully flashed 2.2 ROM in FTM mode

- successfully permrooted with z4root (blade edition)

- successfully installed recovery manager

- successfully installed clockwork recovery (recovery-clockwork-4.0.0.5-v9-gen2-update_signed)

- successfully booted into clockwork, performed backup, wiped all data + cache, installed r2_update_de-branded_blade_gen2-update-signed.zip

Booting the device gets me to the welcome/setup screen with green droid for a few secs and then blank screen with:

USIM is not inserted. Turn the power off and insert an USIM

(Emergency Call -button)

I havent ran into this before, any ideas? I'm going to put in a SIM from my other V9 temporarily to see if it lets me to setup the device and use it normally after that.

EDIT: It's a no-go, as soon as I remove the SIM and boot the tablet it goes all the normal bootup stuff but ends up with a blank screen with USIM is not inserted... and nothing can be done.

EDIT 2: Ok, this ROM can not boot without SIM. I managed to overcome this obstacle with CM7 however :-) Now both V9's are running Cyanogenmod7 Android 2.3.4 Gingerbread pretty much flawlessly. Lock screen has its quirks and most likely bluetooth is unstable (my two blade units has unstable bt after CM7 nightly 102). After clockwork was in, I simply flashed update-cm-7.1.0-RC0-V9-KANG-signed-20110520.zip and gapps-gb-20110520-signed.zip, it worked like a charm.

Edited by JaakkoL
0

Share this post


Link to post
Share on other sites

Posted (edited)

anybody here??? can you please tell me how to do the instruction number 4???

4) download this PATCHED exe (thanks to mrradmir) and place it into the directory you installed MultiDL_MSM7227_V1.00.01

idk know how to do it... can you explain further please?

edit: oh i got it.... and btw, i really did step no. 15!!! i did pray!!! i was nervous... but now i am happy... android 2.2 running on my v9... thanksa bunch! :)

Edited by ceejae
0

Share this post


Link to post
Share on other sites

Posted

anybody here??? can you please tell me how to do the instruction number 4???

4) download this PATCHED exe (thanks to mrradmir) and place it into the directory you installed MultiDL_MSM7227_V1.00.01

idk know how to do it... can you explain further please?

You go here http://zalil.ru/30861793, wait few secs and download should begin. You will download a zip file containing Sales_MultiDL_MSM7227_patched.exe. You then copy this EXE to the directory you previously installed MultiDL...

Alternatively you can get the file from here http://android.leskinendesign.com/Sales_Mu...227_patched.zip

0

Share this post


Link to post
Share on other sites

Posted

You go here http://zalil.ru/30861793, wait few secs and download should begin. You will download a zip file containing Sales_MultiDL_MSM7227_patched.exe. You then copy this EXE to the directory you previously installed MultiDL...

Alternatively you can get the file from here http://android.leskinendesign.com/Sales_Mu...227_patched.zip

thank you very much... i got it... it's up and running... :)

0

Share this post


Link to post
Share on other sites

Posted (edited)

A request for help, I have searched for a similar situation as mine but can't seem to find it so I need to call in the experts to help.

Thanks to the excellent work of KK and others, I have sucessfully modded 3 Mytabs (ZTE V9) up to CM7 without any issues and they are all working fine with the update-cm-7.1.0-RC0-V9-KANG-signed-20110615 ROM on board.

I decided to try RC1 rather than RC0 out and tried to update it to update-cm-7.1.0-RC1-V9-KANG-signed-20110627

No go....stuck at CM7 logo (loop) despite my best efforts.

Took it back to stock 2.1 (again thanks KK) using the Optus_V9_Upgrade_30th_April_patched file and tried again rooting, installing onetouchrecovery etc

ROM loaded fine but went into the CM7 boot loop...no go.

Now I am trying to get in back to the point where I can gen2 it by using the Optus update but when I am using Sales_MultiDL_MSM7227_patched to try and install the patched stock rom (so that I can get back into the official optus 2.1 to 2.2 upgrade I keep getting an error download armprg.bin fail

To get in to take it back to stock I am powering up with the vol - key held down, my windows 7 system then recongised the Mytab as being connected and I am able to feed in the com port to the ZTE programming tool and the port opens ok, but I cannot get past the armprg.bin download fail error.

Thanks in advance,

Sorry if my post isn't clear, after 3 nights of trying to get this puppy going I am dog tired!!

QK

Any ideas?

Edited by a19074
0

Share this post


Link to post
Share on other sites

Posted

Update on the above issue with the zte tool not finding armprg.bin

When I reviewed the error logs from the failed reflash I saw that it was actually looking for the armprgzte.bin file in the sub folder /files so I moved a copy there and tried again, and sure enough it chugged past the 6/100 marker and went all the way to sucessfully reflash the MYTAB.

When I tried to restart using KK's patched Optus rom it went straight into FTM mode, so I went back and tried the official 2.2 optus reflash from here http://www.zte.com.au/optus/V9.htm which worked a treat. I was then able to restart the Tablet into the original 2.2 android with all the glorious bloatware from Optus but at least I could tell I hadn't completely bricked it.

I am still not sure why the CM7 RC1 rom wouldn't work originally, it went into the CM7 boot loop that many have been seeing.

I did try this afternoon to load up KK's earlier RC0 but I am still having troubles.

Would it be possible that the phone memory itself has somehow got a bit screwed up so I don't have enough room for the CM7 to be loaded in there?

My plan tonight is to try one of the repartioning flashes to increase the space available from http://android.modaco.com/content/zte-ligh...imal-cm7-setup/

Hope that helps anyone that comes up a similar error. Still not sure what went wrong

0

Share this post


Link to post
Share on other sites

Posted

I'm not sure if this is the right page to post my question but I'm fed up.I've tried almost every other trick mentioned in the forums and was not able to get into FTM mode.

Things which I've tried:

1) volume - and power on button long press (ends up Green android logo and the LED turning RED, and when connected to laptop, give a "USB device not recognised" message)

2) volume + and power on button long press (no change, the phone boots normally)

3) volume +, volume - and Power on button (The red led blinks and when connected to laptop, displays the Port).

I had installed clockworkmod earlier and removed it by installing recovery.img file posted somewhere in the forum.

I've purchased ZTE V9 from Portugal and the specifications are as follows:

Baseband version: V9B01

Kernel version : 2.6.29, zte-kernel@Zdroid-SMT

Build Number : V9-MSM7227-V02a-Oct282010-Vodafone-PT.

any sort of advise/suggestion/help would be much appreciated.

Thanks in advance.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hello there. I'm new at the business and i tried flashing my v9 into Froyo but it's stuck into FTM mode. I tried everything the way you advised. What could i have done wrong?

Guys, i'm in trouble here. I have installed the sales program and the patched too and have downloaded the unzipped firmwire into my zte, but it just can't skip FTM. I need help, really

Edited by Bardai
0

Share this post


Link to post
Share on other sites

Posted

Well, it seems that nobody can make a real update to any ZTE. It's just a fraud.

0

Share this post


Link to post
Share on other sites

Posted

gud day everyone..can anyone help me how to unbrick my ZTE V9 Light 2.2?..i encountered boot loop when i rooted it to cyanogenmod7..pressing the vol- and power can't help, vol+ and power also can't..help me with this please..sad.gif

0

Share this post


Link to post
Share on other sites

Posted

A Couple of People have asked me now so here are some more involved instuctions:

1) download the two files from the first post

2) unrar both files to a temporary directory

3) install the Sales_MultiDL_MSM7227_V1.00.01 program

4) download this PATCHED exe (thanks to mrradmir) and place it into the directory you installed MultiDL_MSM7227_V1.00.01

5) run Sales_MultiDL_MSM7227_V1.00.01 program and at the bottom left point it at the location you unrared the larger file

6) remove the usb cable and the battery from your device, wait 10 seconds, put it the battery back in.

7) holding down VOL UP + VOL DOWN press the power button, you will see the power LED flash once

8) now connect the USB cable to your PC

9) using hardware manager find the port for your device and set it in Sales_MultiDL_MSM7227_V1.00.01's setting (read the DOC file for more info)

10) at the bottom of the application under 'File Information' press SW Directory and browse to the 'V9_GENERICV1.0.0B03(offical)' directory

11) in Action Mode tick the 'Backup NV' box and then Press 'Start All'

12) you should find a file called 'Channel1.nvm' in the program directory, take a copy of that

13) back in Action Mode tick the 'Download' box and Press 'Start All' again

14) wait

15) pray

I should mention that using this method, I've managed to get my v9 working again, even tho I screwed it first time around :)

EDIT:

Some people have reported better results from re-installing a STOCK ROM and then rebooting the device into FTM mode, rather than the method mentioed in step 7... you might want to give that go

Everything working with ZTE V9 from polish network P4 (Play)

Divice working faster.

Thanks for tutorial.

Regards.

Fifek

0

Share this post


Link to post
Share on other sites

Posted (edited)

<p>

please link me to the v9 diagnostic drivers ,thank you

</p><p><br></p><p>your help will be much appreciated :)</p>

Edited by mccmmm
0

Share this post


Link to post
Share on other sites

Posted

got it running, damn near scared me to death when it wouldn't come out of ftm mode, but works well now.

let me know if you need that file sebastian.

i have the same problem now. it doesn't come out of ftm. what should i do?

0

Share this post


Link to post
Share on other sites

Posted

how will i get the FTM Mode back if i flashed the clockwork Recovery to my zte V9?

0

Share this post


Link to post
Share on other sites

Posted

i finally managed to install CM7 on my ZTE V9C RELIANCE, which initially came shipped with stock 2.3.4 with operator customisations, and carrier SIM lock.

to my great surprise, I am able to use any sim in the tablet now! thanks cyanogen for this

no problems with 3G or GSM data, phone calls or SMS.

my tab has capacitive touch, which seems to work as good as it was.

few issues as of now though, and quite major ones:

1. bluetooth fails to turn on. shows error.

2. no wifi tethering either. error.

3. gps shows the flashing symbol in notification bar, but can't seem to turn it off, no matter what I do.

4. no auto rotation of screen at all.

5. my tablet has a front VGA camera meant for video calls. in the stock 2.3.4, none of the video chat apps were able to recognize it. though the default camera app did. now, I can't seem to find it anywhere. any hopes of getting it to work with skype etc.?

can fixes be applied for these issues? or do I have to wait for another release?

if resolved, I think CM7 will be a successful port onto the V9C too

please help with your suggestions.

thanks in advance.

0

Share this post


Link to post
Share on other sites

Posted

i finally managed to install CM7 on my ZTE V9C RELIANCE, which initially came shipped with stock 2.3.4 with operator customisations, and carrier SIM lock.

to my great surprise, I am able to use any sim in the tablet now! thanks cyanogen for this

no problems with 3G or GSM data, phone calls or SMS.

my tab has capacitive touch, which seems to work as good as it was.

few issues as of now though, and quite major ones:

1. bluetooth fails to turn on. shows error.

2. no wifi tethering either. error.

3. gps shows the flashing symbol in notification bar, but can't seem to turn it off, no matter what I do.

4. no auto rotation of screen at all.

5. my tablet has a front VGA camera meant for video calls. in the stock 2.3.4, none of the video chat apps were able to recognize it. though the default camera app did. now, I can't seem to find it anywhere. any hopes of getting it to work with skype etc.?

can fixes be applied for these issues? or do I have to wait for another release?

if resolved, I think CM7 will be a successful port onto the V9C too

please help with your suggestions.

thanks in advance.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Bonjour moi c'est la ZTE light que j'ai et j'ai a peu près le même problème mon téléphone ne démarre plus normalement ni tactile ni écran(illisible) .en fait je me suis tromper de carte memoire et il a booter sur le dossier image qui était dans la carte mémoire comportant une rom de ZTE blade donc ce qui veut dire que j'ai flasher mon phone ZTE light V9 avec une room ZTE BLADE.J'ai le backup de l'ancien version mais si je le place sur ma memoire dans le dossier image ca ne boot pas es ce que je doit convertir ces fichier image qui sont dans le backup pour que ca puisse booter la dessus? dans l'autre mauvais room il ya des fichiers MBN et dans le backup c'est uniquement des fichiers image. Que dois je faire pour retrouver mon phone a son état initial? comment booter directement sur le backup?:

ci joint une capture d'écran du dossier backup et du mauvais dossier que j'ai utilisé par erreur pour le flasherpost-947885-0-05816000-1323006354_thumb.

Merci d'avance!

Edited by AbdoulKader
0

Share this post


Link to post
Share on other sites

Posted

Nevertheless I got a problem.

Windows 7 doesn't recognize my ZTE when it is in FTM mode. So it doesn't get assigned to a COM port (Windows 7 is asking for a driver) and the flash software won't recognize it.

The ZTE is listed as "ZTE HSUSB Device" with exclamation point in yellow triangle but not as "ZTE Handset Diagnostic (DFU) (COM XY)" as described in the Word File.

i don't understood the solution

can any one explain me more

thanks

0

Share this post


Link to post
Share on other sites

Posted

good!!!!

0

Share this post


Link to post
Share on other sites

Posted

Help! I recently flashed my 2.2 V9 to CyanogenMod.. then flashed the cm7_zte_v9_ahb_oveclocked kernel and google apps for CM7.. then when i turn on the tablet it's stuck at the ZTE logo.. when i go to recovery only the power button works so i can only select reboot.. i cant do anything with it! :(

0

Share this post


Link to post
Share on other sites

Posted

As far as I know there is only the custom 2.1 rom I made, its linked on the other post in this forum...

When you do get the device back, PLEASE PLEASE PLEASE make sure you run rom dump on it, http://android.podtwo.com/romdump/ and share the resulting dump with us..

Hi. Sebastian404. Finally i got my V9 back. But they refused to reinstall stock rom because i put unauthorised software on it. So i stll have a device what can't download apps from Market. My questions:

1. Could i still use ROMDUMP and get some useful infos out of it?

2. Could i make the update to 2.2 with this device from Austria?

3. Do You plan to make a custom rom to 2.3?

Thank you for your answer.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.