• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

GPS crashes with CM7 Gen2

92 posts in this topic

Posted

Nevermind my fix. Stock N57 seems to have fixed the GPS crashes. If not, wipe, and try again. I did a "repo sync" and now gps.blade.so went from ~38mb to ~60mb so it seems a lot has happend in the qcom loc api during the last few days.

As I mentioned on another thread, I had some force-closes and a reboot when using the latest Google Maps, but I downgraded to Maps 5.1 and everything seems okay. Maybe I'll upgrade again when they release a new update or a new nightly/stable comes along.

0

Share this post


Link to post
Share on other sites

Posted (edited)

As I mentioned on another thread, I had some force-closes and a reboot when using the latest Google Maps, but I downgraded to Maps 5.1 and everything seems okay. Maybe I'll upgrade again when they release a new update or a new nightly/stable comes along.

It wasn't just maps causing the restarts for me tho. Other apps using gps did the same so downgrading to maps 5.1 wouldn't have fixed everything. Oddly Copilot never did it. Anyway, only fix so far for me has been kallt_kaffes files.

EDIT.

Out of curiosity I just went and did a complete wipe/factory reset/cache and installed N57 again with out your fix and as soon as I launched maps it restarted so it definitely was not fixed for me in N57. Installing you fix again now.

Edited by Flumpster
0

Share this post


Link to post
Share on other sites

Posted (edited)

It wasn't just maps causing the restarts for me tho. Other apps using gps did the same so downgrading to maps 5.1 wouldn't have fixed everything. Oddly Copilot never did it. Anyway, only fix so far for me has been kallt_kaffes files.

EDIT.

Out of curiosity I just went and did a complete wipe/factory reset/cache and installed N57 again with out your fix and as soon as I launched maps it restarted so it definitely was not fixed for me in N57. Installing you fix again now.

Hmm... I just had one of those reboots too. Did a reboot and started Maps as the first app. I'm not running N57 though. I'm running a version I built myself and it has a slightly different kernel. I'll see if I can reproduce this with a clean N57.

EDIT: Yes, I can reproduce the reboots with N57. After a reboot if Maps are started one of two things happends. It either reboots (maybe 1 out of 5 times) or the GPS starts flashing, then goes off for a few seconds and then comes on again and finally gets a fix. It's like the GPS either gives up and restarts or the whole phone reboots.

With my libs it works perfectly every time. Seems wrapping around the old libs still is a bit better.

Edited by kallt_kaffe
0

Share this post


Link to post
Share on other sites

Posted

Yes, that is the idea but here's a Clockwork installable zip file that does the job for you.

Works great for me. I'm on a Windows flashed GEN2. Google maps never worked with any ROMs, always immediate reboots after (?) satellite fix.

After a lot of testing I switched over to SS for the Easter weekend (for travelling).

Now back on N57 I had the same problem, but immediately after flashing your fix it works like a treat.

Haven't had time to test it for a long time, but I my problem was ALWAYS the immediate reboots and they are solved now! Thank you!

Best,

Jan

0

Share this post


Link to post
Share on other sites

Posted

Also installed via clockworkmod this fix. I have stable 7.0.2 and it fixed my GPS. no reboots since patch.

0

Share this post


Link to post
Share on other sites

Posted

Yes, that is the idea but here's a Clockwork installable zip file that does the job for you.

OK. Nightly 57 did not fix the problem for me. Then I flashed this zip and since then no crashes. Tried maps again and again, a few more GPS dependent applications and then tried again after I restarted the phone. So far so good.

0

Share this post


Link to post
Share on other sites

Posted

Also installed via clockworkmod this fix. I have stable 7.0.2 and it fixed my GPS. no reboots since patch.

0

Share this post


Link to post
Share on other sites

Posted

The GPS reboots weren't as frequent after 7.0.2 & n57, it wasn't every time, but it still crashed sometimes & it could be slow. This fix seems to clear up all the gps issues.

0

Share this post


Link to post
Share on other sites

Posted

gps fix works for me aswell.

0

Share this post


Link to post
Share on other sites

Posted

I'm noticing other crashes after using this fix, lots of screen freezes, I'm not sure that it doesn't cause other stability problems. It seems to fix the GPS reboot problem & it speeds up GPS fixes, but I think it might be less stable overall.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I'm noticing other crashes after using this fix, lots of screen freezes, I'm not sure that it doesn't cause other stability problems. It seems to fix the GPS reboot problem & it speeds up GPS fixes, but I think it might be less stable overall.

I'm not having any issues like that but I'm running a build that was built together with that gps.blade.so and not N57 with the new libs injected. I don't think it should matter but perhaps it does?

I'm currently running this build (I think): http://www.mediafire.com/?c98rne48p7s7c0e

It is NOT an official build so DO NOT REPORT ANY BUGS if you use it.

Basicly it's CM7 pretty much at the same level as N57 or perhaps just a bit "newer" like 57 and a half. It uses GPSSHIM and the old libloc libs (GPSSHIM is a "fake" gps.blade.so that makes it possible to use the old libs with Gingerbread). It also has a kernel that has changes that isn't present in N57 and also the kernel has some touchsceen tweaks. It also has the proximity.init readded but that didn't help anyone but it doesn't break anything asfaik so it doesn't matter. Other than that it should work like N57.

Edited by kallt_kaffe
0

Share this post


Link to post
Share on other sites

Posted

n57 & 7.0.2 have some gps fixes in anyway, the reboot problem wasn't far off being fixed, it was only sometimes. with your libs injected into n57, it's as if the old gen1 gps causing screen freezes & crashes when waking from sleep bug is back. i turned gps off & it hasn't crashed again since, so it's definitely gps triggering the bug.

0

Share this post


Link to post
Share on other sites

Posted

I've been using your lib wrappers for a while. GPS wasn't causing trouble anyway.

Yesterday google maps kept crashing almost as soon as it started. It eventually stayed up.

I don't know if the cause can be put to your wrappers or not, I merely mention it in case it is helpful.

0

Share this post


Link to post
Share on other sites

Posted

Sunday 1 May I upgraded to Gen2 and installed CM7 N57. Monday 2 May, running AllSport GPS my phone rebooted 3 times whilst out on a bike ride.

Today, saw this post so installed the GPS fix and running AllSport GPS my phone rebooted after 31 minutes. I'll try another app and see how I get on but I'm not going for another bike ride now.

On Monday the first time phone reboot was also around 31 minutes, then an hour and then 18 minutes, after which I gave up. I didn't see that it had rebooted tonight until I got home so didn't get a chance to restart AllSport GPS

I'll report back when I have some more results...

0

Share this post


Link to post
Share on other sites

Posted (edited)

I forgot I was going to test this again, sorry about that. I flashed N59 last night as I forgot. This morning I've ran AllSport GPS for 49 minutes and it didn't reboot, this is obviously too early to tell. I'll run some more tests when I get chance

I see N60 is out, so my question is do I keep with N59 and run more tests with that or do I keep up to date with the nightly builds? Not sure what to do, for now I think I'll stick with N59 until the weekend and see how I get on.

Last night (04 May) ran for 48 minutes without reboot; this morning got to 57 minutes and it rebooted. This is N59 without the GPS fix. Does anyone know if the GPS fix will work with later nightly builds?

Installed N61 this morning (5 May) and went for a walk at lunchtime; rebooted after 28 minutes :mellow:

I then installed the GPS over N61 and tried Endomondo on the way home from work in the car; reboot after 28 minutes. Haven't done a full wipe yet so might give that a go and see what happens

Edited by cjp666
0

Share this post


Link to post
Share on other sites

Posted

Yes, that is the idea but here's a Clockwork installable zip file that does the job for you.

I'm running CM7 N95 and I'm having the crashes with Google Maps.

Is this fix still usable for me or can I get into trouble when I apply it?

Thanx

0

Share this post


Link to post
Share on other sites

Posted

installed the patch zip on top of cm7 and now I am enjoying no reboots, thanks! only strange behavior is wake-up from sleep can take a few persistent jabs on the power button but this is a small price to pay.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.