Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[Update] Save ur Bricked V880 and also the IMEI

136 posts in this topic

Posted · Report post

When you go to GEN 2 using that method will you not then lose the fastboot option as it will then be a GEN 2 phone..?

yes you'll still lose fastboot

0

Share this post


Link to post
Share on other sites

Posted · Report post

When you go to GEN 2 using that method will you not then lose the fastboot option as it will then be a GEN 2 phone..?

Ah yes, my bad then :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I'm trying to restore channel1 but when I run the software, next to SW it doesn't say "Phone in download mode" and the restore fails. Any ideas? At the moment I have a phone stuck in FTM mode attached to USB port.

EDIT: Never mind, I got it. :)

Edited by Decadence
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I just not getting this.

I downloaded nvm file from first post so I could correct my 000039 IME to my true IME.

I edited offset 1215 with my own IME.

Flashed nvm back with the tool from first post.(which was a pass)

And now my IME is the same as the demo on first post: 345678910121314. :mellow:

Still If not for dibbles who patiently pointed me to burstlam's instructions,I would not even have got that far.

So I am not complaining here,guess I just too noob to understand some things.

Edited by jikobutsu
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Maybe you have not place the channel1.nvm in the correct place ? Or maybe not save the modifications to the file ? (what's program you use to modify HEX ?)

Anyway, i'm not familiar with this method. But if you read slowly and try to understand how it's work, you can restore your IMEI "fingers in the nose". :o

Good luck. :mellow:

Edited by CaptainSpectacular
0

Share this post


Link to post
Share on other sites

Posted · Report post

Maybe you have not place the channel1.nvm in the correct place ? Or maybe not save the modifications to the file ? (what's program you use to modify HEX ?)

Anyway, i'm not familiar with this method. But if you read slowly and try to understand how it's work, you can restore your IMEI "fingers in the nose". :o

Good luck. :mellow:

If channel1 one was in the wrong place the tool would not be able to flash it and confirm pass

The hex editor I used was HxD Hex editor version 1.7.7.0

0

Share this post


Link to post
Share on other sites

Posted · Report post

Backup the Original IMEI

For those who wanna perform NV backup or restore should know that,

u can't make a nvm backup or restore unless FTM mode of stock recovery has been launch,

for this action need to be done with the FTM protocol instead of DFU mode.

so just flash back the stock recovery and boot it to FTM mode before running this official downloader.

select both RF/BT/IMEI/ulock info and nv backup option , u will get a proper working nvm for future use. )

Snap-2011-04-24-06-28-04.jpg

*********************************************************************

Restoring IMEI

As mention, to make the nv option works , ur have to flash back the stock recovery and get it boot in FTM mode.

if u mess up with ur imei , u can revive it by editing the nvm file and flash it back.

make a backup with mydownloader . edit the channel1.nvm with any hex editor

or download it from here

go to offset 0x1105

Snap-2011-04-23-03-53-05.jpg

the current imei is store in dec format , an imei : 3 45 67 89 10 12 13 14

will be reordered as 3A 54 76 98 01 21 31 41

first digit settle in this way: (0)3>>3(0), A=0

get ur self the orignial imei with the sticker on the phone

reorder it with the above proper format.

save the changes and then restore it with the official downloader

by enabling the "NV RESTORE" and "RF /BT /IMEI" Option.

and u will have yr IMEI back.

**********************************************************

for those who lose their IMEI with a downgrade GEN1 machine and without a proper backup.

download this GEN1 base NVM file:

http://hotfile.com/dl/115553882/d8d599f/Channel1.nvm.html (GEN 1 nvm BACKUP)

ur IMEI location starting from offset 1215, edit it with a hexeditor with proper order.

restore steps are same as Gen2.

0

Share this post


Link to post
Share on other sites

Posted · Report post

my imei is offset at 0x1215

0

Share this post


Link to post
Share on other sites

Posted · Report post

address differed from the updater u choose.

0X1105 or 0X1215

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi guys,i need help!! ^^

I lost my IMEI trying to flash GEN2 to GEN1.

Step1:

I flash "Orange_GEN1_136mb_sysem_no_oem_15mb_cache", it works.

Step2:

By clockworkmod, i restore default orange FR rom ("OFR_P729BV1.0.0B08-update_signed.zip") and it works.

After that i revert back the default recovery (always by clockworkmod with "restore_stock_recovery.zip").

Step3:

I edit your "Channel1" file and i replace fake IMEI by mine.

I "RestorNV",it works.

Step4:

To finish i reboot, the default orange rom finish to setup,

Problem:

Once started No Sim Card code ask. So no network.

I go under android setting -> And it shows my correct IMEI, but IMEISV is 00.

(I also try to flash "Japanese_Jellyfish_RLS9"same problem)

Can someone help me plz =)

Ps: Sorry for my bad english

Edited by RaZoR Liquid
0

Share this post


Link to post
Share on other sites

Posted · Report post

Step3:

I edit your "Channel1" file and i replace fake IMEI by mine.

I "RestorNV",it works.

backup your own channel1.nvm and hex edit, dont use the attached one

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi ..

I upgraded my ZTE V9 to Froyo 2.2 in the process i lost my IMEI so I tried modifying the channel1.nvm file and restoring on line 1215.

This is what i am getting

Correct IMEI is 355912040558572

In the HEX Code I put in 3A 55 19 02 04 55 58 27

But when i restore the channel1.nmv file i get the IMEI 355912040555872 so i get one section of the IMEI incorrect.

When i load it i double check the channel1.nmv I loaded and it shows correct 3A 55 19 02 04 55 58 27

and when i create a backup HEX of it on the phone I get 3A 55 19 02 04 55 85 27

When I load 3A 55 19 02 04 55 85 27 on the hex it still stays the same it doesnt change to 58

Seems like when it loads into the phone the 1210 changes from 58 to 85 from my understanding 58 is correct.

Is there anything I am doing wrong?

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi ..

I upgraded my ZTE V9 to Froyo 2.2 in the process i lost my IMEI so I tried modifying the channel1.nvm file and restoring on line 1215.

This is what i am getting

Correct IMEI is 355912040558572

In the HEX Code I put in 3A 55 19 02 04 55 58 27

But when i restore the channel1.nmv file i get the IMEI 355912040555872 so i get one section of the IMEI incorrect.

When i load it i double check the channel1.nmv I loaded and it shows correct 3A 55 19 02 04 55 58 27

and when i create a backup HEX of it on the phone I get 3A 55 19 02 04 55 85 27

When I load 3A 55 19 02 04 55 85 27 on the hex it still stays the same it doesnt change to 58

Seems like when it loads into the phone the 1210 changes from 58 to 85 from my understanding 58 is correct.

Is there anything I am doing wrong?

Thanks

um ... I am not sure that the nvm files of V880 and V9 are identical.

did u reboot ur machine and check whether it leads to a change with the nvm edited?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Okay, i have no idea what version my blade is. It came with 2.1, and is gen 1 atm. But the problem is that my imei was 0003324... something, but now it is 1516. i didn't have back up, and the 1 is here gave me that imei when i modified it. Can someone give me some support?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

gives up

Edited by hecatae
0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok here goes:

Earlier today my Blade was Gen1, rooted and running Swedish Spring RLS5. I've never had any problems flashing ROMS up to this point.

Then I decided to upgrade to CM07.0.2 Stable by curl66.

The phone was wiped as instructed and reflashed.

After this the phone booted into Clockworkmod Recovery (CWM) and wouldn't move.

I tried using Windows and the Blade Diagnostic solution, successfully flashed Gen2 and Gen1 ROMS (at this point I had no idea what Gen my phone still was) but got nowhere. I restored the NVM file values to the original IMEI and still no progress.

I tried the Blade Custom Generic firmware method using download.exe and although flashing was successful, the phone refused to move past the FTM screen. NVM values were checked, changed and I still got nowhere.

Finally I found this thread and was able to get back to CWM.

The phone refuses to accept any ROMS that I flash. The Ginger Stir Fry flash aborts soon after I "install zip from SD".

I did put Swedish Spring back on but after successful flashing and removing the IMG file, the phone just goes back into CWM.

Have I missed something somewhere or is there something else that I can try? Any help appreciated!

Thanks

V5er

@v5er

Booting into recovery mode (FTM mode and clockworkmod are just two different things that might be in recovery) and not into anything else is usually a symptom of corrupt NV memory, but TPTs should not be able to do any damage to it, so I don't know why it would have happened to you.

Links: what is windows and the blade diagnostics solution? Did you make a nvm backup yourself and then restore it, or did you download one and modify it with your IMEI?

Hi thanks for the reply.

I made back ups of my phone using both Titanium and Clockworkmod. I also tried to restore from the latter but i get errors regarding device cache space for log files. So it doesn't work for me.

I modified any NVM file in the ROMS that I was going to flash or if unavailable I d/l one. In both cases I changed the values to my IMEI using a hexeditor. I did try and backup/restore the NVM file but I wasn't sure which NVM file was being used. In any case it didn't seem to work for me.

Blade diagnostic solution:

http://android.modaco.com/content/zte-blad...-also-the-imei/

Windows diagnostic solution:

http://android.modaco.com/content/zte-blad...ded-gen2-blade/

Ok.

If you hadn't corrupted your NV memory before, you have now. you need to follow the instructions in this thread to restore your IMEI. Its probably appropriate to post further queries on that thread than here. If you do that properly you should be ok

Alright, thank you :)

Apologies for all the quotes but its the recent support history that brings me to this thread.

I just flashed to the Gen2 stock ROM using the software from the first post in this thread.

The "software" text field is now showing FRY_SFIN_P729BV1.0.0BO5

But I can't boot into FTM mode to restore the IMEI.

First question: how do I get into FTM mode?

I've tried power and volume - on reboot. It just sends an android on my screen and then Clockworkmod 3.0.1.4

Second question: Which folder do I put the edited NVM file into to restore it?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Apologies for all the quotes but its the recent support history that brings me to this thread.

I just flashed to the Gen2 stock ROM using the software from the first post in this thread.

The "software" text field is now showing FRY_SFIN_P729BV1.0.0BO5

But I can't boot into FTM mode to restore the IMEI.

First question: how do I get into FTM mode?

I've tried power and volume - on reboot. It just sends an android on my screen and then Clockworkmod 3.0.1.4

Second question: Which folder do I put the edited NVM file into to restore it?

1. you need to restore stock recovery. Flash this file in closkworkmod. Now when you turn on with volume down held it should go into FTM mode.

2. after you have modified channel1.nvm so that it contains your IMEI (use offset 0x1215 with the base file in the OP), put it in the same folder as the flasher and use the NV restore function.

0

Share this post


Link to post
Share on other sites

Posted · Report post

So you know if it worked:

After you flashed the Gen2 firmware, your phone had clockworkmod in the boot partition (where the ROM usually loads from) and the recovery partition (booted when volume down is held).

After you restore stock recovery, the recovery partition will contain a stock image and your phone will boot into FTM when volume down is held.

After restoring the NV memory, if your phone boots into clockworkmod with no buttons pressed then it worked. You then need to follow my guide from step 8 in order to get clockworkmod in recovery again and a ROM installed. Since you now have stock Gen2 firmware, you will not be able to do a TPT unless you follow my guide and flash TPT compatible firmware (just incase you feel the need)

0

Share this post


Link to post
Share on other sites

Posted · Report post

THANK YOU!!!!

This has saved my phone after an official ROM screwed with the bootloader (check my warning about it at http://android.modaco.com/content-page/324...-roms/page/340/ - page 18).

Running Cyanogenmod7 back and happy about it :)

...

look in the pinned section first. nothing was screwed, your phone was upgraded to stock Gen2. it is perfectly possible to install other ROMs on stock Gen2, and perfectly possible to flash back to Gen1/modified Gen2 in that link. this thread should be a last resort.

I hope you backed up your IMEI, because otherwise you will have a corrupt one.

0

Share this post


Link to post
Share on other sites

Posted · Report post

After repeated tries i have failed to restore an emtpy (0) imei on my blade. I have no backup of Channel1.nvm so i have tried reading the file from the phone and changing that. I have also tried to use the Channel1.nvm attached to the topic start. It still isn't working and i was wondering if someone could confirm if it should be possible to set a IMEI which has been set to 0 without having an orignal Channel1.nvm from the phone itself?

Thanks!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

So you know if it worked:

After you flashed the Gen2 firmware, your phone had clockworkmod in the boot partition (where the ROM usually loads from) and the recovery partition (booted when volume down is held).

After you restore stock recovery, the recovery partition will contain a stock image and your phone will boot into FTM when volume down is held.

After restoring the NV memory, if your phone boots into clockworkmod with no buttons pressed then it worked. You then need to follow my guide from step 8 in order to get clockworkmod in recovery again and a ROM installed. Since you now have stock Gen2 firmware, you will not be able to do a TPT unless you follow my guide and flash TPT compatible firmware (just incase you feel the need)

Thanks mate I'll owe you a few beers if this works! I'm now at the final stage and reflashing a ROM. Fingers crossed I won't be seeing another Blackberry trackball again.

Edit: Flashing my backup of SwedSpring5 didnt work again. I got "Error no space in E:recovery/logs") Perhaps the backup was too big?

So I wiped the phone via Clockworkmod and then tried flashing:

Custom Gen2 v7b

This aborted after "installing update" text appeared on the screen...

Flashing a fresh Swedish Spring 5 download worked! Hurrah!!

But the phone is now stuck in airplane mode :) I know something's gone wrong somewhere. How do I fix it?

Edited by V5er
0

Share this post


Link to post
Share on other sites

Posted · Report post

Okay, i have no idea what version my blade is. It came with 2.1, and is gen 1 atm. But the problem is that my imei was 0003324... something, but now it is 1516. i didn't have back up, and the 1 is here gave me that imei when i modified it. Can someone give me some support?

Fixed this by taking phone to warranty :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks mate I'll owe you a few beers if this works! I'm now at the final stage and reflashing a ROM. Fingers crossed I won't be seeing another Blackberry trackball again.

Edit: Flashing my backup of SwedSpring5 didnt work again. I got "Error no space in E:recovery/logs") Perhaps the backup was too big?

So I wiped the phone via Clockworkmod and then tried flashing:

Custom Gen2 v7b

This aborted after "installing update" text appeared on the screen...

Flashing a fresh Swedish Spring 5 download worked! Hurrah!!

But the phone is now stuck in airplane mode :) I know something's gone wrong somewhere. How do I fix it?

good, that's progress.

assuming your phone is in fact a european GSM one, then I think the problem is the NV memory again (perhaps it was something else before). The flasher backs it up and the beginning and restores it at the end, so if it aborted then it probably didn't restore it at the end. The flaher for the custom Gen2 v7b will have made a channel1.nvm in its folder. restore that with the tool form this thread and see if it works.

If that doesn't work then its posssible that the flasher aborted before it could flash amss.mbn (the modem firmware). In that case I would try doing the Gen2 TPT again.

1

Share this post


Link to post
Share on other sites

Posted · Report post

good, that's progress.

assuming your phone is in fact a european GSM one, then I think the problem is the NV memory again (perhaps it was something else before). The flasher backs it up and the beginning and restores it at the end, so if it aborted then it probably didn't restore it at the end. The flaher for the custom Gen2 v7b will have made a channel1.nvm in its folder. restore that with the tool form this thread and see if it works.

If that doesn't work then its posssible that the flasher aborted before it could flash amss.mbn (the modem firmware). In that case I would try doing the Gen2 TPT again.

Thanks again.

Would the NV memory be the issue if my IMEI reading on the phone corresponds to the NVM that I restored?

Also is there a way to check if the amss.mbn file is on my phone or indeed a way to insert the file into the appropriate place?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.