• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

incorrect UserAgent sniffing?

1 post in this topic

Posted (edited)

Hey there,

I just had a hard time to log in to this site after a registration without any problems due to the fact that a login would take me to exactly the same site as if I were not logged in. (see the header, it even thinks I'm in "Windows" not in the Android section o_0)


After trying other Browsers I noticed that this seems to be a issue with my (mozilla gecko-based) Seamonkey, so I tried to spoof the UserAgent of Firefox and *tada* I was logged in instantly (notice: I didn't even have to login again, I already was logged in!):


My original UserAgent is as follows: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv: Gecko/20110320 Lightning/1.0b1 Mnenhy/0.8.0pre15 SeaMonkey/2.0.13

While spoofing Firefox was like this: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv: Gecko/20091102 Firefox/3.5.5

I can even switch between those two and will be presented logged-in/logged-out pages instantly depending on the UA.

It seems that there is some UA-sniffing or similar happening which obviously fails. I'd like to recommend to sniff for GECKO instead of FIREFOX if UserAgent-sniffing is done here / needed. (see http://geckoisgecko.org )

If this issue is based on another incidence, feel free to clarify.

kind regards

Edited by commander_keen

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.