• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[Guide] Flashing firmware to Blade/Libra via windows

210 posts in this topic

Posted · Report post

Is cdma blade n880?

yeah a few people have referred to it as such. I think its sold in Indonesia.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have Indonesian model of ZTE Blade GSM with 256mb RAM (not the CDMA one).

I want to upgrade to custom gen2 160 v10.

My purpose is I just want the extra space, not to unlock to 512 ram.

Can i do the upgrade or will it brick my phone if i do the flashing?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have Indonesian model of ZTE Blade GSM with 256mb RAM (not the CDMA one).

I want to upgrade to custom gen2 160 v10.

My purpose is I just want the extra space, not to unlock to 512 ram.

Can i do the upgrade or will it brick my phone if i do the flashing?

You probably can because it is probably just like the Greek ones. If it isn't and it really only has 256MB then it will get bricked. Post if you tried so others can learn from your experience.

0

Share this post


Link to post
Share on other sites

Posted · Report post

You probably can because it is probably just like the Greek ones. If it isn't and it really only has 256MB then it will get bricked. Post if you tried so others can learn from your experience.

hmm i see then. some people in my country have tried to unlock the RAM to 512 and the result is it bricked their phone.

I dont want to unlock the RAM, i just want to have more space by repartitioning the storage.

So there is no way to flashing the firmware without unlocking the RAM?

Is there any custom firmware compatible with the 256mb RAM ZTE, or there is no way to flashing to custom gen so we just stuck with the default firmware?

0

Share this post


Link to post
Share on other sites

Posted · Report post

hmm i see then. some people in my country have tried to unlock the RAM to 512 and the result is it bricked their phone.

I dont want to unlock the RAM, i just want to have more space by repartitioning the storage.

So there is no way to flashing the firmware without unlocking the RAM?

Is there any custom firmware compatible with the 256mb RAM ZTE, or there is no way to flashing to custom gen so we just stuck with the default firmware?

The issue is that it's impossible to extract firmware from a phone - all the firmware on the internet comes from updates released by ZTE or carriers. If you can find an official update or firmware for your model then it can be modified to change partitions (reasonably simple with a hex editor but a rather frightening thing to do, and not without risk). You may be lucky if you try to install firmware designed for a 256MB blade sold in another country (some Greek ones for example), and it might be possible to install a combination of the chinese v880 firmware (which has 256MB RAM but a different radio) and a European radio. Then again, you may not be lucky and unless you can find an official update the damage will be permanent (barring official repair).

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanx a lot, repartitioning works great!

0

Share this post


Link to post
Share on other sites

Posted · Report post

The issue is that it's impossible to extract firmware from a phone - all the firmware on the internet comes from updates released by ZTE or carriers. If you can find an official update or firmware for your model then it can be modified to change partitions (reasonably simple with a hex editor but a rather frightening thing to do, and not without risk). You may be lucky if you try to install firmware designed for a 256MB blade sold in another country (some Greek ones for example), and it might be possible to install a combination of the chinese v880 firmware (which has 256MB RAM but a different radio) and a European radio. Then again, you may not be lucky and unless you can find an official update the damage will be permanent (barring official repair).

i see. thanks for the explanation. so i guess i must live with the 160mb application data storage. haha.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello!

I have now tried to flash my phone for two days (unsuccessfully). I have a swedish version (Comviq) which came preinstalled with android 2.3.5 (Gen3 i guess?). Since i want to use another operator i've tried to install some custom roms. However the problem lies here: Only the stock gen3 firmware works, when trying some of the other my phone stripes in all kinds of colours.. firmwareing back to stock 3 and everything gets back to normal.

This limits me to gen3 rom since with gen2 roms i get: No network connection.

Thing is, i cant find any rom gen3 that seems to work? except stock which limits me to Comviq!

Help would be appreciated!

thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello!

I have now tried to flash my phone for two days (unsuccessfully). I have a swedish version (Comviq) which came preinstalled with android 2.3.5 (Gen3 i guess?). Since i want to use another operator i've tried to install some custom roms. However the problem lies here: Only the stock gen3 firmware works, when trying some of the other my phone stripes in all kinds of colours.. firmwareing back to stock 3 and everything gets back to normal.

This limits me to gen3 rom since with gen2 roms i get: No network connection.

Thing is, i cant find any rom gen3 that seems to work? except stock which limits me to Comviq!

Help would be appreciated!

thanks

Strange - perhaps the newer phones from comviq have changed physically. You are probably better off starting another thread. post a romdump of the ROM that works so others can investigate. Which gen3 roms have you tried and waht was the problem wiht them? it might be possible to copy across some ril files from your ROM to a gen2 rom to get network to funciton.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Strange - perhaps the newer phones from comviq have changed physically. You are probably better off starting another thread. post a romdump of the ROM that works so others can investigate. Which gen3 roms have you tried and waht was the problem wiht them? it might be possible to copy across some ril files from your ROM to a gen2 rom to get network to funciton.

The only rom gen3 i've found is the stock from comviq. I was finally able to solve this by installing Molodavan rom (i think) with an ad-don aka patcher which solved the radio problem. Its now working properly with a gen2 rom on gen3. Thats fine for me, thought it was bricked for a moment, and the imei has changed but affect the using.

Thanks anyway!

0

Share this post


Link to post
Share on other sites

Posted · Report post

guys i was using this method to partion my gen 2 zte blade .....suddenly at 98% it shows reset in red words . now it just doesn't booot up or anything .any help guys

0

Share this post


Link to post
Share on other sites

Posted · Report post

Awesome !! great instructions no problem whatsoever ! finally i can enjoy ics ! in the custom Gen2 215 v10 firmware package ! it says gen1 tpt compatible that means gen2 tpt is not compatible right ? or ...?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Awesome !! great instructions no problem whatsoever ! finally i can enjoy ics ! in the custom Gen2 215 v10 firmware package ! it says gen1 tpt compatible that means gen2 tpt is not compatible right ? or ...?

It means that if you flash that firmware, you can use Gen 1to Gen 2 type TPTs afterwards. You can't use the stock Gen 2 image.bin type TPTs.

0

Share this post


Link to post
Share on other sites

Posted · Report post

It means that if you flash that firmware, you can use Gen 1to Gen 2 type TPTs afterwards. You can't use the stock Gen 2 image.bin type TPTs.

Ok Thanks a Lot !! :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

i can't do it , can anyone help me please ?

ZTE SKATE 4.3 , i have drestroyed my smartphone .

0

Share this post


Link to post
Share on other sites

Posted · Report post

i can't do it , can anyone help me please ?

ZTE SKATE 4.3 , i have drestroyed my smartphone .

You probably have..! your in the wrong sub forum this is for the zte blade.zte skate is here ---> Zte Skate

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks a Lot Hedgepigdaniel for Helping me recover my phone which was bricked in a week after buying it. ur guide really worked out 4 me

i just wanted to ask if there was any way i could improve my splash image appearence. ie i flashed a new splash.bmp image but it is not getting the same quality as it was when i first bought my phone.(I have a Dell XCD35 (India)). Please Help me out with this graphics issue cause if a put an image for the splash image. i am not just gettin the desired quality i hope u understand me. my splash image just looks like a disaster

Thanks a lot for the method and in advance for this one teeny tiny doubt of mine

0

Share this post


Link to post
Share on other sites

Posted · Report post

I am currently using Dell XCD 35 (European Gen 2) with 512 MB RAM. I am running CM7 stable ROM. I want to repartition my Internal Memory. Can I directly flash the gen2 TPT or I have to downgrade to gen2 stoc and then flash the TPT?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have some problem with clockworkmod recovery.

In recovery manager it says Currently installed recovery: unrecognised and

when I try to boot into recovery at reboot, I get ZTE Blade recovery and not custom recovery.

and when I try to install custom recovery using update.zip, it says cannot install.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Looks like it's 'game over' for my OLED blade.

I tried all the methods 1 to 4, suspecting that the NVRAM was corrupted somehow.

My phone gets hot around the back of the camera area, where the logic board must sit, and the phone will not boot past the green android and Orange logos.

My last throw of the dice was going back to the stock Orange GEN1 TPT image.

Still the phone will still not boot past the logos.

It's been through many rom flashes from 2.2 to the latest ICS roms.

It has served me well.

Any ideas or is it fried?

Going to miss the trusty ZTE Blade/San Fran as the development community has been fantastic in what it has produced.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for that - very clear and comprehensive.

I followed the guide but instead of using swedish spring firmware I used the SD backup from a friend's'phone (identical model) and so got a set-up that I liked.

0

Share this post


Link to post
Share on other sites

Posted · Report post

guys guys guys.. quick help needed..

I did this and now the flasher is showing OPEN in blue color.. Ratio: 0/100. It was 98/100 When I left the device for some time and when I came back I saw this OPEN written there.. is it completed? I mean is it safe to remove?

dont have much time as its battery is draining.. :|

Thanks in advance :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Bricked!!!! can't get past the green android logo and its moving to left side and coming back to middle.. HELP!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Guys I tried following firmware package in FTM mode custom Gen2 160 v10

But after flashing above package. My phone is always booting into FTM mode. It does not boot into recvery at all.

I am not able to proceed further from following steps

  • Unzip the contents of the firmware package you want to flash. Start the program called “download.exe” in the root folder. When the flasher window comes up, press the start button. If the start button is not clickable, use “driverinstaller.exe” to install ZTE drivers and make sure your phone is connected and in FTM mode.
  • Wait a few minutes for your phone to be flashed. The screen will turn black for a while. Do not interrupt this process. A message will inform you when flashing is complete.
  • Disconnect your phone and remove the battery. Reinsert the battery and turn on the phone (normally, with no buttons pressed). Your phone should boot into clockworkmod recovery.

My phone is always booting into FTM mode now. I even tried other package custom Gen2 215 v10

The phone is seems to be stuck in FTM mode even when I start it normally.

What should I do now? :(

Edited by XpressAndy
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.