• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Racer 2.6.32 kernel

95 posts in this topic

Posted

I've not been following developments here for a while, but from the sound of it someone has managed to get the 2.6.32 kernel working... ?

I've uploaded my fixes to the Blade source that I use with clockworkmod recovery, it gives a bootable kernel, but it has the camera and wifi issues..

so this is an appeal to whoever has managed to fix the kernel to share the code....

the git hub can be found here:

https://github.com/sebastian404/blade-kernel

and the commit to see the fixes I've added can be found here:

https://github.com/sebastian404/blade-kerne...603564487c6d586

0

Share this post


Link to post
Share on other sites

Posted

Could you share your config please?

0

Share this post


Link to post
Share on other sites

Posted

config.zipI used config_2011_05_17.

It worked.

Today I change LCD but I can not try the new .config.

Something happened with my linux.

0

Share this post


Link to post
Share on other sites

Posted

Interesting, you build a Blade kernel with the 5mp support...

anyone know what mp is the racer's camera?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Interesting, you build a Blade kernel with the 5mp support...

anyone know what mp is the racer's camera?

I suppose that "CONFIG_MT9T11X=y" is the line that makes our camera to work

Racer has a 3.2mpixels camera.

even with CONFIG_MACH_BLADE=y this kernel works? Wifi also?

Edited by TigTex
0

Share this post


Link to post
Share on other sites

Posted

Well, I'm having problems with the kernel. Whatever I do I always end with a touchscreen without touch... only image.

I'm using Sebastian404 kernel and config... (and also tried other kernels and configs... the same with all)

Any help?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Well, I'm having problems with the kernel. Whatever I do I always end with a touchscreen without touch... only image.

I'm using Sebastian404 kernel and config... (and also tried other kernels and configs... the same with all)

Any help?

Sorry I Don't understand Doesn't touchscreen work?

I use this end work.

CONFIG_TOUCHSCREEN_MSM=y

I test with my chun cm-700 clone rom end original 3UK rom.

Camera works too.

Do you think the touchscreen same.

All of cm rom use touch_to_key. I think this aplication manage the touchscreen not the kernel.

I think this is the problem but it is not sure.

Edited by isziraki
0

Share this post


Link to post
Share on other sites

Posted

So do you mean that you can create a fully working kernel for the racer?

Because i'm trying that for the last 2 days, and nothing...

0

Share this post


Link to post
Share on other sites

Posted

So do you mean that you can create a fully working kernel for the racer?

Because i'm trying that for the last 2 days, and nothing...

About the touch_to_key, I changed the property of the touchtokey. It was "disabled" and I changed it to "enabled" in the init.rc and executed the script and now I will se if it works...

0

Share this post


Link to post
Share on other sites

Posted

have you guys thought of trying newer kernel btw? i tried compiling 2.6.35-11 with config from cm7.0.0 rom and i did have issues :D but my pc died again so i lost all work.. currently using cm7.0.0 again so i guess i cant really contribute but just wanted to ask about it :D

0

Share this post


Link to post
Share on other sites

Posted (edited)

About the touch_to_key, I changed the property of the touchtokey. It was "disabled" and I changed it to "enabled" in the init.rc and executed the script and now I will se if it works...

touch_to_key is the program made by deadlink that makes the racer vibrate when you press the soft keys... It's disabled on boot, it is enabled after that.

If you can make a kernel that boots and works please tell me. I'm having trouble with that.

If someone can make a kernel newer than 2.6.32 to work like equiliym said, it also good. But as far as i know, 2.6.32.9 is the only that will make the camera work.

meanwhile, thank you for all the help :D

Edited by TigTex
0

Share this post


Link to post
Share on other sites

Posted

I suppose that "CONFIG_MT9T11X=y" is the line that makes our camera to work

Sorry I Don't understand Doesn't touchscreen work?

I use this end work.

CONFIG_TOUCHSCREEN_MSM=y

Looking at the defconfig

That is what I have set for both of them....

0

Share this post


Link to post
Share on other sites

Posted

hes tryed that but after boot the touch screen dont work

0

Share this post


Link to post
Share on other sites

Posted

I've tried everything, touchscreen never works. Even with your kernel and configs

0

Share this post


Link to post
Share on other sites

Posted (edited)

#by chun

service touchtokey /system/bin/touch_to_key

disabled

on property:dev.bootcomplete=1

start touchtokey

#by chun

If you run it & touch sceen it give back X,Y position & button name (You touch home it give back home & position)

It is not vibration.

Edited by isziraki
0

Share this post


Link to post
Share on other sites

Posted (edited)

If someone can make a kernel newer than 2.6.32 to work like equiliym said, it also good. But as far as i know, 2.6.32.9 is the only that will make the camera work.

well it might be hopeless but when i get my pc fixed ill try again, if i manage to boot with it, ill post it here for gurus to work :D but i dont know when will that happen :D

edit: oyeah, i tried 2.6.35 for zte blade, from t0mm13b github, found it on google, here is the link

https://github.com/t0mm13b/ZTE-Blade-2.6.35.11

Edited by equiliym
0

Share this post


Link to post
Share on other sites

Posted

Sorry

Keyboard mistake seems it was in kernel. Keyboard is working properly with 2.6.32 for me.

Thank's I am triing to make 2.6.35 at evening.

0

Share this post


Link to post
Share on other sites

Posted

Thank's I am triing to make 2.6.35 at evening.

thanks, i had system failure and still cant fix my pc, need new hdd so i cant help much about it :D

0

Share this post


Link to post
Share on other sites

Posted

Sorry

Keyboard mistake seems it was in kernel. Keyboard is working properly with 2.6.32 for me.

Thank's I am triing to make 2.6.35 at evening.

yesterday I made one working 2.6.32 but once again the touchscreen doesn't work. I can't touch anything. But screen works at 100%.

I beleive that with 2.6.35 the camera won't work, i also tried to make one and touchscreen doesn't work...

0

Share this post


Link to post
Share on other sites

Posted

yesterday I made one working 2.6.32 but once again the touchscreen doesn't work. I can't touch anything. But screen works at 100%.

I beleive that with 2.6.35 the camera won't work, i also tried to make one and touchscreen doesn't work...

well yeah, its in the readme.. but its worth a try, someone might fix it.. doubt it tho but you may never know

Both points 4 and 5 above are broken SO NO CAMERA.. and anyway tis crappy! :D
0

Share this post


Link to post
Share on other sites

Posted

yesterday I made one working 2.6.32 but once again the touchscreen doesn't work. I can't touch anything. But screen works at 100%.

I beleive that with 2.6.35 the camera won't work, i also tried to make one and touchscreen doesn't work...

Use this

CONFIG_TOUCHSCREEN_SYNAPTICS=y

It must work.

0

Share this post


Link to post
Share on other sites

Posted

Use this

CONFIG_TOUCHSCREEN_SYNAPTICS=y

It must work.

That line doesn't even exist...

All you have is

CONFIG_TOUCHSCREEN_SYNAPTICS_I2C_RMI

and also doesn't work.

Please i really need you help with this. If anyone managed to make the touchscreen work tell me how he did it. I need a COMPLETE .CONFIG to compare with mine and see what is wrong.

I only want configs that you tested AND WORKS....

Looks that i cant update the kernel on the new release of the rom that i'm doing... maybe later.

rexchun or any friend, if you read this please PM me.

0

Share this post


Link to post
Share on other sites

Posted (edited)

TigTex

There are my last config & kernel update.

I hope it helps for you.

kernel.zip

Somewhere I saw this

CONFIG_TOUCHSCREEN_SYNAPTICS_I2C_RMI=y

CONFIG_TOUCHSCREEN_CYPRESS_I2C_RMI=y

I used it my first kernel.

Edited by isziraki
0

Share this post


Link to post
Share on other sites

Posted (edited)

I install 3UK rom after I install kernel update. Everything works properly.

I install Ricky nightly & kernel update. It works properly but keyboard has same problem.

I make new boot with TigTex kitchen. I change only kernel. I put it on my cm rom. I install it. I get a new start screen. I didn't look this screen before. Choice setup wizard & touchscreen doesn't work.

I don't understand what have I made wrong? Doesn't kernel update change the whole kernel? I use koush-AnyKernel.

There are kernel updates in my previous reply.

Has anybody any idea?

Thanks.

This rom worked

http://android.modaco.com/content-page/334...-ready/page/20/

post #31

I could get kernel config from it.

Ricky_config.zip

I compare it with my.

I think it uses another source. I don't know witch.

Edited by isziraki
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.