• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Poor WiFi abilities

16 posts in this topic

Posted

Hi All,

Have just come from a Galaxy S to a Galaxy S2, and I want to love it, but the wifi performance seems poor to say the least.

I am sat literally feet away from the router, and quite often web pages just refuse to load, market won't load, other things like remote desktop seem OK most of the time though - it is on the latest firmware (KE7), I just wondered if other people had come across this, and if there is any way to resolve? Or if a fix is likely to come along?

:D

0

Share this post


Link to post
Share on other sites

Posted

Hi All,

Have just come from a Galaxy S to a Galaxy S2, and I want to love it, but the wifi performance seems poor to say the least.

I am sat literally feet away from the router, and quite often web pages just refuse to load, market won't load, other things like remote desktop seem OK most of the time though - it is on the latest firmware (KE7), I just wondered if other people had come across this, and if there is any way to resolve? Or if a fix is likely to come along?

:D

Mine is better than my old HTC Desire.

Maybe your router doesn't like it? Tried it with a different router?

0

Share this post


Link to post
Share on other sites

Posted

Nope, only got the one router at home - not sure what difference a different router would make, it gets the IP address OK, just seems the browser is crap, my old galaxy s never had any issues like this, and is still working fine around the house. Might try a different browser to see if its just the original browser which is like this...

0

Share this post


Link to post
Share on other sites

Posted

Try to hold the phone so you don´t block the lower part (where the backside "bumps" out). At least according to the manual the antennas are supposed to be there.

0

Share this post


Link to post
Share on other sites

Posted

What model/make is your router?

There are probably some non-default settings active on your router. Enabling turbo, after-burner, short pre-amble or changing any threshold values will fcuk up the performance of some clients. Reset all wireless settings to default.

I have tried several different routers and access points and they all deliver top notch performance on the SGS2.

0

Share this post


Link to post
Share on other sites

Posted

What model/make is your router?

There are probably some non-default settings active on your router. Enabling turbo, after-burner, short pre-amble or changing any threshold values will fcuk up the performance of some clients. Reset all wireless settings to default.

I have tried several different routers and access points and they all deliver top notch performance on the SGS2.

Thanks for the replies so far. Interesting idea about not holding the lower part of the phone! I had considered that I could be blocking some antennas a la Iphone4, but didn't know where they were (haven't read the manual :D ) - might also be worth mentioning, I have the phone in a silicon case (typical cheapo ebay job).

My router is a Netgear DG834PN - as far as I know, there is nothing fancy set up in the Wifi - it is a MIMO router so range is pretty good, I have a study at the back of my house and was always able to use my GalaxyS normally in there, but on the s2 it has a "poor" signal with 1mbps link according to the connection status.

I have now installed Dolphin browser so will see if, when the default browser is poor, a different browser improves things...

Thanks for your help so far guys! I am sure if this is a problem, a future firmware upgrade would help!

0

Share this post


Link to post
Share on other sites

Posted

Thanks for the replies so far. Interesting idea about not holding the lower part of the phone! I had considered that I could be blocking some antennas a la Iphone4, but didn't know where they were (haven't read the manual :D ) - might also be worth mentioning, I have the phone in a silicon case (typical cheapo ebay job).

My router is a Netgear DG834PN - as far as I know, there is nothing fancy set up in the Wifi - it is a MIMO router so range is pretty good, I have a study at the back of my house and was always able to use my GalaxyS normally in there, but on the s2 it has a "poor" signal with 1mbps link according to the connection status.

I have now installed Dolphin browser so will see if, when the default browser is poor, a different browser improves things...

Thanks for your help so far guys! I am sure if this is a problem, a future firmware upgrade would help!

Hi, this has been covered in detail over at XDA, mine was very poor to start with but improved when I got a better router, I still think range isnt great but its a lot better for me now I have a decent router.

0

Share this post


Link to post
Share on other sites

Posted

Hi, this has been covered in detail over at XDA, mine was very poor to start with but improved when I got a better router, I still think range isnt great but its a lot better for me now I have a decent router.

could you point me to where on xda I might look? as you can see, I'm not a regular, didn't really know where else to try and find info! what router did you get then? I don't think my router is crap, can obviously get a decent range, it seems better when I am not holding around the bulge at the back! so will keep an eye on it over the next few days :D

0

Share this post


Link to post
Share on other sites

Posted

could you point me to where on xda I might look? as you can see, I'm not a regular, didn't really know where else to try and find info! what router did you get then? I don't think my router is crap, can obviously get a decent range, it seems better when I am not holding around the bulge at the back! so will keep an eye on it over the next few days :D

I wouldn't bother reading the post, its very long and very boring with lots of arguing and little in the way of any real help.

Basically the issue seems to boil down to range, once you move past 2-3 meters away the signal drops rapidly but the speed drops less slowly. Performance is still fairly good however. I personally got very few drop outs with my old router but speed wasn't great. I now have a Virgin superhub and where it has other problems of its own wi-fi performance is very good. I don't think the phone has a fault, i just think the wifi drivers / firmware are a bit ropey and could so with tweaking which I hope will come in upcoming ROMS.

If your wifi is very poor make sure your phone is up to date and do an AB test with another phone at a friends house. If it remains poor there simply return your phone as it must be faulty, wifi isn't fantastic on this phone but it is pretty good with a decent router.

Hope this helps.

0

Share this post


Link to post
Share on other sites

Posted

anyone having this problem - found the app wifi fixer definitely helps.

0

Share this post


Link to post
Share on other sites

Posted

I've read a few complaints on the net about range, but my S2 connects just the same as all my previous phones at home. It also picks up various routers from the neighbours or when walking down the street.

So no problems here

0

Share this post


Link to post
Share on other sites

Posted

I've read a few complaints on the net about range, but my S2 connects just the same as all my previous phones at home. It also picks up various routers from the neighbours or when walking down the street.

So no problems here

my sgs2 has poor wifi reception but wifi fixer has been able to help.

interesting that you have good wifi connectivity.

what firmware version are you using?

this could mean that the poor wifi connectivity can be resolved with a software/firmware upgrade.

i have noticed that the wifi keeps on scanning even after it has established a connection. afaik this is not normal...

0

Share this post


Link to post
Share on other sites

Posted

what firmware version are you using?

Which one is the firmware number ... I see Build, Kernel, Baseband, Android ... but nothing saying firmware :blink:

0

Share this post


Link to post
Share on other sites

Posted

Which one is the firmware number ... I see Build, Kernel, Baseband, Android ... but nothing saying firmware :blink:

It's the build, reads GINGERBREAD.XWxxx and the xxx at the end is what you are looking for.

0

Share this post


Link to post
Share on other sites

Posted

Mine is .XWKDD

0

Share this post


Link to post
Share on other sites

Posted (edited)

Not sure what happened to your Galaxy S2 + router combination.

My S2 definitely much faster than my Galaxy TAB. See below pictures for reference.

Btw, I'm on Singapore Singtel Fibre OpenNet, connected my both devices 12 feets away.

post-31662-0-76917500-1311073786_thumb.jpost-31662-0-24790600-1311073798_thumb.j

Edited by NewForce
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.