beegee1962

[ROM] 18-06-11 Ganbaro ROM V 1.0a for P10AN01 tablets (Viewpad 10s, Mobii, ...)

Recommended Posts

beegee1962    0

First of all, I am sorry for opening a new thread for my ROM, but I didn't find any possibility to change the thread title in this forum.

android-logo-mask-300x149.png

For now this will be the final version of my Ganbarou (頑張ろう [gambaroo] = Japanese for "Try your best!!") ROM.

This ROM is made for tablets like pov Mobii, Viewpad 10s, Smartsurfer 360 MN10U, that have an internal 3G modem and GPS. Of course it works on similar tablets like the Advent Vega, XVision, ...

My main goal is to get a ROM that gives full support to 3G and GPS and be as stable and fast as possible.

ServicePack 1 is available:

It includes:

  • Live wallpapers
  • Fixed problem with screen calibration application
  • Added Suspend mode by short press of power button
  • New version of ROM Updater that works with incremental updates.

    Download link:
    Ganbarou ROM V 1.0a (SP1)
    Screenshots, Changelog und Tips:
    Ganbarou (頑張ろう = Japanese for "Try your best!!") ROM V 1.0
    Ganbarou ROM V 1.0a (SP 1)

    How to flash:
    Method 1: With ClockWorkMod recovery
    • Download ZIP file, copy to your SDcard and use ClockWorkMod to flash it.

      • Get the BeeGee ROM Updater from my Downloadpage.
      • Check the ROM Updater post to see how to use it.
      • Flash the ROM with BeeGee ROM Updater.

      Changelog V 1.0

      [*]3G is automatically on after boot

      [*]ROM Updater integrated

      [*]Game mode for accelerometer added (taken from Corvus ROM)

      And as usual: You use this ROM on your own risk. I am not responsible if you break your device, loose warranty, get into a fight with your wife or loose important company data from your SDcard.

      THIS ROM RUNS BY DEFAULT ON 1.5GHZ OVERCLOCKING. GET SETCPU OR CPU METER FROM THE MARKET TO REGULATE THE SPEED. PERMANENT OVERCLOCKING MIGHT DAMAGE YOUR TABLET. YOU GOT THIS WARNING HERE AND I DO NOT TAKE ANY RESPONSIBILITY IF YOUR TABLET ENDS UP BURNING.

      Some screenshots:

      RU-main1-300x175.png

      Game-Slave-Mode-300x175.png

      Mouse-Host-Mode-300x175.png

Edited by beegee1962

Share this post


Link to post
Share on other sites
pumo    1

last night I did update with beegee rom updater, flashing it works great!

some weird things with rom, google maps cannot be installed from market. how ever I installed it with aptitoide.

also androzic cannot be installed from market.

also in wifi latitude couldnt found my location, because it was quite late I didnt yet try with 3g.

Share this post


Link to post
Share on other sites
beegee1962    0
last night I did update with beegee rom updater, flashing it works great!

some weird things with rom, google maps cannot be installed from market. how ever I installed it with aptitoide.

also androzic cannot be installed from market.

also in wifi latitude couldnt found my location, because it was quite late I didnt yet try with 3g.

Had GMaps already (from my update), tried Androzic, download without problems. Do you have enough internal memory left? Try to free up space with Link2SD and try to clear your cache before downloading. The market downloads to cache first, and if this is too full, download failes.

WiFi latitude location is giving me headaches as well. Doesn't work. GPS functions gives me headaches all the times ;)

I know there should be a AGPS setting but its missing, and "Use GPS satellites" for location is greyed out after reboot. These are the things I want to work on for the next version.

Share this post


Link to post
Share on other sites
pumo    1

there is enough free mem. market didnt find androzic at all, but I found androzics homepage where I can download apk

http://code.google.com/p/androzic/ so that ok.

latitude from wifi isnt important, or even latitude, but however gps would be nice feature if it works ;)

Edited by pumo

Share this post


Link to post
Share on other sites
beegee1962    0
there is enough free mem. market didnt find androzic at all, but I found androzics homepage where I can download apk

http://code.google.com/p/androzic/ so that ok.

latitude from wifi isnt important, or even latitude, but however gps would be nice feature if it works ;)

If you have internal GPS it should work. However the antennas are cheap. Mine doesn't find a fix ever.

Strange that you can't find androzics on the market, I see it without problems. Maybe a regional problem if everything else is ok with the market.

Here is the link to androzics : https://market.android.com/search?q=androzi...so=1&c=apps

Does the link work for you?

Share this post


Link to post
Share on other sites
pumo    1

I check later when I get back to home.

yep, internal gps but earlier ganbaros it did find fix after very long time.

I did allready order better gps antenna but not sure cannot be connect because 3g uses also same antenna if I did understand right from another topic here http://android.modaco.com/index.php?s=&amp...t&p=1709061

"Diversity antenna is used for improving SNR ratio in 3G and for GPS receiver. So be careful to connect it to the proper socket on modem card."

Share this post


Link to post
Share on other sites
beegee1962    0
I check later when I get back to home.

yep, internal gps but earlier ganbaros it did find fix after very long time.

I did allready order better gps antenna but not sure cannot be connect because 3g uses also same antenna if I did understand right from another topic here http://android.modaco.com/index.php?s=&amp...t&p=1709061

"Diversity antenna is used for improving SNR ratio in 3G and for GPS receiver. So be careful to connect it to the proper socket on modem card."

I ordered a replacement as well: http://www.aliexpress.com/snapshot/101444775.html

Should arrive in the next days. GPS antenna should be prepared for the diversity thing.

Will post here if it works.

Share this post


Link to post
Share on other sites
pumo    1

thanks for antenna tip. i might order those also.

I did try latitude with 3g only no location found.

also no miren browser, android booster or androzic found in market, its maybe region thing.

I think those found from market with previous ganbaro.

I also liked vtllauncher so I might get back to 0.3b...

Share this post


Link to post
Share on other sites
beegee1962    0
thanks for antenna tip. i might order those also.

I did try latitude with 3g only no location found.

also no miren browser, android booster or androzic found in market, its maybe region thing.

I think those found from market with previous ganbaro.

I also liked vtllauncher so I might get back to 0.3b...

VTL Launcher is in V 1.0 :P You don't see it ;) ???? That is strange.

Share this post


Link to post
Share on other sites
beegee1962    0
thanks for antenna tip. i might order those also.

I did try latitude with 3g only no location found.

also no miren browser, android booster or androzic found in market, its maybe region thing.

I think those found from market with previous ganbaro.

I also liked vtllauncher so I might get back to 0.3b...

Got the antennas today, replaced the AUX (GPS & diversity) antenna, but still no fix.

Used logcat to see whats going on

D/gps_hw ( 1076): hw_gps_set_position_mode: fix_frequency = 1, mode = 1

D/gps_hw ( 1076): AT>> AT^WPDOM=5

D/gps_hw ( 1076): AT<<

D/gps_hw ( 1076): OK

D/gps_hw ( 1076): set to GPS_POSITION_MODE_MS_BASED

D/gps_hw ( 1076): AT>> AT^WPDFR=65536,1

D/gps_hw ( 1076): AT<<

D/gps_hw ( 1076): OK

D/gps_hw ( 1076): Specify fix number=65536 , interval time=1

D/gps_hw ( 1076): AT>> AT^WPURL=207.114.133.116:59910

D/gps_hw ( 1076): AT<<

D/gps_hw ( 1076): OK

D/gps_hw ( 1076): set_agps_server successful

D/gps_hw ( 1076): AT>> AT^WPURL?

D/gps_hw ( 1076): AT<<

D/gps_hw ( 1076): ^wpurl:207.114.133.116:59910

D/gps_hw ( 1076): OK

D/gps_hw ( 1076): set_agps_server returned = 38

D/gps_hw ( 1076): AT>> at^wpdgp

D/gps_hw ( 1076): at_fd CMD

D/gps_hw ( 1076): AT<<

D/gps_hw ( 1076): OK

D/gps_hw ( 1076): received 32 bytes: $GPGSV,1,1,00*79

D/gps_hw ( 1076): Too short. discarded.

...

The same sequence is received continuesly until I stop the GPS

...

D/gps_hw ( 1076): gps fd event end

D/gps_hw ( 1076): gps thread received 1 events

D/gps_hw ( 1076): gps fd event

D/gps_hw ( 1076): gps fd event end

D/gps_hw ( 1076): hw_gps_stop: called

D/gps_hw ( 1076): agps_status_cb data conn

D/gps_hw ( 1076): gps thread received 1 events

D/gps_hw ( 1076): gps control fd event

D/gps_hw ( 1076): AT>> at^wpend

D/gps_hw ( 1076): AT<<

D/gps_hw ( 1076): OK

D/gps_hw ( 1076): gps thread stopping

Looking on the first commands send to the GPS, it seems it gets the wrong initialization command.

The command AT^WPDOM=5 followed by the setup for aGPS means MS-based only (if I am correct that means it tries to get position with aGPS and not with the real antennas)

It should be:

AT^WPDOM=2: Speed optimal (minimize time-to-fix, MS-based first, PDE-based later if failed)

or

AT^WPDOM=3: Accuracy optimal (PDE preferred, MS in case of failure)

or

AT^WPDOM=4: Data optimal– minimize data exchanged

Seems the GPS is not detected correct or I am understanding the commands wrong.

Anybody has an idea? Real strange is that for others the GPS works with my ROM.

Share this post


Link to post
Share on other sites
pumo    1
VTL Launcher is in V 1.0 :P You don't see it ;) ???? That is strange.

noup.

I updated 1.0 with your rom manager and cleared flash, no vtl. it works strange all way, market wont find almost anything..

I will try again with clockwork tonight.

edit: I found maybe bug from rom manager, after it have flashed and rebooted, I get lock and sound slider but whole touch panel wont respond. buttons work but I have to shutdown whole tablet.

Edited by pumo

Share this post


Link to post
Share on other sites
beegee1962    0
noup.

I updated 1.0 with your rom manager and cleared flash, no vtl. it works strange all way, market wont find almost anything..

I will try again with clockwork tonight.

edit: I found maybe bug from rom manager, after it have flashed and rebooted, I get lock and sound slider but whole touch panel wont respond. buttons work but I have to shutdown whole tablet.

Thanks for the feedback. One thing I actually miss is the possibility to check that the download was correct, e.g. with a md5Checksum. Something that I need to do definitely for the next release.

Can you download the ROM from my website check the md5Checksum and then flash it.

Share this post


Link to post
Share on other sites
Tucnak    0
Got the antennas today, replaced the AUX (GPS & diversity) antenna, but still no fix.

Used logcat to see whats going on

Looking on the first commands send to the GPS, it seems it gets the wrong initialization command.

The command AT^WPDOM=5 followed by the setup for aGPS means MS-based only (if I am correct that means it tries to get position with aGPS and not with the real antennas)

It should be:

AT^WPDOM=2: Speed optimal (minimize time-to-fix, MS-based first, PDE-based later if failed)

or

AT^WPDOM=3: Accuracy optimal (PDE preferred, MS in case of failure)

or

AT^WPDOM=4: Data optimal– minimize data exchanged

Seems the GPS is not detected correct or I am understanding the commands wrong.

Anybody has an idea? Real strange is that for others the GPS works with my ROM.

yes, you are right, i think .....

WPDOM=5 is MS based only

0 Standalone only; MS uses internal GPS functions.

1 Network (PDE-based) only; MS obtains all position determination data from the PDE.

2 Speed optimal (minimize time-to-fix, MS-based first, PDE-based later if failed).

3 Accuracy optimal (PDE preferred, MS in case of failure) .

4 Data optimal– minimize data exchanged between MS and PDE.

5 MS-based only; MS performs all position determination functions.

maybe correct is "Speed optimal"

Share this post


Link to post
Share on other sites
Tucnak    0

Ok, now i have only 3 problems with this ROM:

- 216 MHz CPU issue (no SetCPU installed, and any other similar apps)

- very lazy wake-up ;)(((

- no live wallpapers

Share this post


Link to post
Share on other sites
pumo    1
Thanks for the feedback. One thing I actually miss is the possibility to check that the download was correct, e.g. with a md5Checksum. Something that I need to do definitely for the next release.

Can you download the ROM from my website check the md5Checksum and then flash it.

I downloaded again and reflashed, now vtl works.

but market cant find software what did found with 0.3b. so I get back to it.

Share this post


Link to post
Share on other sites
beegee1962    0
I downloaded again and reflashed, now vtl works.

but market cant find software what did found with 0.3b. so I get back to it.

I guess you flashed without wiping DATA to keep your applications. Try this one: How to get all apps on the market.

Worked for me.

Share this post


Link to post
Share on other sites
beegee1962    0
Ok, now i have only 3 problems with this ROM:

- 216 MHz CPU issue (no SetCPU installed, and any other similar apps)

- very lazy wake-up :P(((

- no live wallpapers

Download CPU Master from market. Set your speed between 456MHz and 1200MHz (or whatever max speed you want and your tablet works stable). Then the first 2 issues will be gone.

I removed live wallpapers, because I don't like them ;)

Flash the attached ZIP file with CWM recovery to get them back.

LiveWallPapers.zip

Share this post


Link to post
Share on other sites
Tucnak    0
Download CPU Master from market. Set your speed between 456MHz and 1200MHz (or whatever max speed you want and your tablet works stable). Then the first 2 issues will be gone.

I removed live wallpapers, because I don't like them ;)

Flash the attached ZIP file with CWM recovery to get them back.

CPU Master does'nt solve 216 MHz issue for me :P My settings is 1000MHz and 12000MHz. After Suspend and long wakeup is 216MHz back :D No other CPU apps :D

Share this post


Link to post
Share on other sites
Tucnak    0

new bug:

- when i connect USB mouse (USB set to host) with ROM v0.3, everything is ok

- with 1.0 is reverted cursor move (when i move mouse to the left, cursor go to the top)

automatic rotation is enabled (settings)

hardware button for lock rotation is unlocked

Gsensor is in GameMode

Share this post


Link to post
Share on other sites
beegee1962    0
new bug:

- when i connect USB mouse (USB set to host) with ROM v0.3, everything is ok

- with 1.0 is reverted cursor move (when i move mouse to the left, cursor go to the top)

automatic rotation is enabled (settings)

hardware button for lock rotation is unlocked

Gsensor is in GameMode

Solution is to set Gsensor into MouseMode with the widget that is in the ROM => "Game Mode Indicator Small" or "Game Mode Indicator Large"

Share this post


Link to post
Share on other sites
beegee1962    0
CPU Master does'nt solve 216 MHz issue for me ;) My settings is 1000MHz and 12000MHz. After Suspend and long wakeup is 216MHz back :P No other CPU apps :D

I had this before with SetCPU, but since I changed to CPU Master (456MHz min and 1200MHz max) I never had the problem again. Sorry, no idea what's wrong. It looks like this problem is kernel related. If you don't need overclocking, you can try one of the older kernels without OC. There the mouse should work as well, but you might get problems with the accelerometer in games. Let me know if you want to try another kernel, I will give you a flashable file.

Share this post


Link to post
Share on other sites
beegee1962    0

ServicePack 1 is available:

It includes:

  • Live wallpapers
  • Fixed problem with screen calibration application
  • Added Suspend mode by short press of power button
  • New version of ROM Updater that works with incremental updates.

Download link:

Ganbarou ROM V 1.0a (SP1)

Screenshots, Changelog und Tips:

Ganbarou (頑張ろう = Japanese for "Try your best!!") ROM V 1.0

Ganbarou ROM V 1.0a (SP 1)

Share this post


Link to post
Share on other sites
Tucnak    0
I had this before with SetCPU, but since I changed to CPU Master (456MHz min and 1200MHz max) I never had the problem again. Sorry, no idea what's wrong. It looks like this problem is kernel related. If you don't need overclocking, you can try one of the older kernels without OC. There the mouse should work as well, but you might get problems with the accelerometer in games. Let me know if you want to try another kernel, I will give you a flashable file.

Still have problem with 216 MHz :) and sometimes digitizer does'nt work (only hardware buttons) B) Can you give me any kernel with 3g and GPS support ? (i have POV with integrated 3G and GPS).

THANKS

Share this post


Link to post
Share on other sites
beegee1962    0
Still have problem with 216 MHz :) and sometimes digitizer does'nt work (only hardware buttons) B) Can you give me any kernel with 3g and GPS support ? (i have POV with integrated 3G and GPS).

THANKS

You can try this one: [KERNEL] Buzz Vega | .32.35 | CIFS | TUN | EXT4 | SLAB | NOOP | WiFi | NTFS | HOST/SLAVE | 0.7, Updated 25/03/11

or this one: [KERNEL] corvusKernel |.32|CIFS|TUN|EXT4|SLAB|CFQ|WiFi|NTFS|HOST/SLAVE|PL2303|XPAD

I had used both kernels in earlier versions of my ROM, but as there is a demand for overclocking, I switched to the newer CorvusKernel 0.2.

You just have to read the posts carefully, as far as I remember, WiFi seemed to be broken until you changed some files in the /system/lib/modules folder. Make a nandroid backup of your current ROM to be safe. Or use VEGAFixer to create a backup that you can flash from your PC if the tablet is no longer booting.

Or, if you can wait a few days (busy in my job at the moment) I can prepare you a ROM version with one of these kernels.

Edited by beegee1962

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.