• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Weird A2SD+ goings on

17 posts in this topic

Posted

HI All

According to Titanium Backup I have 4.13 GB free on my 'SD card (A2SD)' partition, yet my phone keeps complaining there is no space and refuses to install new apps.

Anybody know what is going on? Or better still how to fix it?

~S

0

Share this post


Link to post
Share on other sites

Posted

HI All

It also randomly forgets apps. If I wipe the dalvik cache it will remember some and drop others.

Any ideas?

~S

0

Share this post


Link to post
Share on other sites

Posted

According to Titanium Backup I have 4.13 GB free on my 'SD card (A2SD)' partition, yet my phone keeps complaining there is no space and refuses to install new apps.

Anybody know what is going on? Or better still how to fix it?

A2SD moves /data directory which holds apps. But almost the same amount of free space is needed for app cache which resides in /data/data. This directory is not moved with A2SD and still consumes internal memory.
0

Share this post


Link to post
Share on other sites

Posted

A2SD moves /data directory which holds apps. But almost the same amount of free space is needed for app cache which resides in /data/data. This directory is not moved with A2SD and still consumes internal memory.

A-Ha! is there any way (preferably easy LOL) to move this over too?

Would this also explain the dropped apps?

~S

0

Share this post


Link to post
Share on other sites

Posted

Would this also explain the dropped apps?
What does your computer do when it's out of space and you want to install something? Well it's the same here. The phone goes berserk if you try it (apps don't install, SMS can stop registering,...).

The simplest method (for me) is with data2whatever but you could also use any other script.

Sadly that will require flashing a new rom so you can't just install it now on top of your current rom.

0

Share this post


Link to post
Share on other sites

Posted

What does your computer do when it's out of space and you want to install something? Well it's the same here. The phone goes berserk if you try it (apps don't install, SMS can stop registering,...).
But I'm not talking about refusing to install new apps, it forgets stuff that is already installed. For example at the moment, if I go Menu -> Settings from the main screen, I'm told 'The linked program is no longer installed on your phone' however if I boot to recovery and wipe the dalvik cache it (may) come back while something else gets dropped. The are all still there it's just the phone can't see random one after each dalvik wipe.

The simplest method (for me) is with data2whatever but you could also use any other script.
Thanks, I'll look into that.

Sadly that will require flashing a new rom so you can't just install it now on top of your current rom.
Not a huge problem, I was going to wait for the next version but doing it now and later isn't too much bother.

~S

0

Share this post


Link to post
Share on other sites

Posted

But I'm not talking about refusing to install new apps, it forgets stuff that is already installed.
That could be a side effect of the lack of app cache. You're lucky at least you still get your SMSes. Some phones stop receiving them after they drop under 10mb. :)
0

Share this post


Link to post
Share on other sites

Posted

Hi,

Getting so pissed off with this bloody phone now!

Just tried to flash a new ROM only to be told 'No such file or directory' but when I look (via my Linux box) it's still there. I get the same results when I try from ROM Manager, and when I boot into recovery and do it from there myself.

Is this part of the same thing (even though I told ROM Manager to wipe everything), or something else?

Any ideas on how to fix this mess?

~S

0

Share this post


Link to post
Share on other sites

Posted

I usually do it from recovery. Make sure that you've copied the rom to your SD and that you've wiped the phone (wipe not clear data or whatever the second option is).

Then just select the rom from zip (not update from update.zip).

0

Share this post


Link to post
Share on other sites

Posted

I usually do it from recovery. Make sure that you've copied the rom to your SD and that you've wiped the phone (wipe not clear data or whatever the second option is).

Then just select the rom from zip (not update from update.zip).

That is what I normally do (unless I'm being lazy and using ROM Manager LOL), but recovery (clockwork 2.5.0.7) refuses to see the image on the SD.

I am totally at a loss on how to continue.

~S

P.S. Thanks very much for the help so far though.

0

Share this post


Link to post
Share on other sites

Posted

Did you try formating the SD card or using a different card?

And when you go to the menu where you select the zip file do you actually see it or is it empty?

0

Share this post


Link to post
Share on other sites

Posted

Did you try formating the SD card or using a different card?
Yup, this is a 16GB card, I get the same results when I try with the SD that came with the phone.

And when you go to the menu where you select the zip file do you actually see it or is it empty?
I can see all the files from ROM Manager and Root Explorer, but from recovery all I can see is the clockworkmod folder, and that doesn't show any contents. I think there may be a problem with the recovery rather than memory space.

~S

0

Share this post


Link to post
Share on other sites

Posted

Yes it seems so. Did you try flashing a new recovery through unrevoked?

0

Share this post


Link to post
Share on other sites

Posted

Yes it seems so. Did you try flashing a new recovery through unrevoked?
Tried and failed. It tells me it failed to get root. and asks if the firmware is too new. Any suggestions on how to continue from here?

~S

0

Share this post


Link to post
Share on other sites

Posted

Hmm. Maybe by running a RUU and re-rooting. I don't know because it's a first for me.

0

Share this post


Link to post
Share on other sites

Posted

Hmm. Maybe by running a RUU and re-rooting. I don't know because it's a first for me.
I ran the AlphRev S-Off disk and told it to push a new recovery to the phone, that appeared to work great until the SD (both FAT32 and EXT3 partitions) vanished! So not really any further forward.

~S

0

Share this post


Link to post
Share on other sites

Posted

I ran the AlphRev S-Off disk and told it to push a new recovery to the phone, that appeared to work great until the SD (both FAT32 and EXT3 partitions) vanished! So not really any further forward.
Partitioned and put the SD that came with the phone back in, and all seems to be running as it should again. No idea why it killed the big SD, but apart from having a tiny SD, the phone is working so at least I can get on with stuff again.

~S

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.