• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ROM MOD][Gen2] Simple Stir Fry (Updated 01/10) - b27

139 posts in this topic

Posted

Fair enough, but I greatly prefer them to the Froyo versions present in b18 :)

That was b16 i think, they are stock gingerbread in B17 & B18, just a little misshaped at the end & the text colour changed to black. I prefer the Froyo ones myself, but I couldn't get the text to line up right, similar 9patch png problems, maybe taking them from another phone would work, but it doesn't bother me enough to change it.

There are a few options in framework that it's worth decompiling to set, also a load of useless mdpi graphics which can be removed, but just decompiling & recompiling breaks a bunch of graphics, need to remove the '.9' from the file name then recompile again & keep fingers crossed that it doesn't really need to be 9patch to fix it. It can easily get messy. Problem is that if you use the framework from b18 unmodified you'll get the transparent white background/black text notifications rather than the stock version, although the rest of the notification settings are in SystemUI.apk

0

Share this post


Link to post
Share on other sites

Posted

I just started using this rom yesterday and I love it! Big thanks to wbaw for the main rom and Matthew for making this version! It's clean, fast, seems very stable and battery life seems to be great aswell.

I flashed the full version of Simple Stir Fry, but now I realized that I probably wanted the stock android dialer and not the ZTE version. The ZTE version is nice though, but I'm using the SIP calling feature of gingerbread and since this seems to work better with the stock android dialer, I guess I should have picked the lite version of SSF (I like the colored settings menu though).

Is there any way to restore the stock android dialer without having to reflash with the lite version?

1

Share this post


Link to post
Share on other sites

Posted

I just started using this rom yesterday and I love it! Big thanks to wbaw for the main rom and Matthew for making this version! It's clean, fast, seems very stable and battery life seems to be great aswell.

I flashed the full version of Simple Stir Fry, but now I realized that I probably wanted the stock android dialer and not the ZTE version. The ZTE version is nice though, but I'm using the SIP calling feature of gingerbread and since this seems to work better with the stock android dialer, I guess I should have picked the lite version of SSF (I like the colored settings menu though).

Is there any way to restore the stock android dialer without having to reflash with the lite version?

I think there might be, check in the Gingerbread Goodies thread for a patch to flash the CM7 dialler? That might work

Wbaw - Odd, as I've recompiled the framework on this, to remove the CRT animation (as it's the framework from b9) unless we're talking about a different thing here?

1

Share this post


Link to post
Share on other sites

Posted

I think there might be, check in the Gingerbread Goodies thread for a patch to flash the CM7 dialler? That might work

Thanks! Tried that and it seems to work perfectly! :)

0

Share this post


Link to post
Share on other sites

Posted (edited)

I think there might be, check in the Gingerbread Goodies thread for a patch to flash the CM7 dialler? That might work

Wbaw - Odd, as I've recompiled the framework on this, to remove the CRT animation (as it's the framework from b9) unless we're talking about a different thing here?

Maybe it's my version of apktool that's broken then? UOT kitchen does the same thing too. Are your lockscreen sliders light grey when pressed? or did you use one from after I fixed it (i'd probably fixed it before b9)? There was also a problem with the tabs in applications (like contacts), white line under the deselected tabs rather than grey, that was fixed later than the lockscreen, not sure if it was fixed in b9, i think i fixed that around the same time as I fixed the notifications to be readable on the transparent background. tab_selected_bar*.png were the files affected by that, just need to replace those files with ones from a working version, remove the '.9' from the file name & recompile, if it's a problem. There could still be a few minor graphics errors hiding, there are about 200 of those 9patch png files, I'm not sure if any others are broken - can't just replace them all because some of them need to be 9patch pngs.

If its got jog_tab_bar_left_end_normal.png rather than jog_tab_bar_left_end_normal.9.png then it's one that I fixed so that it can be decompiled & recompiled without causing the lockscreen bug.

I thought you were using the stock unmodified framework, I didn't change it for the first few betas, I think I'd fixed the lock screen thing by b9.

I think the only things that are visually different between the current framework & stock are the text colour on the lock screen sliders & the notifications.

I also changed these values in framework bools.xml , not sure which beta, but they affect animations...

<bool name="config_sf_limitedAlpha">true</bool>

<bool name="config_sf_slowBlur">true</bool>

They should both be true, imo, it seems to be a bit smoother after I changed those.

Edited by wbaw
0

Share this post


Link to post
Share on other sites

Posted

Maybe it's my version of apktool that's broken then? UOT kitchen does the same thing too. Are your lockscreen sliders light grey when pressed? or did you use one from after I fixed it (i'd probably fixed it before b9)? There was also a problem with the tabs in applications (like contacts), white line under the deselected tabs rather than grey, that was fixed later than the lockscreen, not sure if it was fixed in b9, i think i fixed that around the same time as I fixed the notifications to be readable on the transparent background. tab_selected_bar*.png were the files affected by that, just need to replace those files with ones from a working version, remove the '.9' from the file name & recompile, if it's a problem. There could still be a few minor graphics errors hiding, there are about 200 of those 9patch png files, I'm not sure if any others are broken - can't just replace them all because some of them need to be 9patch pngs.

If its got jog_tab_bar_left_end_normal.png rather than jog_tab_bar_left_end_normal.9.png then it's one that I fixed so that it can be decompiled & recompiled without causing the lockscreen bug.

I thought you were using the stock unmodified framework, I didn't change it for the first few betas, I think I'd fixed the lock screen thing by b9.

I think the only things that are visually different between the current framework & stock are the text colour on the lock screen sliders & the notifications.

I also changed these values in framework bools.xml , not sure which beta, but they affect animations...

<bool name="config_sf_limitedAlpha">true</bool>

<bool name="config_sf_slowBlur">true</bool>

They should both be true, imo, it seems to be a bit smoother after I changed those.

Hmm, well that's definitely the framework from b9 I'm using, and it has no lockscreen bugs, and the issue you mentioned with applications isn't there, either. I'm using a completely stock SystemUI (I think) so maybe that partially causes the problem? I'll take a look at the bools.xml when I get the chance. Obviously I've never used UOT as I prefer the stock look :P

1

Share this post


Link to post
Share on other sites

Posted

I would like to have lite version but with colorful settings. Or full version with stock dialler. Can some one make this? Or which one is easier to make by myself and how?

Can I just copy dialler from lite version to full verison zip and then install that? Or can I just copy some color file from full version zip to lite version zip?

0

Share this post


Link to post
Share on other sites

Posted

I would like to have lite version but with colorful settings. Or full version with stock dialler. Can some one make this? Or which one is easier to make by myself and how?

Can I just copy dialler from lite version to full verison zip and then install that? Or can I just copy some color file from full version zip to lite version zip?

Copy Settings.apk from system/app to the lite version :) Overwrite the existing version.

1

Share this post


Link to post
Share on other sites

Posted

Thanks Matthew for this great ROM!

(thanks to wbaw and all the forefathers too.... wouldn't like to offend anyone ;-))

I've been using it for a couple of days now.

This ROM is simple, clean and fast. Exactly what I was looking for.

p.s. I got help from a dude at another forum to add support for the Hebrew language, both keyboard and proper right to left support (he patched some of the libraries for me). If anyone else is interested in these fixes, I'm happy to share my ROM.

1

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, I know there's 'no wipe, no whine policy' but I've got a question.

Had any of you have problem with wi-fi? I cannot enable it on Simple Stir Fry (b18), it does automatically disable after 2 secs, and in this time doesn't see any network...

Now my sin (way of installation):

Before SSF i was using CM7 149, then:

- in recovery I've formatted /boot, /cache and /system

- installed SSF, reboot

- many force closes (most from Facebook and Music)

-reboot

- less FCs:) (reinstallation of Facebook and changing folder name from Music to something random and back fixed problems)

- reboot

- no ringtones

- reboot

- ringtones back:)

And then everything seemed to be working, with all my apps, data and settings from CM7. It was so beautiful.

Then I went back home and tried to connect via wifi...

Any ideas?

Edited by aNtArCt
0

Share this post


Link to post
Share on other sites

Posted

Hi, I know there's 'no whipe, no whine policy' but I've got a question.

Had any of you have problem with wi-fi? I cannot enable it on Simple Stir Fry (b18), it does automatically disable after 2 secs, and in this time doesn't see any network...

Now my sin (way of installation):

Before SSF i was using CM7 149, then:

- in recovery I've formatted /boot, /cache and /system

- installed SSF, reboot

- many force closes (most from Facebook and Music)

-reboot

- less FCs:) (reinstallation of Facebook and changing folder name from Music to something random and back fixed problems)

- reboot

- no ringtones

- reboot

And then everything seemed to be working, with all my apps, data and settings from CM7. It was so beautiful.

Then I went back home and tried to connect via wifi...

Any ideas?

Yes, I really should add this to my main page, as it's listed on the Ginger Stir Fry page - NO WHIPE, NO WHINE

CM7 is built on a different kernel and a different base - you're lucky you got the phone to boot, let alone have any apps work. Wipe data and do a factory reset, and reinstall the ROM. That will fix your issues.

1

Share this post


Link to post
Share on other sites

Posted (edited)

Yes, I really should add this to my main page, as it's listed on the Ginger Stir Fry page - NO WHIPE, NO WHINE

CM7 is built on a different kernel and a different base - you're lucky you got the phone to boot, let alone have any apps work. Wipe data and do a factory reset, and reinstall the ROM. That will fix your issues.

But there's only one issue: no wifi connection. Except this one everything is working as it should (tested for about 6hours), so I still have a little hope that this can be fixed.

Isn't there any posibility to somehow 'reinstall' wifi driver or any system file connected with this?

If it was possible then (I think) many people would start using yours SSF, factory reset when you have apps and data collected in months is simply not an option:(

Edited by aNtArCt
0

Share this post


Link to post
Share on other sites

Posted

As well as formatting /boot, /cache & /system you ought to go into advanced and wipe dalvic cache & battery stats too.

Hi, I know there's 'no wipe, no whine policy' but I've got a question.

Had any of you have problem with wi-fi? I cannot enable it on Simple Stir Fry (b18), it does automatically disable after 2 secs, and in this time doesn't see any network...

Now my sin (way of installation):

Before SSF i was using CM7 149, then:

- in recovery I've formatted /boot, /cache and /system

- installed SSF, reboot

- many force closes (most from Facebook and Music)

-reboot

- less FCs:) (reinstallation of Facebook and changing folder name from Music to something random and back fixed problems)

- reboot

- no ringtones

- reboot

- ringtones back:)

And then everything seemed to be working, with all my apps, data and settings from CM7. It was so beautiful.

Then I went back home and tried to connect via wifi...

Any ideas?

0

Share this post


Link to post
Share on other sites

Posted

As well as formatting /boot, /cache & /system you ought to go into advanced and wipe dalvic cache & battery stats too.

I also did this steps.

0

Share this post


Link to post
Share on other sites

Posted

I also did this steps.

When switching ROMs, wiping Data is pretty much a given, as it causes issues like this. Since you can't switch from CM7 to any other ROM, I'm not too bothered. The only way you're likely to get Wifi back is by wiping.

1

Share this post


Link to post
Share on other sites

Posted (edited)

When switching ROMs, wiping Data is pretty much a given, as it causes issues like this. Since you can't switch from CM7 to any other ROM, I'm not too bothered. The only way you're likely to get Wifi back is by wiping.

But what exactly has auto switching off wifi problem to do with non wiped data?

Or maybe there are some processes responsible for wifi connection whom I can wipe data & cache from settings > applications? Any hint?

If we solve this problem then we get very simple way to move to your ROM from CM7 without losing anything...

Edited by aNtArCt
0

Share this post


Link to post
Share on other sites

Posted

factory reset when you have apps and data collected in months is simply not an option:(

Nonsense :D

That's what Back-Up programs are for.....

Get a Program that can restore your downloaded apps and data as a single batch and it's really easy. After installing the ROM and booting, install your backup program from the Market and restore all your apps by batch....

First time I upgraded to a GSF version, I made a note of the steps and have refined it on further updates so I've now got it down to a fine art (for me), although I bet a load of steps are unneccessary !!!!

0

Share this post


Link to post
Share on other sites

Posted

Hi, could you please add MD5s for each file for verification?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Fantastic work. Cheers. One question: what happened to the News & Weather app/widget. That's stock Android right?

Edited by Pierreism
1

Share this post


Link to post
Share on other sites

Posted (edited)

Fantastic work. Cheers. One question: what happened to the News & Weather app/widget. That's stock Android right?

Hmm, not too sure what happened to that. I'll either add a patch to re-add it or add a new build tomorrow :) I'll also add an MD5 if I can be bothered, as I've never heard anyone having an issue with MD5 for a ROM download :P

Edited by Matthew Ferguson
1

Share this post


Link to post
Share on other sites

Posted

I've never had any problems with MD5 in the history of modding my Blade either! Never checked once.

Oh and one further niggle: the Gallery submenus when you go to Share or Edit a picture or whatever are opaque-ish grey instead of transparent black. Is that something to do with the opaque grey notification bar? Is there any way to get them both back to black? You're using the stock notification bar from Froyo, not Gingerbread yes?

0

Share this post


Link to post
Share on other sites

Posted

I've never had any problems with MD5 in the history of modding my Blade either! Never checked once.

Oh and one further niggle: the Gallery submenus when you go to Share or Edit a picture or whatever are opaque-ish grey instead of transparent black. Is that something to do with the opaque grey notification bar? Is there any way to get them both back to black? You're using the stock notification bar from Froyo, not Gingerbread yes?

No no, I'm using the stock one from Gingerbread. The froyo one is white and grey.

This is an interesting bug, possibly most likely to do with the gallery version, I'll ask Wbaw if he's changed anything there, and I'll see what happens if I slip the CM7 version into the ROM. On froyo the submenus were black, as you describe, so I have no idea.

Also, the notification AREA in gingerbread was never, ever black. That was one of Wbaw's tweaks that I removed (when it was in place).

2

Share this post


Link to post
Share on other sites

Posted

Problem with the black notification area is there is some text on the 'ongoing' notifications which is black & I can't find a way to change that. So you end up with some text on some notifications being totally unreadable. That's why I changed it to light grey. The gallery is the CM7 version, I changed it a couple of versions ago, I'm not sure if I even messed with it at all, so not sure where that bug came from, it isn't related to the notification bar at all though.

News & weather is GenieWidget.apk

2

Share this post


Link to post
Share on other sites

Posted

many thank to whoever's done a good job with the rom....now able to access iplayer thru skyfire

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.