• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

09 Aug: Superboot - root access for the ZTE Skate

293 posts in this topic

Posted

oh another question,like on the iphone when u jailbreak that has android got things like installous and cydia and themes like winterboard :D

0

Share this post


Link to post
Share on other sites

Posted

Tried using an XP machine and Win7, no go! When the drivers are installed off the phone and the phone is connected (with USB debugging on), a new Handset ADB interface is listed in device manager. As soon as I run install-superboot-windows.bat the phone vibes, green android man appears and nothing happens. If I check device manager again the hanset ADB interface is missing, and a generic Android Device appears further down the list (with yellow !). Win7 also asked for another driver at this point.

Is there another way we can install this without having to use a computer?

0

Share this post


Link to post
Share on other sites

Posted

you can get them from the android sdk here http://developer.and.../sdk/index.html download the .zip extract it to desk top (easier to find) then run the sdk manager .exe

cancel the choose packages to install pop up.

click on available packages then open third party tab then the google inc tab then select google usb driver package.

then press install selected.

when its finished the drivers will be in the folder where you extracted the android sdk

under--> android-sdk-windows /extras /google /usb_driver

let me know if you need help how to install them for your phone.

Already had them installed using the sdk manager version 4 also the handsent drivers but it still did nothing and now it does not recognise phone when plugged in as anything other than a storage device tryed on another xp machine also by copying the usb_driver folder over to it so i could point to it when asked to instal drivers again but it said your device has not been installed so stumped really.

0

Share this post


Link to post
Share on other sites

Posted (edited)

this is how i got it to work using vista

make sure usb debugging is turned on.

follow the superboot guide until you get to the point where it says waiting for device and phone stops at green android logo.

now press start & right click on my computer or computer witch ever yours says then click manage.

then select device manager.

now under other devices it should say androidphone double click the androidphone then the driver tab & open update driver.

select browse my computer for driver software.

use the browse for driver software to direct it to the usb_driver folder from the android sdk.

then underneath click let me pick from a list of driver devices on my computer.

the box will be empty so press have disc.

now select the drive you have the android sdk installed on for me it woz C:\

now direct it threw the android sdk to the usb_driver folder.

for me it woz ----> android-sdk-windows / extras / google / usb_driver

open the usb_driver folder & select the android_winusb.inf press ok then next.

windows will give some warning saying if you want to proceed just ignore it & press yes and install.

now there might be two androidphone devices in device manager (one under the other) disable the one that has the yellow triangle next to it by right clicking then pressing disable.

soon as you do that the process should continue and the phone will reboot after a minute or two and should be rooted.

if not run the superboot process again and it should work.

NOTE: i uninstalled the - handset_usb_driver.exe - that is installed from the phone before starting.

when you plug the phone in and it pops up to reinstall the .exe just close it.

when your rooted & have clockwork you can reinstall them.

also since you have unlinstalled the handset usb drivers your phone might be mounted as

the drivers disc if so right click and eject.

hope this helps solve your problem it did for mewink.gif

Edited by tillaz
0

Share this post


Link to post
Share on other sites

Posted

Thanks Tillaz for the info. Doesn't work for me though. Tried every which way and I cannot install the Google drivers (XP). I just get "The specified location does not contain information about your hardware" message.

Reminds me of all the hassle we had with the Advent Vega drivers (only worse).

0

Share this post


Link to post
Share on other sites

Posted

you could just leave it plugged in to usb cable .and try doing it without drivers installed.

1. just run adb -windows

2. fastboot-windows

3.install-superboot-windows

reason i did this was i installed a gen2 clockwork to test and though id bricked it. this helped me get it back working.

hope this helps you .

0

Share this post


Link to post
Share on other sites

Posted

you could just leave it plugged in to usb cable .and try doing it without drivers installed.

1. just run adb -windows

2. fastboot-windows

3.install-superboot-windows

reason i did this was i installed a gen2 clockwork to test and though id bricked it. this helped me get it back working.

hope this helps you .

Tried all that no go! 1 and 2 just ask for options and switches, 3 doesn't find any device and then waits for it?

0

Share this post


Link to post
Share on other sites

Posted (edited)

are you on stock rom .have you tried custom rom .it will detect your device.you can always restore after it .

i did superboot on windows 7 .maybe you need to do that on win7

Edited by wrtease
0

Share this post


Link to post
Share on other sites

Posted

this might work .switch phone of and hold volume down it will stay at green logo.then connect usb cable and do the three options i gave earlier worth a go.

0

Share this post


Link to post
Share on other sites

Posted

None of that works on XP. I'll try Win7 when I get home tonight.

0

Share this post


Link to post
Share on other sites

Posted

Ahhhhhhh..... success! Thank you tillaz and wrtease for your input. I can honestly say I don't know what happened. After frantically installing and uninstalling various drivers and pulling the battery in and out, I must have beat my mobile and poor computer into submission! I ended up with two android devices installed in Device manager, and that seemed to do the trick.

Now to get rid of all that horrible Orange trash.

0

Share this post


Link to post
Share on other sites

Posted

their is an ap in market that gets rid of orange crap.

glad you got it.

0

Share this post


Link to post
Share on other sites

Posted

their is an ap in market that gets rid of orange crap.

glad you got it.

Yes I saw that, Antek App Manager... already done ;)

0

Share this post


Link to post
Share on other sites

Posted

Finally done although not on xp was waiting for my windows7 disk to arrive as i had decided to try it anyway the same as with xp happened.

1 detects phone installs handset usb drivers

2 waiting for device as with xp it's looking for drivers again so I tell win7 to find them and unlike xp it does and installs them job done.

Not sure where win7 is looking for them but at least it found them.

0

Share this post


Link to post
Share on other sites

Posted

The other way round. I couldn't do it under Vista/7 but managed to root my OMC in Windows XP.

It might be because of the 64-bit driver issue I guess.

Finally done although not on xp was waiting for my windows7 disk to arrive as i had decided to try it anyway the same as with xp happened.

1 detects phone installs handset usb drivers

2 waiting for device as with xp it's looking for drivers again so I tell win7 to find them and unlike xp it does and installs them job done.

Not sure where win7 is looking for them but at least it found them.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I plugged the phone both on and off into my vista pc but I don't have anything happening. It just says "waiting for device" and the phone led doesn't blink or anything.

I tried turning the phone with volume pressed but got a white FTM Logo on the screen and had to pull the battery out to reboot....

Also I've got all drivers installed but in device manager no ADROIDPHONE...

I haven't got a clue...does anybody have a granny guide for installing superboot...

Edited by dadashi
0

Share this post


Link to post
Share on other sites

Posted (edited)

I plugged the phone both on and off into my vista pc but I don't have anything happening. It just says "waiting for device" and the phone led doesn't blink or anything.

I tried turning the phone with volume pressed but got a white FTM Logo on the screen and had to pull the battery out to reboot....

Also I've got all drivers installed but in device manager no ADROIDPHONE...

I haven't got a clue...does anybody have a granny guide for installing superboot...

page 3 post 44 & 54 i explain how to install the drivers for androidphone in vista.

Edited by tillaz
0

Share this post


Link to post
Share on other sites

Posted (edited)

page 3 post 44 & 54 i explain how to install the drivers for androidphone in vista.

It took me on and off all day but I managed it...here several tips

1- When you plug the OMC into pc usb you get a cd-drive in my computer, eject it !!! otherwise you won't get Androidphone device in device manager

2- You'll probably have to install java before you can install the sdk/google driver download tool, you'll be given the link by the sdk tool

3- When you execute SDK Manager.exe it might not start....I had to look under properties and choose win98/millemium compatibility to get it to work!

4-Even after starting SDK Manager.exe and choosing googleusbdrivers it still took four attempts before it finaly downloaded the drivers into the extra folder in the same SDK directory

5-Vista wouldn't allow to choose the *.inf data,... choose to find the driver from the list of device drivers on pc and then choose to search drives, choose your sdkmanager folder/google/extra and the *.inf data

6-Vista finds two Androidphone devices in Device manager, for the first one choose Android Bootloader interface and the second Android composite ADB interface

7-You don't have to turn your OMC off like we had to do with the SanFrancisco last year, keep it on when it's plugged in...modaco's superboot and clockwork reboot the OMC themselves after the flash

After these steps modaco superboot and clockwork flashes flawlessly....

Edited by dadashi
0

Share this post


Link to post
Share on other sites

Posted (edited)

Finally got it rooted today, thanks to everyone who posted help esp Paul and Tillaz and Dadashi

Edited by Tony.h
0

Share this post


Link to post
Share on other sites

Posted (edited)

hello,

can i flash it into my ZTE Skate SFR (Staraddict) build: GB_P743FV1.0.0B03?

Edited by magikstar29
0

Share this post


Link to post
Share on other sites

Posted

hello,

can i flash it into my ZTE Skate SFR (Staraddict) build: GB_P743FV1.0.0B03?

im not sure is it an unlocked version you have ?

0

Share this post


Link to post
Share on other sites

Posted

sfr -> operator lock

im not sure is it an unlocked version you have ?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.