• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Trouble updating apps

10 posts in this topic

Posted

Hello Folks,

I am on StreakDroid 1.9.1

Most of the time I am getting "Package File is Invalid"

I've done following so far:

1. Reinstalled 1.9.1 and then try to update the apps, gives the same error message

2. Reinstalled 1.9.1, did factory reset, restored my apps using Platinum Backup and tried to update the apps, gives the same message

Anyone else have similar issue?

Any help please?

Thank you,

0

Share this post


Link to post
Share on other sites

Posted

I used to get that periodically when I was on SD 1.9.0. I'm on Simple Streak 1.2 now and have not had the problem return. This fix is NOT guaranteed to work but it might.

Settings==> applications==>All. Select Market app and delete data cache, cache and up at the top "delete updates". DO NOT delete the entire market app. Reboot and when finished enter the Market. You will have to accept the EULA again. That should help. If not, you might need to change the fingerprint to a stock fingerprint that the Market will accept.

kraz

0

Share this post


Link to post
Share on other sites

Posted

I used to get that periodically when I was on SD 1.9.0. I'm on Simple Streak 1.2 now and have not had the problem return. This fix is NOT guaranteed to work but it might.

Settings==> applications==>All. Select Market app and delete data cache, cache and up at the top "delete updates". DO NOT delete the entire market app. Reboot and when finished enter the Market. You will have to accept the EULA again. That should help. If not, you might need to change the fingerprint to a stock fingerprint that the Market will accept.

kraz

Hey Kraz, thanks for the help.

I tried what you suggested but no luck. I am not sure what do you mean by "changing the fingerprint to stock". Can you please explain a little bit about it?

Thank you again!

0

Share this post


Link to post
Share on other sites

Posted

Hey Kraz, thanks for the help.

I tried what you suggested but no luck. I am not sure what do you mean by "changing the fingerprint to stock". Can you please explain a little bit about it?

Thank you again!

Info on fingerprint

0

Share this post


Link to post
Share on other sites

Posted

Thank you Marvin! That helped. I did a fresh install, then did a factory reset and then restored my apps from Titanium Backup again and it seems to be working now.

However I do see that when I try download certain apps from the market, it complaints that "This app is incompatible with my phone". Is there anyways to force app to be installed?

I am using Trapster and i was trying to update it.

Thank you.

0

Share this post


Link to post
Share on other sites

Posted

Thank you Marvin! That helped. I did a fresh install, then did a factory reset and then restored my apps from Titanium Backup again and it seems to be working now.

However I do see that when I try download certain apps from the market, it complaints that "This app is incompatible with my phone". Is there anyways to force app to be installed?

I am using Trapster and i was trying to update it.

Thank you.

If you know that the app will work with your phone editing build.prop to change the fingerprint will probably allow you to install the app. What rom where you on when you first installed the apps in question? You can go here and click on the build number of the rom you had. Then download the update.zip file (most have them). Extract the files and then copy the fingerprint from that build.prop to your own. Of course you have to be rooted to do this, Some users report that they have issues updating after a Titanium Backup restore.

0

Share this post


Link to post
Share on other sites

Posted

If you know that the app will work with your phone editing build.prop to change the fingerprint will probably allow you to install the app. What rom where you on when you first installed the apps in question? You can go here and click on the build number of the rom you had. Then download the update.zip file (most have them). Extract the files and then copy the fingerprint from that build.prop to your own. Of course you have to be rooted to do this, Some users report that they have issues updating after a Titanium Backup restore.

Thanks for the quick reply. Will try that later this noon and will post back with my updates.

Thank you again!

0

Share this post


Link to post
Share on other sites

Posted

Thanks for the quick reply. Will try that later this noon and will post back with my updates.

Thank you again!

RESOLVED!!

All I had to do is uninstall the app, restarted the phone and installed the app from the market and it worked.

Thank you folks.

0

Share this post


Link to post
Share on other sites

Posted

RESOLVED!!

All I had to do is uninstall the app, restarted the phone and installed the app from the market and it worked.

Thank you folks.

Glad you got it sorted.

0

Share this post


Link to post
Share on other sites

Posted (edited)

@the.mister.D

Sorry for the late reply. I was going to reference the same post #219 at xda. marvin02 beat me to the post. AND, he was the original author of the post #219!!! Glad you got it fixed.

@marvin02

Thanks for the great Streak database you host!

kraz

Edited by krazman
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.