• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[APP] TPT Helper

158 posts in this topic

Posted

Well I say awesome, but I can't actually get it to work! I want a little more than the 160 system I currently have for ICS.

if I create a TPT of 160 system and 2mb cache then it's fine. If I try and create a different system size (I've tried 165, 170, 175, 180) and do check image directory it lists appsboot.mbn and partition_zte.mbn as no match on the md5 check.

Using a gen 1 Blade TPT'd to gen 2 (which I selected as the model on first use)

What am I doing wrong?

You don't need to use the check image option after making a TPT with custom partition sizes. That option downloads the files, checks the md5sums and then edits those 2 to give the sizes you wanted. As they have been changed, the md5sums are different from those listed in the nandroid.md5 file, so they won't match anymore if you use check image. Once it tells you the TPT has been built, you can just start it from there.

1

Share this post


Link to post
Share on other sites

Posted

That worked fine thanks! 170mb now. The only reason I even used that check is because it told me too when I attempted to start the tpt from within the rom and I thought ooh that sounds a good idea. :D

0

Share this post


Link to post
Share on other sites

Posted

my volume keys don't work. using your app, can I TPT from a CM7 rom? or does it only work with ZTE roms?

also for the same reason, I need touch recovery (which can be found here). can I replace the recovery.img found in the "image" folder with the touch one and it will be okay?

0

Share this post


Link to post
Share on other sites

Posted

my volume keys don't work. using your app, can I TPT from a CM7 rom? or does it only work with ZTE roms?

also for the same reason, I need touch recovery (which can be found here). can I replace the recovery.img found in the "image" folder with the touch one and it will be okay?

It only works on ZTE based roms like Swedish Snow. You can replace the recovery.img manually and it should be fine yeah.

1

Share this post


Link to post
Share on other sites

Posted

okay thanks.

0

Share this post


Link to post
Share on other sites

Posted

Sorry, but this programme doesn't work for me.

I've made custom tpt (2/140/299) and in tpt mode it stopped at:

load /mmc1/image/qosblhd_cfgdata.mbn

I had to remove battery and install from other image folder.

Same problem . . . not work for me . . . i had try stock 220/162/37 . . . freeze at load /mmc1/image/qosblhd_cfgdata.mbn

when i only upload image folder on sd card and use menu+power+volume+ phone was normally start . . . without green text

0

Share this post


Link to post
Share on other sites

Posted

Same problem . . . not work for me . . . i had try stock 220/162/37 . . . freeze at load /mmc1/image/qosblhd_cfgdata.mbn

when i only upload image folder on sd card and use menu+power+volume+ phone was normally start . . . without green text

Some phones seem to have a problem with the custom TPT files. I will try changing them for others that may work better in the next release.

0

Share this post


Link to post
Share on other sites

Posted

I have been trying to use a custom partition with 200 system 2 cache for my gen 1->(TPT)->gen 2 upgraded blade.

The TPT gets built, image directory checks out ok, but rebooting from the app, or manually by holding + and menu, both result in the green android logo, i.e. the TPT doesn't start.

I'm running Tilals coldfusion.

Is there anything i'm doing wrong?

Thanks

0

Share this post


Link to post
Share on other sites

Posted

Same problem . . . not work for me . . . i had try stock 220/162/37 . . . freeze at load /mmc1/image/qosblhd_cfgdata.mbn

when i only upload image folder on sd card and use menu+power+volume+ phone was normally start . . . without green text

The same as me :(

I can't get it to work to try ICS :(

0

Share this post


Link to post
Share on other sites

Posted

Same problem here... Made 165MB /system (2MB /cache, 274MB /data). It is an Orange San Francisco, a bit more than a year old, TFT model, bought used (so, I don't know what the previous owner did to it, received it like this).

Blade Checker reported:

European Blade (512MB RAM) detected

Stock/Windows Upgraded Gen 2 Phone detected

Use image.bin style TPTs

Current partition sizes:

System: 136MB

Data: 302MB

Cache: 2MB

My settings in the TPT Helper:

Phone Type: ZTE Blade/Orange San Francisco

Blade Gen: Stock Gen 2/3/Windows Upgraded Gen 2

ZTE Blade Type: European ZTE Blade

Phone Type: Orange San Francisco 2 (selected by default, didn't ask me)

I have probably given too much info, but I have no idea if this is due to the user error, or if it's something else. Being a second owner sometimes sucks...

0

Share this post


Link to post
Share on other sites

Posted

if it is Orange San Francisco it's stock Gen 1 unless upgraded with windows flasher - and then the partitions are not as they used to be. check your current partition size.

I made 190sys 2cache and the rest data using this wonderful tool, BUT I don't have vol keys so I had to install a genuine ZTE ROM (old wbaw's GSF) and start the TPT from there. you should try it.

0

Share this post


Link to post
Share on other sites

Posted

The same as me :(

I can't get it to work to try ICS :(

Hopefully the new files in the next version will fix this.

Same problem here... Made 165MB /system (2MB /cache, 274MB /data). It is an Orange San Francisco, a bit more than a year old, TFT model, bought used (so, I don't know what the previous owner did to it, received it like this).

Blade Checker reported:

European Blade (512MB RAM) detected

Stock/Windows Upgraded Gen 2 Phone detected

Use image.bin style TPTs

Current partition sizes:

System: 136MB

Data: 302MB

Cache: 2MB

My settings in the TPT Helper:

Phone Type: ZTE Blade/Orange San Francisco

Blade Gen: Stock Gen 2/3/Windows Upgraded Gen 2

ZTE Blade Type: European ZTE Blade

Phone Type: Orange San Francisco 2 (selected by default, didn't ask me)

I have probably given too much info, but I have no idea if this is due to the user error, or if it's something else. Being a second owner sometimes sucks...

Try changing the second setting to TPT Upgraded Gen 2, then making the TPT again. Some of the very first Gen 1 to Gen 2 TPTs used an old layout, so they show up as stock Gen 2 when they are not, this might be the case here.

1

Share this post


Link to post
Share on other sites

Posted (edited)

Try changing the second setting to TPT Upgraded Gen 2, then making the TPT again. Some of the very first Gen 1 to Gen 2 TPTs used an old layout, so they show up as stock Gen 2 when they are not, this might be the case here.

I was really tired last night when I wrote, so I somehow skipped your previous answer (general problem with some Blades, will be fixed in the next update).

Won't this brick my device if I choose the wrong one? Even if it does, I will unbrick it, but have to ask. The TPT size that I had was offered when I chose Stock/Windows upgraded.

Anyhow, before that I have to figure out how to force it to even enter the TPT - was a bit push me pull you the first time around, now it won't enter either TPT or CWM (except from the OS menu). I have installed the Swedish Snow in order to be able to run it from the TPT Helper, but to no avail, it just won't do a thing.

EDIT: My bad, tried what you suggested, worked like a charm! And my fear of bricking was for nothing :)

The others who have problems with freezes on load /mmc1/image/qosblhd_cfgdata.mbn should try to use the same logic, and maybe try to change their settings.

Thanks!

Edited by Nikola86BG
0

Share this post


Link to post
Share on other sites

Posted

I was really tired last night when I wrote, so I somehow skipped your previous answer (general problem with some Blades, will be fixed in the next update).

Won't this brick my device if I choose the wrong one? Even if it does, I will unbrick it, but have to ask. The TPT size that I had was offered when I chose Stock/Windows upgraded.

Anyhow, before that I have to figure out how to force it to even enter the TPT - was a bit push me pull you the first time around, now it won't enter either TPT or CWM (except from the OS menu). I have installed the Swedish Snow in order to be able to run it from the TPT Helper, but to no avail, it just won't do a thing.

EDIT: My bad, tried what you suggested, worked like a charm! And my fear of bricking was for nothing :)

The others who have problems with freezes on load /mmc1/image/qosblhd_cfgdata.mbn should try to use the same logic, and maybe try to change their settings.

Thanks!

The two TPT types (image.bin and Gen 1 to Gen 2) are incompatible. If you are trying to use the wrong one, then like you experienced, it won't even start.

I think the freezing on load /mmc1/image/qcsblhd_cfdata.mbn is a different issue. Some phones don't seem to like that version of the files (but it works fine on both that I tried it on). There are newer files that do seem to work, so when I get time to update it, I will change it to use them instead.

0

Share this post


Link to post
Share on other sites

Posted

The two TPT types (image.bin and Gen 1 to Gen 2) are incompatible. If you are trying to use the wrong one, then like you experienced, it won't even start.

I think the freezing on load /mmc1/image/qcsblhd_cfdata.mbn is a different issue. Some phones don't seem to like that version of the files (but it works fine on both that I tried it on). There are newer files that do seem to work, so when I get time to update it, I will change it to use them instead.

It did run. Twice. And I did get the freezing on load /mmc1/image/qcsblhd_cfdata.mbn. After that, it didn't want to start at all. That is what I'm saying, and it may well turn out that I am not the only one making this mistake. I am just the first one to remember to overload you with the data :)

0

Share this post


Link to post
Share on other sites

Posted

any way to tpt chinese blades without any isssues,,,,,,,,,,,,,,,,,,,,,,,,,,,

0

Share this post


Link to post
Share on other sites

Posted

any way to tpt chinese blades without any isssues,,,,,,,,,,,,,,,,,,,,,,,,,,,

If you're trying to install ICS, they should already have enough space on the system partition.

0

Share this post


Link to post
Share on other sites

Posted

Hi all,

Sorry for the probably idiot question, but I'm quite a newbie on flashing ROMs for my ZTE and want to avoid making mistakes...

I would like to flash "Swedish Snow RLS7 (Android 2.3.5) " on my ZTE Blade, European GEN1.

My understanding is that this ROM being GEN2, I first need to use TPT for upgrading it to GEN2.

What are the steps I should take on TPT ? Is there a way to directly upgrade to GEN2 and flash the ROM, or is this a 2 steps process ? Where should I put the downloaded ROM (on my SD?) and how do I get TPT to install this one ?

I didn't really find a step-by-step guide for newbies on this forum...

Thanks a lot for your answers

0

Share this post


Link to post
Share on other sites

Posted

Hi all,

Sorry for the probably idiot question, but I'm quite a newbie on flashing ROMs for my ZTE and want to avoid making mistakes...

I would like to flash "Swedish Snow RLS7 (Android 2.3.5) " on my ZTE Blade, European GEN1.

My understanding is that this ROM being GEN2, I first need to use TPT for upgrading it to GEN2.

What are the steps I should take on TPT ? Is there a way to directly upgrade to GEN2 and flash the ROM, or is this a 2 steps process ? Where should I put the downloaded ROM (on my SD?) and how do I get TPT to install this one ?

I didn't really find a step-by-step guide for newbies on this forum...

Thanks a lot for your answers

dell xcd 35 or idea blade?
0

Share this post


Link to post
Share on other sites

Posted (edited)

***EDIT - for the record.. sometimes it helps to talk - i made the new TPT for a GEN 1 - after finding a wiki on it****

***rule that applies to me... as it was a GEN 1 device - that had been TPT'd to Gen 2, i would still need a Gen 1 TPT***

Hi, i hope that someone can help me out?

I have a zte blade OLED

Blade Checker Says:

European Blade (512MB RAM) detected

TPT Upgraded Gen 2 Phone detected

Use Gen 1 style TPTs

Current Partition sizes:

System : 160 MB

Data : 294 MB

Cache : 2MB

Now.. the ICS rom i want to upgrade to is

[iCS] [CM9] [4.0.4] ColdFusionX for the ZTE Blade [ROM] [uPDATED - 09/05]

from searching through threads ive found that people have suggested System size of 200MB - 220MB

So following advise i found your other tool

TPT Helper

Detects Blade

Detects European Blade

Now asks for Blade Gen...

By stock, my phone was a Gen1 - so i select "other" from the list

Stock Gen2

Stock Gen3

Other

Unknown

Then it asks:

Gen 1

Stock Gen 2

TPT upgraded Gen 2

Windows Upgraded Gen 2

Stock Gen 3

TPT upgraded Gen 3

Windows upgraded Gen 3

Unknown

here i dont know which option to choose as "Blade checker Says"

TPT Upgraded Gen 2 Phone detected

Use Gen 1 style TPTs

so from the 2 options do i choose?

TPT Upgraded Gen 2 Phone detected

TPT upgraded Gen 2

OR

Use Gen 1 style TPTs

Gen 1

So the other bit would be i set System to

Cache to what? 2MB (for ics?)

System to : 220 (for ics?)

System : 160 MB

Data : (will be autoset by remainder)

please advise?

Cheers and thanks for reading!

Edited by Jesta99
0

Share this post


Link to post
Share on other sites

Posted

hello, whenever i try to make a custom TPT it hangs on the message "unzipping, please wait" I have tried making different TPT sizes, 185MB and 190MB system but it never finished unzipping.

Am I just being impatient, should this process take a long time? Thanks

0

Share this post


Link to post
Share on other sites

Posted

In opposite to other posters I had no problems with my TPTed Gen1 to Gen2 Blade.

@Jesta99 I selected "TPT upgraded Gen 2"

Then I used the custom sized TPT with 2MB cache / 220 MB system.

Works perfectly with all ICS Roms...

0

Share this post


Link to post
Share on other sites

Posted

When I select gen 2 upgraded via TPT (which my phone is), when i try to make a custom TPT I dont get the downloading screen - it goes straight to unzipping and never finishes.

I have selected my phone as gen 2 stock (even though I upgraded via TPT) and it now lets me create custom TPTs. If I flash it to my phone now, will it brick it? Thanks

0

Share this post


Link to post
Share on other sites

Posted

When I select gen 2 upgraded via TPT (which my phone is), when i try to make a custom TPT I dont get the downloading screen - it goes straight to unzipping and never finishes.

I have selected my phone as gen 2 stock (even though I upgraded via TPT) and it now lets me create custom TPTs. If I flash it to my phone now, will it brick it? Thanks

Probably not. Normally the TPT just shouldn't be applied. But since it won't work anyway I wouldn't risk trying it.

0

Share this post


Link to post
Share on other sites

Posted

Hi all,

Sorry for the probably idiot question, but I'm quite a newbie on flashing ROMs for my ZTE and want to avoid making mistakes...

I would like to flash "Swedish Snow RLS7 (Android 2.3.5) " on my ZTE Blade, European GEN1.

My understanding is that this ROM being GEN2, I first need to use TPT for upgrading it to GEN2.

What are the steps I should take on TPT ? Is there a way to directly upgrade to GEN2 and flash the ROM, or is this a 2 steps process ? Where should I put the downloaded ROM (on my SD?) and how do I get TPT to install this one ?

I didn't really find a step-by-step guide for newbies on this forum...

Thanks a lot for your answers

You can convert to Gen 2 and install the rom directly using the TPT method in the Swedish Snow thread. If you want to be able to install ICS roms later, then you might want to use a different TPT to convert to Gen 2 and then flash Swedish Snow via recovery as the Swedish Snow TPT will not give you a big enough system partition for ICS.

***EDIT - for the record.. sometimes it helps to talk - i made the new TPT for a GEN 1 - after finding a wiki on it****

***rule that applies to me... as it was a GEN 1 device - that had been TPT'd to Gen 2, i would still need a Gen 1 TPT***

Hi, i hope that someone can help me out?

I have a zte blade OLED

Blade Checker Says:

European Blade (512MB RAM) detected

TPT Upgraded Gen 2 Phone detected

Use Gen 1 style TPTs

Current Partition sizes:

System : 160 MB

Data : 294 MB

Cache : 2MB

Now.. the ICS rom i want to upgrade to is

[iCS] [CM9] [4.0.4] ColdFusionX for the ZTE Blade [ROM] [uPDATED - 09/05]

from searching through threads ive found that people have suggested System size of 200MB - 220MB

So following advise i found your other tool

TPT Helper

Detects Blade

Detects European Blade

Now asks for Blade Gen...

By stock, my phone was a Gen1 - so i select "other" from the list

Stock Gen2

Stock Gen3

Other

Unknown

Then it asks:

Gen 1

Stock Gen 2

TPT upgraded Gen 2

Windows Upgraded Gen 2

Stock Gen 3

TPT upgraded Gen 3

Windows upgraded Gen 3

Unknown

here i dont know which option to choose as "Blade checker Says"

TPT Upgraded Gen 2 Phone detected

Use Gen 1 style TPTs

so from the 2 options do i choose?

TPT Upgraded Gen 2 Phone detected

TPT upgraded Gen 2

OR

Use Gen 1 style TPTs

Gen 1

So the other bit would be i set System to

Cache to what? 2MB (for ics?)

System to : 220 (for ics?)

System : 160 MB

Data : (will be autoset by remainder)

please advise?

Cheers and thanks for reading!

The Gen 1 to Gen 2 TPTs which are used on TPT upgraded Gen 2 phones are Gen 1 style TPTs. You should pick the TPT upgraded Gen 2 option (although it actually doesn't matter as its just setting the type of TPT to use and its the same for both those options). It should be clearer in the next release.

When I select gen 2 upgraded via TPT (which my phone is), when i try to make a custom TPT I dont get the downloading screen - it goes straight to unzipping and never finishes.

I have selected my phone as gen 2 stock (even though I upgraded via TPT) and it now lets me create custom TPTs. If I flash it to my phone now, will it brick it? Thanks

It might take a few minutes to unzip, but if its taking longer than 5/10 mins, then that seems a bit strange. The files it needs are saved to your sdcard, so if there are already there it doesn't download them again. You could try deleting the TPT Helper folder from your sdcard to download it again in case something has been corrupted.

If you try and flash a stock Gen 2 TPT and your phone isn't that type, it should just not start. Its unlikely that it could brick it, but if you don't have that type of phone then there's no reason to try in case something does happen.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.