jusumgeezer

Really Bad Wi-fi on new SGS2 faulty phone or modem?

7 posts in this topic

Hi

just bought a GS2 I love the phone, but the wi-fi is terrible, pretty much non existent. However I'm not too sure exactly what the problem is

.

My home wi-fi is Virgin Media via a D-link router into the Virgin Modem (not the superhub, had too many problems with it) P.C's on the network connect fine, as does my SanFrancisco & ipod touch.

I have the modem/router in the livingroom but even if I sit in the same room (less than a metre away) the SGS2 has problems connecting & holding the connection.

It seems to be constantly searching & even lists other networks on my street fine. But Sometimes after I enter the password it says "remembered not in range" or connects for a few seconds then cuts out, barely long enough to connect to a webpage or the appstore.

I read that sometimes this phone can have problems connecting to networks with TKIP so have changed my router to AES only, I also installed WIFI Fixer, both seemed to have a temporarily improvement , but it's soon back to poor performance again.

I really don't know if this is a problem with Virgin Media, D-link routers or if I should return the phone? any thoughts on this greatly appreciated.

I installed MCR GR5 out of the box,

Baseband I9100HHKH3

Kernel: [email protected] #1

Thanks Guys

0

Share this post


Link to post
Share on other sites

I read elsewhere where someone replaced the wifi router and it improved, so it could be your wifi router?

Do you have any spare wifi router/device that you can borrow to test?

0

Share this post


Link to post
Share on other sites

yep, I still should have the superhub somewhere in the shed, but that was riddled with problems due to bad firmware/design by virgin. Maybe I should ask them about getting it changed & trying again, but it's a pain in the ass if the rest of my network goes to pot just for the chance the phone may connect better. I might see if I can get the phone swapped first, whilst its still so new.

0

Share this post


Link to post
Share on other sites

yep, I still should have the superhub somewhere in the shed, but that was riddled with problems due to bad firmware/design by virgin. Maybe I should ask them about getting it changed & trying again, but it's a pain in the ass if the rest of my network goes to pot just for the chance the phone may connect better. I might see if I can get the phone swapped first, whilst its still so new.

My WiFi isn't great either, Its ok but not great but although it may be low its never lost connection, I think its just a dodgy reading, I've also noticed a bit of a wifi death grip issue with this phone.

0

Share this post


Link to post
Share on other sites

To be honest over the past day or to it's seemed to have improved quite a bit. I'll see if it remains stable before I make any major changed, shop said I have 28 days to return it for faulty exchange.

0

Share this post


Link to post
Share on other sites

yep, I still should have the superhub somewhere in the shed, but that was riddled with problems due to bad firmware/design by virgin. Maybe I should ask them about getting it changed & trying again, but it's a pain in the ass if the rest of my network goes to pot just for the chance the phone may connect better. I might see if I can get the phone swapped first, whilst its still so new.

You should call VM and ask them to upgrade your Superhub to the R30 firmware, it's way more stable, and the Superhub does have very good wireless coverage as well as allowing you to user 5Ghz (although I don't think the SGS2 is dual band ;o)

0

Share this post


Link to post
Share on other sites

The SGS2 has a poor wireless antenna compared to most other devices; I could see and connect to an additional 3-4 networks from my desk with my old Blade as compared to my SGS2.

Also, a bit like the iPhone4, if you hold it in a normal grip the signal is reduced because the antennas are all packed into the 'lip' at the bottom of the phone, turn it around in your hand and you'll often gain some bars on both the Wifi and phone signal strength indicators.

Samsung seem to be somewhat in denial about this issue.

Edited by fLaMePr0oF
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.