• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[STOPPED] CyanogenMod Beta2 Omnia 2 (updated: 04.05.2012)

5247 posts in this topic

Posted

just the same as what you do in windows, in wm connect your i8000 with usb mass storage mode, choosing my storage or storage card, which due to where you want to install android and make partitions

So if I burn UBUNTU onto a CD, boot my laptop from the CD hence running UBUNTU

Can I then connect my phone using usb to the laptop now running UBUNTO

How can I now see the phone from UBUNTU to format and copy files

I appreciate your help

0

Share this post


Link to post
Share on other sites

Posted (edited)

So if I burn UBUNTU onto a CD, boot my laptop from the CD hence running UBUNTU

Can I then connect my phone using usb to the laptop now running UBUNTO

How can I now see the phone from UBUNTU to format and copy files

I appreciate your help

On your phone, go to settings

samsung -> General -> USB connection

select mass storage -> ok to confirm.

Connect your phone to your computer via USB.

Ubuntu should automatically mount your storage

Edited by synescu
0

Share this post


Link to post
Share on other sites

Posted

So if I burn UBUNTU onto a CD, boot my laptop from the CD hence running UBUNTU

Can I then connect my phone using usb to the laptop now running UBUNTO

How can I now see the phone from UBUNTU to format and copy files

I appreciate your help

No offence, but play around a bit with ubuntu, get used to terminal and its commands and so on. Then you learn to know what it does

When you get feeling with it, install gparted on your ubuntu. Make a back up of your sd and my storage. Connect your phone and try!

Because linux/ununtu is completely different from windows, it does things different then windows does. Therefore there is no explanation applicable from a windoze mindset.

If you really want to start now, just install gparted in ubuntu. It is a windows-style partition-manager which is easy to handle. It is self-explaining.

One thing: try google to understand primary, logical and extended partitions.

You can install it from commandline using the command 'sudo apt-get install gparted'

0

Share this post


Link to post
Share on other sites

Posted

in terms of comparison...:) to which device our O2 could compare from a native android terminal?

our performance could be better??in terms of speed?

by the way, great work from the developers!!!im testing now beta 3! really awesome work for them!!

thx!!!!

0

Share this post


Link to post
Share on other sites

Posted

No offence, but play around a bit with ubuntu, get used to terminal and its commands and so on. Then you learn to know what it does

When you get feeling with it, install gparted on your ubuntu. Make a back up of your sd and my storage. Connect your phone and try!

Because linux/ununtu is completely different from windows, it does things different then windows does. Therefore there is no explanation applicable from a windoze mindset.

If you really want to start now, just install gparted in ubuntu. It is a windows-style partition-manager which is easy to handle. It is self-explaining.

One thing: try google to understand primary, logical and extended partitions.

You can install it from commandline using the command 'sudo apt-get install gparted'

Thank you very much guys for this help,

Say now I booted UBUNTU from a CD, because I want to keep my windows installation intact

How do I get UBUNTU to connect to the internet using my broadband connection so that I can

download and Install gparted

0

Share this post


Link to post
Share on other sites

Posted

With Beta 2 i could only use 3G - HDSPA. Now, with beta 3, i can only use 2G - Edge and i can't disable "Only 2G connections". Checkede phone info in *#*#4636#*#* and i get "GSM Only" and can't change it. Need to use WCDMA to enable 3G, is there any workarround this?

0

Share this post


Link to post
Share on other sites

Posted (edited)

With Beta 2 i could only use 3G - HDSPA. Now, with beta 3, i can only use 2G - Edge and i can't disable "Only 2G connections". Checkede phone info in *#*#4636#*#* and i get "GSM Only" and can't change it. Need to use WCDMA to enable 3G, is there any workarround this?

Finally, someone with same problem as me! I played around with it. Took out sim, toggled 2G, flicked airplane mode and restarted (dont know which order i did it in, but i played around with it). Now i have ONLY 3G, and '2G only' unticks itself continuously.

I dont mind this too much, get decent internet speeds. But i would like to switch to 2G to save battery life.

Anyone else have this problem? Know a solution?

Edited by AoSra1n
0

Share this post


Link to post
Share on other sites

Posted

Holy s*** the camera is fast like hell now :D

0

Share this post


Link to post
Share on other sites

Posted

I used Automatic install package to install on SD card but I was stuck in "Would you like to use FAT32?..."

Then, it asked me "Yes/No/Cancel?". I can't answer as Omina dont have hard keyboard. What can I do?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Thank you very much guys for this help,

Say now I booted UBUNTU from a CD, because I want to keep my windows installation intact

How do I get UBUNTU to connect to the internet using my broadband connection so that I can

download and Install gparted

That was what I meant by my previous post.

Are you on wifi? If yes, search on google on your wifi card + ubuntu. Networkcable should work out of the box. If not, also google is your best friend.

My advise: put your networkcable into your computer and work from that if you only use ubuntu to connect to your phone.

There are tons of forums about ubuntu and connecting to the internet

Edited by erikcas
0

Share this post


Link to post
Share on other sites

Posted

I used Automatic install package to install on SD card but I was stuck in "Would you like to use FAT32?..."

Then, it asked me "Yes/No/Cancel?". I can't answer as Omina dont have hard keyboard. What can I do?

Remove all partitions from sdcard and install one more time.

0

Share this post


Link to post
Share on other sites

Posted

Bahh, after reboot a couple of times the My Storage partition table get corrupted. Tried flash a new rom to restore the original partition table and then create again a linux partition, but the problem still, stuck at Android Logo loading (not the Kernel one, the animated).

If anyone have some tip to restore "My Storage" partition table. Already tried rewrite mbr, wipe data with 00, etc, etc... nothing works. The FAT32 partition works fine, but seems that when i boot haret.exe some thing corrupt, then it get stucked at android logo loading.

0

Share this post


Link to post
Share on other sites

Posted

Bahh, after reboot a couple of times the My Storage partition table get corrupted. Tried flash a new rom to restore the original partition table and then create again a linux partition, but the problem still, stuck at Android Logo loading (not the Kernel one, the animated).

If anyone have some tip to restore "My Storage" partition table. Already tried rewrite mbr, wipe data with 00, etc, etc... nothing works. The FAT32 partition works fine, but seems that when i boot haret.exe some thing corrupt, then it get stucked at android logo loading.

As far as I remember to restore original partitions, You have to flash MST. But it's rather strange, because my android has rebooted several times with no problems.

1

Share this post


Link to post
Share on other sites

Posted

Some phones come by default with My Storage as a Primary Partition. Mine is one of them. To make a successfull install, it will be requiered to erase the partition and make a new extended and logical partition.

0

Share this post


Link to post
Share on other sites

Posted

None bugs! But camera has a very low resolution!

To restore MyStorage use NueStorageRecovery

0

Share this post


Link to post
Share on other sites

Posted

Bahh, after reboot a couple of times the My Storage partition table get corrupted. Tried flash a new rom to restore the original partition table and then create again a linux partition, but the problem still, stuck at Android Logo loading (not the Kernel one, the animated).

If anyone have some tip to restore "My Storage" partition table. Already tried rewrite mbr, wipe data with 00, etc, etc... nothing works. The FAT32 partition works fine, but seems that when i boot haret.exe some thing corrupt, then it get stucked at android logo loading.

If you have ubuntu, you could try this

Startup gparted, attach your phone, then gparted (in the menu) --> refresh devices

Now you should see my storage. Remove all partitions and unplug and reboot phone.

Let the phone format your storage if it asks.

Then again plug phone, refresh devices and make your partitions. unplug and reboot phone.

Worked several times wih me.

0

Share this post


Link to post
Share on other sites

Posted

None bugs! But camera has a very low resolution!

To restore MyStorage use NueStorageRecovery

Camera has full 5MP resolution. Change it in options.

1

Share this post


Link to post
Share on other sites

Posted

Bahh, after reboot a couple of times the My Storage partition table get corrupted. Tried flash a new rom to restore the original partition table and then create again a linux partition, but the problem still, stuck at Android Logo loading (not the Kernel one, the animated).

If anyone have some tip to restore "My Storage" partition table. Already tried rewrite mbr, wipe data with 00, etc, etc... nothing works. The FAT32 partition works fine, but seems that when i boot haret.exe some thing corrupt, then it get stucked at android logo loading.

The installation of a new rom will not mess withe the partitions ...

Just try to format them under WinMo ...

If you got something in your MyStorage, and install a new ROM, that data will not be erased ...

0

Share this post


Link to post
Share on other sites

Posted

boys!!! where find a tutorial for "my storage" installatiom????? in sd card is slow and lag. battery drain in 3 hours.

0

Share this post


Link to post
Share on other sites

Posted

boys!!! where find a tutorial for "my storage" installatiom????? in sd card is slow and lag. battery drain in 3 hours.

Follow steps on 2nd post

forum.xda-developers.com/showthread.php?t=1040025

0

Share this post


Link to post
Share on other sites

Posted

No USB should work. How d You think I'm using it? Time - airplane on-off or 3g connection on boot.

USB works after a few restarts :)

Time still wrong, I boot with 3g connection, also did airplane on-off but no luck, may be is just me, may be is because Froyo reports my phone number as Unknown, any way i can always use a workaround.

Thanks Devs!!! better everyday

0

Share this post


Link to post
Share on other sites

Posted

As far as I remember to restore original partitions, You have to flash MST. But it's rather strange, because my android has rebooted several times with no problems.

Yes, that is what i did, flash a full .mst rom, It restores the partition table. Then i recreate all partitions, should solve the problem, but didn't. Still stucked at Android logo loading.

If you have ubuntu, you could try this

Startup gparted, attach your phone, then gparted (in the menu) --> refresh devices

Now you should see my storage. Remove all partitions and unplug and reboot phone.

Let the phone format your storage if it asks.

Then again plug phone, refresh devices and make your partitions. unplug and reboot phone.

Worked several times wih me.

That is what i've been doing, several times, but does not work.

1) Rewrite partition table, recreate partitions. Partition Tool does not found any error.

2) Then i configure everything, run haret.exe, kernel load and jump to the Android (Loading animation) where it's stucked.

3) Right after reboot, if a plug my phone as usb device, Partition Tool will say that my Fat32 partition is corrupted.

The installation of a new rom will not mess withe the partitions ...

Just try to format them under WinMo ...

If you got something in your MyStorage, and install a new ROM, that data will not be erased ...

Maybe a custom rom, but a full (.mst) erases every thing. And if the partition table was modified, it will recreate the original partition table.

.

Thanks anyway. I've flashed a .mst rom about 4 times since yesterday, formating and erasing partitions several times.

I'll stop for a while to give a rest for my "MyStorage"

0

Share this post


Link to post
Share on other sites

Posted (edited)

Yes, that is what i did, flash a full .mst rom, It restores the partition table. Then i recreate all partitions, should solve the problem, but didn't. Still stucked at Android logo loading.

.......

If You have adb, connect phone to the computer while booting and view logcat (adb logcat) - it should show what prevents android from starting.

Edited by voyteckst
0

Share this post


Link to post
Share on other sites

Posted

Yes, that is what i did, flash a full .mst rom, It restores the partition table. Then i recreate all partitions, should solve the problem, but didn't. Still stucked at Android logo loading.

That is what i've been doing, several times, but does not work.

1) Rewrite partition table, recreate partitions. Partition Tool does not found any error.

2) Then i configure everything, run haret.exe, kernel load and jump to the Android (Loading animation) where it's stucked.

3) Right after reboot, if a plug my phone as usb device, Partition Tool will say that my Fat32 partition is corrupted.

Maybe a custom rom, but a full (.mst) erases every thing. And if the partition table was modified, it will recreate the original partition table.

.

Thanks anyway. I've flashed a .mst rom about 4 times since yesterday, formating and erasing partitions several times.

I'll stop for a while to give a rest for my "MyStorage"

have you changed, or added the Startup.txt to MyStorage?

0

Share this post


Link to post
Share on other sites

Posted (edited)

have you changed, or added the Startup.txt to MyStorage?

Yes, i guess i find the problem, see:

If You have adb, connect phone to the computer while booting and view logcat (adb logcat) - it should show what prevents android from starting.

Thanks, i can see the log, but it's too long and i can't copy from Windows Dos.

EDIT: I saw the log at Windows with "adb logcat". Some of the last lines was saying something about "couldn't extract apk /media". Hard to say, i don't remember puff ...

So i was going to load linux, there i could use the "adb logcat" and copy the message. But now i'm stuck at Kernel (Android on omnia 2 loading).

Seems that the partition was corrupted, now it does not jump from kernel to Android. Like i said before, i can format and try again but the problem would still. Tried several times, it's a partitiom problem.

Edited by rom_omnia2
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.