• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

<< LINK2SD GUIDE >> (UPDATED PLEASE READ)

161 posts in this topic

Posted · Report post

isnt possible use data2whatever in omc? thx =)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I formated to SD to 1 partition again with partition tool, then went into clockworkmod formatted the SD again and made a 2second 256mb (0m???) partition. When i rebooted into Atomic and put the format to ex2 and now i can install apps again :)

I have all apps installed i want,even more then i use so i think 256mb is enough and i still have the internal data free.

Did a 160mb system and 35mb cache TPT, with a 256mb partition in clockworkmod and all my problems are gone now :)

Its a perfect fit i made google music 4.1 a system app and its full now so thats perfect. And i have enough spacef for my apps now.

Edited by Wacky.ddw
0

Share this post


Link to post
Share on other sites

Posted · Report post

after you set this up you will notice that your internal memory is affected very little or not at all after installing apps.

i had 112 apps on my phone at one point with 125mb of free internal space

smile.gif

Followed the tutorial, but in settings I can only see 62.25mb Available space, with a total space of 162MB (Internal Storage). Is this correct or did I miss something?

JC

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

your not getting the mount script error with back ups because the script is already created in the back up, it looks like its failing to create new scripts for you, not sure why though... have you tried using another sdcard to successfully create the mount script then add your other card back once the script is created.

Edited by tillaz
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

read only normally means its not getting root permission to allow write, have you tried using root explorer to set it to allow all permissions on link2SD manually?

Edited by tillaz
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

read only normally means its not getting root permission to allow write, have you tried using root explorer to set it to allow all permissions on link2SD manually?

I tried this the first time i had this but it allready said rw instaid of ro

http://forum.xda-dev...d.php?t=1031980

But its fixed now, its just weird i have to restore it in 2 times. :S

Edit:

I flashed the new kernel for Atomic and then made a backup (backup A), then removed all apps that my friends wont use/need removed my accounts etc. Then i made a backup from that (backup B).

When i restored back to backup A everything was working i had all the apps i deleted back, scripts where working and i could install apps.

And i can flash backup b to my friends phone and link2sd still works.

So everthing is working could this be kernel related, or where my previous backups currupted?

Edited by Wacky.ddw
0

Share this post


Link to post
Share on other sites

Posted · Report post

hey all,

tillaz first off, love your work! im currently using atomic and it works fantastically.

i have encountered a problem, however, when i use minitool partition i get an error when trying to create the second partition. "Minitool partition wizard cannot create a new partition on this removable disk. If you want to create several partition on this removable disk, you need to delete all the partitions first". also my computer wont detect it :/

oh and i can move apps to the sd through the phone without errors

does anyone know whats wrong/ how to solve?

thanks

val

0

Share this post


Link to post
Share on other sites

Posted · Report post

hey all,

tillaz first off, love your work! im currently using atomic and it works fantastically.

i have encountered a problem, however, when i use minitool partition i get an error when trying to create the second partition. "Minitool partition wizard cannot create a new partition on this removable disk. If you want to create several partition on this removable disk, you need to delete all the partitions first". also my computer wont detect it :/

oh and i can move apps to the sd through the phone without errors

does anyone know whats wrong/ how to solve?

thanks

val

You can also reboot into clockworkmod format your SDcard there first and make a external partition trough clockworkmod, it works better for me :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

You can also reboot into clockworkmod format your SDcard there first and make a external partition trough clockworkmod, it works better for me :)

ah ok, brill thanks. i actually found what was wrong in the end, dont know how i managed it but i think it was my removable hardware drivers :S i plugged it in another computer and it popped up in 'my computer' with no problems

0

Share this post


Link to post
Share on other sites

Posted · Report post

knowing it was the driver, i did a system restore back to a few days ago and it fixed it :D

thanks

val

0

Share this post


Link to post
Share on other sites

Posted · Report post

How can you resize the ext partition in minitool, I make space from my main partition but still can't add to my second????

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello guys

I always followed the website, but I never write anything. I used Atomic Rom since issue 2.5, and for the version 4.0, I did some changes on the files (I put the LauncherPro back, for instance), but installed like a dream. I tested the CynogenMod for some days, and then I back to Atomic :-)

My question is more or less like below from Link2SD. On Cynogen, after I retore all my apps, i had like 100Mb internal free and using big part of my 2nd partition. Now, when i back with Atomic, after restore the same apps (33 apps), I have around 35Mb internal, and 69% free of the 2nd partition. What Im doing wrong, I had no error messgaes, all the times installed OK and works. But I really doesnt understand why my internal is allways low, all do all the cleanings with Link2SD sometimes...

Please, this getting me crazy, and I didnt find any answer yet, so if someone can give me an advice, I appreciate!

Thanks!

Fernando

Followed the tutorial, but in settings I can only see 62.25mb Available space, with a total space of 162MB (Internal Storage). Is this correct or did I miss something?

JC

0

Share this post


Link to post
Share on other sites

Posted · Report post

Quick question about Link2SD. This is not regarding an OMC but a Samsung Galaxy Ace ("SGA"), I have posted on the relevant forum but they seem to be pretty slow in answering.

I bought for my wife SGA a 16gb sd card. I would like to use Link2SD like i have done with my OMC. I have tried a couple of time following the tutorial on the first page of this post but it does not seem to work (I am getting a SD Card damaged message and then ask me to reformat the card).

The questions I have are:

1. Phone is not rooted, is this a problem?

2. Do I follow exactly the tutorial like for an OMC or do I have to change any parameter?

3. If anyone knows of a tutorial to follow specific to the SGA please send me the link

Thanks for any help and sorry as I realise that it is the wrong forum. Thanks

JC

0

Share this post


Link to post
Share on other sites

Posted · Report post

Quick question about Link2SD. This is not regarding an OMC but a Samsung Galaxy Ace ("SGA"), I have posted on the relevant forum but they seem to be pretty slow in answering.

I bought for my wife SGA a 16gb sd card. I would like to use Link2SD like i have done with my OMC. I have tried a couple of time following the tutorial on the first page of this post but it does not seem to work (I am getting a SD Card damaged message and then ask me to reformat the card).

The questions I have are:

1. Phone is not rooted, is this a problem?

2. Do I follow exactly the tutorial like for an OMC or do I have to change any parameter?

3. If anyone knows of a tutorial to follow specific to the SGA please send me the link

Thanks for any help and sorry as I realise that it is the wrong forum. Thanks

JC

yes, you need to be rooted

this tutorial will work for all phones

0

Share this post


Link to post
Share on other sites

Posted · Report post

Re: mount script errors

There has just been an update to Link2SD released to the market which apparently fixes certain mount script errors - I'm NOT sure if these are related to the issues being reported here, but it may be worth installing the latest version from the Market to see if it fixes anyone's issues.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

yes, you need to be rooted

this tutorial will work for all phones

Thanks tillaz, I will root the phone and try it. Is the unallocated space the same as for the OMC, I have seen tutorials where they allocated a bigger space?

JC

EDIT: For some reasons this method don't work on the Galaxy ace, it keeps saying that the SD card is damaged and when I go to Settings/storage the SD card does not show, if I select to mount the card, it basically asks me to format the card and lose the partition. I may have a look at this method and see if it works:

http://androidforums.com/samsung-galaxy-ace/360571-tut-how-force-install-apps-sd-card-without-root.html

Edited by jeannot18
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks tillaz, I will root the phone and try it. Is the unallocated space the same as for the OMC, I have seen tutorials where they allocated a bigger space?

JC

EDIT: For some reasons this method don't work on the Galaxy ace, it keeps saying that the SD card is damaged and when I go to Settings/storage the SD card does not show, if I select to mount the card, it basically asks me to format the card and lose the partition. I may have a look at this method and see if it works:

http://androidforums...thout-root.html

i think its your sdcard, if you have an omc that is set up for link2sd and working fine just pop than sdcard in the galaxy ace and see if it works,

if it dose then the other sdcard has a problem.

some lower quality sdcards are knowing not to be able to handle the repartition, but the way you setup the sdcard is not phone specific its universal like the sdcard

0

Share this post


Link to post
Share on other sites

Posted · Report post

i think its your sdcard, if you have an omc that is set up for link2sd and working fine just pop than sdcard in the galaxy ace and see if it works,

if it dose then the other sdcard has a problem.

some lower quality sdcards are knowing not to be able to handle the repartition, but the way you setup the sdcard is not phone specific its universal like the sdcard

Thanks tillaz, I don't know what the problem was. It could be that I was setting up the second partition as Fat32 instead of Ext2. I use this method at the end:

I did root the phone first

http://www.postiar.com/post/25584/applications-on-the-sd-with-link2sd-froyo-and-gingerbread.html

Thanks anyway tillaz

JC

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi, just wondering how I go about using link2sd with multiple SD cards and also do I need to do anything to the internal memory to free up some space?

Cheers

p.s. Can it transfer apps between sd cards?

Edited by sonofignorance
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello,

i need help , i tried to follow the guide to the link2sd however now my phone can't recognize my sd card and so my computer. what can i do ? how can i revert it ?

thank's

Elad

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello,

i need help , i tried to follow the guide to the link2sd however now my phone can't recognize my sd card and so my computer. what can i do ? how can i revert it ?

thank's

Elad

reformat in partition wizard

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

reformat in partition wizard

Hi tillaz , thank's for your help. how can i see the sd card in 'partition wizard' if it wont recognize on my computer ?<div><br></div><div>i will explain : i think i can't see SD card on computer since i can't mount it on my phone and this is because it wont recognize on my phone. does it mean i need to use Micro sd card reader to connect to PC and then format ?</div><div><br></div><div>&nbsp;thank's

Elad

</div>

Edited by ellevy12
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hey guys could do with some help. Trying to get through this tutorial with my second SD card (32gb). I followed the partionning section to the key except getting the partion to 507.54 exactly. Ended up with 3 partions 1. 30.5gb fat32 primary 2. 495mb apx fat32 primary 3. 15mb logical. I don't know if this is the problem but when open link2sd and I selected Fat32 it says the following:

Mount script error

mount script cannot be ceated.

Mount: Invalid argument

and it didn't tell me to reboot.

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello

I'm using Link2Sd for a while now ( since more or less the day I have the ZTE Skate , because of the poor 162Mb of internal memory reserved for the apps )

I'm pretty happy with it .. except after each reboot of the device ... the 2nd partition is not mounted at start-up

I have to do "fast reboot" once or twice ... to have it back and get back all my apps that are linked to the SD.

I should maybe try Atomic V5 (or V6) , to see if it's the same ( compare to V4 )

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi all,

i managed to work out the tutorial !!

however , i have a question about the internal memory : i have about 87 MB used and i dont know how to free them up. any suggestions ?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.