Racerboy

[ROMS] Latest 2.3.7 cm7.1.0/7.2.0 Racerboy-ROMS

1927 posts in this topic

so it's back to square one again :D

:P until the proprietarys are sorced for it or can be fettled so they do work.

pretty much, yes.. we do have those armv6 egl for ics but they dont work on racer, i cant tell why but probably because of other libs that needs editing and i cant fix any of them.. deadlink might since i think he wrote ril for gen2 and others but who knows when will we see him online

2

Share this post


Link to post
Share on other sites

I just installed Racerboy's update-cm-7.2.0-RC1-racer-signed and I am pretty impressed with it so far however I did find some problems which may or may not be related to CM.

My digital compass is out by 112 degrees and points East instead of North I read somewhere this is a known bug with CM but isn't there someway of fixing this or has anyone attempted it??

Secondly the wifi tethering option is broken is can broadcast SSID just fine but when connected either open or wpa2/psk it never assigns an IP address to the client (tested on Windows XP and Android 2.1).

Does Racer tethering work with CM7.20 or just not for this ROM??

I have Barnacle as an alternative but it's adhoc which is fine for laptops but not Android phones they won't connect to ad-hoc networks.

Thirdly the Power Control widget gets stretched on the desktop but not in vertical layout or when setting up the buttons.

Is this known problem with Power Control and CM??

Fourthly the low battery warning light (blinking red) is set to 10% or below is there anyway to change this to 5%??

And now probably the most serious problem, using Wifi and Bluetooth audio (a2dp) doesn't play together nicely.

I listen to Digitally Imported using their Android app "com.audioaddict.di" this works well with the Stock 2.1 and my Bluetooth headphones.

However when I try the same setup with Racerboy's ROM wifi connectivity crawling like a dialup modem it keeps loosing throughput and eventually dies.

When I disconnect my headphones the application contiunes as normal but through the speaker which isn't what I want.

If I listen to Digitally Imported using my Android 2.1 + Bluetooth headpones next to the other Racer with Racerboy's ROM both play fine without buffering.

This is a real shame I quite like the DSP audio effects (and yes I have same problem with DSP disabled) but Wifi + Bluetooth isn't stable enough for me. :(

Is this a known CM problem or with this ROM??

Apart from that everything else seems stable enough apart from Bluetooth audio.

Richard S.

Edited by redhawkuk
0

Share this post


Link to post
Share on other sites

you shoud totally try a different release.. as for low battery indicator, i think thats in framework, i know i decompiled mine to change values but dont see whats the problem with it being on 10%

1

Share this post


Link to post
Share on other sites

I guess it's just a habit of mine I prefer to run the batteries down on my phones before I charge them that way I am performing a full charge / discharge cycle.

I can still get quite a bit of usage out of my Racer at 10% which is why I think at warning light at 5% would be preferable, however some might disagree.

Anyway I'm going to try a few other ROMs it's just a pity about the Bluetooth and Wireless connectivity otherwise it would have been perfect.

Richard S.

0

Share this post


Link to post
Share on other sites

So far I have tested the following ROMs and none have been able to provide Wifi Tethering or stable Bluetooth Audio with Wifi internet radio streaming:

Racerboy: update-cm-7.2.0-RC1-racer-signed

Racerboy: update-cm-7-20120225-NIGHTLY-Racer-v2-signed

Racerboy: cm7_2.3.7_Racer_full-224 download without swap

Rexchun 2.3.4 B0 English - poor touch sensitivity

Equiliym Sense-Like Racer Sense 2.3 Release 2

Equiliym Sense-Like Racer Sense 2.2 Release 3 - tethering mode reboots handset, bluetooth a2dp is low bit rate quality but Wifi still works with performance hit.

I did some searching and these CM7 problems seem to present with ZTE Blade as well as the ZTE Racer gen1 http://code.google.c.../detail?id=3659

If you want to test the Bluetooth problem yourself you don't even need a Bluetooth headset just do the following:

Enable Wifi and Bluetooth then run the Digitally Imported Radio app (or Sky or any other streaming app) in the background.

Go to "Wireless and networks", "Bluetooth settings" and tick the "Discoverable" box.

After about 5 seconds Digitally Imported should skip and chock to death due to no wifi connectivity.

It's all very strange and very annoying considering Bluetooth and Wifi work flawlessly with the stock 2.1 ROM. :mellow:

Richard S.

Edited by redhawkuk
0

Share this post


Link to post
Share on other sites

have you tried setting wifi not to disconnect when screen goes off? maybe its that.. i also dont recall anyone reporting a bug on senselike 2.2r3 for that, would have checked it

1

Share this post


Link to post
Share on other sites

It's not a screen issue the wifi connection just simply dies as soon as there is Bluetooth activity i.e. Bluetooth Audio streaming.

I've tried nearly every CM7 based ROM so far only sense like 2.2 r3 and RickyWyatt 2.2 ROM have work but with erratic download speeds.

I can tell this for a fact because the Digital Imported radio application has a data buffer indicator to show download progress.

With Android 2.1 this indicator is always full however with Android 2.2 the buffer jumps up and down between 50 to 100%.

Perhaps Android 2.2 / 2.3 have increased Bluetooth priority over wifi communications I just don't see any reason why both devices can't co-exist.

Richard S.

0

Share this post


Link to post
Share on other sites

you cant tether both bt and wifi if thats what you are doing

also you might want to try different kernels

1

Share this post


Link to post
Share on other sites

Edit: fixed it for her, great rom.

Edited by Atomix86
0

Share this post


Link to post
Share on other sites

I am actually trying to tethering my Mobile 3G network but using the built-in tethering support of Android 2.2 / 2.3 just doesn't work.

In the end I used a tethering application from the Google Market I guess that's why people write these programs in the first place.

As for the Bluetooth / Wifi conflict I think CM7 is at fault perhaps only Racer / Blade are affected but needless to say a problem that requires investigating and fixing.

For the time being I'm staying with Android 2.2 at least I can still use the *983*0# "AudioLoop" hack to boost the volume on my headphones. ;)

Richard S.

0

Share this post


Link to post
Share on other sites

yeah i saw on blades forum they have this too, users say thats common for most devices

1

Share this post


Link to post
Share on other sites

Hi, I installed update-cm-7.2.0-RC1-racer-signed in my zte racer recently but after 3 days I can't hear anyone during calls. it just works on speaker. I did a hard reset and it stills the same. does anyone had the same problem?

I had android 2.1 eclair before installing this rom.

Need some help, please. :(

0

Share this post


Link to post
Share on other sites

Does it work if you reboot??

Richard S.

Edited by redhawkuk
0

Share this post


Link to post
Share on other sites

I never thought I would get to say this but I now have Bluetooth audio and Wifi working together with CM7 although wifi connectivity is still a bit unstable like Android 2.2.

The problem seems to be related to the Kernel so far I've been trying out all ROMs distributed with the Vamshi Kernel however today I tried one with Deadlink's - Racerboy ICS MOD #252 ICS Mod Deadlink Kernel.

Do any of these kernel authors still come here it would be interesting to get some feedback with regards to Wifi / Bluetooth connectivity conflicts??

btw: I still can't get Asphalt 5 in game music to work with any CM7 ROM Vamshi or Deadlink for that matter, is this a known problem with Asphalt 5 and Android 2.3??

Richard S.

Edited by redhawkuk
0

Share this post


Link to post
Share on other sites

regadring that post, i dont play games on racer due to low ram so i dunno.. i played poker tho and it had music.. as for kernels, you can get deadlinks kernel on his github, just google it, vamshi never released his source

1

Share this post


Link to post
Share on other sites

Hello, after upgrading to ROM # 257, everything worked ok, except the wifi and bluetooth, they activate and deactivate automatically seconds later, the Mac's wifi is also not showing what I do to solve this problem? My phone is gen2 phone with a 3.2mp cam, i installed the ROM + Patch using clockworkmod...

Thanks in advance.

0

Share this post


Link to post
Share on other sites

Hi, install update-cm-7.2.0-RC1-racer-signed on my ZTE Racers, work for 2 days without any problem until the third day, desconfiguro the touch screen not working as it should work and I can not do anything. What should I do?, Can you help me?

1

Share this post


Link to post
Share on other sites

Hello, after upgrading to ROM # 257, everything worked ok, except the wifi and bluetooth, they activate and deactivate automatically seconds later, the Mac's wifi is also not showing what I do to solve this problem? My phone is gen2 phone with a 3.2mp cam, i installed the ROM + Patch using clockworkmod...

Thanks in advance.

hey can you tell all the pros and cons of the #257 rom u have upgraded to as i am also thinking of upgrading my racer to it
0

Share this post


Link to post
Share on other sites

HI, ME SOMEONE OF THE LINK FOR THE KERNEL 2.6.35.7 ZTE RACER

0

Share this post


Link to post
Share on other sites

Thanks Racerboy for the lastest ROM , great job ! I'm coming from a stock 2.1 ROM and this one work perfectly , finaly i can install all 2.2 and up apps ^__^

Here a shot from my Racer cm7 on sslauncher ( need 2.2 and up )

Senza_titolo_1.jpg

0

Share this post


Link to post
Share on other sites

Hello all,

I installed again, the problem persists green screen ...

I noticed that when the language is english, reset the device the problem is solved.

but when we change the language to Portuguese (which is my case) the green screen still appears when changing the orientation of the screen or open a program.

Anyone know how to solve this?

It seems weird... but the screen flash appeared on my phone for english ()US) and english (UK)... But it disappeared for German ... So now i have my phone in german and no more green screen when rotating...

0

Share this post


Link to post
Share on other sites

I have a problem with update-cm-7.2.0-RC1-racer-signed ... The Gallery does not update. I had to install quickpick... and can't choose personalised ringtones-notifications... if I put the files on media/audio/notifications, they don't even appear on ringtone selection... Any clues?

0

Share this post


Link to post
Share on other sites

I have a problem with update-cm-7.2.0-RC1-racer-signed ... The Gallery does not update. I had to install quickpick... and can't choose personalised ringtones-notifications... if I put the files on media/audio/notifications, they don't even appear on ringtone selection... Any clues?

you should try adding sdcard speed fix to your init.d, will boost your sd read speed thus gallery and other related apps that uses sdcard will read/work faster.. i always include that in my roms p;

1

Share this post


Link to post
Share on other sites

you should try adding sdcard speed fix to your init.d, will boost your sd read speed thus gallery and other related apps that uses sdcard will read/work faster.. i always include that in my roms p;

Problem solved... I realised i had deactivated the media server on startup... So, even if i triggered a media scan, it wouldn't start...

0

Share this post


Link to post
Share on other sites

Problem solved... I realised i had deactivated the media server on startup... So, even if i triggered a media scan, it wouldn't start...

that kind of thing never crossed my mind D:

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.