• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

CM7 & MMS Issues

20 posts in this topic

Posted · Report post

Hello everybody.

I have been noticing a bug on CM7 for quite some time now. It's a known bug, that affects many devices (actually, I *believe* it affects them all), and that me and Tom_G have discussed recently. I created this topic for the purpose of having a place where people can actively discuss the issue and gather all the relevant info. While I could discuss it in the official CM7 topic, it'd get lost between all the other messages.

First of all, some brief notions of how MMS work: MMSs are data sent over your carrier. This means that you need Data Enabled in order to send a MMS. You can activate Data on Settings, although it comes enabled by default on CM7 (Settings -> Wireless & Networks -> Mobile Network). Without Data Enabled, your MMS will fail to send, and you will not be able to receive MMSs either.

In order to send a MMS, you also need a MMS APN. There are two main types of APN that concern the topic: MMS and Internet APN. Both are related to the usage of Data by the network, and the network knows how to differentiate "MMS Data" from "Internet Data" . However, they are independent, and you are not required to use "Internet Data" in order to use the MMS APN.

The problem with CM is exactly that: for some reason, on CM7 you *need* a functional Internet APN in order to send a MMS. That is not how it is supposed to work, nor it is how it works on other ROMs (for example, GSF). For those with a Data plan, this is a minor bug. But for those without one, this means I have to pay for a day of Internet Data (1.29€) everyday I want to send/receive a MMS. If CM7 allowed me to send/receive solely based on the MMS APN (like it is supposed to), no Data would be charged (my phone plan includes unlimited MMSs to everyone on my carrier).

2G/3G does not interfere with the process itself; having 3G enabled simply makes sending/receiving data faster. You can still receive MMSs on 2G.

That being cleared out, let us see how you can test if you have the issue or not:

- Step 1: Make sure your MMS APN is well configured. (Settings -> Wireless & Networks -> Mobile Networks -> Access Point Names).

- Step 2: Delete your Internet APN, or click on it and change its "APN" field (I changed mine from net2.vodafone.pt to 123net2.vodafone.pt; whenever I want it working again I'll just go there and take the 123 out).

- Step 3: Try to send a MMS without the functioning Internet APN.

- Step 4 (optional): Try sending a MMS with the Internet APN correctly configured.

- Step 5: Report your results.

I am currently away from home but will be posting logcats of this issue soon. MMSs work as they should on GSF (they work without an Internet APN), if someone wants a comparison. I tried pushing MMS.apk app to CM7, but it didn't solve the issue: Tom_G suspects it is in the framework. Perhaps it'd help if Wbaw told us which apps he copied from CM7 to his ROM (and therefore, which apps do not appear to be responsible for the issue).

Thanks for your time!

Blues003

2

Share this post


Link to post
Share on other sites

Posted · Report post

The problem with CM is exactly that: for some reason, on CM7 you *need* a functional Internet APN in order to send a MMS.

Not true

Tom_G suspects it is in the framework.

When the problem was originally described I suspected it was in the framework, but now that I have tested on several of my devices (including blade) and not been able to replicate the problem I'm not so sure. For me it all functions as it should. It may be related to a problem with APNs, so please when reporting your results include the name and country of your provider.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Not true

I am sorry, I worded it wrong. In *my* case, that is how that is happening. :)

When the problem was originally described I suspected it was in the framework, but now that I have tested on several of my devices (including blade) and not been able to replicate the problem I'm not so sure. For me it all functions as it should. It may be related to a problem with APNs, so please when reporting your results include the name and country of your provider.

I doubt it has to do with the APNs, as I have tried configuring them manually and through a market App (APN Portugal, which always worked for me on other ROMs), and the end result is the same. Also, comparing the CM7 APNs to the ones that work on GSF/other Roms/the ones recommended by my carrier, there are no differences.

In any case, I am on a ZTE Blade bought in Portugal, on the portuguese Vodafone carrier.

0

Share this post


Link to post
Share on other sites

Posted · Report post

This bug also affects other CM roms with different devices.. so its no related to blade

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

This bug also affects other CM roms with different devices.. so its no related to blade

As matter of interest, which Android AOSP version was it that it worked under... I know its in Gingerbread 2.3.5, its the historical thing I am querying about, did it work okie in Froyo.... get the drift? ;)

Since GSF, in which Blues003 stated that it works fine no problem, which suggests that something was changed in CM7's framework in relation to the MMS, either through the low level framework or in the app package itself.... a line missing from the java code or similar that is causing the issue that is seen in CM7 and not in AOSP.

My take is this, GSF is based on AOSP stock code, CM7 is forked from there, with modded enhancements so its quite possible that something got deleted in there or taken out when the AOSP code got merged into the CM7 repo for modding... :)

Edited by t0mm13b
0

Share this post


Link to post
Share on other sites

Posted · Report post

My take is this, GSF is based on AOSP stock code, CM7 is forked from there, with modded enhancements so its quite possible that something got deleted in there or taken out when the AOSP code got merged into the CM7 repo for modding... :)

GSF is not forked directly from AOSP, the ZTE roms are forked from CAF (which is forked from AOSP but includes a lot of changes).

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

#

Edited by kirkintokyo
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I don't think it does need a "functional" internet apn, although mms's do send fine under my internet apn.

For me, If i delete my internet apn and keep the mms apn, then reboot the phone, mms's won't send.

Then if I disable mobile data then re-enable it, mms's will send and auto receive fine under my mms apn.

Then after reboot, mms's won't send again.

So something goes wrong during boot if using a mms only apn.

In gsf and my stock froyo rom, mms's send and receive fine regardless whether mobile data is enable or disabled(but auto receive is easily disabled under messenger settings).

So I think mms's are supposed to send and receive regardless of mobile data being on or off.

I don't mind to have mobile data turned on (when i only have a mms apn set up) but having to remember to disable then re-enable mobile data is well a "bug".

I'm running cm7.1 but ive always had the same problem on all cm versions i've tried.

If i knew how I would love to make a patch, but i just don't have a clue how to edit source code.

I hope somebody somewhere is kind enough to fix this bug

Sorry for the long explanation.

Edited by kirkintokyo
0

Share this post


Link to post
Share on other sites

Posted · Report post

I don't get the issue here. I'm using GSF b27

I'm on O2 IRL and yes if I disable data then I can't send an MMS, obviously you need to have your a data apn configured whether it be an MMS or Internet data you want to send/receive.

I'd be in exactly the same boat as Blues003 as I'm on prepay:

"But for those without one, this means I have to pay for a day of Internet Data (1.29€) everyday I want to send/receive a MMS"

So all I did was copy my apn settings for O2 IRL so now that I have 2, the only change i've made is the apn type:

My normal "Data" apn type is set to: default,supl

Whereas my "MMS" apn type is set to: mms

No issues, when I send an MMS with data disabled, the "MMS" apn is used, quickly connecting to send the message and then disconnecting again once done.

Can't you simply do the same in CM7, split out your apn settings instead of using one global for "default,supl,mms"?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have exactly the same problem in 2 differents ZTE BLADE with CMT 7.1.0 stable.

The carriers are:

Vodafone PORTUGAL

Optimus PORTUGAL

It would be wonderful to solve this...

1

Share this post


Link to post
Share on other sites

Posted · Report post

I have exactly the same problem in 2 differents ZTE BLADE with CMT 7.1.0 stable.

The carriers are:

Vodafone PORTUGAL

Optimus PORTUGAL

It would be wonderful to solve this...

I have this issue to on n251....

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I really think that someone don´t want to see the problem.

But this is a BIG bug. On any other ROMS- stock, Swedish Spring, Moldavian Mountain Mile High, sending MMS works fine without data connection ON.

In my case: APNs set manually, data connection off, try to send MMS, hangs on sending(happens on all CM7 nightlys and stable).

On any other ROM same settings,data connection off, when sending MMS data connection turns on by itself and turns off when MMS is send. Same goes for receiving. For people without free mobile data like me it´s one of the options:

1) Pay for a day of internet data and have data connection on the whole day(drains battery);

2)No MMS at all;

With my carrier(Swedish Comviq) I have free mms and it goes through mms apn instead of internet one on all other Roms so I am not charged for it.

SO SORRY BUT THIS IS A CYANOGENMOD BUG. NO FIX WHATSOEVER.

That stops me from using Cyanogenmod till it´s fixed cause I love all the other goodies in it.

Keep up a good work Devs.

Edited by zabtcent
0

Share this post


Link to post
Share on other sites

Posted · Report post

I have MMS and don't pay for internet.

I only have the MMS APN, and I have to uncheck and check the "data connection" on (I have to uncheck and check it everytime I reboot), this way it works.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have MMS and don't pay for internet.

I only have the MMS APN, and I have to uncheck and check the "data connection" on (I have to uncheck and check it everytime I reboot), this way it works.

But isn´t it like it shouldn´t be. What happens if you want to use internet, hmm? And I don´t get it that people really don think that tis is an issue. CM is very good but this should be fixed. I hope it will

0

Share this post


Link to post
Share on other sites

Posted · Report post

it´s an issue that comes from CM6.. my x10mini has the same bug..

0

Share this post


Link to post
Share on other sites

Posted · Report post

I dont have problem with APN, but i have problem with resolution MMS. I sent big image, but it resized in auto-mode to 192x256. I cant find settings where i can choise send MMS-image resolution :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

Having both problems here - must enable data before sending an MMS, otherwise it will try to send it for a couple of minutes and fail with no data connection produced.

Attaching picture to a message also resizes it to something completely unusable. I haven't measured the size, but pictures of hundreds of kilobytes down ot 1-10 kilobytes.

My phone is a ZTE Blade with sej's CM7-7.2.0-RC0-KANG-n257plus2

0

Share this post


Link to post
Share on other sites

Posted · Report post

Having both problems here - must enable data before sending an MMS, otherwise it will try to send it for a couple of minutes and fail with no data connection produced.

Attaching picture to a message also resizes it to something completely unusable. I haven't measured the size, but pictures of hundreds of kilobytes down ot 1-10 kilobytes.

My phone is a ZTE Blade with sej's CM7-7.2.0-RC0-KANG-n257plus2

same issue with the same rom..

my carrier is TIM-IT

0

Share this post


Link to post
Share on other sites

Posted · Report post

Exact the same happens to me. No MMS send/receive without data turned on.

I tried 3 ways that i´ve seen in web and that worked with some:

- "Use root explorer, and make sure it is set to R/W mode (read/write). Navigate to /data/data/com.android.providers.telephony/databases/telephony.db and delete that file, then restart your phone. After the restart, you should be able to send and receive MMS messages."

- "On the settings of internet APN, replace APN type: where is 'default,supl', delete supl (apn type is only 'default')"

- "Use a APN app"

None this worked with me.

Carrier: TMN (Portugal)

(this problem seems to be frequent on portuguese blades, right? But only happens on some, lots of people don´t have this problem)

0

Share this post


Link to post
Share on other sites

Posted · Report post

I don't think it does need a "functional" internet apn, although mms's do send fine under my internet apn.

For me, If i delete my internet apn and keep the mms apn, then reboot the phone, mms's won't send.

Then if I disable mobile data then re-enable it, mms's will send and auto receive fine under my mms apn.

Then after reboot, mms's won't send again.

So something goes wrong during boot if using a mms only apn.

This worked. But... Not a satisfactory solution.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.