Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Archos 80 G9 Root (Phase 1)

76 posts in this topic

Posted · Report post

As you may have read on my Twitter feed, I have been busy working away on root for the Archos 80 G9. And here is Phase 1.

This portion gives you root access via ADB. This does not installed Superuser.apk / su, that is Phase 2 which is in the works now. You do need to do this before you can do the next bit, so no reason to wait! ;)

You follow these instructions at your own risk!

Note: This method is only tested against ROM versions 3.2.22 and 3.2.46.

How-to

Simply follow the instructions below and you will finish up with root access via ADB (root shell).

  1. Ensure you have ADB installed on your machine. If you do not, you can download it here - DOWNLOAD (ROMraid).
  2. Open a command / terminal window.
  3. Ensure you can see your device in ADB - do 'adb devices' (or 'adb-windows devices' / 'adb-linux devices' / 'adb-mac devices' as appropriate). If you do not and you are using Windows, check device manager to ensure that you have any required drivers installed. If you still can't see your device or are not using Windows, edit adb_usb.ini (which can be found at 'C:\Users\%USERPROFILE%\.android\adb_usb.ini' on Windows and '~/.android/adb_usb.ini' on Mac / Linux) and add the line ' 0x0e79' before restarting adb ('adb kill-server').
  4. Download 'Step 1' of the root process - DOWNLOAD - MD5: 6645915d4f252888a9dc0303519b15a6
  5. Download 'Step 2' of the root process - DOWNLOAD - MD5: dc16d0c53bc420be4b898481e31fdc2a
  6. With the 2 files in your current directory and your device connected issue the following commands (waiting for the device to reboot after the reboot commands):

    adb push 1 /data/local/
    adb push 2 /data/local/
    adb shell chmod 0755 /data/local/1
    adb shell chmod 0755 /data/local/2
    adb shell /data/local/1
    adb reboot
    adb shell /data/local/2
    adb reboot[/code]


  7. And that's it! Now when you connect via adb shell you should see the '#' prompt which means you have a root shell. Easy! :)
  8. P

    PS Thanks go out to lilHermit who assisted with packaging this exploit. :)

1

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you very much...looking forward for the phase 2 :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

great

if you want i testing on Archos 101 Gen 9 ?

but if you have the drivers for 7 64bits

send me a link or a solution

Edited by cajl-jbmm
0

Share this post


Link to post
Share on other sites

Posted · Report post

I strongly suspect this will work on the 101. Please try! :)

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

good news paul..try when archos send me a new tablet..the first send them for display problem..

0

Share this post


Link to post
Share on other sites

Posted · Report post

I strongly suspect this will work on the 101. Please try! :)

P

for

adb shell reboot : operation not permitted , i use asb reboot fot the step 1 and 2

but i have the "#" only the "$" with adb shell

if you have a solution for the 101 , i will be testing that

for the 80 it is ok

ps i have all archos !

0

Share this post


Link to post
Share on other sites

Posted · Report post

for

adb shell reboot : operation not permitted , i use asb reboot fot the step 1 and 2

but i have the "#" only the "$" with adb shell

if you have a solution for the 101 , i will be testing that

for the 80 it is ok

ps i have all archos !

Ah yes, I meant to write 'adb reboot'. :D

Hmmm, so it doesn't work on the 101 then... you can help me by sending me some files, i'll PM you.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I just got my 80 G9 tablet and am loving it. When I get home from work tonight I'll try rooting it. Thanks for the great review and the root guide Paul!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Ah yes, I meant to write 'adb reboot'. :D

Hmmm, so it doesn't work on the 101 then... you can help me by sending me some files, i'll PM you.

P

Ok paul

i wait your files

for SU il dl the apk from the market

but this apk don't work

abd when i use Setcpu i said : no root

Edited by cajl-jbmm
0

Share this post


Link to post
Share on other sites

Posted · Report post

Is possible overclock, the processor is same turbo version..

0

Share this post


Link to post
Share on other sites

Posted · Report post

i think NOT

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is possible overclock, the processor is same turbo version..

Accually turbo version has newer OMAP4 chip. Not the same that 1ghz models have.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Accually turbo version has newer OMAP4 chip. Not the same that 1ghz models have.

are you sure?

read in wikipedia:

http://en.wikipedia....nstruments_OMAP

omap 4430 work from to 1ghz to1,2ghz..

for me the processor is same..there is different multiplier..

Edited by superino
0

Share this post


Link to post
Share on other sites

Posted · Report post

are you sure?

read in wikipedia:

http://en.wikipedia....nstruments_OMAP

omap 4430 work from to 1ghz to1,2ghz..

for me the processor is same..there is different multiplier..

the 1.5ghz turbo version will be the one using new omap 4460 .

i hope they will make 1.8ghz version also using omap 4470 chips.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

for the 8GO omap4430 1 Ghz

fort he 16go omap4430 1.2Ghz

fort he 250go omap4460 1.5Ghz

the really diiff is the GPU

4430 : PowerVR SGX540 @ 304 MHz

4460 : PowerVR SGX540 @ 384 MHz

1 ghz or 1.2 ghz it is the same ....

i wait the 1.5 ghz

Edited by cajl-jbmm
0

Share this post


Link to post
Share on other sites

Posted · Report post

hi paul

after the root have you sound ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

if you have problem when you use android_winusb.inf

replace by this

android_winusb.txt

rename this .txt fie on .inf file and copy in your rep of usb_driver

i use this file because my OS is senven 64 bits

0

Share this post


Link to post
Share on other sites

Posted · Report post

The method works perfectly on my Archos 80 G9 and my Archos 101 G9 machines... Thanks a lot for this!

Are there any news about phase 2 (superuser.apk)?

0

Share this post


Link to post
Share on other sites

Posted · Report post

on your 101 gen 9 Great

for my 101 it is not possible

what is your frimwre ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

on your 101 gen 9 Great

for my 101 it is not possible

what is your frimwre ?

I just updated to 3.2.56 a few minutes before trying this.

0

Share this post


Link to post
Share on other sites

Posted · Report post

thanks

i dont use thoses commands with the new firmawre...

0

Share this post


Link to post
Share on other sites

Posted · Report post

just don't feel alarmed if your devices gets stuck in the second reboot (mine did :-)).

switch it off and on again and everything should be fine.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I just updated to 3.2.56 a few minutes before trying this.

yes it is good

post-936273-0-40601000-1319130865_thumb.

But i have no sound now !

Edited by cajl-jbmm
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

and my 101 wont wake up from standby anymore :-(

i will reset the device to factory defaults and try again later...

Edit:

Retried it after a complete reset of the device to factory defaults.

Same result again, tablet works fine, root shell is accessible but the wakeup from standby won't work anymore, just leaving me with a blank screen and the need to turn the power off and on again...

Edited by trace3k
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

and my 101 wont wake up from standby anymore :-(

i will reset the device to factory defaults and try again later...

Edit:

Retried it after a complete reset of the device to factory defaults.

Same result again, tablet works fine, root shell is accessible but the wakeup from standby won't work anymore, just leaving me with a blank screen and the need to turn the power off and on again...

I had the same problem, update or downgrade your firmware version, this will clear the root too!

Download one of these to your Archos and run it:

Version 3.2.56 (Latest as of 21/10/11): http://update.archos..._archos_it4.aos

Version 3.2.46: http://update.archos..._archos_it4.aos

Version 3.2.22 (Oldest): http://update.archos..._archos_it4.aos

Edited by Woshmistro
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.