• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[KERNEL] TechnoLover's Kernel Edition 1.5 (25.06.2012)

762 posts in this topic

Posted · Report post

Techno is back! :D I should change my playlist now. :blink:

1.5 works very well on Gingerounnay 3.0.1

No more power button issue. Just sometimes a litte power button lag lower then 1 second.

Really nice work! ;)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I know I probably shouldn't ask this but, are you planning on adding anything to this kernel on 1.6? I would like to know what's coming up! Or is the project finished?

Edited by Mtman1
0

Share this post


Link to post
Share on other sites

Posted · Report post

I have lost my boot sound when blue android logo comes up on boot used to make a sound and vibrate on stock and 1.4 kernel using 1.5 now and not working?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have lost my boot sound when blue android logo comes up on boot used to make a sound and vibrate on stock and 1.4 kernel using 1.5 now and not working?

0

Share this post


Link to post
Share on other sites

Posted · Report post

it consumes the battery faster than a cigarette!

0

Share this post


Link to post
Share on other sites

Posted · Report post

it consumes the battery faster than a cigarette!
Only if you have it overclocked ;) but lol
0

Share this post


Link to post
Share on other sites

Posted · Report post

My GPS stays on in next to signal never used to come up till I used Google maps ect wont go off unless I turn off completely never happened on 1.4c

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi all

I have got a problem, indeed i triyed to install this kernel but when the phone reboot after installation, the phone freezes on the screen technolover's edition.

I'm in stock rom 2.3.6 and i installed busybox so i need your help thanks ;) (sorry for my bad english, i'm french)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi all

I have got a problem, indeed i triyed to install this kernel but when the phone reboot after installation, the phone freezes on the screen technolover's edition.

I'm in stock rom 2.3.6 and i installed busybox so i need your help thanks ;) (sorry for my bad english, i'm french)

You must use this busybox installer by JRummy Apps Inc.

Bysubox by Stephen (Stericson) not work properly with TechnoKernel.

Restore original kernel in recovery, boot device and install busybox by JRummy, then inside bysubox installer run busybox installation process and after try to flash TechoKernel.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks the problem is fixed.

This new kernel is great thanks to Genrix and Technolover's :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

why you don't add swap support?

0

Share this post


Link to post
Share on other sites

Posted · Report post

i think no need of spaw here, especially if you use you SD for storing apps

0

Share this post


Link to post
Share on other sites

Posted · Report post

i've notice this kernel has the same problem of the 1.3...

after open camera or play a video the fps are at 43! :( is possible to fix it in any way?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Is there some documentation to build and pack the kernel?

EDIT:

I tried to build the kernel, but I get errors when building the ath6kl driver (wifi), can someone help me?

I'm using the config I found on my device (using kernel 1.5)

These are the errors I'm getting: http://pastebin.com/mkpxCQid

To build the kernel:

http://source.androi...ng-kernels.html

You need a Linux box (I tested it on a Debian system).

-Create a work directory

mkdir android

cd android
-Download the android prebuilt
git clone https://android.googlesource.com/platform/prebuilt
-Set env variables:
export PATH=$(pwd)/prebuilt/linux-x86/toolchain/arm-eabi-4.4.3/bin:$PATH

export ARCH=arm

export SUBARCH=arm

export CROSS_COMPILE=arm-eabi-
You can put these lines in a file env.sh and load it with the following command instead of setting every env variable every time you need it
source env.sh
-Download kernel source:
git clone git://github.com/marcOcram/Acer-Liquid-MT-Gingerbread-Kernel.git
-Configure the kernel. You can find the current kernel configuration on the Acer Liquid Metal (if you're using Technolover's Kernel) in the file proc/config.gz
cd Acer-Liquid-MT-Gingerbread-Kernel/kernel

make menuconfig
-Build the kernel
make

Edited by sakya
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

No one knows how to fix the problem with the wifi driver?

I tried to build the kernel without the ath6kl driver and install it on my device: the kernel works, but obviously wifi doesn't work. :(

EDIT:

I found a solution (the only?).

The driver cannot be built from the source code: I reused the file ar6000.ko found in the zip of Technolover's Kernel and added to my pack.

I also had to change the setlocalversion script in the kernel source to remove the additional "+" that adds after "-perf", else the driver would not load

EDIT: If anyone is interested this is the kernel I built, it's the same as version 1.5 but with swap enabled

Download it here

EDIT: And this is the same kernel built with the Linaro toolchain

Download it here

Edited by sakya
0

Share this post


Link to post
Share on other sites

Posted · Report post

It's possible/recommended to apply Techno Kernel after about a 2 weeks of a fresh install of CM7?

0

Share this post


Link to post
Share on other sites

Posted · Report post

anyone??

0

Share this post


Link to post
Share on other sites

Posted · Report post

freak, question is: Why shoud be not?

Sure, is possible.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah you can

0

Share this post


Link to post
Share on other sites

Posted · Report post

In the next release, can you try to port the usb–host feature? Is it possible?

It should be possible, devs have managed to port it to Gingerbread powered devices like the Galaxy S. It would be an epic feature :D

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Yeah you can

I mean because i have installed cm7 since one month ago, and i did not know so far, that if I apply this kernel i would have any compatibility trouble or not.

Before I apply the kernel do i need to do wipe to dalvik cache or any other thing?

It is possible to unistall it?

Edited by freakk
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi, is there a way to modify gpu voltage? I'd like to undervolt gpu.

I use technolover's kernel 1.3a and I haven't found such option.

Edited by Carter07
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi, is there a way to modify gpu voltage? I'd like to undervolt gpu.

I use technolover's kernel 1.3a and I haven't found such option.

with 1.5 you can do it through the Liquid MT control app (by technolover) and I'm pretty sure you can do it with 1.3, just download the app and go :D
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Mtman, I tried updating MT control to v1.4 but it's the same.

I can find only options to control cpu voltage but not gpu voltage.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.