PaulOBrien

1 Nov V20l: Stock Gingerbread for ClockworkMod (rooted / rooted+deodex)

85 posts in this topic

So... Flashed v20l extracted 725BB, restoring from CWM right now.. Will report for changes

0

Share this post


Link to post
Share on other sites

Is GPS working in this release? I can't get GPS fix...

BR

That gb release has the same problem like others. If you boot with the gps off you cant get any position but if you reboot with the gps "on" you can fix gps.

Also I flashed a 20l from xda and every reboot dalvik-cache is rebuilded, anyone ?

BR.

Edited by yukkio
0

Share this post


Link to post
Share on other sites

So... Flashed v20l extracted 725BB, restoring from CWM right now.. Will report for changes

Oh my, something's definitely changed here.. 1st time opening GMaps at my balcony (clear view of the sky - 1st use of GPS) got a GPS fix in less than 10s with 7m accuracy - best ever seen on th o2x.

Strange behaviour:

A) Momentarily i see the HSPA icon turning white (no connection to google servers supposedly ) and green again, w/out any loss of data connection though

B)When i get GPS fix, the GPS icon dissapears (fix remains strong @ 7m)

0

Share this post


Link to post
Share on other sites

That gb release has the same problem like others. If you boot with the gps off you cant get any position but if you reboot with the gps "on" you can fix gps.

Also I flashed a 20l from xda and every reboot dalvik-cache is rebuilded, anyone ?

BR.

Cannot confirm this. I flashed the v20l-extracted BB and restored Paul's deodexed-rooted v20l. Upon boot i had GPS toggle off and despite that, as i mention above, i got the fastest n most accurate GPS fix ever seen (by me lol) on the o2x.

0

Share this post


Link to post
Share on other sites

So... Flashed v20l extracted 725BB, restoring from CWM right now.. Will report for changes

Well there certainly is a difference. I flashed the new BB and LGMobile Support Tool now identifies the version as V20L instead of V20C - I'm still running Gr4.

I think LG BB versions are a bit like kernel versions - the number may stay the same, but there might be some significant changes!

0

Share this post


Link to post
Share on other sites

@ lap33733 (and people plagued w the data/cell connection issues)

Give the new v20l-extracted 725BB a try (links a few posts above). GPS fix is super-fast and till now ive had no issues with data/cell. Maybe.. maybe we got a winner (fingers crossed)

0

Share this post


Link to post
Share on other sites

@ lap33733 (and people plagued w the data/cell connection issues)

Give the new v20l-extracted 725BB a try (links a few posts above). GPS fix is super-fast and till now ive had no issues with data/cell. Maybe.. maybe we got a winner (fingers crossed)

Which fls file did you use? The R375_SIC.fls?

0

Share this post


Link to post
Share on other sites

Which fls file did you use? The R375_SIC.fls?

All four files. See here.

0

Share this post


Link to post
Share on other sites

Which fls file did you use? The R375_SIC.fls?

I flashed one fls after the other, in size order (r375, aeneas, slb,psi). Upon flashing each one, i disconnect the phone when i see the (2nd) LG logo (when at 100% and green 'completed' appears at smartflash u momentarilly see the LG logo, then the software update screen again, then black screen and then the LG logo again - right after that), close Smartflash, open it again, connect phone and repeat the flashing with the next fls. Hope im making myself clear

0

Share this post


Link to post
Share on other sites

I flashed one fls after the other, in size order (r375, aeneas, slb,psi). Upon flashing each one, i disconnect the phone when i see the (2nd) LG logo (when at 100% and green 'completed' appears at smartflash u momentarilly see the LG logo, then the software update screen again, then black screen and then the LG logo again - right after that), close Smartflash, open it again, connect phone and repeat the flashing with the next fls. Hope im making myself clear

Thanks both of you, must have overseen "all files":)

I wait for the 20l to install again.

0

Share this post


Link to post
Share on other sites

@ lap33733 (and people plagued w the data/cell connection issues)

Give the new v20l-extracted 725BB a try (links a few posts above). GPS fix is super-fast and till now ive had no issues with data/cell. Maybe.. maybe we got a winner (fingers crossed)

This V20L 0725 baseband + RIL combi is really good so far!

It fixed my "H not reverting to 3G after background data" (assume is fast dormacy?) and "Wifi turn off after phone sleeps" issues on Gr4!

0

Share this post


Link to post
Share on other sites

This V20L 0725 baseband + RIL combi is really good so far!

It fixed my "H not reverting to 3G after background data" (assume is fast dormacy?) and "Wifi turn off after phone sleeps" issues on Gr4!

Everything does seem to be quite stable, havent seen the phone behaving like this for some time now. I do however notice a rather big battery drain for some reason, anyone else seeing this?

0

Share this post


Link to post
Share on other sites

Check your super user app!

Apologies, just me taking things for granted. Installed SuperUser and it works fine.

0

Share this post


Link to post
Share on other sites

Am using this ROM together with 725 and am still experiencing data issues on my Vodafone network. These issues were also there on GR4, but no issues experienced with Cyanogen 7.1.0 and baseband 725.

So based on everyones more recent posts, it appears that this could be related to the actual version of 725 being used. Having looked back at where I got my current 725, it was from the link provided on Pauls GR4 release. Interestingly, when I click on this link, the file name states v20c!!! Is it as simple as this being the issue ? Never quite understood why some people experienced the issue, whereas others didnt, but this might explain it.

GetRIL has my current RIL as 0725 (V20l, Italy) and says its a match (Just for info)

Will flash the baseband from the link below and feedback on data connections.

http://forum.xda-developers.com/showpost.php?p=18972567&postcount=62

0

Share this post


Link to post
Share on other sites

Every reboot dalvik-cache is rebuilded... so boot time is much

0

Share this post


Link to post
Share on other sites

Back to gr4 + topogigi tweaks + HP SR1 That's more stable for now.

0

Share this post


Link to post
Share on other sites

Thanks alot! (V20L stock with root has root for me)

Is there a way to bring up the about phone dialog without going through settings? (It crashes for me..)

Upgrading the baseband to the V20l 725 solves the crashing!

0

Share this post


Link to post
Share on other sites

If i have a ext4 ROM on my phone atm do i need to do a ext4->ext3 for this rom to work?

0

Share this post


Link to post
Share on other sites

Regarding BB 823, it is important to flash all four otherwise O2X will not work properly - or at least mine didn't. After flashing the remaing 3 fls's then I started receiving text messages which has been "lost" for 3-4 days....

Will do the ROM update later this evening when I'm more sure about the BB823 :)

But what is the difference between the two ROM's Paul has put here, I'm not familiar with "deodexe" thingy, sounds like something you put under your arms.

0

Share this post


Link to post
Share on other sites

I tried to flash the new baseband. The first file OK. The second timed out. I even restarted the PC to be sure.

Did this happened to anyone? Any ideas how to overcome the obstacle?

0

Share this post


Link to post
Share on other sites

I tried to flash the new baseband. The first file OK. The second timed out. I even restarted the PC to be sure.

Did this happened to anyone? Any ideas how to overcome the obstacle?

Happened to me as well, so I flashed in a different order -> 1,3,2,4.

Not sure if order is really important, everything seems to work :P.

0

Share this post


Link to post
Share on other sites

Regarding BB 823, it is important to flash all four otherwise O2X will not work properly - or at least mine didn't. After flashing the remaing 3 fls's then I started receiving text messages which has been "lost" for 3-4 days....

Will do the ROM update later this evening when I'm more sure about the BB823 :)

But what is the difference between the two ROM's Paul has put here, I'm not familiar with "deodexe" thingy, sounds like something you put under your arms.

Deodex means that apps starts quicker, lg made o2x for a quick first boot to impress us and journalists instead of making the usage as fast as possible. Booting with deo first time takes a while, I prefer that option. Anybody correct me if I am wrong;)

0

Share this post


Link to post
Share on other sites

Happened to me as well, so I flashed in a different order -> 1,3,2,4.

Not sure if order is really important, everything seems to work :P.

Now I managed to flash the first three. I get the time out error on the fourth! Yak. It is getting annoying

Edit:

I managed to flash all of them, the phone is starting......wow....boot loop? what in the name of Ζeus!

Edit 2: I'am the unlucky one. Boot loop and I don't know what I did wrong. So I am flashing back the 725 of V20C, let's see....flashed ok....restarting...wait for it, wait for it and......boot loop again!

I am destroyed...

Edit 3: I did a nandroid restore and it seems ok. I am so stupid but I will try again!

Edited by Tsaglis
0

Share this post


Link to post
Share on other sites

Now I managed to flash the first three. I get the time out error on the fourth! Yak. It is getting annoying

Edit:

I managed to flash all of them, the phone is starting......wow....boot loop? what in the name of Ζeus!

Edit 2: I'am the unlucky one. Boot loop and I don't know what I did wrong. So I am flashing back the 725 of V20C, let's see....flashed ok....restarting...wait for it, wait for it and......boot loop again!

I am destroyed...

Edit 3: I did a nandroid restore and it seems ok. I am so stupid but I will try again!

This is what i did and worked as a charm (copied from a few posts b4)

I flashed one fls after the other, in size order (r375, aeneas, slb,psi). Upon flashing each one, i disconnect the phone when i see the (2nd) LG logo (when at 100% and green 'completed' appears at smartflash u momentarilly see the LG logo, then the software update screen again, then black screen and then the LG logo again - right after that), close Smartflash, open it again, connect phone and repeat the flashing with the next fls. Hope im making myself clear

EDIT: btw does anybody notice a rather high battery drain? Im on 50% after about 7-8 h on battery with very light use

Edited by Ximo F. Verde
0

Share this post


Link to post
Share on other sites

I'm a newbee so clearly don't mistake me for an expert :lol:

I first flashed the big one, thought that was it and then upgraded the BB and RIL to 823, then found that nothing was really working stable, then saw that I should also flash the three smaller files as well - did that and everything worked again :P text phone gps wifi BT etc.thumps up.

I noticed that the phone was rebooting after each flash - so it's important to stay alert at depress the vol down button during boot. :blink:

Would also like to add, that I tried this new release in the first posting - that didn't go well - there seems to be some conflicts between the 823 BB / RIL stuff and the new ROM. applications crashing and I couldn't hardly reboot into recovery since the sdcard didn¨t mount and I couldn't manually mount it. So finally I took out the battery when rebooting into recovery just the sec before it started booting - then finally it did mount the sdcard so I could revert to GR4.

I probably did something wrong :o

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.