• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Superboot - Galaxy Nexus root solution

101 posts in this topic

Posted · Report post

Could someone answer my questions please?

Can we apply r3 over r2 directly or do we need to perform some task prior applying r3?

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

Could someone answer my questions please?

Can we apply r3 over r2 directly or do we need to perform some task prior applying r3?

Thanks

Just apply r3 - it is fine if you have already applied r2 - it doesn't effect it.

0

Share this post


Link to post
Share on other sites

Posted · Report post

My vibrate function seems to have stopped working after this. Maybe it happened as part of the bootloader unlocking, not sure.

Anyone else got the same problem?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Running R3 in Linux and I get:

$ ./install-superboot-linux.sh

./install-superboot-linux.sh: line 2: ./fastboot-linux: No such file or directory

Running ./fastboot-linux directly gives me the same error. The file is definitely in the directory.

Anyone any ideas?

Edited by micflan
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Switched over to Windows and got the phone rooted. Thanks!

I had to install the the PDANet software to install the usb-drivers before it got past the "Waiting for device" screen though, as jmagee pointed out. You can download PDANet here.

Edited by micflan
0

Share this post


Link to post
Share on other sites

Posted · Report post

I've had my phone for all of 3 days but I've got quite a bit configured & setup. Is there anyway to backup my apps, settings etc without root?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've had my phone for all of 3 days but I've got quite a bit configured & setup. Is there anyway to backup my apps, settings etc without root?

Rooting does not wipe your phone but unlocking the bootloader does - have you not unlocked yet? If you have then rooting will not remove you data.

To back up data requires root I think. You can back up SMS via one of many apps from the market. What data are you trying to keep?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Rooting does not wipe your phone but unlocking the bootloader does - have you not unlocked yet? If you have then rooting will not remove you data.

To back up data requires root I think. You can back up SMS via one of many apps from the market. What data are you trying to keep?

:( I was looking for an answer to this question ... I was hoping there was some way to do this without wiping my phone. Will it always be this way or is there a possibility of unlocking bootloader without wipe in the future?

Another question - is unlocking of the bootloader "supported" by Samsung? or am I voiding warranty?

0

Share this post


Link to post
Share on other sites

Posted · Report post

This may be a silly question but I've just got my GN and whereas using an HTC device is childs play using a Samsung device is completely new. If I'm going to flash a new ROM as soon as I've unlocked the phone so is using this Superboot needed? I don't care about just rooting the stock ROM and seeing as custom ROMs come with a boot.img anyway I assume I'm good to go?

0

Share this post


Link to post
Share on other sites

Posted · Report post

This may be a silly question but I've just got my GN and whereas using an HTC device is childs play using a Samsung device is completely new. If I'm going to flash a new ROM as soon as I've unlocked the phone so is using this Superboot needed? I don't care about just rooting the stock ROM and seeing as custom ROMs come with a boot.img anyway I assume I'm good to go?

Yep, you don't need the superboot. Just unlock the bootloader, flash the revocery and after that flash a rom.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Nice one mate, thought it was that simple! :D

Finally got mine turned on after having it all day in work and not being able to play. It's a seriously nice handset

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Could anyone please gimme some help?

I have previously rooted/unlock, however after the recent samsung/google volume patch, i have lost root.

what's the easiest way of doing this again please? (without wiping) I am still unlocked.

Thanks in anticipation

sorted - i just did it again - d'oh

Edited by GriZlore
0

Share this post


Link to post
Share on other sites

Posted · Report post

I haven't seen any confirmation that this works for the LTE nexus?

Also, could I use the boot.superboot.img in the zip file to manually root my LTE nexus using adb?

Thanks.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm locked up in a bootloop, any help out there..

0

Share this post


Link to post
Share on other sites

Posted · Report post

Just got the Verizon LTE Samsung Galaxy Nexus. Drivers installed through PDAnet fine, got to bootloader mode, however when I run either install-superboot-windows.bat or 'fastboot-windows oem unlock', I get this error:

... FAILED <command write failed <Unknown error>>

0

Share this post


Link to post
Share on other sites

Posted · Report post

Got one from Telstra (AUS)

Installed PDANet fine and recognises my phone. Can copy things back and forth fine.

Get to bootloader mode fine too

Whenever I try to do either commands in command prompt, just says < waiting for device > and sits there, until i CTRL+C...

Any thoughts?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Got one from Telstra (AUS)

Installed PDANet fine and recognises my phone. Can copy things back and forth fine.

Get to bootloader mode fine too

Whenever I try to do either commands in command prompt, just says < waiting for device > and sits there, until i CTRL+C...

Any thoughts?

Was the phone recognized also in the bootloader mode?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Was the phone recognized also in the bootloader mode?

Ahh... here's the problem...

Can't seem to get it updated... grabbed the Samsung_USB_Driver_for_Mobile_Phones_v1_4_6_0.exe already and pointing it to the install location picked up nothing.

I have the Android SDK installed as well... but for some reason, I can't install the Google USB Driver package...

I assume this needs to be fixed somehow?

Downloading Google USB Driver package, revision 4

File not found: C:\Program Files (x86)\Android\android-sdk\temp\usb_driver_r04-windows.zip (Access is denied)

0

Share this post


Link to post
Share on other sites

Posted · Report post

PDANet fixed the problem with the device not being recognized properly in bootloader mode for me. It's the next step now that my LTE nexus doesn't like.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Guys I need some help Please! I unlocked the bootloader fine. I use superboot, now Im in a boot loop on the Google screen. Did I miss something. I have the Galaxy Nexus LTE version. Thanks for the future help

0

Share this post


Link to post
Share on other sites

Posted · Report post

Guys I figured it out. SO I booted in to recovery and got the adroid with a red triangle with exclamation mark. So I used this tut to fastboot CWM and VUALLA! All good.

Guys I need some help Please! I unlocked the bootloader fine. I use superboot, now Im in a boot loop on the Google screen. Did I miss something. I have the Galaxy Nexus LTE version. Thanks for the future help

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dave90,

Can you please elaborate? I'm in the same situation and would really appreciate some more detail about how you resolved.

Much thanks.

Guys I figured it out. SO I booted in to recovery and got the adroid with a red triangle with exclamation mark. So I used this tut to fastboot CWM and VUALLA! All good.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Sure so basically I ran that superboot like you did and got the Google boot loop. So I went into the recovery and noticed the android with the red triangle with the exclaimation mark. So I said hmm.. is it possible my revocery image got corrupt. So I downloaded and fastboot push the CWM image and poof I was good. Here is the tutorial.

Koushik Dutta - Yesterday 8:52 PM (edited) - Public

Unlocking/rooting your Galaxy Nexus

This process is similar to all the other Nexus phones, which come unlockable thanks to google:

Download:

Clockwork Recovery for Galaxy Nexus (CDMA):

http://download.clockworkmod.com/recoveries/recovery-clockwork-5.5.0.4-toro.img

Superuser update package:

http://download.clockworkmod.com/test/su.zip

Using a console and fastboot (which can be obtained in various places, look around):

# boot into fastboot by powering off, then turning the phone on with volume-up + power

# unlock

fastboot oem unlock

# boot recovery

fastboot flash recovery recovery-clockwork-5.5.0.4-toro.img

# note the trailing slash when pushing the superuser zip

adb push su.zip /sdcard/

Install su.zip from clockwork recovery like you normally would. This is not a permanent recovery flash. That will be available later today.

In case you flash recovery, you can revert back to stock recovery with this image:

http://download.clockworkmod.com/test/stock-toro-recovery.img

Full/official factory images:

https://groups.google.com/group/android-building/msg/f6002e27c9b41a5d?pli=1

Here is the original source.

Hope this helps.

Dave90,

Can you please elaborate? I'm in the same situation and would really appreciate some more detail about how you resolved.

Much thanks.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Sure so basically I ran that superboot like you did and got the Google boot loop. So I went into the recovery and noticed the android with the red triangle with the exclaimation mark. So I said hmm.. is it possible my revocery image got corrupt. So I downloaded and fastboot push the CWM image and poof I was good. Here is the tutorial.

...

CWM is unable to install su.zip b/c it can't mount /sdcard/. I can get in via adb shell & see the files & permissions are all there. Am I missing something?

Edited by thwg
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I installed the volume fix manual and i lost root by the look of it.

I connect to my PC and boot into boot loader and double click install-superboot-windows.bat and my phone restarts but i still dont think i have root again as cwm will not install.

How can i check if i have root? I look in .system.,bin for SU but i cannot see it

Ash

EDIT:

Seems my wifi was playing up and so was taking ages to download CMW so i used my mobile network instead and it works fine.

But while in bootloader i can not connect to my phone with adb. It dosnt show in device list.

Edited by 318vert
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.